Kirjoittaja Aihe: [RATKAISTU] cryptsetup ja LUKS ongelma  (Luettu 1667 kertaa)

kopla

  • Käyttäjä
  • Viestejä: 57
    • Profiili
[RATKAISTU] cryptsetup ja LUKS ongelma
« : 22.12.10 - klo:22.42 »
Hei

Yritän tehdä kryptatun USB-levyn, mutta jokin menee pieleen.

Asensin cryptsetupin ja latasin moduulit (aes,dm_mod,dm_crypt ja sha256) tämän jälkeen ajan
Koodia: [Valitse]
sudo cryptsetup --verify-passphrase -c aes-cbc-essiv:sha256 -y -s 256 luksFormat /dev/sdb1joka kysyy
Koodia: [Valitse]
Are you sure? (Type uppercase yes): yes
Kuitenkin mitään salasanaa tms. ei kysytä tämän jälkeen.

Seuraavaksi ajoin
Koodia: [Valitse]
sudo cryptsetup luksOpen /dev/sdb1 secureTämän jälkeen ajan
Koodia: [Valitse]
sudo mkfs -t ext3 -m 1 -O dir_index,filetype,sparse_super /dev/mapper/secure, joka herjaa
Koodia: [Valitse]
Could not stat /dev/mapper/secure --- No such file or directory
Mikä tässä menee pieleen? Yritin seurata tätä ohjetta https://help.ubuntu.com/community/EncryptedFilesystemsOnRemovableStorage, mutta eipä tunnu toimivan.
« Viimeksi muokattu: 24.12.10 - klo:12.59 kirjoittanut kopla »

Tha-Fox

  • Käyttäjä
  • Viestejä: 3315
  • Arch Linux && CentOS
    • Profiili
    • http://kettu.dy.fi
Vs: cryptsetup ja LUKS ongelma
« Vastaus #1 : 23.12.10 - klo:01.03 »
En tiedä, voiko olla näin yksinkertainen, mutta tuossahan pyydetään vastaamaan "YES", eikä "yes", jos nyt oikein tuon uppercasen tulkitsen. Mutta ei kai syy noin yksinkertainen voi olla?

kopla

  • Käyttäjä
  • Viestejä: 57
    • Profiili
Vs: cryptsetup ja LUKS ongelma
« Vastaus #2 : 24.12.10 - klo:12.58 »
Ongelma oli juuri tuossa, että kirjoitin pienellä yes kun pyydettiin YES.
Mielenkiintoista, että tuo ei ilmoittanut mitään, että toimintoa ei suoritettu tms.