Kirjoittaja Aihe: Ongelma Rubygamen asentamisessa  (Luettu 586 kertaa)

valokettu

  • Käyttäjä
  • Viestejä: 12
    • Profiili
Ongelma Rubygamen asentamisessa
« : 08.12.10 - klo:19.05 »
Asensin kaikki tarvittavat paketit ja sitten yritin:
Koodia: [Valitse]
sudo gem install rubygameJa sain seuraavanlaisen virheviestin:
Koodia: [Valitse]
ERROR:  Error installing rubygame:
ffi requires Ruby version >= 1.9.2.
Sitten asensin ruby1.9.2:n noudattamalla ohjeita #ubuntu irc-kanavalta. Seuraavilla sivuilla on ohje miten asentaa ko. paketti (noudatin ensimmäisen sivun ohjetta):
http://www.ubuntuupdates.org/ppa/pratikmsinha_ruby_1.9.2
http://ubuntuforums.org/showthread.php?t=1560070

Kun asensin sourcesta (jälkimmäinen ed. linkki) niin tuli seuraava error:
Koodia: [Valitse]
ERROR:  Loading command: install (LoadError)
    no such file to load -- zlib
ERROR:  While executing gem ... (NameError)
    uninitialized constant Gem::Commands::InstallCommand

Asensin zlib1g yms. mutta silti herjaa samalla errorilla. Osaako kukaan auttaa tässä? Nyt ei anna asentaa mitään gemillä...
« Viimeksi muokattu: 14.12.10 - klo:19.19 kirjoittanut valokettu »

Storck

  • Vieras
Vs: Ongelma Rubygamen asentamisessa
« Vastaus #1 : 15.12.10 - klo:02.47 »
En ymmärrä hölkäsen pöläystä koko asiasta mutta tutkin hieman, sivut saattaa olla ihan vääriä tai tuttuja mutta laitan kuitenkin. (oli eriäväisyyksiä tuossa asennustavassa)

http://rubyforge.org/frs/?group_id=5089

http://rubygame.org/wiki/Debian_based_GNU/Linux_Distro_Installation_Guide

Toivotaan että oli ainakin se apu että joku tietävä kohdistaa katseensa :)