Kirjoittaja Aihe: Kiinteä verkko ei toimi ellei kaapeli ole kytketty bootin aikana  (Luettu 2454 kertaa)

jtjk

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Moi,

Minulla on 10.04 pyörimässä HP Mini 5103:ssa ja alunperin verkko ei toiminut siinä ollenkaan. Lopulta lisäsin rivin GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_os_name=Linux" grub conffiin ja sain verkon toimimaan.

Ongelma on vain siinä että jos kaapeli ei bootin aikana ole kytketty, ei sitä saa toimimaan mitenkään ilman uutta boottia.

ifconfig ei näytä eth0:aa lainkaan vaan sanoo device not found jos yritän sitä pakottaa ylös.

Ideoita?

ps. WLANin ja built-in-3G:n kanssa oli myös hirveä säätö ennen kuin toimi. Jos taistelet samojen kanssa, kysele vinkkejä.

juyli

  • Vieras
Ongelma on vain siinä että jos kaapeli ei bootin aikana ole kytketty, ei sitä saa toimimaan mitenkään ilman uutta boottia.

Jos yhteytesi tarjoaa dhcp-palvelimen, riittää dhclient <verkkolaite> tai dhcpcd <verkkolaite>
Myös verkon uudelleenkäynnistys muilla tavoin on mahdollista.
sudo start <palvelu> tms.
Uudelleenkäynnistys ei ole tarpeen, jos vain osaat hieman tarkemmin kertoa yhteydestäsi.
Omilla yhteyksilläni riittää, kun laitan piuhan, wlan-laitteen tai mokkulan paikoilleen... ongelmitta.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Näkyykö ok tällä komennolla:

Koodia: [Valitse]
lspci | grep eth -i
Yritä perään tätä:

Koodia: [Valitse]
sudo dhclient
Löysikö korttisi ?
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

jtjk

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Näkyykö ok tällä komennolla:

Koodia: [Valitse]
lspci | grep eth -i
Yritä perään tätä:

Koodia: [Valitse]
sudo dhclient
Löysikö korttisi ?

Melko erikoista sanoo dmesg:
[   17.473203] eth0: Broadcom BCM4353 802.11 Hybrid Wireless Controller 5.60.48.36
[   17.535375] udev: renamed network interface eth0 to eth1

Ja tuo langaton toimii siis moitteetta ja sitä kutsutaan eth1

:~$ lspci | grep eth -i
02:00.0 Ethernet controller: Marvell Technology Group Ltd. Device 4381 (rev ff)

jtjk

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Jos yhteytesi tarjoaa dhcp-palvelimen, riittää dhclient <verkkolaite> tai dhcpcd <verkkolaite>
Myös verkon uudelleenkäynnistys muilla tavoin on mahdollista.
sudo start <palvelu> tms.
Uudelleenkäynnistys ei ole tarpeen, jos vain osaat hieman tarkemmin kertoa yhteydestäsi.
Omilla yhteyksilläni riittää, kun laitan piuhan, wlan-laitteen tai mokkulan paikoilleen... ongelmitta.

Niin kyllä mulla on dhcp ja dhclient eth0 sanoo myös device not found. service network-manager stop|start ei auta. Sen sijaan sudo reboot auttaa ja olisi kyllä kiva tietää mikä tuossa voi olla :)

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Netissä ehdotettiin tämmöistä asiaa:   Tee ensin varmuuskopio tiedostosta "/etc/udev/rules.d/70-persistent-net.rules"  ja poista sen jälkeen tuosta kaikki ne rivit jotka eivät ala risuaidalla (#) ja tallenna.  Varmista että verkkokortin kaapeli on kiinni koneessa ja käynnistä kone uudestaan niin sen pitäisi tunnistaa uudestaan korttisi ja luoda uusi sisältö tuohon tiedostoon. 



Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

jtjk

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Tämä viimeisin taisi auttaa... joskin edelleen jos boottaan ilman piuhaa, ei eth0:aa näy mutta kun pistän piuhan kiinni niin se mystisesti ilmestyy jostain :) Pääasia että toimii. Kiitos.

Nyt seuraavan ongelman kimppuun, joka on vastaava asia joka ilmenee sisäisen 3G:n kanssa (Qualcomm Gobi 2000/HP un2420). Laite toimii välillä kuin junan vessa ja välillä laite katoaa omia aikojaan eikä sitä saa millään takaisin. Bootti Windowsiin auttaa jossa laitetta täytyy connection managerin kanssa pistää päälle ja pois pari kertaa ja bootata takaisin ubuntuun.

Ilokaasu

  • Käyttäjä
  • Viestejä: 1547
    • Profiili