Kirjoittaja Aihe: Enemy Territory ei toimi oikein  (Luettu 14084 kertaa)

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #20 : 04.08.06 - klo:12.59 »
Itselläni on gf4 ja Athlon 1700+ ja joku 360mt rammia. Kokeillaas sitten tuota consolea.

Milläs hakusanoilla niitä configeja löytyis? ja jos tiiät jonkun hyvän konfigin kertoisitko mulle? :)

No toihan on jo tykki näyttis. ;)

http://velocity.lunarpages.com/tweaks.html Tuossa hieman noita settareita. Kannattaa lukea vaikka koko sivusto läpi. Paljon hyvää tietoa aloittelialle.

http://www.rtcw.jolt.co.uk/content/enemy_territory/cmdcvarlist/index.html Kaikki cvarit selitettyinä.

http://www.repsej.com/etconfig.php Tuolla saa jo hyvän alun omalle cfg-tiedostolle.

Noilla varmaan pääset jo alkuun. Eli tuolla config builderilla jos teet niin vaikka copypasteat ne kaikki tekstit geditiin ja tallennat /usr/local/game/enemy territory/etmain kansioon (tai minne sitten oletkaan pelin asentanut), mutta kuitenkin juuri etmain kansioon autoexec.cfg nimellä. Sitten käynnistät pelin. Komennat pelin konsolessa /exec autoexec.cfg, jonka jälkeen /vid_restart ja uudet konffit ovat silloin käytössä. Esim. sateet, räjähdykset,  varjot jne. kannattaa ottaa pois -> parempi fps ja parempi näkyvyys = enemmän frägejä  ;D

Toivottavasti jotain apua oli...

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #21 : 04.08.06 - klo:13.10 »
Jes! Sateen saa pois! Sen olen aina halunnut tehdä. :)
alias vililikku

tn

  • Käyttäjä
  • Viestejä: 472
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #22 : 04.08.06 - klo:13.14 »
Noilla varmaan pääset jo alkuun. Eli tuolla config builderilla jos teet niin vaikka copypasteat ne kaikki tekstit geditiin ja tallennat /usr/local/game/enemy territory/etmain kansioon (tai minne sitten oletkaan pelin asentanut), mutta kuitenkin juuri etmain kansioon autoexec.cfg nimellä.
Itse suosittelisin laittamaan nuo konffit oman kotihakemiston alaisuuteen kansioon ~/.etwolf/etmain/ (vai olikohan se ~/.wolfet/etmain/). Tästä seuraa pari etua:
a) Ei tarvitse säätää mitään sudo-räpellyksiä, kun omaan kotihakemistoon on kaikki oikeudet.
b) Jokaisella käyttäjällä voi nyt olla omat konffinsa.

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #23 : 04.08.06 - klo:13.59 »
 kun sillä konffitiedostoautomaatilla lukee slow, medium ja fast, onko slow hidas kone ja medium keskinopea ja fast nopea kone?
alias vililikku

jakeee

  • Käyttäjä
  • Viestejä: 49
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #24 : 04.08.06 - klo:14.15 »
Juuri niin.

Itsekin aloin heti säätämään konffeja itselleni :D

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #25 : 04.08.06 - klo:14.17 »
Aaaaaargh! Ei auttanut vaikka otin Xgl:än pois käytöstä, en vain saa et:tä koko ruudullle. asensin sen uudelleenkin. ei auttanut. byhyyyyyy!

Muoks: Kokeilin äsken SuperTuxia, se kyllä suostui menemään paneelin päälle, mutta sillä oli isot paksut mustat reunat ympärillä ja vaan pikkunen (ehkä 800x600 reso?) kuva missä pelataan. Eli kyse on varmaankin näytön linux yhteensopivuudessa?
« Viimeksi muokattu: 04.08.06 - klo:14.29 kirjoittanut Vililikku »
alias vililikku

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #26 : 04.08.06 - klo:18.40 »
Mikä näytönohjain? Itselläni ollut ongelmia uusimmasta nvdian ajurista lähtien(reson tunnistus häsmäkkä jotenkin kusee). Sain sen kyllä toimimaan oikein kun etsin modeline generaattorilla tarvittavat resot ja siihen liittyvät virkistystaajuudet(sul on tfti näyttö niin en mainitte niistä virkistystaajuuksista sen enempää) ja laiton vielä monitorin kohdalle se nykyseisen virkistystaajuudeen alaviivalla liitettynä resoon("800x600_xxx" "1024x768_xx").

Sitten laitoin vielä et:n konfeihin sen että se käyttää haluttua refreshratea pistämällä tiedostoon autoexec.cfg rivin seta r_displayrefresh xx, missä tämä xx on käyttämäni virkistystaajuus(Tee siis tiedosto /home/username/.etwolf/etmain/ kansioon autoexec.cfg tiedosto ja liitä siihen ne ja muutkin konft mitä netistä haet/ tee itse, hiirelle on hyvä tehdä seta in_dgamouse "2", koska tämä poistaa kaikki turha kiihdytykset, jolloin hiiren liike on normaalimpaa ammuttaessa).

ps. itse haeskellu noita konfeja joskus tuolta, mutta näyttää olevan aika bugiset nuo uudet sivut...

EDIT: linkki vanhentunut
« Viimeksi muokattu: 13.10.06 - klo:01.18 kirjoittanut tuke81 »
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

tomppa

  • Käyttäjä
  • Viestejä: 165
  • Debian4.0
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #27 : 04.08.06 - klo:19.13 »
Laitetaas vielä tähänkin. Eli jos joku tuntee ohjelman nimeltä etswitch ja on saanut sen kunnolla toimimaan niin otan ohjeita mielelläni vastaan. :) Kirjoitinkin tästä joskus, mutta en saanut siihen vastausta. Eli ohjelmahan pienentää pelin ja palauttaa sen eli ei tarvitse sammuttaa peliä aina jos haluat esim. katsoa ircistä jotain. Oma ongelma oli että hiiri ei reagoinut enää sen jälkeen, kun sitä ohjelmaa käytti.

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #28 : 04.08.06 - klo:20.38 »
Ei oikein pelannu se etswitch mullakaan, kun sitä joskus kokeilin. Itse tehny tämän mukaan...

ja tosiaan ruudunsäästäjä kannattaa sulkea ensin kuin rupeaa pelaamaan.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #29 : 05.08.06 - klo:10.36 »
Minulla on GeForce 4 MX. Hei, et toimii. Eli lisäsin vain sen virkistystaajuuden et:n konffiin ja toimii. Kiitos Tuke!
alias vililikku

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #30 : 05.08.06 - klo:13.55 »
Miten saisi FPS:ää suuremmaksi? Vaikka pelaisin 640xjotainjotain resolla FPS on vain jotain 20.
alias vililikku

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
    • Janin sivut
Re: Enemy Territory ei toimi oikein
« Vastaus #31 : 05.08.06 - klo:14.23 »
Jos ET on niin raskas peli ettei se toimi tuolla GF4 MX kortillasi. Mx on riisuttu malli.
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

eliasj

  • Käyttäjä
  • Viestejä: 4073
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #32 : 05.08.06 - klo:14.53 »
Jaa jaa. Muttasiis sehän on niin, että FPS nousee kun huonontaa grafiikoita yms.?
alias vililikku

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
    • Janin sivut
Re: Enemy Territory ei toimi oikein
« Vastaus #33 : 05.08.06 - klo:14.57 »
Nii siis joo tokihan se nousee kun karsii efektejä ym.
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Re: Enemy Territory ei toimi oikein
« Vastaus #34 : 05.08.06 - klo:16.59 »
No pari cvarria mitkä noihin vaikuttaa on ainakin nämä:
Koodia: [Valitse]
seta com_maxfps "76" //Maksimi fps:n rajoitus, liika vaihtelu ei ole hyvästä(radarissa tuolla kortilla ei pitkälle pötkitä)
seta com_hunkMegs "xxx" // xxx/muistin määrä koneessa = korkeintaan puolet muistista esim jos on koneessa muistia 512 laita 256 tai 192
seta cg_bloodDamageBlend "0" //veriroiskeet veke
seta cg_gibs "0" //Ruumiin kappaleet veke
seta cg_showblood "0" // Ei verta
seta cg_bloodFlash "0" //Ei mene ruutu punaseksi kun osuu
seta cg_wolfparticles "0" //Vesisade ja muuta pois
seta cg_shadows "0" //varjot pois
seta cg_coronas "0" //Auringon säde pois
seta r_flares "0"
seta r_picmip "3" //vähiten yksityiskohtaiset grafiikat
seta r_picmip2 "3" //Vähän sama asia en ole ihan varma onko tällä edes vaikutusta et:ssä voi olla rtcw jäänne..
seta r_drawsun "0" //...
seta r_dynamiclight "0"
seta r_fastsky "1"
seta r_textureMode "X_X" //X_X = GL_LINEAR(pikseli mössöä),  GL_LINEAR_MIPMAP(vähemmän pikseli mössöä), GL_LINEAR_MIPMAP_LINEAR(mössöttyä triple bufferia) tai GL_LINEAR_MIPMAP_NEAREST(täyet graffat) eli siis esim  seta r_textureMode "GL_LINEAR_MIPMAP"

Lisäksi tökkiminen voi johtua yhteys asetuksista, eli kokeile seuraavia:
seta rate "25000"
seta snaps "40"
seta cl_maxpackets "100"
seta cl_packetdup "0"

Kaikki siis voi laittaa autoexec.cfg:hen jos pistät sinne jotain muisti juttuja johonkin väliin laita kommentointi merkit // eteen.
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...