Kirjoittaja Aihe: Netti hävisi Ubuntusta! (Ratkaistu!)  (Luettu 3753 kertaa)

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Netti hävisi Ubuntusta! (Ratkaistu!)
« : 17.06.10 - klo:11.27 »
Onnistuin kaiketi tekemään joitakin virheasennuksia Telewell 510 v3 modeemin asetuksissa, koska netti ei enää toimi. Outoa on se, että Windowsin puolella toimii.
Yritin virittää dcpp:n toimimaan aktiivina huonoin tuloksin.
Kun ei osaa, niin ei osaa. Ohjeita oli vaikka kuinka, mutta kun ei, niin ei.
Löytyisikö joku taikasana päätteeseen, joka korjaisi ongelmani? Tahtoisin käyttää Ubuntua.

Kiitos jo neuvoista

Olen jo resetoinut Telewellin. Ei apua. Kirjoitin päätteeseen "sudo dhclient", ei apua. Apua...
« Viimeksi muokattu: 19.06.10 - klo:06.25 kirjoittanut TimOlli »

juyli

  • Vieras
Vs: Netti hävisi Ubuntusta!
« Vastaus #1 : 17.06.10 - klo:11.54 »
Onnistuin kaiketi tekemään joitakin virheasennuksia Telewell 510 v3 modeemin asetuksissa, koska netti ei enää toimi. Outoa on se, että Windowsin puolella toimii.

ifconfig, route ja cat /etc/resolv.conf? Noita komentoja voi käyttää myös manuaalisesti, jos tarpeen. Tuossa Telewellissä on mielestäni ominaisuutena, että portit 1-2 ovat natattuja, mutta portit 3-4 ovat siltaavia. Voit tietenkin myös tutkailla, miten Windows ottaa yhteyden. (Esim. koneen ip selviää komennolla ipconfig. Tuosta IP:stä on tulkittavissa, onko kyseessä NAT (IP:t jakaa Telewell) vaiko siltaava yhteys, jolloin IP:t ym. noudetaan palveluntarjoajalta.)
Telewellin manuaali löytyy Telewellin sivuilta: http://www.telewell.fi/ohjekirjat/TW-EA510_v3c_finnish_manual.pdf
« Viimeksi muokattu: 17.06.10 - klo:12.03 kirjoittanut juyli »

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #2 : 17.06.10 - klo:12.34 »
Mitä tarkoittaa manuaalisesti?
Windowsin puolella selvitin, että nat on päällä.
Olen nyt resetoinut Telewellin neulalla manuaalisesti ja selaimella ohjelmallisesti. Ei apua.
Miten Ubuntun saisi etsimään nettiä? Windowsissa oli muistaakseni joku korjaus-nappula. Olisiko Ubuntussa sellaista?

Jakke77

  • Käyttäjä
  • Viestejä: 3867
  • Oulu (Oinaansuo)
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #3 : 17.06.10 - klo:12.37 »
avaat päätteen ja annat siihen nuo juylin mainitsemat komennot.
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #4 : 17.06.10 - klo:15.53 »
Nuo kaksi ensimmäistä antoivat jotakin informaatiota, jota en ymmärtänyt. Ja tuo "cat" ei tehnyt näennäisesti mitään, mutta kun yritin sammuttaa päätettä, ilmoitti hän, että prosessi kesken. Puolitoista tuntia oli päällä, eikä mitään tapahtunut.
Kiitos näistä. Olisiko lisää koodeja?
« Viimeksi muokattu: 17.06.10 - klo:17.08 kirjoittanut TimOlli »

Lasse.

  • Käyttäjä
  • Viestejä: 1668
  • Techjunkie.
    • Profiili
    • Liquid Flower Games
Vs: Netti hävisi Ubuntusta!
« Vastaus #5 : 17.06.10 - klo:17.31 »
Idea olisi tietysti, että annat sen informaation tänne syynättäväksi.
Kone 1: Intel Core i5 2500K, 8GB DDR3, nVidia GTX 560 Ti 1GB, 2x1TB & 1x 250GB HDD, Windows 7 & Arch
Kone 2: Lenovo Ideapad Z370 (i5-2410M, 4GB RAM & GeForce 410M) Chakra
Google LG Nexus 4 (ParanoidAndroid)
Linuxia noin vuodesta 2004.

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #6 : 17.06.10 - klo:18.55 »
Tuollaista se ilmoitteli.

ifconfig:
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0  
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)
 


route:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface


Ja kuten sanottu, tuo "cat" ei sanonut mitään.
« Viimeksi muokattu: 18.06.10 - klo:21.00 kirjoittanut TimOlli »

juyli

  • Vieras
Vs: Netti hävisi Ubuntusta!
« Vastaus #7 : 17.06.10 - klo:19.10 »
ifcinfig:
lo        Link encap:Local Loopback 
Jo tuosta on nähtävissä, ettei verkkokorttisi (vai mitä tuo verkkolaitteesi sitten onkaan?) ole käytössä lainkaan.
 
route:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

Mitään reititystä ei ole käytettävissä, jos verkkolaitettasi ei tunnisteta - tai osata ottaa käyttöön.

Ja kuten sanottu, tuo "cat" ei sanonut mitään.
Tiedosto /etc/resolv.conf määrittää nimipalvelimet. Kun verkkosi ei toimi, ei tuollakaan ole mitään merkitystä.
Oletuksena käytettäessä dhcp:tä, saa kone dhcp-palvelimelta ko. tiedot - oli sitten kyseessä ADSL-palvelin tai sillattu yhteys suoraa palveluntarjoajaan.
Lähtökohtana siis tässä tapauksessa on saada verkkokorttisi määritellyksi. Vieläkö maltat kertoa, miten Windows määrittelee verkkokorttisi sekä ipconfig:in tiedot verkkoyhteydestä (ipconfig on Windowssin dos-ikkunassa käytettävä komento (komentotulkkina esim. cmd.exe vrt. Linuxin vastaavat pajon monipuolisemmat shell:it).)

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #8 : 17.06.10 - klo:20.17 »
Kas kun tuo verkkokortti toimii täällä Windowsin puolella... Outoa.

Microsoft Windows XP [versio 5.1.2600]
(C) Copyright 1985 - 2001 Microsoft Corp.


Windows IP-määritykset


Ethernet-sovitin Lähiverkkoyhteys:

        Yhteyskohtainen DNS-liite . . . . : TeleWell.gateway
        IP-osoite . . . . . . . . . . . . : 192.168.0.103
        Aliverkon peite . . . . . . . . . : 255.255.255.0
        Oletusyhdyskäytävä. . . . . . . . : 192.168.0.254


Tämänkö tahdoit nähdä?

Anteeksi, mutta en ymmärrä miten näytän sinulle nämä Windowsin jutut. Ellei sitten tuo riitä, jonka kopioin. Kerro, niin toimin.


TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #9 : 17.06.10 - klo:20.59 »
Menen unten maille, mutta olisi kiva aamulla herätä ja huomata joku maaginen koodinpätkä tai joku muu juttu, jolla asia hoituisi. Paljon pyydän, tiedän, mutta itse en asiaa osaa hoitaa. Auttakkee...

Jakke77

  • Käyttäjä
  • Viestejä: 3867
  • Oulu (Oinaansuo)
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #10 : 18.06.10 - klo:07.59 »
katsoppa ohjeet ja tuki sovelluksesta internet ja verkot jutuista jos siellä olisi vinkkiä, esim. manuaaliseen säätelyyn
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #11 : 18.06.10 - klo:10.07 »
Miten vastaa tämä komento (kopioi komennon vastaus tänne):

Koodia: [Valitse]
lspci | grep -i ether
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #12 : 18.06.10 - klo:11.29 »
Olen lueskellut ohjeita jos minkälaisia, mutta aiempien tapausten perusteella olen huomannut, että tältä foorumilta saa parhaat neuvot, varsinkin kun en ole mikään älyn jättiläinen näissä asioissa.

lspci | grep -i ether: antoi tämän...
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a1)

Tuo ei minulle valkene...

Ps/edit:
Tämä Windowsin käyttö hermostuttaa... Sain juuri muun perheen käyttämään mielummin Ubuntua...
« Viimeksi muokattu: 18.06.10 - klo:13.54 kirjoittanut TimOlli »

910

  • Käyttäjä
  • Viestejä: 96
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #13 : 18.06.10 - klo:14.40 »
Annapa vielä seuraava komento:

Koodia: [Valitse]
dmesg | grep eth

Tulosteena saat luultavasti useita rivejä, joilla esiintyy ethX, missä X on todennäköisesti 0. Yritä sitten nostaa verkkoliitäntä ylös komennolla:

Koodia: [Valitse]
sudo ifup eth0

Jos tuon edellisen dmesg-komennon tulosteessa oli jokin muu kuin eth0, korvaa eth0 sillä. Liitä tänne ifup-komennon tuloste. Jos komento ei tulosta mitään, anna vielä komento:

Koodia: [Valitse]
ifconfig

JarTak

  • Käyttäjä
  • Viestejä: 333
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #14 : 18.06.10 - klo:17.55 »
Pakko heittaa sellanen idea tässä, että ei kait netin kuvake ole vain yläpaneelista hävinnyt pois. Jos näin on käynyt, nin silloin wlania käytettäessä kone ei ilmoita, että verkkoja on saatavilla ja vikaa voidaan etsiä ties mistä. Kuvakkeen saa paneeliin lisäämällä paneeliin ilmoitusalue kuvakkeen.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #15 : 18.06.10 - klo:19.48 »
Voisi kurkistaa mitä tämä näyttää:

Koodia: [Valitse]
lsmod
Tuon nVidian Ethernet-ajuri lienee (?) nimeltään "forcedeth".  Ellei se näy tuossa pitkähkössä listauksessa  (pyörittele listan alku myös näkyviin...) niin

Koodia: [Valitse]
sudo modprobe forcedeth
ja katso syntyikö eloa.  Jos ei niin

Koodia: [Valitse]
dmesg | grep -i eth
ja kopioi tuloste tänne kiitos.


Jos "forcedeth" kuitenkin näkyi tuolla "lsmod" listassa niin kiinnostaa mitä "sudo dhclient" tulostaa.
« Viimeksi muokattu: 18.06.10 - klo:20.01 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #16 : 18.06.10 - klo:21.38 »
No niin.
Hiukan hankalaa tämän käyttisten välillä surffailu... Mutta tässä näitä tulosteita.

timo@timo-desktop:~$ dmesg | grep eth  
[    0.794522] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    0.794872] forcedeth 0000:00:14.0: PCI INT A -> Link[APCH] -> GSI 23 (level, low) -> IRQ 23
[    0.794877] forcedeth 0000:00:14.0: setting latency timer to 64
[    1.312762] forcedeth 0000:00:14.0: ifname eth0, PHY OUI 0x5043 @ 1, addr 00:1b:fc:9f:63:ec
[    1.312767] forcedeth 0000:00:14.0: highdma pwrctl gbit lnktim desc-v3

timo@timo-desktop:~$ sudo ifup eth0
[sudo] password for timo:  
Ignoring unknown interface eth0=eth0.

timo@timo-desktop:~$ ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0  
          RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)

timo@timo-desktop:~$ lsmod
Module                  Size  Used by
binfmt_misc             6587  1  
snd_hda_codec_analog    58566  1  
mt2060                  4107  1  
af9013                 19926  1  
fbcon                  35102  71  
tileblit                2031  1 fbcon
font                    7557  1 fbcon
bitblit                 4707  1 fbcon
softcursor              1189  1 bitblit
vga16fb                11385  0  
vgastate                8961  1 vga16fb
snd_hda_intel          21877  2  
snd_hda_codec          74201  2 snd_hda_codec_analog,snd_hda_intel
snd_hwdep               5412  1 snd_hda_codec
snd_pcm_oss            35308  0  
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70662  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy           1338  0  
snd_seq_oss            26726  0  
snd_seq_midi            4557  0  
snd_rawmidi            19056  1 snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
radeon                674135  3  
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
ppdev                   5259  0  
ttm                    49943  1 radeon
drm_kms_helper         29297  1 radeon
parport_pc             25962  1  
drm                   162471  5 radeon,ttm,drm_kms_helper
dvb_usb_af9015         23159  0  
dvb_usb                14457  1 dvb_usb_af9015
snd                    54148  16 snd_hda_codec_analog,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
asus_atk0110            9017  0  
agpgart                31724  2 ttm,drm
k8temp                  3024  0  
i2c_algo_bit            5028  1 radeon
dvb_core               86142  1 dvb_usb
soundcore               6620  1 snd
i2c_nforce2             5199  0  
snd_page_alloc          7076  2 snd_hda_intel,snd_pcm
lp                      7028  0  
parport                32635  3 ppdev,parport_pc,lp
usbhid                 36110  0  
hid                    67032  1 usbhid
ohci1394               26950  0  
pata_amd                8766  0  
ieee1394               81181  1 ohci1394
forcedeth              49556  0  
sata_nv                19440  5  

timo@timo-desktop:~$ dmesg | grep -i eth
[    0.794522] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.64.
[    0.794872] forcedeth 0000:00:14.0: PCI INT A -> Link[APCH] -> GSI 23 (level, low) -> IRQ 23
[    0.794877] forcedeth 0000:00:14.0: setting latency timer to 64
[    1.312762] forcedeth 0000:00:14.0: ifname eth0, PHY OUI 0x5043 @ 1, addr 00:1b:fc:9f:63:ec
[    1.312767] forcedeth 0000:00:14.0: highdma pwrctl gbit lnktim desc-v3

timo@timo-desktop:~$ sudo dhclient
Internet Systems Consortium DHCP Client V3.1.3
Copyright 2004-2009 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/
 
Listening on LPF/eth0/00:1b:fc:9f:63:ec
Sending on   LPF/eth0/00:1b:fc:9f:63:ec
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPOFFER of 192.168.0.103 from 192.168.0.254
DHCPREQUEST of 192.168.0.103 on eth0 to 255.255.255.255 port 67
DHCPACK of 192.168.0.103 from 192.168.0.254
bound to 192.168.0.103 -- renewal in 21179 seconds.


...että sellaista. Taisi olla teillä samakin koodi ehdotuksena, mutta laitoin nyt kuitenkin kaikki näkyviin, mitä sain.

sudo modprobe forcedeth
Tämä käsky oli erikoinen. Ensimmäisellä kerralla teki pitkähkön listauksen ilman, että ehdin edes enteriä painaa (copy/paste). Kun sitten jouduin (mokani takia) kirjoittamaan (copy) koodin uudelleen, se ei tulostanut mitään. Ei edes sitten, vaikka tein kaiken uudellen ihan koneen käynnistyksestä lähtien.

No. Toivottavasti nuo aukeavat teille ja viitsitte antaa jonkun neuvon. Kiitos jo taas etukäteen.

Ai niin. Kuvake on tallessa paikallaan.
« Viimeksi muokattu: 18.06.10 - klo:23.03 kirjoittanut TimOlli »

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Netti hävisi Ubuntusta!
« Vastaus #17 : 19.06.10 - klo:00.12 »
Tuosta nyt näkee heti että Ethernet korttisi toimii ok, ajuri on latautunut ja sait jopa ip-osoitteen sille oikein eli se on siltäosin toimintakunnossa.  Oletko tarkastanut asetukset tuolta verkkoyhteyskuvakkeen kautta ?  Hiiren oikea ja "Muokkaa yhteyksiä..." --> Kiinteä  -->  Muokkaa nappi.   Ruksit:  Yhdistä automaattisesti,  Saatavilla kaikille käyttäjille.  Lisäksi IPv4 -lehdellä DHCP. Katso mallia kuvista alla miltä lopputuloksen pitäisi näyttää.  (Jos tuo "Auto eth0" puuttuu tai siellä ei ole mitään niin tee se "Lisää" napin kautta.)

Lainaus
Kun sitten jouduin (mokani takia) kirjoittamaan (copy) koodin uudelleen, se ei tulostanut mitään. Ei edes sitten, vaikka tein kaiken uudellen ihan koneen käynnistyksestä lähtien.

Tämä on aivan ok.  Se komento ylläolevassa muodossa ei tee mitään jos kyseinen ajuri on jo valmiiksi ladattu.


Klikkaa kuvat alla isommaksi.


[ylläpito on poistanut liitteen]
« Viimeksi muokattu: 19.06.10 - klo:00.55 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

TimOlli

  • Käyttäjä
  • Viestejä: 237
    • Profiili
Vs: Netti hävisi Ubuntusta! (Ratkaistu!)
« Vastaus #18 : 19.06.10 - klo:06.24 »
No niin. Asia ratkesi lopulta todella yksinkertaisesti.

Kiitos kaikille. Ajaaskel sai minut lopulta oikeille jäljille ja homma oli lopulta yhtä täppää vailla.

Hermoilin ilmeisesti homman kanssa, enkä tullut klikanneeksi oikealla tuota netti-kuvaketta. Olisin kyllä siitä itsekin tuon saattanut oivaltaa. Nimittäin tarvitsi vain laittaa rasti ensimmäisenä aukeavaan valikkoon kohtaan "ota verkko käyttöön"... se oli siinä. Hävettää oikeastaan.

Kiitos kaikille vielä. Ehkä opin tästäkin jotakin, ehkä en. Muille neuvoksi... tarkista ensin kaikki yksinkertaisimmat asiat.