Kirjoittaja Aihe: skanneriongelma, snapscan e40  (Luettu 5231 kertaa)

apositio

  • Käyttäjä
  • Viestejä: 64
    • Profiili
skanneriongelma, snapscan e40
« : 29.06.05 - klo:16.46 »
USB-skannerini, Agfa Snapscan e40, ei pelitä Ubuntussani (Hoary). Silmäilin tuossa päivän http://snapscan.sourceforge.net-sivustoa ja kokeilin sitä sun tätä... mutta ei nyt kyllä omat taidot riitä. Kuten arvata saattaa, Linux/Ubuntu on pyörinyt koneella vasta puolisen vuotta. :) Skanneria ei ole aiemmin ollut ensinkään.

Komento lsusb kertoo laitteen tunnistuvan: "Bus 003 Device 023: ID 06bd:208d AGFA-Gevaert NV Snapscan e40", mutta XSane-skannausohjelman avaaminen herjaa "failed to open device 'snapscan:libusb:003:023' invalid argument". Cat /proc/bus/usb/devices antaa puolestaan tällaisen tulosteen:
T:  Bus=03 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 23 Spd=12  MxCh= 0
D:  Ver= 1.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs=  1
P:  Vendor=06bd ProdID=208d Rev= 1.00
S:  Manufacturer=AGFA
S:  Product=SNAPSCAN
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=02(O) Atr=02(Bulk) MxPS=   8 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=16ms


Ajuriongelmako siis? Mitenköhän edetä? Kiitellen jeesistä jo etukäteen!  :)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Re: skanneriongelma, snapscan e40
« Vastaus #1 : 02.07.05 - klo:14.12 »
minulla on itselläni Agfa Snapscan e50 ja kuvittelisin, että e40 toimii aikalailla samalla tavalla. e50 nimittäin odottaa, että skannerin initialisointivaiheessa skanneriin ladataan sisälle firmware (mikä kyllä tekee firmwaren päivityksestä todella helppoa, mutta aiheuttaa jotain muita ongelmia). firmwaren voi ottaa joko skannerin ajurilevyltä tai valmistajan nettisivulta (varsinkin jos siihen on tullut firmwarepäivityksiä sen ilmestymisen jälkeen).

sen jälkeen sanelle pitää kertoa, missä formware sijaitsee editoimalla sanen configurointitiedostoja. omalla pääkoneellani ei ole ubuntua ja testikonekin on nyt muussa käytössä, mutta ainakin tällä koneella editoitava tiedosto on /etc/sane.d/snapscan.conf (luulisi, että ainakin osa snapscan.conf pysyy samana joten etsinnän pitäisi ainakin olla helppoa).

tuossa tiedostossa pitää olla polku skannerin firmwareen, siellä saattaa ollakin valmiina kommentoitu esimerkki. omassa tapauksessani tuolla lukee:
firmware /etc/sane.d/Snape50.bin

jossa firmware on Snape50.bin ja kopioin sen itse tuohon hakemistoon valmistajan kotisivuilta. varmista myös kopioinnin jälkeen, että sinulla on riittävät oikeudet käyttää tuota tiedostoa ;)
Janne

apositio

  • Käyttäjä
  • Viestejä: 64
    • Profiili
Re: skanneriongelma, snapscan e40
« Vastaus #2 : 05.07.05 - klo:14.18 »
Jeps, ongelma ratkesi tällä. Kiitos!  :)