Kirjoittaja Aihe: Sähköposti ei toimi! [Ratkaistu]  (Luettu 13777 kertaa)

910

  • Käyttäjä
  • Viestejä: 96
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #20 : 14.06.10 - klo:09.10 »
kaikki tuntuisivat toimivan...

Mietin vaan, että mikä on voinut aiheuttaa tämän, kun viestiä ei enään lähde, vaikka ennen toimi hyvin ja asetuksiin en ole koskenut (muistaakseni).

Kun lähetän viestin, logiin tulee viesti
2010-06-05 07:04:29 1OKkcX-0000UR-Je <= olli@******* U=olli P=local S=375
2010-06-05 07:04:29 1OKkcX-0000UR-Je ** emai@osoite R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after MAIL FROM:<olli@*******> SIZE=1410: host mail.inet.fi [195.156.147.15]: 553 <olli@*******> Invalid mail address, must be fully qualified domain
2010-06-05 07:04:29 1OKkcX-0000UU-Qg <= <> R=1OKkcX-0000UR-Je U=Debian-exim P=local S=1333
2010-06-05 07:04:29 1OKkcX-0000UR-Je Completed
2010-06-05 07:04:30 1OKkcX-0000UU-Qg ** olli@******* R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<olli@*******>: host mail.inet.fi [195.156.147.15]: 501 <olli@*******> Invalid mail address, must be fully qualified domain
2010-06-05 07:04:30 1OKkcX-0000UU-Qg Frozen (delivery error message)


Tässä smarthostiksi asettamasi TeliaSoneran postipalvelin vastaa, että sekä lähettäjä-, että vastaanottajaosoitteet ovat virheellisiä. Ovathan osoitteet varmasti muotoa olli@jotain.fi, eivätkä esim. olli@jotain?


Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #21 : 14.06.10 - klo:12.11 »
Lainaus
Tässä smarthostiksi asettamasi TeliaSoneran postipalvelin vastaa, että sekä lähettäjä-, että vastaanottajaosoitteet ovat virheellisiä. Ovathan osoitteet varmasti muotoa mrX@jotain.fi, eivätkä esim. mrX@jotain?
Muistaakseni ovat.
« Viimeksi muokattu: 04.03.12 - klo:21.17 kirjoittanut Mr. X »

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3394
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #22 : 15.06.10 - klo:09.59 »
Kerron nyt lyhyesti uudestaan FQDN / postipalvelin asiat mistä kirjoitin noin vuosi sitten. Tein itse Postfix: in kanssa mutta tämä lienee sovellettavissa muihinkin postipalvelinohjelmiin.   Eli:
- Jos posti ei lähde niin katso logista mitä tapahtuu
- FQDN (= Fully Qualified Domain Name  = pitkä domain nimi  =  host nimi + domain nimi)  
- Sain itse fqdn -herjan logiin yrittäessäni Ubuntulla Postfixiä, aiemmin olin käyttänyt sitä Mandrake: lla vuosia ja vuosia ongelmitta.   Pienen tutkailun tuloksena päättelin että Soneran postipalvelin tarkastaa lähettäjän postipalvelimen domainin spämmin estämiseksi ja lähettäjän pitää olla "inet.fi" hallinnoimassa osoiteavaruudessa / domainissa.   Sitten alkoi pähkäily:  Mistä ihmeestä näkee mitä tuo Soneran palvelin mahdollisesti toivoisi ?   Päättelin että Soneran oma DHCP antaisi tuohon vastauksen.  Tästä on kerrottu tuossa aiemmassa FQDN viestissäni.   Itse muutin koneen nimen niin että se oli pitkä nimi tyyliin "aaa.bbb.inet.fi"  ja posti alkoi kulkea herjoitta.    Tähän on varmaan toinenkin hieman tyylikkäämpi ratkaisu mutta en lähtenyt tutkimaan sitä.  
Laitoin siis Ubuntu postipalvelinkoneen host-nimeksi koko pitkän rimpsun jonka rakensin siitä mitä Soneran DHCP oli tarjonnut.

Tässä linkki vanhempaan tarinaani:

http://forum.ubuntu-fi.org/index.php?topic=26606.msg203404#msg203404

PS.  Vaikka tuo kone on muuttuvalla ip: llä (DHCP) niin havaintoni mukaan ip-osoite säilyy kun kone on aina päällä.

« Viimeksi muokattu: 15.06.10 - klo:10.13 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #23 : 25.06.10 - klo:07.49 »
var/log/exim4/mainlog

2010-06-25 07:43:27 1OS0lD-0000PA-6m <= mrX@joku.fi U=mrX P=local S=378
2010-06-25 07:43:27 1OS0lD-0000PA-6m ** mrX@sähköposti.fi R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after MAIL FROM:<mrX@joku.fi> SIZE=1413: host mail.inet.fi [195.156.147.15]: 553 <mrX@joku.fi> unable to verify address
2010-06-25 07:43:27 1OS0lD-0000PD-P5 <= <> R=1OS0lD-0000PA-6m U=Debian-exim P=local S=1310
2010-06-25 07:43:27 1OS0lD-0000PA-6m Completed
2010-06-25 07:43:28 1OS0lD-0000PD-P5 ** mrX@joku.fi R=smarthost T=remote_smtp_smarthost: SMTP error from remote mail server after RCPT TO:<mrX@joku.fi>: host mail.inet.fi [195.156.147.15]: 550 RCPT address has non-existant domain <joku.fi>
2010-06-25 07:43:28 1OS0lD-0000PD-P5 Frozen (delivery error message)
« Viimeksi muokattu: 04.03.12 - klo:21.18 kirjoittanut Mr. X »

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3394
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #24 : 25.06.10 - klo:16.13 »
En pysty auttamaan heti Exim: ssä kun en ole pystyttänyt koskaan, ehtisin sen ehkä joskus myöhemmin pystyttämän / tutkimaan.  Etkö pysty soveltamaan Postfix: ssä jo toimineita arvoja / asetuksia Exim: iin vaikka lukemalla Exim: in dokumentaatiota ?  Sinullahan oli jo toimiva Postfix, laitatko sen lisäksi Exim: iä opiskelun tms. vuoksi ?

Joku muu tuntee varmaan Exim: iä ?
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #25 : 28.06.10 - klo:09.01 »
Lainaus
Sinullahan oli jo toimiva Postfix, laitatko sen lisäksi Exim: iä opiskelun tms. vuoksi ?
Itse asiassa en tiedä/muista kuinka/milloin olen postfix:in asentanut, joten postfix ei ole minulle tuttu.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #26 : 29.06.10 - klo:08.32 »
Kuinka muuten voi täydellisesti poistaa exim:in? Olen yrittänyt vaikka mitä, mutta aina jotain löytyy (mm. kansioita). 

mrl586

  • Käyttäjä
  • Viestejä: 4554
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #27 : 29.06.10 - klo:10.19 »
sudo apt-get purge paketti
sudo updatedb && locate exim
sudo rm -r exim_kansio

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #28 : 29.06.10 - klo:21.26 »
Onko komentoa, joka poistaa ohjelman ja tiedostot yms. yhtä aikaa?

Tha-Fox

  • Käyttäjä
  • Viestejä: 3315
  • Arch Linux && CentOS
    • Profiili
    • http://kettu.dy.fi
Vs: Sähköposti ei toimi!
« Vastaus #29 : 29.06.10 - klo:23.08 »
Tuon purge-vivun pitäisi poistaa ohjelman asetukset. En tiedä, onko ohjelmalla jotain muutakin kuin asetuksiin ja varsinaiseen ohjelmaan liittyviä tiedostoja.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #30 : 30.06.10 - klo:08.56 »
Exim on nyt kai poistettu, mutta kun aloin postfixsiä virittää, huomasin se tarvitsevan rekisteröidyn domainnin, eikä sitä minulla juuri nyt ole. Voiko postia siis lähettää ilman domainia?

Kokeilin exim:in poistamisen jälkeen asentaa sen uudestaan, mutta kone valitteli virhettä:

E: exim4-config: aliprosessi installed post-installation script palautti virhetilakoodin 1
E: exim4-base: riippuvuusongelmia - jätetään asetukset säätämättä
E: exim4-daemon-light: riippuvuusongelmia - jätetään asetukset säätämättä
E: exim4: riippuvuusongelmia - jätetään asetukset säätämättä
« Viimeksi muokattu: 04.03.12 - klo:21.18 kirjoittanut Mr. X »

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #31 : 30.06.10 - klo:09.34 »
Nyt postfix valittaa, kun yritin asentaa sitä uudestaan:

E: postfix: aliprosessi installed post-installation script palautti virhetilakoodin 75

Tha-Fox

  • Käyttäjä
  • Viestejä: 3315
  • Arch Linux && CentOS
    • Profiili
    • http://kettu.dy.fi
Vs: Sähköposti ei toimi!
« Vastaus #32 : 30.06.10 - klo:12.54 »
Korjatkoon viisaammat, mutta ymmärtääkseni sähköpostia ei voi lähettää ilman domainia.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #33 : 30.06.10 - klo:13.26 »
Kyllä posti ainakin exim:ssä kulki ilman rekisteröityä domainia.

Tha-Fox

  • Käyttäjä
  • Viestejä: 3315
  • Arch Linux && CentOS
    • Profiili
    • http://kettu.dy.fi
Vs: Sähköposti ei toimi!
« Vastaus #34 : 30.06.10 - klo:14.02 »
Käsittääkseni riittää, kunhan koneella on vain jokin järkevä FQDN, vaikkapa koti1525.pp.inet.fi

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #35 : 30.06.10 - klo:14.04 »
Ainakin exim:ssä, mutta postfix:ssä kone valittaa ettei käy, tai jotain sellaista.

mrl586

  • Käyttäjä
  • Viestejä: 4554
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #36 : 30.06.10 - klo:19.52 »
Ainakin exim:ssä, mutta postfix:ssä kone valittaa ettei käy, tai jotain sellaista.
Voisitko kertoa tarkan virheilmoituksen?

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #37 : 30.06.10 - klo:20.27 »
Postfix:in asentaminen ei onnistu:

E: postfix: aliprosessi installed post-installation script palautti virhetilakoodin 1

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3394
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #38 : 30.06.10 - klo:20.41 »
Muistan että viimeksi sait sen Postfix asennuksen onnistumaan Synaptic: in kautta jos oikein käsitin:

http://forum.ubuntu-fi.org/index.php?topic=32824.msg256473#msg256473

« Viimeksi muokattu: 30.06.10 - klo:20.43 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Mr. X

  • Käyttäjä
  • Viestejä: 151
    • Profiili
Vs: Sähköposti ei toimi!
« Vastaus #39 : 30.06.10 - klo:20.47 »
Silloin onnistuin asentamaan exim:in (vaikka vastaus ei sitä kerrokkaan), ja senpä takia se on tutumpi. 
Aamulla kuitenkin aloin asentaa postfix:siä niiden ohjeiden mukaan, ja onnistuikin, joten se on nyt tutumpi, mutta jotain onnistuin taas kerran sähläämää.  :-\