Kirjoittaja Aihe: Ubuntu 10.04 & näyttöongelma  (Luettu 2415 kertaa)

mimmi

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Ubuntu 10.04 & näyttöongelma
« : 25.05.10 - klo:13.25 »
Hei,

pitemmän aikaan kevättä ehdin käyttämään Mint 8 Helenaa LTS, kunnes siirryin uuteen versioon eli Mint 9 Isadora LTS. Tämän siirtymän jälkeen näytössä alkoi esiintyä häiriöitä: värittömiä vaakasuoraisia raitoja, jotka ovat tulevat välähdyksenomaisesti särähdyksinä. Välillä kapeampana ja välillä levempänä raitana. Nämä häiriöt eivät ole tarkkaan säännöllisiä, mutta silti välillä tiheämmin ja välillä harvemmin, tai häiriöt eivät integroidu mihinkään toimintoon (esim. videon katsomiseen tai korkeaan käyttötehoon), vaan tulevat sattumanvaraisesti. Muuten näyttö toimii hyvin ja ei ole ongelmia muuten tietokoneen kanssa. Mintin puolella en saanut ongelmaa ratkaistua, joten päätin kokeilla nyt Ubuntua (10.4. LTS, 32-bit) puhtaana uutena asennuksena ja sama ongelma vain jatkuu.  

Voiko tämä ongelma johtua sopimattomasta näytönohjaimen ajurista (olettaen että lähekkäin rakentuneet Mint 9 ja Ubuntu 10.04 käyttävät samaa näytönohjaimen ajuria, mutta eri mitä Mint 8 ), vai onko näyttöni yksinkertaisesti hajoamassa? Tietokoneeni on ollut käytössä alle vuoden.

Läppärini on HP Compaq Presario CQ61-210SO ja sen näytönohjain on Intel Graphics Media Accelerator 4500MHD.

Olen koittanut vaihtaa resoluutiota sekä näytön päivitystiheyttä, mutta näistä mikään ei ole auttanut.
Olen toivoton. Kaikenlaiset neuvomisyritykset otan kiitollisena vastaan!
« Viimeksi muokattu: 25.05.10 - klo:13.28 kirjoittanut mimmi »

oobetimer

  • Käyttäjä
  • Viestejä: 1470
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #1 : 25.05.10 - klo:21.48 »

Voiko tämä ongelma johtua sopimattomasta näytönohjaimen ajurista (olettaen että lähekkäin rakentuneet Mint 9 ja Ubuntu 10.04 käyttävät samaa näytönohjaimen ajuria, mutta eri mitä Mint 8 ), vai onko näyttöni yksinkertaisesti hajoamassa? Tietokoneeni on ollut käytössä alle vuoden.


Jospa kokeilet jonkin muun distron live-CD:llä, että oireileeko näyttö. Jos ei oireile, niin silloin Ubuntussa / Mintissä on vikaa..  ::)
13/2/2009 and friday....

http://debian-fi.dy.fi/

mimmi

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #2 : 25.05.10 - klo:23.31 »

Voiko tämä ongelma johtua sopimattomasta näytönohjaimen ajurista (olettaen että lähekkäin rakentuneet Mint 9 ja Ubuntu 10.04 käyttävät samaa näytönohjaimen ajuria, mutta eri mitä Mint 8 ), vai onko näyttöni yksinkertaisesti hajoamassa? Tietokoneeni on ollut käytössä alle vuoden.


Jospa kokeilet jonkin muun distron live-CD:llä, että oireileeko näyttö. Jos ei oireile, niin silloin Ubuntussa / Mintissä on vikaa..  ::)

No jos oletetaan, että vika on tullut uudempien distroversioiden myötä, niin voinko mitenkään käyttää uudempia versioita vanhemmasta lainatuilla näyttöavuilla? Uudemmassa versiossa sain toimimaan äänet sekä langattoman paljon paremmin mitä aiemmassa, niin en muuten haluaisi luopua Ubuntu 10.04 (tai Mint 9).

Pikaisesti testattuna Mint 8 livenä ei tuota näyttöhäiriöitä, mutta häiriöiden epäsäännöllisyyden takia testailen vielä huomenna paremmin tätä.

timbba

  • Käyttäjä
  • Viestejä: 1413
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #3 : 26.05.10 - klo:06.30 »
Mulla on toi sama Intelin 4500MHD näytönohjain läppärissäni ja olen käyttänyt Lubuntu 10.04 versiota täysin ongelmitta parisen kuukautta. Ettei vaan vika ole näissä turhakkeissa eli työpöytätehosteissa? Onko niitä kokeiltu ottaa pois käytöstä?

mimmi

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #4 : 26.05.10 - klo:22.39 »
Mulla on toi sama Intelin 4500MHD näytönohjain läppärissäni ja olen käyttänyt Lubuntu 10.04 versiota täysin ongelmitta parisen kuukautta. Ettei vaan vika ole näissä turhakkeissa eli työpöytätehosteissa? Onko niitä kokeiltu ottaa pois käytöstä?
Tehosteiden poisottamisen jälkeen ongelma vähän helpottuu, mutta silti tulee välillä näitä välähdyksiä. Onko vielä jotain muuta vastaavaa muutettavaa? Tai miten muuten voisin parantaa toimivuutta?

Ilmeisesti ongelma tosiaan on vain tässä uudemmassa distroversioissa, kun toinen pitempi kokeilu Mint 8:n maailmassa ei tuottanut yhtään ongelmaa koko aikana.

jemaku

  • Käyttäjä
  • Viestejä: 328
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #5 : 10.06.10 - klo:15.28 »
Suurin muutos näytönohjaimille taitaa olla KMS:ään siirtyminen.
 https://wiki.ubuntu.com/X/KernelModeSetting

Sen saa vissiin pois käytöstä Intelille komentamalla ensin
Koodia: [Valitse]
gksudo gedit /etc/modprobe.d/i915-kms.conf(Tuo siis luo tiedoston /etc/modprobe.d/i915-kms.conf)

Kirjoita sinne
 options i915 modeset=0
Tallenna ja sulje.

Ja tuo muutos kumotaan poistamalla koko /etc/modprobe.d/i915-kms.conf (Jos sitä ei ennestään ollut.)
esim. 
Koodia: [Valitse]
sudo rm /etc/modprobe.d/i915-kms.conf

Tosin täällä ei kai kirjoitella tuollaisista ongelmista, eli ei välttämättä auta.
 https://wiki.ubuntu.com/X/Quirks#Intel%20Driver%20Quirks

mimmi

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Ubuntu 10.04 & näyttöongelma
« Vastaus #6 : 12.06.10 - klo:21.56 »
Suurin muutos näytönohjaimille taitaa olla KMS:ään siirtyminen.
 https://wiki.ubuntu.com/X/KernelModeSetting

Sen saa vissiin pois käytöstä Intelille komentamalla ensin
Koodia: [Valitse]
gksudo gedit /etc/modprobe.d/i915-kms.conf(Tuo siis luo tiedoston /etc/modprobe.d/i915-kms.conf)

Kirjoita sinne
 options i915 modeset=0
Tallenna ja sulje.

Ja tuo muutos kumotaan poistamalla koko /etc/modprobe.d/i915-kms.conf (Jos sitä ei ennestään ollut.)
esim. 
Koodia: [Valitse]
sudo rm /etc/modprobe.d/i915-kms.conf

Tosin täällä ei kai kirjoitella tuollaisista ongelmista, eli ei välttämättä auta.
 https://wiki.ubuntu.com/X/Quirks#Intel%20Driver%20Quirks


Aaah, uskomatonta, mutta tämä auttoi! Kiitos, kiitos, kiitos!

Tämän tilalle tuli pienempi ongelma, jonka luulen löytäneeni selvitettynä täältä.

eli kohta 6) How to Fix the Big and Ugly Plymouth Logo in Ubuntu 10.04.

Ohjeiden mukainen toimenpide meni grubin päivitykseen asti hyvin, kunnes grubin päivitys päättyi tähän:

/etc/default/grub: 9: splash”: not found

Onko tähän vielä jotain ratkaisua?