Kirjoittaja Aihe: 9.10 Pulseaudio -> Alsa  (Luettu 4081 kertaa)

motalb

  • Käyttäjä
  • Viestejä: 275
    • Profiili
9.10 Pulseaudio -> Alsa
« : 19.03.10 - klo:23.04 »
Asentelin jokunen aika sitten testimielessä xp:n virtualboxiin karmicissa.
Toimi muuten mainiosti, mutta äänet olivat hirveän särisevät ja esimerkiksi flashvideon katsominen sai 2-ytimisen prossun lähes 100% kierroksille, vaikka virtuaalikoneelle oli annettu vain yksi ydin.
Päättelin varsin pian että ongelma piilee pulseaudiossa, mutta en löytänyt mieleistäni ratkaisua mm tältä foorumilta.
No, enpä sillä sitten suuremmin päätäni vaivannut kun pelkästä kokeilusta kuitenkin vain oli kysymys.

Eilen sitten sattumalta osuin ketjuun "pulseaudio jack alsa"
http://forum.ubuntu-fi.org/index.php?topic=32566.msg252937#msg252937

Tämän ketjun avulla löysin englanninkielisen ohjeen siitä miten pulseaudion saa sammutettua poistamatta sitä kokonaan. Kokeilin ohjetta hetimiten, ja hyvin toimii! Nyt kun alsa on aktiivinen, toimivat virtuaali xp:n äänet hienosti.


Tässä ohje suomeksi niille jotka haluavat 9.10:ssä käyttää alsaa, mutta myös helposti pulseaudiota:
(Tämä edellyttää että oikeuksien hallinta on hanskassa)

Ensin luodaan tiedosto nimeltään client.conf ja siihen kirjoitetaan rivi:
Koodia: [Valitse]
autospawn = noTiedosto tallennetaan kotikansiossa olevaan piilotettuun .pulse-kansioon. Tämä estää pulseaudiota uudelleenkäynnistymästä.
Sitten sammutetaan pulseaudio päätteessä:
Koodia: [Valitse]
pulseaudio -kJa jos pulseaudio ei käynnisty samantien uudestaan, niin ensimmäinen vaihe on onnistunut.
Jos pelkkä uudelleenkäynnistymisen estäminen ei riitä niin kannattaa siirtyä seuraavaan vaiheeseen.

Pulseaudion käynnistyminen kirjautumisen yhteydessä estetään seuraavasti:
Sijainnista /etc/X11/Xsession.d/ siirretään 70pulseaudio vaikkapa kotikansioon. Mielellään jonnekin mistä sen löytää jos haluaa palauttaa alkuperäiset asetukset. Tämä operaatio estää pulseaudiota käynnistymästä automaattisesti kirjautumisen yhteydessä.

Tarpeen mukaan pulseaudion voi käynnistää päätteessä
Koodia: [Valitse]
pulseaudio -Dja sammuttaa
Koodia: [Valitse]
pulseaudio -k

Käsittääkseni karmicissa on alsa vakiona vaikka ei toimikaan pulseaudion ollessa käynnissä. En ole varma siitä syystä että virtualboxin kanssa harjoitellessani asentelin yhtä ja toista saadakseni äänet pelittämään.
Englanninkielisessä ohjeessa suositellaan asennettavaksi gnome-alsamixer joka sekin oli minulla jo ennestään.
gnome-alsamixer löytyy ihan pakettienhallinnasta.

Alkuperäinen ohje löytyy http://ubuntuforums.org/showthread.php?t=1325890 seitsemännestä viestistä

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #1 : 19.03.10 - klo:23.55 »
Käsittääkseni karmicissa on alsa vakiona vaikka ei toimikaan pulseaudion ollessa käynnissä.

<nipo>

alsa on linuxkoneissa nykyään aina ja käytännössä se hoitaa äänilaitteita matalimmalla tasolla. ilman alsaa ei pulsesta, jackista, aRtsista, phononista, gstreamerista, jne. ole äänipuolella  yhtään mitään hyötyä, ksoka äänilaitetta ei pystytä käsittelemään.

alsa myös toimii aina jos koneesta kuuluu pihaustakaan äänikortin kautta. se, että alsaa suoraan käyttävä sovellus ei pysty varaamaan äänikorttia pulsen ollessa käynnissä on aivan toinen ongelma ja se ei todellakaan korjaannu sillä, että pulseaudio otetaan pois käytöstä. toki se vapauttaa äänilaitteen yhdelle softalle kerrallaan, mutta kaksi samanaikaista äänilähdettä ei silti onnistu.

itse olen ratkaissut edellä mainitun ongelman kierrättämällä myös alsaa suoraan käpistelevät softat pulsen kautta. aikaisemmin käytin dmixiä, mutta pulse on helpompi käyttää, konffata ja suoraan sanottuna se toimii aivan hemmetin hyvin.

</nipo>
Janne

nm

  • Käyttäjä
  • Viestejä: 13027
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #2 : 20.03.10 - klo:03.43 »
itse olen ratkaissut edellä mainitun ongelman kierrättämällä myös alsaa suoraan käpistelevät softat pulsen kautta. aikaisemmin käytin dmixiä, mutta pulse on helpompi käyttää, konffata ja suoraan sanottuna se toimii aivan hemmetin hyvin.

9.10:ssä Alsan default-äänilaite kierrätetään oletuksena PulseAudion kautta, eli käyttäjän ei tarvitse muuttaa asetuksia sitä varten. Myös dmixin pitäisi toimia suoraan, jos PulseAudio on pois päältä. Tarkemmat tekniset säädöt, kuten näytteenottotaajuuden vaihtaminen 44,1 kHz:iin on kyllä tehtävä itse .asoundrc:ssä, jos oletukset eivät riitä.

VirtualBoxin, Winen ja muiden Alsan rajapintaa käyttävien ohjelmien äänen säröytyminen on aika yleinen ongelma karmicissa ja se johtuu Alsan pulse-liitännäisessä olevasta bugista. David Henningsson on julkaissut korjauksen PPA:ssaan, mutta se ei ilmeisesti auta aivan kaikissa tapauksissa (tai käyttäjät ovat tehneet jotain väärin). Lucidissa tätä ongelmaa ei käsittääkseni enää ole.
« Viimeksi muokattu: 20.03.10 - klo:03.48 kirjoittanut nm »

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #3 : 20.03.10 - klo:11.04 »
9.10:ssä Alsan default-äänilaite kierrätetään oletuksena PulseAudion kautta, eli käyttäjän ei tarvitse muuttaa asetuksia sitä varten.

mielenkiintoista. ainakaan itselläni näin ei ole ollut, eikä muuten ollut lucidissakaan, kun jouduin sen kiintolevyrikon vuoksi asentamaan uusiksi. tämä tosin 64-bittisellä, sikäli kun siinä on eroja.

Myös dmixin pitäisi toimia suoraan, jos PulseAudio on pois päältä.

niinhän sen pitäisi ja esim. debianissa se toimiikin, mutta yhdessäkään ubuntuasennuksessa se ei ole minulla toiminut.

Tarkemmat tekniset säädöt, kuten näytteenottotaajuuden vaihtaminen 44,1 kHz:iin on kyllä tehtävä itse .asoundrc:ssä, jos oletukset eivät riitä.

kyseinen esimerkki onnistui jossain välissä jollain pulsen kilkkeelläkin, en vaan tähän hätään löydä sitä.

VirtualBoxin, Winen ja muiden Alsan rajapintaa käyttävien ohjelmien äänen säröytyminen on aika yleinen ongelma karmicissa ja se johtuu Alsan pulse-liitännäisessä olevasta bugista.

tästä tiettyjä intelin äänipiirejä vaivaavasta bugista en ollutkaan tietoinen. sen sijaan olen monesti törmännyt tapauksiin joissa ääni säröytyy alsan master volumen ollessa liian suurella. tämä on ollut ominaisuus linuxissa niin kauan kuin olen sitä itse käyttänyt.
Janne

motalb

  • Käyttäjä
  • Viestejä: 275
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #4 : 20.03.10 - klo:12.56 »
Minulle äänet eivät ole erityisen tärkeitä, ja minulla voi olla päiväkausia äänet mutella. Mutta ottaa päähän jos ne eivät sitten toimi kunnolla  kun niitä tarvitsisin. Eli tuo pulseaudion sammutusohje on varsin sopiva kaltaiselleni pekka peruskäyttäjälle joka ei ole perehtynyt äänijärjestelmien syvimpään olemukseen. Hoitaa pois akuutin ongelman ja on helppo tarvittaessa palauttaa ennalleen.

Vastauksista tuli minulle uutta tietoa alsan ja pulseaudion suhteesta. Toivottavasti muillekin, sillä jo pelkästään tällä foorumilla erilaiset ääniin liittyvät ongelmat ovat erittäin yleisiä aiheita.

Löytyisikö näihin jotain opasta jostakin? Ehkä jopa suomeksi?
itse olen ratkaissut edellä mainitun ongelman kierrättämällä myös alsaa suoraan käpistelevät softat pulsen kautta. aikaisemmin käytin dmixiä, mutta pulse on helpompi käyttää, konffata ja suoraan sanottuna se toimii aivan hemmetin hyvin
Eli miten pulsea konffataan ja miten esim wine saadaan käyttämään alsan sijasta pulsea?

Tässä voisi taas olla mahdollisuus oppia jotain uutta :)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #5 : 20.03.10 - klo:23.59 »
Eli miten pulsea konffataan ja miten esim wine saadaan käyttämään alsan sijasta pulsea?

pulsen konffaus ei varsinaisesti auta tässä tilanteessa ja winelle ei löydy oletuksena äänille pluginia pulseaudion käyttämiseksi. sen sijaan winen voi edelleen antaa käyttää alsaa suoraan, mutta alsan voi konffata niin, että ohjelmat jotka luulevat käyttävänsä alsaa suoraan, käyttävätkin pulsea.

käytännössä se menee niin, että editoidaan alsan kofigurointitiedostoa tai luodaan sellainen jos sitä ei ole olemassa. jos haluaa, että muutokset tulevat voimaan kaikille koneen käyttäjille, on syytä editoida tiedostoa /etc/asound.conf. tämän tiedoston editoiminen vaatii pääkäyttäjän oikeuksia. jos taas riittää, että asetukset on käytössä vain yhdellä käyttäjällä, voidaan editoida käyttäjän oikeuksin kotihakemistossa olevaa piilotiedostoa ~/.asoundrc.

tiedoston sisällöksi laitetaan seuraavaa:
Koodia: [Valitse]
pcm.!default {
    type pulse
}
ctl.!default {
    type pulse
}

tiedosto tallennetaan ja alsa käynnistetään uudestaan tai kone bootataan, jotta alsa käynnistyisi uudelleen.

winen kanssa ainakin karmicissa oli syytä olla käytössä wine1.2, mutta lucidissa sekä paketti wine, että paketti wine1.2 näyttävät olevan sama asia.
Janne

realpet

  • Käyttäjä
  • Viestejä: 167
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #6 : 21.03.10 - klo:10.43 »
pulsen kautta. aikaisemmin käytin dmixiä, mutta pulse on helpompi käyttää, konffata ja suoraan sanottuna se toimii aivan hemmetin hyvin.

Miten pulsen saa käyttämään SP/DIF-lähtöä automaattisesti kaikelle materiaalille niin, että kanavia ei huku matkalla eikä tarvi käsin jumpata mitään uudelleenkäynnistyksiä? Viimeksi kun turhauduin pulsen kanssa, niin tuo oli mahdotonta.

- Petri

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #7 : 21.03.10 - klo:13.13 »
Miten pulsen saa käyttämään SP/DIF-lähtöä automaattisesti kaikelle materiaalille niin, että kanavia ei huku matkalla eikä tarvi käsin jumpata mitään uudelleenkäynnistyksiä? Viimeksi kun turhauduin pulsen kanssa, niin tuo oli mahdotonta.

no, paha sanoa yleisesti, mutta omalla kohdallani käytössä on usb-dac joka näkyy koneelle ulkoisena äänikorttina. sen kanssa menen mikseri-ikonin kautta Sound Preferences ikkunaan ja siellä Hardware-tabiin. valitsen mun äänilaitteen (USB Audio DAC) ja sille profiiliksi Digital Stereo Duplex (IEC958). tosin kanavia minun tapauksessani on vain kaksi.
Janne

nm

  • Käyttäjä
  • Viestejä: 13027
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #8 : 21.03.10 - klo:16.56 »
Miten pulsen saa käyttämään SP/DIF-lähtöä automaattisesti kaikelle materiaalille niin, että kanavia ei huku matkalla eikä tarvi käsin jumpata mitään uudelleenkäynnistyksiä? Viimeksi kun turhauduin pulsen kanssa, niin tuo oli mahdotonta.

Jeps. PulseAudio ei vieläkään tue pakatun äänen (DD/DTS/MP2/...) läpivientiä, eli se on hoidettava suoraan Alsan iec958-laitteen kautta. Pulse saattaa kuitenkin varata tuon laitteen, kun se on asetetettu viemään äänet digitaaliseen ääniulostuloon ja jokin ohjelma soittaa ääntä. Tällöin äänipalvelin on sammutettava tai sen ulostuloa on vaihdettava ennen kuin digitaalista monikanavaääntä voi viedä ulos.

Pari ratkaisuvaihtoehtoa:

1. Käytä äänipiirin analogi->S/PDIF-miksausta

Jotkut äänipiirit (ainakin HDA-pohjaiset) osaavat miksata analogisen stereoulostulon äänen S/PDIF:iin silloin kun laite on PCM-tilassa. Toiminnon voi kytkeä päällä (gnome-)alsamixerin "S/PDIF"-valinnalla. Silloin läpivienti voi onnistua myös PulseAudion kanssa asettamalla sen ulostuloksi analoginen stereo. Kun mediasoitin vaihtaa S/PDIF-ulostulon DD/DTS-läpivientimoodiin, Pulsen kautta kulkevat äänet lakkaavat kuulumasta digitaaliulostulosta ja niiden sijaan viedään pakattu ääni ulkoiselle dekooderille.

Ongelmana tässä on se, että ALSA ei välttämättä osaa palauttaa analogiäänen reititystä DD/DTS-toiston jälkeen, ennen kuin kaikki äänilaitetta käyttävät ohjelmat on käynnistetty uudelleen. Ainakin itselläni on ollut tämä ongelma pitkään ja on edelleen Debianin ALSA 1.0.22:ssa. Asetusten muuttaminen iecsetillä ei auta, vaan joudun listaamaan kaikki äänilaitteita käyttävät prosessit (lsof /dev/snd/*) ja sulkemaan tai tappamaan ne. Tämän jälkeen reititys palautuu, kun seuraavan kerran toistan ääntä analogilaitteen kautta.

Pulseaudion tapauksessa äänipalvelin on käynnistettävä uudelleen, jos tämä vika iskee, eli alkuperäinen ongelma vain muuttaa hieman muotoaan. Ilmeisesti joillain Karmicin käyttäjillä homma kuitenkin toimii: http://ubuntuforums.org/showthread.php?t=1304614&page=3


2. Käynnistä mediasoitin pasuspenderilla

PulseAudion saa helposti pois alta ja iec958-laitteen vapaaksi pulseaudio-utils -paketin pasuspender-apuohjelmalla. Lisää vain "pasuspender --" mediasoittimen käynnistyskomennon alkuun. Esimerkiksi päävalikossa olevan SMPlayerin komennoksi tulisi tämä:

Koodia: [Valitse]
pasuspender -- smplayer %U
HUOM! Mediasoitin pitää asettaa käyttämään suoraan Alsan iec958-laitetta. Jos ohjelma yrittää käyttää Pulselle reititettyä Alsan oletusäänilaitetta tai Pulsea suoraan, äänen (ja todennäköisesti videon) toisto jäätyy välittömästi.




9.10:ssä Alsan default-äänilaite kierrätetään oletuksena PulseAudion kautta, eli käyttäjän ei tarvitse muuttaa asetuksia sitä varten.

mielenkiintoista. ainakaan itselläni näin ei ole ollut, eikä muuten ollut lucidissakaan, kun jouduin sen kiintolevyrikon vuoksi asentamaan uusiksi. tämä tosin 64-bittisellä, sikäli kun siinä on eroja.

Ei ole eroa; minullakin on 64-bittinen karmic, jossa tuo on toiminut ilman mitään säätämisiä. Alsan pääasetustiedoston, /usr/share/alsa/alsa.conf:n alussa ladataan /usr/share/alsa/pulse.conf, joka sisältää tällaista:

Koodia: [Valitse]
# PulseAudio alsa plugin configuration file to set the pulseaudio plugin as
# default output for applications using alsa when pulseaudio is running.
hook_func.pulse_load_if_running {
        lib "libasound_module_conf_pulse.so"
        func "conf_pulse_hook_load_if_running"
}

@hooks [
        {
                func pulse_load_if_running
                files [
                        "/usr/share/alsa/pulse-alsa.conf"
                        "/etc/asound.conf"
                        "~/.asoundrc"
                ]
                errors false
        }
]

pulse-alsa.conf puolestaan sisältää samat asetukset, jotka annoit tuossa aiemmin. Eli jos nämä tiedostot ovat paikallaan ja äänipalvelimen tunnistus (libasound_module_conf_pulse.so) toimii, ei pitäisi olla tarvetta kirjoitella omia säätöjä /etc/asound.confiin tai .asoundrc:hen. Tunnistusmekanismissa on myös se etu, että Pulsen voi halutessaan poistaa tai sammuttaa ilman että asoundrc:tä tarvitsisi käydä muokkaamassa.

Motalbilla tämä osa ainakin toimi VirtualBoxin ja Winen ääniongelmista päätellen.


Myös dmixin pitäisi toimia suoraan, jos PulseAudio on pois päältä.

niinhän sen pitäisi ja esim. debianissa se toimiikin, mutta yhdessäkään ubuntuasennuksessa se ei ole minulla toiminut.

Hmm. Ehkäpä Ubuntun ALSA-paketoinnista puuttuu sitten jotain dmix-asetuksia USB-DA-muuntimellesi. Täällä toimii tosiaan HDA:lla tuokin.
« Viimeksi muokattu: 21.03.10 - klo:17.39 kirjoittanut nm »

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #9 : 21.03.10 - klo:18.20 »
pulse-alsa.conf puolestaan sisältää samat asetukset, jotka annoit tuossa aiemmin. Eli jos nämä tiedostot ovat paikallaan ja äänipalvelimen tunnistus (libasound_module_conf_pulse.so) toimii, ei pitäisi olla tarvetta kirjoitella omia säätöjä /etc/asound.confiin tai .asoundrc:hen. Tunnistusmekanismissa on myös se etu, että Pulsen voi halutessaan poistaa tai sammuttaa ilman että asoundrc:tä tarvitsisi käydä muokkaamassa.

juu, noin tuo on lucidissakin ja ajatus tuon takana on ihan fiksu. puhtaalta pöydältä asennetussa lucidissa äänet eivät toimineet ainakaan omassa setupissani ennen manuaalista konffausta. karmicista en tiedä, koska en koskaan asentanut sitä puhtaalta pöydältä, en varmaan olisi asentanut lucidiakaan jos systeemilevyni ei olisi hajonnut.

Motalbilla tämä osa ainakin toimi VirtualBoxin ja Winen ääniongelmista päätellen.

minulla muuten toimi äänet moitteetta sekä virtualboxissa että wine1.2:ssa karmicin puolella ja nyt lucidissa wine1.2:lla. virtualboxia minulla ei ole ollut vielä tarvetta käyttää. tämä sekä koti- että työkoneella.

Hmm. Ehkäpä Ubuntun ALSA-paketoinnista puuttuu sitten jotain dmix-asetuksia USB-DA-muuntimellesi. Täällä toimii tosiaan HDA:lla tuokin.

ongelma ei ole esiintynyt ainoastaa kotikoneellani vaan myös töissä intelin äänipiirillä. manuaalikonffauksen jälkeen sekin on toennut.
Janne

realpet

  • Käyttäjä
  • Viestejä: 167
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #10 : 21.03.10 - klo:22.59 »
Lainaus
Miten pulsen saa käyttämään SP/DIF-lähtöä automaattisesti kaikelle materiaalille niin, että kanavia ei huku matkalla eikä tarvi käsin jumpata mitään uudelleenkäynnistyksiä? Viimeksi kun turhauduin pulsen kanssa, niin tuo oli mahdotonta.

Jeps. PulseAudio ei vieläkään tue pakatun äänen (DD/DTS/MP2/...) läpivientiä, eli se on hoidettava suoraan Alsan iec958-laitteen kautta. Pulse saattaa kuitenkin varata tuon laitteen, kun se on asetetettu
...
...
Asetusten muuttaminen iecsetillä ei auta, vaan joudun listaamaan kaikki äänilaitteita käyttävät prosessit (lsof /dev/snd/*) ja sulkemaan tai tappamaan ne. Tämän jälkeen reititys palautuu, kun seuraavan kerran toistan ääntä analogilaitteen kautta.
...
...
Lisää vain "pasuspender --" mediasoittimen käynnistyskomennon alkuun. Esimerkiksi päävalikossa olevan SMPlayerin komennoksi tulisi tämä:

HUOM! Mediasoitin pitää asettaa käyttämään suoraan Alsan iec958-laitetta. Jos ohjelma yrittää käyttää Pulselle reititettyä Alsan oletusäänilaitetta tai Pulsea suoraan, äänen (ja todennäköisesti videon) toisto jäätyy välittömästi.
...

Eli tuossa yllä näkyy juurikin ponttini :). Kun Ubuntun jakeluun tuotiin Pulse mukaan niin
a) Käyttiksen updaten yhteydessä täysin toimiva monikanava-spdif-alsa-konfiguraatio rikkui niin että heilahti
b) Se ensimmäinen mukaan otettu Pulsen versio oli verisesti rikki
c) Ei se Pulse toimi yllämainitussa kokoonpanossa vieläkään

HTPC-kokonpanossani tuon Pulsen mukaantulon jälkeen monen epätoivoisen konfigurointisession jälkeen Pulse lähti mäkeen kuin nato-ohjus ja takaisin ei tule. Miksi ihmeessä se piti ottaa jakeluun mukaan oletuskonfiguraationa?

Asiasta mitään isommin ymmärtämättä en pysty käsittämään sitä, miksei Pulse pysty käsittelemään noita pakattuja ääniä ja ainakin viimeksi kun jaksoin jotain aiheeseen liittyvää viestiketjua seurata, oli kehittäjän mielipide se, että 'ei se nyt vaan onnistu' kun jotenkin mystisesti alsalla asian pystyy kuitenkin konfiguroimaan.

- Petri

nm

  • Käyttäjä
  • Viestejä: 13027
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #11 : 22.03.10 - klo:00.10 »
Asiasta mitään isommin ymmärtämättä en pysty käsittämään sitä, miksei Pulse pysty käsittelemään noita pakattuja ääniä ja ainakin viimeksi kun jaksoin jotain aiheeseen liittyvää viestiketjua seurata, oli kehittäjän mielipide se, että 'ei se nyt vaan onnistu' kun jotenkin mystisesti alsalla asian pystyy kuitenkin konfiguroimaan.

Mielestäni pelkkä ALSA ei toimi sen paremmin, eli jos jokin ohjelma soittaa ääntä digitaaliseen ulostuloon, pakatun äänen läpivienti ei toimi samanaikaisesti, eikä mediasoitin edes pysty avaamaan äänilaitetta. Sitten kun muut ohjelmat sulkee pois, läpivienti onnistuu. Myös Pulsen kanssa läpiviennin pitäisi toimia silloin kun äänipalvelimella ei ole aktiivisia asiakkaita. Jos näin ei ole Karmicin Pulsessa, siinä on varmaankin bugi.

Sinänsä S/PDIF-läpiviennin toteuttamisessa äänipalvelimeen ei pitäisi olla mitään ylipääsemätöntä teknistä estettä, eli Pulse voisi vain vaihtaa passthrough-tilaan silloin kun jokin ohjelma haluaa toistaa pakattua ääntä. Miksaus ei toimisi ja ainoastaan yksi ohjelma voisi toistaa ääntä kerrallaan, mutta yleensähän tämä riittää. Lisäksi miksaus olisi mahdollista toteuttaa purkamalla ja pakkaamalla ääni uudelleen lennossa AC-3-formaattiin, vaikka se lisääkin hieman viivettä.

Nykyisillä kehittäjillä ei tunnu olevan suurta mielenkiintoa tämän toteuttamiseen, eli jonkun muun pitäisi tarttua projektiin. Nythän Canonical palkkaa sopivasti Ubuntu Desktop Sound Engineerin, joten työhakemusta vain sisään. ;)

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #12 : 22.03.10 - klo:11.08 »
Lainaus
Nythän Canonical palkkaa sopivasti Ubuntu Desktop Sound Engineerin, joten työhakemusta vain sisään.

Tuleekohan lyhyt oikeasti mahdollisten hakijoiden lista:  "nm", "aoa", ?,,, :)
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

planetisti

  • Käyttäjä
  • Viestejä: 421
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #13 : 22.03.10 - klo:12.11 »
Linuxin vapaus on tässä selkeästi edistystä haittaava tekijä. On saatava yhteinen systeemi, mutta siihen käyttäjät eivät suostu. Aina joku ominaisuus puuttuu tai joku ei toimi. Vähintään jonkun ohjelman lähdekoodista kääntäminen on pakollista. Distribuutiot ovat osasyy, kuten ohjelmien kehittäjät. Alkaa pikkuhiljaa menemään hermo tähän amatöörimäiseen pelleilyyn näiden eri systeemeiden kanssa. Mutta minkäs teet...

Itselleni uusin ihanuus on se, ettei ffado toimi uuden firewire-stackin kanssa. Olipa  hieno juttu, monta vuotta säädetään, ja valmis koodi oli ajan tasalla varmaan alle vuoden.

Tässä hienoa keskustelua asiaan liittyen, eikä tästä taida mitään tulla tulevaisuudessakaan asenteista päätellen:
http://insanecoding.blogspot.com/2009/06/state-of-sound-in-linux-not-so-sorry.html

EDIT: anteeksi hieman OT vuodatus, en vain pysty käsittämään tätäkään ongelmaa, ilmeisesti lennart ei omista digitaalisen tulon omaavaa vahvistinta...
« Viimeksi muokattu: 22.03.10 - klo:12.23 kirjoittanut planetisti »

eap

  • Käyttäjä
  • Viestejä: 240
  • si fallor sum
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #14 : 22.03.10 - klo:15.32 »
Taitaa mennä vähän OT, mutta minulla tämä Pulse on aiheuttanut sen, että 8.04 (32 bit) jälkeisissä ubuntuissa en ole saanut skypeä toimimaan siten, että tuleva ja lähtevä ääni pelaisi usb-headsetissa ja soitto koneen kajareista. 8.04:ssä tämä vielä onnistuu. Skype kyllä pelaa näissä uudemmisssakin, mutta kaikki äänet kulkevat samaa reittiä. Muuten äänet pelaavat haluamallani tavalla, mutta Skype on minulle se tärkein ja juuri mainitsemallani systeemillä (salarakas ei jaksa kuunnella ääntäni "tynnyristä" (=koneen kajarit ja pöytämikki)) :) . Liekö sitten syy pulsen vai skypen.

Linux user #424871

Kullervo

  • Käyttäjä
  • Viestejä: 830
    • Profiili
Vs: 9.10 Pulseaudio -> Alsa
« Vastaus #15 : 22.03.10 - klo:15.53 »
Taitaa mennä vähän OT, mutta minulla tämä Pulse on aiheuttanut sen, että 8.04 (32 bit) jälkeisissä ubuntuissa en ole saanut skypeä toimimaan siten, että tuleva ja lähtevä ääni pelaisi usb-headsetissa ja soitto koneen kajareista.

Minä ratkaisin vastaavan ongelman asentamala  paprefs-paketin (PulseAudio-Asetukset) ja sen Simultaneus Output välilehdelle väkänen "Lisää näennäisulostulolaite...." -kohtaan.

Lisäys:
Ja kyse on Karmic / Skype kokoonpanosta
« Viimeksi muokattu: 22.03.10 - klo:15.56 kirjoittanut Kullervo »