Kirjoittaja Aihe: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04  (Luettu 2871 kertaa)

Janiporo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Eli tarkotus olisi saada kyseinen purkki mounttaamaan automaattisesti ubuntun käynnistyessä.

Salasanan olen tietty peittänyt muotoon ****, ja muitakin tietoja "vääristellyt"  :P
(ja tiijän et tää ei oo nyt turvallinen tapa laittaa salasanoi tonne /etc/fstab -tiedostoon, mut haluisin saada ton vaan mounttimaan kiltisti, ja sit miettii siitä etiäppäi)  ::)

"manuaalisesti" saan sen mounttaamaan terminaalissa komennolla:
Koodia: [Valitse]
sudo mount -t smbfs //192.168.1.100/Volume_1 /media/stg5 -o username=WORKGROUP/admin,password=****  ;D

Jos koitan lisätä /etc/fstab -tiedostoon (roottina tietenkin) seuraavan pätkän siihen ihan loppuun:
Koodia: [Valitse]
//192.168.1.100/Volume_1 /media/stg5 -o username=WORKGROUP/admin,password=****
Ni terminaali huutelee (mount -a -käskyllä):
Koodia: [Valitse]
mount: tuntematon tiedostojärjestelmän tyyppi ”-o”
  >:(

Apuuva, miten saan tuon oikeellalailla aseteltua, en edes tiedä mikä tuo -o -valitsin on, enkä löydä justiinsa dataa siitä.  ???

Tähän on varmaan joku kiertokonstikin, miten ton saa tehtyy jollai skriptil, mutta tahtosin saaha sen nyt noin "oikeel" taval.

Puuttuuko joku ohjelma vai oonko vaan urpo, kiitos  ;D

jurkki

  • Käyttäjä
  • Viestejä: 48
    • Profiili
Vs: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04
« Vastaus #1 : 13.02.10 - klo:08.31 »
Koetas
Koodia: [Valitse]
//192.168.1.100/Volume_1  /media/stg5  smbfs  username=WORKGROUP/admin,password=****  0 0

tosiutelias

  • Käyttäjä
  • Viestejä: 171
    • Profiili
Vs: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04
« Vastaus #2 : 13.02.10 - klo:08.35 »
Minun silmääni pistää tuo "-o", vaihda se "smbfs":ksi, itselläni tuo rimpsu on:
Koodia: [Valitse]
//192.168.10.45/Volume_2 /mnt/tila smbfs guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0
No niin, olin hidas, mutta nuo loppu rimpsut vaikutti WIN yhteensopivuuteen (lähinnä skandeihin).

Janiporo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04
« Vastaus #3 : 13.02.10 - klo:15.39 »
Jurkin ohje toimi. ;D

Tosiutelias, ilimottaa: 
mount: tuntematon tiedostojärjestelmän tyyppi ”unicode”  :o

Kokeilen tuolla ekalla nyt, jos ilmenee onkelmia, niin palaan asialle. ja Jurkki, KIITOS!  ;D

Janiporo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04
« Vastaus #4 : 14.02.10 - klo:13.49 »
Eli ne skandit, tms merkistökoodaus on sit seuraava ongelma  ::)

Isänmaantoivot tiedostokansio näkyy seuraavasti:
"Is�nmaantoivot (virheellinen merkistökoodaus)"

Koitan setvii tota itekki, mut kaikki apu kelpaa kyllä  ???


Janiporo

  • Käyttäjä
  • Viestejä: 51
    • Profiili
Vs: Samba + D-LINK DNS-323 verkkolevy + automount. Ubuntu 8.04
« Vastaus #5 : 15.02.10 - klo:18.31 »
Tällä hoitu homma, niin että win yhteensopivuus toteutuu esim skandien osalta:

Koodia: [Valitse]
//192.168.1.100/volume_1 /media/stg5 smbfs username=WORKGROUP/admin,password=****,uid=1000,iocharset=utf8,unicode 0 0
Eli kiitos molemmille, kun lainasin hiukka kummaltakin  ;D

Tosiutelias:
Testaillessani ilmotti erroriks "Warning: ignoring deprecated smbfs option 'codepage=unicode'"
Ni jätin siis tästä pois tuon pätkän "codepage=unicode," Ja homma toimi  ::)