Kirjoittaja Aihe: Ongelma SIS-näytönohjaimen kanssa!  (Luettu 2403 kertaa)

ATKD

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Ongelma SIS-näytönohjaimen kanssa!
« : 26.12.09 - klo:15.11 »
Latasin netistä sis_drv.o-402 näytönohjaimen, mutta minä en tiedä miten ihmeessä se asennetaan...
Onko ehdotuksia?

ATKD
« Viimeksi muokattu: 26.12.09 - klo:20.37 kirjoittanut Tuplanolla »

Jakke77

  • Käyttäjä
  • Viestejä: 3933
  • Oulu (Oinaansuo)
    • Profiili
U_G_H

Aspire E5-575G V1.27 CPU: Intel i3-6100U (4) @ 2.300GHz GPU: Intel® HD Graphics 520 GPU: NVIDIA GeForce 940MX Samsung SSD 970 EVO Plus 500GB

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Vs: Ongelma SIS-näytönohjaimen kanssa!
« Vastaus #2 : 26.12.09 - klo:20.38 »
Minkälainen näytönohjain se on?
Päätteeseen lspci ja sen tuloste tänne.

Eikö toimi hyvin vai miksi tarvitsee ajuria asentaa erikseen?

ps. laitoin vähän kivemman aiheen ;)
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

ATKD

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Ongelma SIS-näytönohjaimen kanssa!
« Vastaus #3 : 28.01.10 - klo:20.14 »
Minkälainen näytönohjain se on?
Päätteeseen lspci ja sen tuloste tänne.

Eikö toimi hyvin vai miksi tarvitsee ajuria asentaa erikseen?

ps. laitoin vähän kivemman aiheen ;)

00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-to-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)

Tossa toi tuloste on.. :)

http://ubuntuforums.org/showpost.php?p=5028155&postcount=5 ei toimi :(

Zarok

  • Käyttäjä
  • Viestejä: 23
    • Profiili
Vs: Ongelma SIS-näytönohjaimen kanssa!
« Vastaus #4 : 30.01.10 - klo:00.19 »
Täällä päässä valitettavasti painitaan saman piirisarjan kanssa ja Asus K50C läppärin kera.

Olen SiS on Linux ja Antonio J Oliveiran sivun pohjalta koittanut ratkaista ongelmaa. Olen käyttänyt noita .deb-pakattuja esikäännettyjä ajureita, jotka luovat itselleen sopivan xorg.confin automaattisesti ja kopioi ajurifilet paikalleen.

Ongelma tulee sen jälkeen kun koitan käynnistää tietokoneen. Olen löytänyt Ubuntu Forumsilta monia menestystarinoita noiden kanssa, mutta ongelmana tuntuu olevan tämän näytön paneeli. Kaikki onnistujat ilmoittavat käyttäneensä näyttöä jossa oletusresona on 1280x800, ja tässä näytössä oletus on 1366x768. Lopputuloksena saan rebootin jälkeen ruutuun vaan muutaman vilkkuvan väriviivan, ja siinä se.

Olettaisin että minun pitää säätää xorg.confia tarkemmin saadakseni ruudun asetukset toimimaan, mutta omat kyvyt eivät tähän todellakaan riitä. Olisiko jollain taitavammalla kaverilla kykyä neuvoa? Avopuoliso saa raivaria ajatuksesta että joutuisi käyttämään Windowsia, ja tämä 800x600-reso ei oikein ole toimiva.

Edit: Ilmeisesti olen oikeassa tuon xorg.conf-homman kanssa, löysin Launchpadista toisen henkilön saman läppärimallin kanssa jolla tulee samaa ongelmaa. Omista logeista löytyy samoja virheitä kuin tuosta pastebin-linkistä/launchpad-postista.
« Viimeksi muokattu: 30.01.10 - klo:00.42 kirjoittanut Zarok »

tuke81

  • Käyttäjä
  • Viestejä: 1667
    • Profiili
Vs: Ongelma SIS-näytönohjaimen kanssa!
« Vastaus #5 : 01.02.10 - klo:17.43 »
Uhh SiS, ei ole kyllä helppoa saada tuota toimimaan muulla kuin Vesa:lla. Mitä nyt tuota yhtä logia katsoin, niin kaikki tarjolla olevat metamodet hylätään eikä X:lle ole käytössä yhtään sopivaa modea. Onkos koneella windowssia? Windowsin käyttämän modelinen saa powerstrip softalla kattottua, tuolla on ohjeet.

Toki jos omakone olisi tekisin pikaisen modelinen generaattorilla(luultavasti hankkiutuisin eroon melko pikaisesti):
Koodia: [Valitse]
~$ cvt -r 1366 768 60
# 1368x768 59.85 Hz (CVT) hsync: 47.28 kHz; pclk: 72.25 MHz
Modeline "1368x768R"   72.25  1368 1416 1448 1528  768 771 781 790 +hsync -vsync

Lisäisin hieman tavaraa /etc/X11/xorg.confiin:
Koodia: [Valitse]

...
Section "Monitor"
   #omille rivilleen. Se mikä tässä jo on valmiina, saa olla jatkossakin
   # 1368x768 59.85 Hz (CVT) hsync: 47.28 kHz; pclk: 72.25 MHz
   Modeline "1368x768R"   72.25  1368 1416 1448 1528  768 771 781 790 +hsync -vsync
EndSection
...
Section "Screen"
    #Tähän lisätään seuraavanlainen subsectioni ellei tuota jo ole
    SubSection     "Display"
        Depth       24
        Modes       "1368x768R" "1024x768" "800x600" "720x400" "640x480" #modelinesta suoraan toi nimi 1368x768R
    EndSubSection
EndSection
...

En todellakaan tiedä toimiiko se tuolla modelinella/onko se varmasti turvallinen. 60hz kuiten yleisesti tft virkistystaajuus, eikä tuo pixel clockaan kuulosta liian isolta, mutta omalla vastuulla sitten kokeilette. Jos saat powerstripillä sen modelinen käytä sitä, sen nyt varmasti luulisi toimivan ellei sitten tuossa sis:n ajurissa ole bugeja  ::). Dri tukea ei tuolle ole .l 3D:tä et tule saamaan toimimaan ja EXA:n sijaan XAA:ta varmaankin tulisi käyttää. Nyt jo pelkkä kuvan saaminen näytölle noilla ajureilla on jo iso voitto...
Miksi tehdä jotain helposti, kun sen voi tehdä vaikeastikin...