Kirjoittaja Aihe: Locale ongelma: ääkköset eivät toimi Ubuntu server 9.10:ssä  (Luettu 12218 kertaa)

Grainer

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Päivitin ubuntu server 9.04:n 9.10:een ja ääkköset lakkasivat toimimasta. Olen varmistanut kielipakettien asennuksen (language-pack-fi, language-pack-fi-base) ja puukottanut localesäädöt /etc/environment -tiedostoon.

Localesäädöt ovat:
Koodia: [Valitse]
grainer@linuxservu:~$ locale
LANG=en_US.UTF-8
LANGUAGE=en_US:en
LC_CTYPE=fi_FI.UTF-8
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE=fi_FI.UTF-8
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES=en_US.UTF-8
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=
grainer@linuxservu:~$ more /etc/environment
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANG="en_US.UTF-8"
LC_CTYPE="fi_FI.UTF-8"
LC_COLLATE="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"
LC_NUMERIC="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_MEASUREMENT="fi_FI.UTF-8"
LC_IDENTIFICATION="fi_FI.UTF-8"
LANGUAGE="en_US:en"
grainer@linuxservu:~$

Tarkoituksena olisi, että järjestelmän kieli olisi englanti, mutta ääkkösetkin toimisivat (eli virheilmoitukset yms. tulisivat englanniksi, jolloin ne voi suoraan googlata). LC_ALL:n säätäminen suomeksi ei tunnu muuttavan mitään.

Terminaalissa ääkköset toimivat yhden kirjaimen viiveellä jotenkin oudosti. Jos esimerkiksi kirjoitan "äää" ja painan entteriä, järjestelmä näkee komennon "ää", jos tämän jälkeen kirjoitan komennon "ls" , järjestelmä löytää jostain kadonneen kolmannen ä-kirjaimen ja näkee komentoni "äls". Tämän jälkeen ei-ääkkösiä sisältävät komennot toimivat oikein. Ääkkösiä sisältävä outputti (esim. tiedostolistaus, missä tiedostonimissä on ääkkösiä) ei näy oikein.

Grainer

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Updatea:

Jos otan winukkakoneelta puttyllä yhteyttä servuun, putty säädettynä UTF-8 tilaan, niin motdin vanhan osan ääkköset näkyvät oikein, mutta uuden osan ei. Jos taas otan ISO-8859-15 -tilassa yhteyttä, niin uuden osan ääkköset näkyvät oikein, mutta vanhan osan ei.

Locale väittää edelleen, että servu käyttää UTF-8:ia.


Edit:
Muokkasin motdia siis screenin sisältä vimillä puttyn kautta (säädettynä UTF-8:lle). Vimissä kummatkin ääkköset näkyivät mystisesti oikein. Myös irssissä ääkköset toimivat tällä hetkellä.
« Viimeksi muokattu: 08.12.09 - klo:21.26 kirjoittanut Grainer »

nm

  • Käyttäjä
  • Viestejä: 13096
    • Profiili
Tarkista, että nuo molemmat käyttämäsi localet on listattu /var/lib/locales/supported.d -hakemiston tiedostoissa: cat /var/lib/locales/supported.d/*

Jos ei ole, lisää puuttuva locale uudelle riville vaikkapa /var/lib/locales/supported.d/local -tiedostoon.

Aja sitten sudo dpkg-reconfigure locales vaikka et olisikaan muuttanut mitään -- tällä varmistetaan, että localet on oikeasti tehty järjestelmään. Katso, että dpkg-reconfigure locales tosiaan tekee molemmat.

Grainer

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Kiitoksia. Localet löytyvät, eli tässä ei ole virhettä. Olen väliaikaisratkaisuna siirtynyt käyttämään fi_FI@euro localea. Sillä ääkköset näkyvät oikein työkoneelta (työkoneella jokin Fedoran versio ja localena juuri fi_FI@euro). Kotikoneellakin toimii, kun puttyn säätää tätä vastaavasti. Ongelmana on vain se, että tietääksen 9.04-käyttiksellä minulla oli käytössä UTF-8. Pitänee varmaan kaivaa kaapista vanha käyttämätön palvelinkone ja asentaa siihen Ubuntu server 9.04 (ulkomuistista samoin kuin asensin nykyiselle palvelinalustalle) ja katsoa, että mitkä localesäädöt siellä on oletuksena. Muistaakseni en niitä erityisemmin tuunaillut sillon ja tosiaan muistelen niiden olleen UTF-8 -merkistöllä.

Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
Päivitin ubuntu server 9.04:n 9.10:een ja ääkköset lakkasivat toimimasta. Olen varmistanut kielipakettien asennuksen (language-pack-fi, language-pack-fi-base) ja puukottanut localesäädöt /etc/environment -tiedostoon.

Tarkoituksena olisi, että järjestelmän kieli olisi englanti, mutta ääkkösetkin toimisivat (eli virheilmoitukset yms. tulisivat englanniksi, jolloin ne voi suoraan googlata). LC_ALL:n säätäminen suomeksi ei tunnu muuttavan mitään.

Terminaalissa ääkköset toimivat yhden kirjaimen viiveellä jotenkin oudosti. Jos esimerkiksi kirjoitan "äää" ja painan entteriä, järjestelmä näkee komennon "ää", jos tämän jälkeen kirjoitan komennon "ls" , järjestelmä löytää jostain kadonneen kolmannen ä-kirjaimen ja näkee komentoni "äls". Tämän jälkeen ei-ääkkösiä sisältävät komennot toimivat oikein. Ääkkösiä sisältävä outputti (esim. tiedostolistaus, missä tiedostonimissä on ääkkösiä) ei näy oikein.

Aivan sama juttu (äää -> ää) oli omassa serverissä. Paitsi, että sen älkeen, kun olin ottanut PuTTY:llä yhteyttä koneeseen, kaikki localet ovat olleet POSIX ja scandit eivät toimi nappaimistolta lainkaan, edes SSH 3.2.9:llä.
Jokseenkin kaikkea on tullut kokeiltua, paitsi meditointia.

Alkaa jo ihmetyttää, miten nämä localet pitäisi saada käyttöön. Usealta palstalta löytyy guru-tieto, että UTF-8 on natiivisti käytössä. Loppukäyttäjät eivät kuitenkaan tunnu tätä käsittävän, koska kaikki kokeilut viittaavat aivan muuhun. Monelta taholta on myös kerrottu, että asetukset asettuvat oikein asennuksessa. Vaan kun eivät asetu.
Asetukset pitäisi tehdä /etc/default/locale -tiedostoon, eikä /etc/environment. Tälläkään ei näytä olevan lopullista vaikutusta, koska ainakin itselläni molemmissa on kopioituna yllä olevan listan mukaiset arvot. Silti locale -komento ilmoittaa kaikiksi arvoiksi 'POSIX' vielä koneen boottauksen jälkeenkin.

Toivottavasti joku jossain joskus ottaa työkseen ja korjaa viimeinkin tämän localisaation kuntoon. Tätä on nimittäin odotettu jo kohta 15 vuotta. Muutoksia kyllä on tullut, mutta ei korjauksia. Hyvä ohjekin olisi riittävä. Jos tämä lokalisaatio olisi ratkottavissa antamalla nippu komentoja, ne varmaan voisi kirjata scriptin muotoon.
Itse olisin valmis vaikka formatoimaan kaikki serverini, jos tuon scriptin ajo vaatisi sitä.
« Viimeksi muokattu: 19.01.10 - klo:02.32 kirjoittanut Mistofelees »

retu

  • Käyttäjä
  • Viestejä: 905
    • Profiili
En tiedä auttaako, mutta olen törmännyt tämmöiseen:

Päivitin läppärille xubuntun 9.10 version. Kyseessä siis englanninkielinen. Asentelin sitten samalla kertaa suomalaiset locale asetukset eli muutin (muistaakseni /etc/default/locale -tiedostoon) samat asetukset kuin tuossa alkuviestissä ja loin localen fi_FI.UTF-8.

Koodia: [Valitse]
sudo locale-gen fi_FI.UTF-8
Moni ohjelma ei tottele näitä asetuksia, joten eihän se kaikkea korjannut, mutta ilokseni huomasin mm. oletus paperikoon muuttuneen joissakin ohjelmissa A4:ksi.

Kun avasin läppäriltä ssh-yhteyden ubuntu server koneelleni (LTS 8.04), huomasin etteivät ääkköset enää toimineet näppäimistöltä. Katsoin locale komennolla että käytössä oli suomalaiset asetukset eli muuttujat kopioituivat ssh-yhteyden yli. Ajoin sitten em. locale-gen komennon myös serverillä ja ääkköset toimivat taas.

Jos avaan ssh-yhteyden windowsista käyttäen cygwin + openssh yhdistelmää, ääkköset temppuilevat juuri kuten 1. viestissä. Tiedostonimissä olevat ääkköset eivät myöskään näy oikein. Kun avaan yhteyden puttyllä (utf-8 merkistö valittu yhteysasetuksista), kaikki toimii kuten pitääkin. Tällä hetkellä palvelimella on seuraavat localet:

Koodia: [Valitse]
$ locale -a
C
en_US.utf8
fi_FI.utf8
POSIX
Ehkä yhteyden saisi jotenkin toimimaan myös cygwinin kautta, ilman utf-8 merkistöä, mutta ei mielestäni maksa vaivaa. Pelkään rikkovani jotain  ;D


Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
En tiedä auttaako, mutta olen törmännyt tämmöiseen:

Päivitin läppärille xubuntun 9.10 version. Kyseessä siis englanninkielinen. Asentelin sitten samalla kertaa suomalaiset locale asetukset eli muutin (muistaakseni /etc/default/locale -tiedostoon) samat asetukset kuin tuossa alkuviestissä ja loin localen fi_FI.UTF-8.

Koodia: [Valitse]
sudo locale-gen fi_FI.UTF-8
Moni ohjelma ei tottele näitä asetuksia, joten eihän se kaikkea korjannut, mutta ilokseni huomasin mm. oletus paperikoon muuttuneen joissakin ohjelmissa A4:ksi.

Kun avasin läppäriltä ssh-yhteyden ubuntu server koneelleni (LTS 8.04), huomasin etteivät ääkköset enää toimineet näppäimistöltä. Katsoin locale komennolla että käytössä oli suomalaiset asetukset eli muuttujat kopioituivat ssh-yhteyden yli. Ajoin sitten em. locale-gen komennon myös serverillä ja ääkköset toimivat taas.

Jos avaan ssh-yhteyden windowsista käyttäen cygwin + openssh yhdistelmää, ääkköset temppuilevat juuri kuten 1. viestissä. Tiedostonimissä olevat ääkköset eivät myöskään näy oikein. Kun avaan yhteyden puttyllä (utf-8 merkistö valittu yhteysasetuksista), kaikki toimii kuten pitääkin. Tällä hetkellä palvelimella on seuraavat localet:

Koodia: [Valitse]
$ locale -a
C
en_US.utf8
fi_FI.utf8
POSIX


En saanut vieläkään toimimaan.
root@XXXX:~# dpkg-reconfigure localepurge
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LC_MONETARY = "en_US.ISO8859-1",
        LC_NUMERIC = "en_US.ISO8859-1",
        LC_MESSAGES = "C",
        LC_COLLATE = "en_US.ISO8859-1",
        LC_CTYPE = "iso_8859_1",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Package configuration

Huvittavana sivujuonena on sekin, että locale -a antaa ison pinon EN-localeja, vaikka ne eivät näy localepurgen listalla. Fi-lokaaleista sensijaan on selvä pula. Toisaalta EN:
root@XXXX:~# locale -a
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
en_AG
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_NG
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZW.utf8
fi_FI.utf8

Ottaen huomioon, että asennus on tehty suoraan levyltä, minusta asiat voisivat olla paremminkin.

retu

  • Käyttäjä
  • Viestejä: 905
    • Profiili
On mullakin läppärillä noita koko liuta, mutta ei ylimääräisistä localeista liene mitään haittaa. Paitsi vievät tietysti hieman levytilaa. Serverillä on kuitenkin vain edellisessä viestissä mainitut. Liittyisikö ne ylimääräiset kielipaketteihin. Eli luo ne varmaan automaattisesti, jos on graafinen käyttöliittymä ja englannin kieli asennettu. En ole asentanut suomi-paketteja (language-pack-fi tai language-pack-fi-base) kumpaankaan, kun en kaipaa suomennoksia. Luon vain asetustiedostot locale-gen komennolla.

Tämä herja: "locale: Cannot set LC_CTYPE to default locale: No such file or directory" kertoo että LC_CTYPE asetus on pielessä. 1. litaniassa mainitaan LC_CTYPE = "iso_8859_1" ???, onko tuommoista olemassakaan. Samoin LC_COLLATE = "en_US.ISO8859-1", mutta kuitenkin "en_US.ISO8859-1" puuttuu. Pitäisi siis korjata nuo asetukset vaikka "fi_FI.UTF-8" muotoon.

Yritin edellä kertoa ettei ssh-yhteys päätteestä toimi, jos koneilla on eri merkistö (cygwin & iso8859-1 vs. ubuntu & utf-8). Ehkä sen saa toimimaan luomalla puuttuvat localet ja laittamalla asetukset kohdalleen. En ole kokeillut eikä minusta kannatakaan, koska utf-8 on parempi ;D Helpointa on käyttää yhteysohjelmaa, kuten putty, jossa merkistön voi valita yhteysasetuksista kohdekoneen mukaan.

Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
Tämä herja: "locale: Cannot set LC_CTYPE to default locale: No such file or directory" kertoo että LC_CTYPE asetus on pielessä. 1. litaniassa mainitaan LC_CTYPE = "iso_8859_1" ???, onko tuommoista olemassakaan. Samoin LC_COLLATE = "en_US.ISO8859-1", mutta kuitenkin "en_US.ISO8859-1" puuttuu. Pitäisi siis korjata nuo asetukset vaikka "fi_FI.UTF-8" muotoon.

Joo, kiitos. En minäkään tiedä, miten nuo asetukset voisi korjata vaikka "fi_FI.UTF-8" muotoon.
Ihmetyttää kyllä hieman, miten serverissä voi olla tuollaiset "onko olemassakaan" asetukset, koska koko asennus on tehty srv-CD:ltä.

retu

  • Käyttäjä
  • Viestejä: 905
    • Profiili
Öh, jos se /etc/default/locale kerran on ok, mutta locale komento kertoo jotain ihan muuta, niin jossain välissähän ne menee vituralleen. Ei kait sitten muu auta kuin että pitäisi vaan ruveta järjestelmällisesti selvittämään missä välissä.

timbba

  • Käyttäjä
  • Viestejä: 1413
    • Profiili
Onko tuohon locale ongelmaan kellään ratkaisua? Itsellä:

locale
Koodia: [Valitse]
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

cat /etc/default/locale
Koodia: [Valitse]

LC_MESSAGES="fi_FI.UTF-8"
LANG="fi_FI.UTF-8"      
LC_PAPER="fi_FI.UTF-8"  
LC_MEASUREMENT="fi_FI.UTF-8"
LC_NUMERIC="fi_FI.UTF-8"
LC_MONETARY="fi_FI.UTF-8"
LC_TIME="fi_FI.UTF-8"  
LC_CTYPE="fi_FI.UTF-8"  
LC_COLLATE="fi_FI.UTF-8"
LC_NAME="fi_FI.UTF-8"
LC_ADDRESS="fi_FI.UTF-8"
LC_TELEPHONE="fi_FI.UTF-8"
LC_ALL="fi_FI.UTF-8"

locale -a
Koodia: [Valitse]
C
POSIX
en_US.utf8
fi_FI.utf8

En ymmärrä.. Tämä siis ssh:n yli.
« Viimeksi muokattu: 14.02.10 - klo:07.21 kirjoittanut timbba »

timbba

  • Käyttäjä
  • Viestejä: 1413
    • Profiili
Ja ratkaisu löytyi sitten melko nopeasti :)

Eli serverin päätyyn yks rivi lisää ssh:n tiedostoon /etc/ssh/sshd_config:
Koodia: [Valitse]
AcceptEnv LANG LC_* LANGUAGE

Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
Ja ratkaisu löytyi sitten melko nopeasti :)

Eli serverin päätyyn yks rivi lisää ssh:n tiedostoon /etc/ssh/sshd_config:
Koodia: [Valitse]
AcceptEnv LANG LC_* LANGUAGE

Ei auta minun serverissäni. Ellen sitten ymmärrä jotenkin ohjettasi väärin.
Tuolla /etc/ssh/sshd_config -tiedostossa on jo rivi:
AcceptEnv LANG LC_*
Siis ilman sanaa 'LANGUAGE'
Pitääkö sen siis olla 'LANGUAGE' vai jokin kieltä ilmaiseva sana, esim 'fi' tai 'FI' tai 'fi_FI' tai jotain muuta ?

Aikani kokeiltuani hävisivät scandit kokonaan SSH 3.2.9:stä. Ruudulle ei siis tule mitään komentorivillä. JOE-editorissa sentään tulee d ja v valkoisen mustalla pohjalla.

Vaikuttaa siltä, että kenelläkään ei ole tuolla kehittelypäässä aikaa pistäää näitä Linuxin aakkosia kuntoon. Ehkä sitten ensi tai seuraavalla vuosituhannella..

Itsekin olen haaskannut näiden scandi-ongelmien kanssa vuosien kuluessa satoja tunteja. Kuinkahan paljon muut ?

Kaikkeen tarjotaan tätä UTF:ää ratkaisuksi. Miksiköhän sitä ei saada missään toimimaan ?

nm

  • Käyttäjä
  • Viestejä: 13096
    • Profiili
Väittäisin, että haukut nyt väärää puuta. Alkuperäinen ongelmasi johtui SSH-clientista ja sen jälkeen jokin tekemäsi muutos on sekoittanut palvelimen merkistöasetukset.


Aivan sama juttu (äää -> ää) oli omassa serverissä.

Tässä tilanteessa asiakasohjelmaa ei ole asetettu vastaanottamaan UTF-8-dataa. SSH Secure Shell 3.2.9 ei taida edes taipua siihen -- UTF-8-merkkikoodausta käyttävät palvelimet olivat vielä aika harvassa vuonna 2003, joten ilmeisesti ominaisuudelle ei ollut kysyntää. Joudut siis käyttämään Windows-koneessasi PuTTYä tai jotain muuta uudempaa toteutusta.

PuTTY:ssä UTF-8:n saa päälle asetusikkunan valinnalla: Window->Translation->Received data assumed to be in which character set
Kuvia: http://anti.teamidiot.de/nei/2007/02/irssi_putty_screen_unicode_utf/#putty

Tämä on SSH:n osalta ainoa tarvittava merkistösäätö puhtaan Ubuntu Server -asennuksen jälkeen. UTF-8-merkistöä käyttävissä Linux/Unix-asiakkaissa ei tarvitse koskea mihinkään.


Lainaus
Paitsi, että sen älkeen, kun olin ottanut PuTTY:llä yhteyttä koneeseen, kaikki localet ovat olleet POSIX ja scandit eivät toimi nappaimistolta lainkaan, edes SSH 3.2.9:llä.

Taisit tehdä jonkin muun muutoksen samalla. Pelkkä yhteyden ottaminen ei vaikuta lokalisaatioasetuksiin pysyvästi.

Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
Väittäisin, että haukut nyt väärää puuta. Alkuperäinen ongelmasi johtui SSH-clientista ja sen jälkeen jokin tekemäsi muutos on sekoittanut palvelimen merkistöasetukset.
Aivan sama juttu (äää -> ää) oli omassa serverissä.

Saattaa johtua SSH:stakin, mutta eivät toimi scandit millään muullakaan, eivät edes terminaalissa.
Sitäpaitsi olisi vallan mukavaa, jos pikkuhiljaa näiden 15 vuoden jälkeen tähän scandiongelmaan olis tarjolla kunnollinen ratkaisu ja dokumentaatio. Bill Gates nauraa partaansa tätä lokalisaatioon liittyvää kohellusta.

Lainaus
Paitsi, että sen älkeen, kun olin ottanut PuTTY:llä yhteyttä koneeseen, kaikki localet ovat olleet POSIX ja scandit eivät toimi nappaimistolta lainkaan, edes SSH 3.2.9:llä.

Taisit tehdä jonkin muun muutoksen samalla. Pelkkä yhteyden ottaminen ei vaikuta lokalisaatioasetuksiin pysyvästi.
[/quote]

Niin sitä luulisi. Tässä on kuitenkin jo nähnyt, että tämä Ubuntu 9.10 on jatkuvaa veitsen terällä tasapainottelua. Jokainen uusi päivitys räjäyttää pakan ja kaiken saa aina aloittaa alusta.
Samba toimi eilen. Tänään ei toimi.
Taitaa olla parasta haeskella toimiva distro

nm

  • Käyttäjä
  • Viestejä: 13096
    • Profiili
Saattaa johtua SSH:stakin, mutta eivät toimi scandit millään muullakaan, eivät edes terminaalissa.

Kyllä ne toimivat puhtaassa asennuksessa, kunhan kieli ja näppäinasettelu on valittu oikein asennuksen aikana. Minkä tahansa järjestelmän saa tietysti rikki säätämällä.

williamsmith61

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Kun avasin läppäriltä ssh-yhteyden ubuntu server koneelleni (LTS 8.04), huomasin etteivät ääkköset enää toimineet näppäimistöltä. Katsoin locale komennolla että käytössä oli suomalaiset asetukset eli muuttujat kopioituivat ssh-yhteyden yli. Ajoin sitten em. locale-gen komennon myös serverillä ja ääkköset toimivat taas.

Mistofelees

  • Käyttäjä
  • Viestejä: 540
    • Profiili
Saattaa johtua SSH:stakin, mutta eivät toimi scandit millään muullakaan, eivät edes terminaalissa.
Kyllä ne toimivat puhtaassa asennuksessa, kunhan kieli ja näppäinasettelu on valittu oikein asennuksen aikana. Minkä tahansa järjestelmän saa tietysti rikki säätämällä.

Nyt sain yhden koneen tottelemaan scandeja. Päätteenä Putty, translation UTF-8. Locale antoi sitkeästi joka rivillä POSIX, paitsi LANG ja LC_ALL olivat tyhjiä.
Koneen omalla ruudulle locale antoi täysin järkevät vastaukset. Olivat korjautuneet jossain välivaiheessa.

Iski mieleen, josko vika ei olekaan localeissa an sich, vaan ssh:ssa. Tarkemin sanoen SSH-serverissä.
Ubuntussa on käytössä openssh-server ja openssh-client. Päivitetään ne:

Nämä on tehty joskus aiemmin:
dpkg-reconfigure localepurge
apt-get install locales
apt-get install language-pack-fi
locale-gen --purge fi_FI.UTF-8
export LC_ALL=fi_FI.UTF-8
Kirjoitettu tiedostoon /home/.profile:
        LC_ALL=fi_FI.UTF-8

Tähän mennessä scandit pelaavat puttyssä komentorivillä, mutta eivät kaikissa sovelluksissa. Esim JOE-editori antoi merkillisiä C% -merkkejä

Nyt tehdään näin:
Koneen omalla ruudulla:
- apt-get purge openssh-server
- apt-get purge openssh-client
- apt-get install openssh-server openssh-client

Ei tarvi edes bootata. TOIMII. (jopa tiedoston nimessäkin voi olla scandeja. Ans kattoo, mitä scriptit niistä tuumaavat)

SUMMA SUMMARUM: Jotain on mennyt rikki openssh:n asetuksissa jo 9.04 asentaessa, eikä tämä korjaantunut edes 10.04 päivityksessä.

retu

  • Käyttäjä
  • Viestejä: 905
    • Profiili
^wtf?

Nyt, kun tämä taas pulpahti pinnalle, pitää kertoa että utf-8 toimii windowsissakin. ;)

Jonkin aikaa sitten ilmestynyt cygwin 1.7 versio nimittäin tuntuu hanskaavan homman ihan mukavasti. Päätteenä käytän mintty ohjelmaa, jonka asetuksista voi valita localeksi "fi_FI" ja merkistöksi "UTF-8". Oletus on kuitenkin locale "C", jos sattuu käyttämään windowsin omaa "päätettä".

Tähän mennessä scandit pelaavat puttyssä komentorivillä, mutta eivät kaikissa sovelluksissa. Esim JOE-editori antoi merkillisiä C% -merkkejä
Joe on mullakin käytössä. En jaksa opetella vim:ä enkä jaksa odottaa emacsia. ;D

Joe taitaa oletuksena käyttää päätteen merkistöä. Jos muokattava tiedosto on eri merkistössä, näkyy hassuja merkkejä ääkkösten paikalla. Joe osaa kuitenkin homman ihan helposti: näppäile ctrl-t e (eli encoding) ja valitse tiedostossa käytetty merkistö. Tabulaattoria painamalla saa valikon tai sitten voi vain kirjoittaa merkistön nimen. Siellä on myös aliaksia, ansi on sama kuin iso-8859-1.

Ai niin, moden luuta varmaan kohta sipaisee, joten pitää vielä täsmentää että tuo alun wtf liittyy edeltävään sikanautaan eikä Mistofeleen viestiin.
« Viimeksi muokattu: 15.10.10 - klo:11.41 kirjoittanut retu »

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
jep, luuta sivalsi ja käyttäjälle ban - joku yllättävän nokkela spambot.

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-