Kirjoittaja Aihe: compiz.real syö 70% cpu-tehosta ja äänet napsuu [RATKAISTU]  (Luettu 1712 kertaa)

purkka

  • Käyttäjä
  • Viestejä: 3
    • Profiili

EDIT: eka viesti ja heti väärälle palstalle, sopii siirrellä peruskäyttöön


Hei!
Linux-aloittelija olen ja pikku ongelmaa pukkaa.

Elikkä compiz.real niminen prosessi käyttää 70-80% cpu-tehosta. Ongelma hoituu tappamalla prosessi mutta bootin jälkeen sama tilanne. Sama ongelma ilmeisesti muillakin: http://ubuntuforums.org/showthread.php?t=493463 mutta en tuolta löytänyt vihjeitä. Compiz fusionin ei pitäis olla käytössä, asentelin kokeilumielessä mutta poistin paketit. Myöskään visuaaliset tehosteet eivät ole käytössä.

Alla 9.10 ubuntu, kone Acer 5920G missä näyttiksenä NVIDIA 8600M GT. NVIDIA-ajuri versio 173 (jostain syystä uudempi 185 ei asennu).
Compizin versio 0.8.4

Ja vielä sellanen pikku ongelma että välillä mm. painettaessa jotain nappia, vaihdettaessa selaimen välilehteä tai muuttaessa äänenvoimakkuutta kuuluu napsahdus/paukahdus kajareista. Siihen jotain korjausta?


« Viimeksi muokattu: 12.11.09 - klo:19.33 kirjoittanut purkka »

nm

  • Käyttäjä
  • Viestejä: 14990
    • Profiili
Vs: compiz.real syö 70% cpu-tehosta ja äänet napsuu
« Vastaus #1 : 12.11.09 - klo:03.07 »
Elikkä compiz.real niminen prosessi käyttää 70-80% cpu-tehosta. Ongelma hoituu tappamalla prosessi mutta bootin jälkeen sama tilanne. Sama ongelma ilmeisesti muillakin: http://ubuntuforums.org/showthread.php?t=493463 mutta en tuolta löytänyt vihjeitä. Compiz fusionin ei pitäis olla käytössä, asentelin kokeilumielessä mutta poistin paketit. Myöskään visuaaliset tehosteet eivät ole käytössä.

Compiz kuitenkin on selvästi käytössä... Jos et tarvitse sitä, poista paketit, niin ei ainakaan pääse häiritsemään:

Koodia: [Valitse]
sudo apt-get remove compiz-core

Lainaus
Alla 9.10 ubuntu, kone Acer 5920G missä näyttiksenä NVIDIA 8600M GT. NVIDIA-ajuri versio 173 (jostain syystä uudempi 185 ei asennu).

Tuossa näytönohjaimessa on hyvä videon rautapurku, jota pääsisi hyödyntämään 185- tai 190-sarjan ajureilla VDPAU-rajapinnan kautta. Kokeile asentaa 190-sarjan ajuri täältä: https://launchpad.net/~nvidia-vdpau/+archive/ppa


Lainaus
Ja vielä sellanen pikku ongelma että välillä mm. painettaessa jotain nappia, vaihdettaessa selaimen välilehteä tai muuttaessa äänenvoimakkuutta kuuluu napsahdus/paukahdus kajareista. Siihen jotain korjausta?

http://forum.ubuntu-fi.org/index.php?topic=29914.0

Eli kommentoi (lisää #-merkki alkuun) tai poista /etc/modprobe.d/alsa-base.conf -tiedostosta rivi:

Koodia: [Valitse]
options snd-hda-intel power_save=10 power_save_controller=N
Tiedoston muokkaus onnistuu päätteessä komennolla sudo nano /etc/modprobe.d/alsa-base.conf tai graafisesti: gksudo gedit  /etc/modprobe.d/alsa-base.conf

Käynnistä kone uudelleen muutoksen jälkeen.
« Viimeksi muokattu: 12.11.09 - klo:03.11 kirjoittanut nm »

purkka

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Ja kaikki toimii. Kiitoksia kovasti selkeästä vastauksesta!