Kirjoittaja Aihe: Acer - atheros ar928x - wlan-ongelmat [RATKAISTU]  (Luettu 4974 kertaa)

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Mo!
Päivitin ubuntun 9.10 -versioon, ja aiemmassakin versiossa nihkeästi toiminut wlan ei nyt lähde käyntiin.

Ongelma: Yhteys piuhalla toimii, mutta kun piuhan irroittaa, ei wlan "käynnisty". Verkonhallinnassa lukee "langattomat verkot -- laite ei valmis". Käynnistyksen jälkeen myös "yhteys katkaistu". Viesti muuttuu ruksittuani ensin pois "ota langaton käyttöön" ja sen jälkeen täpän takaisin.
Hjelp! Yhteys wpa-salaus, kone lähes uudenkarhea acer 5538.

lspci:
Koodia: [Valitse]
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev ff)
08:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 02)

iwconfig:
Koodia: [Valitse]
wlan0     IEEE 802.11bgn  ESSID:""  
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated  
          Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ifconfig -a:
Koodia: [Valitse]
eth0      Link encap:Ethernet  HWaddr 00:26:22:1e:4b:97  
          inet addr:192.168.100.10  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::226:22ff:fe1e:4b97/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1619 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1267 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1742088 (1.7 MB)  TX bytes:156988 (156.9 KB)
          Interrupt:28 Base address:0x4000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vboxnet0  Link encap:Ethernet  HWaddr 0a:00:27:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 0c:60:76:32:08:01  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 0C-60-76-32-08-01-00-00-00-00-00-00-00-00-00-00  
          [NO FLAGS]  MTU:0  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

ifconfig näyttää vain eth0:n ja lo:n. Ath9k ajurit pitäis olla ok. Tosiaan edellisessä versiossa oli samaa ongelmaa, mutta muutaman yrityksen ja resetin jälkeen yhteys lähti pelaamaan.
Tänks!
« Viimeksi muokattu: 10.12.09 - klo:16.16 kirjoittanut Nurssi »
Acer 5538 - Ubuntu 9.04

VKZ

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Vs: 9.10 - wlan - laite ei valmis?
« Vastaus #1 : 01.11.09 - klo:15.28 »
Itse pistin eilen päivityksen päälle, mutta ennen kuin asentaminen alkoi tulin toisiin ajatuksiin ja peruin päivityksen. WLAN lakkasi kuitenkin toimimasta täysin samoin oirein kuin sulla.

Kerro ihmeessä tänne jos keksit miten saa jälleen toimimaan  :)

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan - laite ei valmis?
« Vastaus #2 : 02.11.09 - klo:14.02 »
Mikään temppuilu ei tuntunut auttavan, joten otin ns. isoimman lekan ja asensin 9.04:n takaisin. Jotenkin tuntuu, että 9.10:n wlan-ajurit ei oo vielä valmiita. Odottelemalla siitä varmaan selviää. Nyt tosin on riesana vanha vika, eli verkon kuormituksen noustessa yhteys menee poikki ja se pitää "resetoida" verkonhallinnan ikonista. Salaamattomalla verkolla moista ei ollut. Muilla samaa onkelmaa?

VKZ: Auttaisko tuohon kaikkien nettiajureiden (ainakin wlan-) täysi poisto ja uudelleen asennus? Sekin tietty että miten ne synapticilla löytää kaikki... Sieltä varmaan itse koittaisin.

Acer 5538 - Ubuntu 9.04

peran

  • Vieras
Vs: 9.10 - wlan - laite ei valmis?
« Vastaus #3 : 02.11.09 - klo:15.05 »
VKZ: Auttaisko tuohon kaikkien nettiajureiden (ainakin wlan-) täysi poisto ja uudelleen asennus? Sekin tietty että miten ne synapticilla löytää kaikki... Sieltä varmaan itse koittaisin.

Epäilen vahvasti, että siinä hommassa vetää vesiperän.

Mutta jos siihen ryhdyt, niin dmesg ja modprobe ovat ystäviäsi.

Koodia: [Valitse]
man modprobeKertoo lisää kuinka lisäät ja poistat kernel-moduleita. dmesg:llä näet tekstimuodossa mitä modulit on lokiin jättäneet (lähinnä modulien poistot ja lisäämiset).

Siis tää ei oo Windows, niin kaikki Windows-kikat ei tässä hyvin toimi.

Edit - Siellä on siis kaikkimodulit.

VKZ

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Vs: 9.10 - wlan - laite ei valmis?
« Vastaus #4 : 02.11.09 - klo:15.13 »
Tässä kävi kuten niin monesti muutenkin esineitä tai tietokonetta korjatessani: sain toimimaan yhtään tietämättä mitä tein...

Koodia: [Valitse]
:~$ lsmod | grep ath

ath5k                 107520  0
mac80211              217592  1 ath5k
led_class              12036  1 ath5k
cfg80211               38288  2 ath5k,mac80211
Oletan, että noi olis langattomaan verkkokorttiin liittyviä ajureita tms.

Koodia: [Valitse]
gksu gedit /etc/modprobe.d/blacklist.confKäsityskykyni mukaan tuolla listauksella taas saisi disabloitua ajurien lataamista...

Lisäsin blaclistiin kaikki Atherokseen viittaavat ajurit eli:
Koodia: [Valitse]
blacklist ath5k
blacklist mac80211
blacklist led_class
blacklist cfg80211

WLAN ei toiminut edelleenkään - aiemminhan luki "laite ei valmis" verkkoyhteyden ikonissa, mutta nyt ei löytynyt koko langatonta ollenkaan. Ei sinänsä ihme koska käsittääkseni nyt siis estin mustalla listalla kaikkien wlan-ajurien lataamisen!
Poistin cfg80211 listalta. Wlan ei toiminut.
Poistin led_class listalta. Wlan ei toiminut.
Poistin mac80211 listalta. Wlan ei toiminut.
Poistin ath5k listalta. Wlan toimii! Hetkinen, blacklist.conf on siis nyt täysin sama kuin aloittaessani, mutta silti wlan toimii  ;D

Osaako joku kertoa mitä tässä siis oikein tapahtui?

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #5 : 10.11.09 - klo:19.19 »
Löytyykö keneltäkään ratkaisuja tähän wlan-jäätymisongelmaan? "Ominaisuus" alkaa olla oikeasti ärsyttävä, jo youtubea katsottaessa pitää kököttää modeemin vieressä piuha kiinni, muuten ei onnistu tiedonsiirto  :( 

Oireet kerrattuna: Suuremmilla tiedonsiirroilla wlan-yhteys pätkäisee, eikä lähde pelaamaan ilman network-managerista verkon nimeä klikkaamalla. Normaali nettiselailu ym onnistuu lähes aina normaalisti.
Wlan-korttina atheroksen ar928x, ajurit ath9k. Käyttis 9.04 ubu. Wlanissa salaus päällä (ei saa pois).
HALP!!
Acer 5538 - Ubuntu 9.04

Jallu59

  • Käyttäjä
  • Viestejä: 3430
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #6 : 18.11.09 - klo:11.06 »
Atheroksesta jotain tuolla:
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide
Tiedä auttaako, kun itselläe ei ole tuota.

Ystävällisin terveisin

Jallu59
Jari J. Lehtinen, Wanhempi (iki?)tietoteekkari & tietotekniikkakonsultti Turust, P4-HT / 3,0 GHz, Intel945 IGP 226MB & 4GBram & UbuntuStudio 14.04. Toshiba Satellie 50-C, i5 dual-core 2,3GHz, ubuntu-mate 16.04 LTS

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #7 : 19.11.09 - klo:16.55 »
Lainaus
https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide
Hmm, tuolla esitettiin yhdeksi syyksi langattoman "kanavalta tippumista", eli jokin toinen wlan-laite häiritsee liikennettä eikä ubu saa enää vanhasta taajuudesta kiinni. (6.1 - dropped connections)

Vaihdoin Elisan purkista taajuuden kanavaksi "1" automaattiasetuksen sijaan. Tuntuu että verkosta putoilemiset ovat vähentyneet  ??? Täytyykö ubuntusta vaihtaa vielä jokin asetus, että se pysyisi jatkuvasti tällä taajuudella?

Lisäkysymys: mikä salaustapa on vähiten altis häiriöille, wpa, wpa2, wep? Jos osa ongelmaa olisi siinä.

Kiitän!
Acer 5538 - Ubuntu 9.04

nm

  • Käyttäjä
  • Viestejä: 15458
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #8 : 19.11.09 - klo:18.07 »
Lisäkysymys: mikä salaustapa on vähiten altis häiriöille, wpa, wpa2, wep? Jos osa ongelmaa olisi siinä.

Se varmaan riippuu monestakin tekijästä, kuten ajurista ja tukiasemasta. Mutta jos haluat salata liikennettä, noista ei kannata edes harkita muita kuin WPA2:ta.

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #9 : 02.12.09 - klo:21.32 »
Tähän verkosta putoilemiseen näyttää olevan syynä Elisan Kotiboxi -nimellä kulkeva modeemi / wlan-purkki. Huono ratkaisu sinänsä, sillä laitetta ei voi päivittää, vaan sinne ajetaan päivitykset Elisan toimesta. Nykyisellä firmwarella ubuntu putoilee kanavalta. No, ratkaisu näkyy olevan odottaminen tai uusi reititin...

Tietääkö kukaan, toimiiko Ubu 9.10 - acer 5538 -yhdistelmässä jo wlan??
Acer 5538 - Ubuntu 9.04

mrl586

  • Käyttäjä
  • Viestejä: 4638
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #10 : 02.12.09 - klo:22.17 »
Tietääkö kukaan, toimiiko Ubu 9.10 - acer 5538 -yhdistelmässä jo wlan??
Ehkä toimii, ehkä ei. Kerro millainen wlan-piiri tuossa koneessa on.

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #11 : 03.12.09 - klo:10.11 »
Ekasta viestistä löytynee... Atheroksen AR928X. Vai sitäkö haettiin?
Acer 5538 - Ubuntu 9.04

Nurssi

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: 9.10 - wlan laite ei valmis 9.09 - wlan pätkii
« Vastaus #12 : 10.12.09 - klo:14.39 »
No eihän se toimi... PRKL!

MUOKS! Nyt toimii! Ubuntu forums:

Lainaus
Uncomment the ath_pci blacklist in /etc/modprobe.d/blacklist-ath_pci.conf.
You check if ath9k (or ath5k) is loaded in /etc/modules
Koodia: [Valitse]
echo ath9k | sudo tee -a /etc/modulesThen you install linux-backports-modules-karmic and linux-backports-modules-wireless-karmic-generic (and linux-backports-modules-wireless-karmic-generic-pae if you can but I didn't need it)
Reboot and all should be fine!

Tällaiset taikasanat kehiin, ja Aceri sai kuin uuden elämän. 9.10 on toistaiseksi toiminut niin hyvin kuin voi toivoa. Näköjään tämä langattoman katkeilu johtui 9.04:n kiemuroista. Kiitti kaikille apua tarjonneille!
« Viimeksi muokattu: 10.12.09 - klo:16.14 kirjoittanut Nurssi »
Acer 5538 - Ubuntu 9.04