Kirjoittaja Aihe: Karmic ja mokkula  (Luettu 20265 kertaa)

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #20 : 06.01.10 - klo:18.16 »
Kun pin-kysely on poistettu sim-kortista niin saa yhteyden hyvin vähäisillä asetuksilla.  Noissa soittonumero ja APN -kentissä täytynee olla jotain järkevää, ei juuri piittaa muista eli voi jättää tyhjiksi. Nuo DNS-asetukset ovat tärkeät ja ratkaisu tuohon alkuperäiseen kysymykseen jonka käyttäjä "Eetu_" oli tehnyt.  Näytän tässä esimerkin millaisella yhteydellä olen nyt kiinni tänne foorumiin, ei paljon välitä noista käyttäjätunnus/salasankentistä  :)


[ylläpito on poistanut liitteen]
« Viimeksi muokattu: 06.01.10 - klo:18.36 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Täti Monika

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #21 : 06.01.10 - klo:19.40 »
Kun pin-kysely on poistettu sim-kortista niin saa yhteyden hyvin vähäisillä asetuksilla.  Noissa soittonumero ja APN -kentissä täytynee olla jotain järkevää, ei juuri piittaa muista eli voi jättää tyhjiksi. Nuo DNS-asetukset ovat tärkeät ja ratkaisu tuohon alkuperäiseen kysymykseen jonka käyttäjä "Eetu_" oli tehnyt.  Näytän tässä esimerkin millaisella yhteydellä olen nyt kiinni tänne foorumiin, ei paljon välitä noista käyttäjätunnus/salasankentistä  :)


Ei tarvinnut poistaa PIN-kyselyä ja minulla on mikroSD, ei SIM-korttia. Sain toimimaan, kun noudatin niitä ohjeita, että pitää luoda uusi mobiiliyhteys, kun tikku (Huawei) on tunnistettu. Tällä systeemillä ilmeisesti pitää luoda joka kerta uusi mobiiliyhteys, varsinkin kun tuo Verkkonhallintaohjelma kämmii, eikä suostu hyväksymään muokkauksia. Konsolissa tietty voisi muokata.

Minulla kyllä  tarvitaan PIN,

DNS-asetuksia ei ole.

Kiitos kaikille vinkeistä tässä ketjussa.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #22 : 06.01.10 - klo:19.59 »
Ei sitä pin-kyselyä tietenkään ole pakko poistaa mutta se helpottaa elämää. On siellä piilossa se sim-korttikin, itse luulin myös että sitä ei ole kun ei heti löytynyt muuta kuin tuo microSD.   Se sim on siellä tikun usb-liittimen puoleisessa päässä, siinä on pieni kolo mistä sen saa vedettyä ulos.  Kännykässä voi poistaa tuon pin-kyselyn sim-kortista.  Miksi tein tuon itselleni ?  Koska itselläni tuo pin ei pysy tuolla Network Managerissa (verkon hallinta) vaan häipyy aina kun tikun irrottaa koneesta.  Tuo DNS-virhe voi tulla joka toisella tai joka kymmenennellä kerralla ellei ole käsin asetettu. Silloin yhteys syntyy mutta webbiselaus ei toimi.    
Voit tietysti luoda joka kerta määritykset uudestaan jos haluat toimia sillä tavalla, ei kyllä ole tarpeen.  Ja tuon verkon hallinnan saa käyntiin tällä jos ei muuten onnistu:
Koodia: [Valitse]
sudo nm-connection-editor
« Viimeksi muokattu: 06.01.10 - klo:20.12 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Mario92

  • Käyttäjä
  • Viestejä: 691
  • OMNOMNOMN
    • Profiili
    • Marioplaneetta
Vs: Karmic ja mokkula
« Vastaus #23 : 06.01.10 - klo:21.12 »
...ja minulla on mikroSD, ei SIM-korttia.
Paljosta lyödään vetoa että siinä on kummatkin ;)

Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa.

Täti Monika

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #24 : 06.01.10 - klo:22.21 »
...ja minulla on mikroSD, ei SIM-korttia.
Paljosta lyödään vetoa että siinä on kummatkin ;)

Joo, todennäköisesti on. Olen kyllä kasannut sen  tikun itse,  enkä muista mitä siellä on, mutta se teipattu kiinni, koska luukku ei pysy kunnolla kiinni muuten.  En noin äkkiseltään löytänyt SIM-korttia ja sitten aattelin, että on integroitu siihen mikroSD:hen... Noh. Tädin muisti on niin huono.

Minulla tikku toimii ihan hyvin, eikä pätki. Katsotaan sitten kun seuraavan kerran yritän ottaa yhteyttä...





oobetimer

  • Käyttäjä
  • Viestejä: 1470
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #25 : 06.01.10 - klo:22.43 »
...ja minulla on mikroSD, ei SIM-korttia.
Paljosta lyödään vetoa että siinä on kummatkin ;)

Joo, todennäköisesti on. Olen kyllä kasannut sen  tikun itse,  enkä muista mitä siellä on, mutta se teipattu kiinni, koska luukku ei pysy kunnolla kiinni muuten.  En noin äkkiseltään löytänyt SIM-korttia ja sitten aattelin, että on integroitu siihen mikroSD:hen... Noh. Tädin muisti on niin huono.

Minulla tikku toimii ihan hyvin, eikä pätki. Katsotaan sitten kun seuraavan kerran yritän ottaa yhteyttä...


Elisan DNS-osoitteet ovat 193.229.0.40 ja 193.229.0.42

Käyttäjätunnus on rlnet ja salasana on internet  

Huawei E220:ssa sim-kortti löytyy mokkulan kyljestä.. :)

« Viimeksi muokattu: 06.01.10 - klo:22.45 kirjoittanut oobetimer »
13/2/2009 and friday....

http://debian-fi.dy.fi/

sniveri

  • Käyttäjä
  • Viestejä: 322
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #26 : 07.01.10 - klo:12.32 »
Tuskailin pari päivää tuon saunalahden ZTE MF636+ tikun kanssa ja yhteyttä ei saanut luotua Windows XP:ssä, Vistassa, Ubuntu 9.10:ssä eikä Ubuntu 10.04:ssä vaikka teki minkä ohjeen mukaan tahansa. Huvikseni kokeilin tökätä tikussa olevan simin puhelimeen tekemättä mitään muutoksia ja yhteys onnistui laakista, tämän jälkeen vaihdoin kortin takaisin mokkulaan ja ihme ja kumma alkoi toimimaan suoraan ainakin lucidissa :D
Ubuntu 10.04 64-bit Desktop
Ubuntu 10.04 32-bit Desktop x 2
Ubuntu 10.04 32-bit Server

sniveri@diasp.eu

Täti Monika

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #27 : 07.01.10 - klo:12.41 »
Kyllä tämä tikku Huawei 220E Elisa pelittää ja ihan  edellämainituilla kissa, koira käyttäjätunnuksella ja salasanalla. PIN-koodi pitää olla, kun en ole sitä PIN-kyselyä poistanut. Huvittavaa on että tämä ElisaKissaKoiraPIN-yhteys myös näkyy Verkonhallintaohjelmassa olevan tai olleen käytössä, mutta muut eivät vaikka ne ovat toimineet.


Jos katkaiseen yhteyden ja yrittää uudestaan yhdistää uudelleen useamman kerran,  niin sitten   tulee jossain vaiheessa vaikeuksia. Ilmeisesti tuo yhteyden mountaaminen on hidasta tai siten Verkonhallinnassa on jotain ongelmaa.

DNS-tietoa ei edelleenkään tarvitse antaa.


ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #28 : 07.01.10 - klo:13.22 »
Se verkonhallinta vaikuttaa hieman bugiselta tikkujen kanssa.  Sen takia olen kehottanut ihmisiä poistamaan pin-kyselyn vaikka se usein toimiikin ja sen takia myöskin olen kehottanut laittamaan jotkut dns-osoitteet käsin vaikka nekin usein toimivat automaattisesti.   juju on siinä sanassa   *usein*.   Kännykällä on hyvä testata sim-kortti että se ok ennen kuin tekee suuremman työn muiden asioiden kanssa.  Ellei toimi kännykässä niin ei sitten missään. Samalla vaivalla kyllä poistaa sen pin-kyselynkin... :)
« Viimeksi muokattu: 07.01.10 - klo:13.34 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

ululu

  • Käyttäjä
  • Viestejä: 4
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #29 : 10.01.10 - klo:04.55 »
Soneran liittymä tuntuu toimivan koneellani paljon hitaammin linuxissa kuin windowsissa.

Tein hieman kokeiluja koska käytössäni on tällä hetkellä Sonera sekä DNA mobiilinetit.

Käyttiksenä Debian Lenny ja ajurina option.ko. (Samassa koneessa on myös windows jolla molemmat yhteydet toimivat täydellä nopeudella   :-\)

Laitteina Huawei e1552 (josta lsusb ilmoittaa vendor=12d1 product=1001)
sekä nokian kännykkä 6220 classic

Liittymät: Sonera 3.6 megan ja DNA 2 megan nopeudella


Sonera simkortti + huawei
nopeus noin 20 kps
useampi yhtäaikainen lataus voi nostaa nopeuden jopa 300 kps

Sonera simkortti + nokia
nopeus noin 20 kps
useampi yhtäaikainen lataus voi nostaa nopeuden jopa 300 kps

DNA simkortti + huawei
nopeus noin 200 kps

DNA simkortti + nokia
nopeus noin 200 kps


Elikkä hitaus ei johdu laitteesta vaan soneran liittymästä.

Mikäli lataan tiedostoa soneran liittymällä niin se tulee noin 20 kps nopeudella, mutta jos lataan kahta tiedostoa yhtäaikaa niin nopeus nousee noin 40 - 60 paikkeille eli tuplaantuu, useilla yhteyksillä pääsee kaistan koko nopeuteen joten esim. bittorrent liikenne sujuu hyvin.

Arvelin ensin että ongelma on usbserial tai option moduuleissa joten kokeilin airprime sekä sierra moduuleja sekä asensin uuden kernelin(2.6.32.2) jossa arvelin olevan paremmat ajurituet. - mikään näistä ei kuitenkaan muuttanut soneran liittymän toimintaa.

Kokeilin myös umtsmon ja vodavone-mobile-connect ohjelmilla yhteyden ottamista, mutta liittymä toimi täysin samallatavoin.

Toimiiko soneran liittymä jollakulla asianmukaisesti linuxissa?

sniveri

  • Käyttäjä
  • Viestejä: 322
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #30 : 10.01.10 - klo:11.10 »
Aikaisempiin tuskailuihin täytyy lisätä se että kun sain mokkulan toimimaan työpaikalla vaihtelemalla sim-kortteja puhelimeen ja takaisin tikkuun, niin kotonapa ei enää toiminutkaan. IP:n haki automaattisesti mutta yksikään sivu ei auennut, firefox vaan ilmoitteli alakulmassa että opening page, tätä jatkui noin 4 tuntia ennenkuin kyllästyin temppuilemaan.

Jätin tikun kiinni yöksi ja aamulla netti alkoikin pelailemaan n. 2megan yhteyksillä. Ainoa asia mikä tuossa vielä kiusaa on se että kun yhteys menee poikki, ei yhteyttä saa takaisin kuin repimällä tikun irti ja laittamalla takaisin, jossa kestää melko kauan ennenkuin yhteys lopulta muodostuu uudelleen. Tämä siis Ubuntu 10.04 64-bit + saunalahden ZTE MF636.

EDIT: Korjauskin tuohon yhteyden katkeiluun on jo olemassa ja hienosti pelaa:

http://forum.ubuntu-fi.org/index.php?topic=28298.msg244030#msg244030
« Viimeksi muokattu: 10.01.10 - klo:20.52 kirjoittanut sniveri »
Ubuntu 10.04 64-bit Desktop
Ubuntu 10.04 32-bit Desktop x 2
Ubuntu 10.04 32-bit Server

sniveri@diasp.eu

kaapeli

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #31 : 11.01.10 - klo:10.07 »
kiitokset oobetimerille. puolen vuoden tuskailun jälkeen nyt mokkula pelaa nätisti.

Täti Monika

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #32 : 01.02.10 - klo:19.50 »
Täytyy kyllä sanoa, ettei  tämä tikku (Huawei 220E/Elisa) nyt ihan kauniisti pelitä, varsinkin aloittaminen on vaikeaa. Tosin tikku ei toimi kovin hyvin WIn XP -läpppärisskään (nimenomaan aloitus on vaikeaa), vaikka on siihen "suunniteltu".

Välillä ei mountaannu ollenkaan, välillä mountaantuu, mutta  NetworkManager ei tunnista. Välilllä pitää laittaa tikku kiinni jo käynnistettäessä ja välillä vasta kun on järjestelmä lataantunut,....

Yleensä pelittää ihan hyvin, jos saan sen ensin toimimaan. Joskus katkeaa, mutta sitten pitää ottaa tikku pois   ja  laittaa uusiksi.

Viimeisin juttu minkä huomasin, että kun olen laittanut yhden nimisen liittymään (jotka kaikki johtavat samaan tikkkuun) ruksin siihen, että yhdistä automaattisesti, niin joskus yhdistääkin automaattisesti, mutta uskomattominta on se, että kun umounttaa tikun, niin sitten NM yhdistää ja se pelittää ihan hyvin. Voiko se oikeasti olla umonttantunut?   En ihan ymmärrä päätteen mount - l listauksen tulosta. Lsusb.llä Huawein tikku näkyy. MountManagerin mukaan ei ole mountaantunut.

Yritin konfata tuota etc/network/interfaces 'ia, että saisin   tikun  toimimaan paremmin, mutta yritin tehdä siitä kiinteää liittymää...en oikein hallitse konfauksia..

Onko joku konfannut?

Onko joku konfannut  NetworkManageria?

anttu-t

  • Käyttäjä
  • Viestejä: 180
    • Profiili
    • Siptune
Vs: Karmic ja mokkula
« Vastaus #33 : 02.02.10 - klo:10.26 »
Välillä ei mountaannu ollenkaan, välillä mountaantuu, mutta  NetworkManager ei tunnista. Välilllä pitää laittaa tikku kiinni jo käynnistettäessä ja välillä vasta kun on järjestelmä lataantunut,....

...

Onko joku konfannut  NetworkManageria?


Tuollaiset satunnaiset temppuilut voisivat johtua USB-portin/kaapelin sähkön riittämättömyydestä. Kokeile lyhyempää ja laadukkaampaa/paksumpaa USB-kaapelia tai Y-kaapelia, joka ottaa sähkön kahdesta USB-liittimestä. (Kaapelin kuparin paksuuden tunnistat kaapelin kuoreen printatusta AWG-arvosta. Mitä pienempi numero, sitä paksumpi kupari.)

Täällä on ohjetta Network managerin konffaukseen.


ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #34 : 02.02.10 - klo:10.45 »
Lainaus
mutta uskomattominta on se, että kun umounttaa tikun, niin sitten NM yhdistää ja se pelittää ihan hyvin

Puhutko nyt tuosta muistitikkuosasta joka on myös Huaweissa ?  Ei se tarvitse tuota muistitikkuosaa mihinkään yhteydenmuodostuksessa, voit vallan hyvin ottaa vaikka pois sen microSD kortin sieltä mokkulasta ja yhteys tulee silti.   Eli tuossa tikussa (ainakin E160E mallissa ) on sekä mokkula/nettitikku  että muistitikku samassa laitteessa, luulen että sinun Huawei on samankaltainen.
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Täti Monika

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #35 : 02.02.10 - klo:12.52 »
Lainaus
mutta uskomattominta on se, että kun umounttaa tikun, niin sitten NM yhdistää ja se pelittää ihan hyvin

Puhutko nyt tuosta muistitikkuosasta joka on myös Huaweissa ?  Ei se tarvitse tuota muistitikkuosaa mihinkään yhteydenmuodostuksessa, voit vallan hyvin ottaa vaikka pois sen microSD kortin sieltä mokkulasta ja yhteys tulee silti.   Eli tuossa tikussa (ainakin E160E mallissa ) on sekä mokkula/nettitikku  että muistitikku samassa laitteessa, luulen että sinun Huawei on samankaltainen.

Joo, niinhän se tietenkin on, että mikroSD mounttautuu, mutta SIM ei...
Mutta yleensä se käynnistäminen vaatii

Pitää kokeilla  sen mikroSD:n poistoa, se saattaa häiritä...

Ja kiitos piuhavinkistä ja mountausohjesta.


ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #36 : 02.02.10 - klo:20.33 »
Nuo USB2 johdot ovat muuten kriittisiä pituuden / laadun / häviöiden / vaimennuksen suhteen, itselläni yksi ulkoinen levy johon ei voi lisätä edes pientä pätkää jatkokaapelia ---- lakkaa toimimasta 100 % varmasti kokonaan.  
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1250
    • Profiili
    • kotisivu
Vs: Soneran 3G-yhteyksien hitaus
« Vastaus #37 : 28.03.10 - klo:16.16 »
Soneran liittymä tuntuu toimivan koneellani paljon hitaammin linuxissa kuin windowsissa.

Todettu myös tuttavalla Soneran kanssa. Ja itse asiaa myös itselläni on sama ongelma, mokkulakäyttöä vain niin vähän ja 384kbit/s-rajoituksella että oletin yleisiä verkko-ongelmia joita en ole jaksanut niin puida. Mutta selvästi ongelma on isompi ja täysin kestämätön jos maksaa suuremmasta nopeudesta kuin 384kbit/s.

Soneran laitteet siis tökkivät Linuxin kanssa. Aiheesta on myös Ubuntuun kirjattu bugiraportti https://bugs.launchpad.net/ubuntu/+source/linux/+bug/525049, mutta kyllähän tämä palveluntarjoajan vastuulla on ettei laitteissa ole tuollaista epäyhteensopivuutta joka ilmenee Linuxista yhdistettäessä. Etenkin kun summataan seuraavat huomiot:
  • Ongelmana on, että tiedostojen siirtonopeus on max. n. 15-20kB/s
  • Sama ongelma täällä kahdella eri mokkulalla, Huawei E220 ja Huaewei E1550. Muilla eri mokkuloita ja samat ongelmat.
  • Ubuntun versiolla ei väliä, sama ongelma esim. 8.04 ja 10.04
  • Saunalahden liittymän kanssa molemmat mokkulat toimivat liittymän täydellä nopeudella. Samoin ilmeisesti DNA jne. kuten mainittu
  • Kahta tiedostoa ladattaessa molemmat tulevat tuolla 15-20kB/s-nopeudella, eri yhteisnopeus kaksinkertainen!
  • YLE Areenan videot toimivat, vaikka kaistan puolesta ei pitäisi -> käyttääkö YLE UDP:ta, ongelmat Soneran kanssa TCP-yhteyksien kanssa?

Onkohan joku jo soitellut Soneralle päin ongelmasta? Varmasti erittäin hankala asia saada heitä kiinnostumaan, ja alkavat välittömästi empiä "joku Linux-juttu" jne., ainakin kunnes huomioi että muut operaattorit toimivat moitteetta ja ongelma on suht selvästi rajattavissa.

Mitähän TCP-asetuksia voisi kokeilla sillä aikaa? En mitenkään pidättelisi hengitystä sen suhteen että Soneran kautta päästäisiin ihan heti käsiksi sellaiseen henkilöön, jolla on riittävä tekninen pääsy laitetasolle näissä asioissa.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3396
    • Profiili
Vs: Karmic ja mokkula
« Vastaus #38 : 28.03.10 - klo:19.08 »
Lainaus
Onkohan joku jo soitellut Soneralle päin ongelmasta?

Kysytty on Soneralta:

http://www5.sonera.fi/keskustele/viewtopic.php?f=53&t=2071
« Viimeksi muokattu: 28.03.10 - klo:19.10 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Timo Jyrinki

  • Sr. Member
  • ****
  • Viestejä: 1250
    • Profiili
    • kotisivu
Vs: Karmic ja mokkula
« Vastaus #39 : 28.03.10 - klo:19.24 »
http://www5.sonera.fi/keskustele/viewtopic.php?f=53&t=2071

Hmm ok. Enpä itse vielä edes lukenut että joku oli kokenut toimivan/täysinopeuksisen Soneran verkon jollain *buntulla ja mokkulalla. Aiempaan luettelooni voi kyllä lisätä "ongelma sekä 32-bittisessä että 64-bittisessä Ubuntussa", koska molempia on myös kokeiltu jo.

Löysin nyt ensimmäisen TCP-asetuksen joka tuntuisi korjaavaan ainakin omassa testitapauksessani nopeuden. Minulla ei itselläni ole kuitenkaan mahdollisuutta testata muuta kuin 384kbit/s-nopeudella, enkä tiedä onko tällä negatiivisia vaikutuksia jossain muualla:
Koodia: [Valitse]
echo 0 | sudo tee /proc/sys/net/ipv4/tcp_window_scaling