Kirjoittaja Aihe: [RATKAISTU]Ongelmana Deltacon luurit ja C-Media USB ajurit.  (Luettu 2753 kertaa)

J-P

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Taas mennään ubuntulla laitteiden kanssa pers eellä puuhun(ja tullaan pää edellä alas). Mutta sille ei voi mitään koska laitteet on hankittu windowsia ajatellen. Laitteena siis Deltacon jokumikälie headset C-Median ajurilla. Ubuntu kyllä tunnistaa C-Median ja äänilaitteina näkyy Alsan, OSS ja Pulseaudion kanssa. Siis tyyliin: C-Media USB Headphone Set USB Audio (ALSA). Ääniä lähtee joka tapauksessa vain sisäisistä kajareista(läppäri). Softakonffausta on jo jonkun ohjeen mukaan koitettu. Windowsin uusin ajuri lienee joku "CM(X) 108 Like sound device". Kuukeloinnilla en ole löytänyt mitään ohjeita. Äänet mitä olen saanut toistaiseksi kuulumaan on vain ääniasetusten testiäänet. Kaikki muut äänet tulevat läpppärin omista kaiuttimista. Ja jos yhtään jelppaa niin 9.04 on ubuntun versio ja läppäri on HP Pavilion dv5. Vehkeet olisi tarkoitus saada pelaamaan myös skypellä joten äänitysjututkin pitäisi saada toimintaan.
« Viimeksi muokattu: 16.09.09 - klo:19.54 kirjoittanut J-P »

Teho

  • Käyttäjä
  • Viestejä: 477
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #1 : 14.09.09 - klo:19.17 »
En tiedä oliko ongelmani sama C-Media USB äänikortin kanssa kuin sinulla, mutta... Itsellä ongelma oli se että ubuntun omista ääni asetuksista ei voinut säätää minkään muun kuin rytmilaatikon ja totemin ääniulostuloa. Ratkaisuna oli laittaa ubuntun omista ääniasetuksista joka kohtaan Pulseaudio-äänipalvelin ja asentaa pavucontrol paketti synaptic-pakettienhallinasta. Sillä sitten pystyi päättämään sovelluskohtaisesti ääniulostulon.

J-P

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #2 : 14.09.09 - klo:21.14 »
Laitoin tuon pavucontrollin ja ääniasetuksista "Mikserin oletuskanavat" kohtaan "Playback C-Media .... (Pulseaudio)". Pavucontrollista defaulttina ovat plbc:ssä ja rcod:ssa C-Media laite. Silti äänet tuppaavat tunkemaan läppärin kaiuttimiin. Pavucontrollin ati(läppärin kaiuttimien) voimakkuuden säätö vaikuttaa ääneen mutta kuulokkeiden säädintä saa renkata miten tykkää eikä pihaustakaan tule ulos. Miten tolla pavucontrollilla saa muka säädettyä sovelluksiin oma laite? Mulla meinaan näkyi vain defaultin asetus.

Teho

  • Käyttäjä
  • Viestejä: 477
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #3 : 14.09.09 - klo:22.50 »
Tosiaan ääniasetuksista kaikkiin kohtiin (äänitapahtumat, musiikit ja elokuvat jne.) "PulseAudio-äänipalvelin" ei "Playback C-Media .... (Pulseaudio)". Sen jälkeen pavucontrollista pitäisi pystyä (ainakin minun tapauksessani) säätämään oletusulostulon kaikille käynnissä oleville ohjelmille Playback välilehdestä. Ohjelmat eivät kuitenkaan esiinny sivulla ohjelman vaan äänikortin nimen mukaan (ei ole harmainta aavistusta miksi) kuitenkaan käytössä olevaa streamia ei ole vaikea spotata. Ulostulon voi vaihtaa painamalla alaspäin osoittavaa hakasta streamin kohdalta -> Move Stream -> ja valitaan haluttu äänikortti.

Jos jollakin on tiedossa helpompi tapa tehdä tämä niin kertokaa ihmeessä. Ja edelleen pitää painottaa, etten tiedä onko kyseessä sama ongelma :p

J-P

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #4 : 15.09.09 - klo:08.08 »
Ääniasetuksista en saa tota "mikserin oletuskanavat" kohtaa kuin Ati...(Pulseaudio). Kaikissa muissa kohdissa on Pulseaudio-äänipalvelin. Mutta sitten taas Playback välilehdellä pavucontrollissa ei ole kuin system soundit. Firefoxia tai rytmiboxia ei näy missään. Myöskään mitään hakasia ei näy missään, jollet tarkoita niitä mitkä ovat siinä alhaalla alasvetovalikossa. Ja samasta ongelmasta en minäkään tiedä mitään, mutta olen huomannut että vähän soveltamalla eri ohjeita saadaan toimiva lopputulos. Kaikki ohjeet otetaan siis vastaan.

Teho

  • Käyttäjä
  • Viestejä: 477
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #5 : 15.09.09 - klo:15.45 »
Mutta sitten taas Playback välilehdellä pavucontrollissa ei ole kuin system soundit. Firefoxia tai rytmiboxia ei näy missään. Myöskään mitään hakasia ei näy missään, jollet tarkoita niitä mitkä ovat siinä alhaalla alasvetovalikossa.
Itsellä ilmestyy aina uusi kohta siihen luetteloon kun käynnistän ohjelman (jossa on ääniä), hakanen on silloin jokaisessa streamissa erikseen eli en tarkoita sitä alhaalla olevaa. Enempää sitten en osaa sanoa.

J-P

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #6 : 15.09.09 - klo:16.35 »
Niin ajattelinkin. Mulla siis siihen luetteloon ei tule mitään ohjelmia, vaikka auki on tulikettu ja rytmilaatikko. Kiitos sulle näistä ohjeista, toivottavasti joku muu osais jelppiä eteenpäin.

J-P

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Vs: Ongelmana Deltacon luurit ja C-Media USB ajurit.
« Vastaus #7 : 16.09.09 - klo:19.03 »
Laitetaan nyt vähän lisäinfoa. Eli sain siis skypen testcallin toimimaan täydellisesti arpomalla skypen omista asetuksista jotkut C-Mediat. Todennäköisesti tämä käyttää alsamixeriä, ainankin äänensäätö toimi alsasta( sekä playback että record). Eli laitteet siis toimintakykyisiä ubuntun kanssa(ko/kö). Kaikki päättömätkin ohjeet otetaan vastaan(, ja niitä noudatetaan oman harkinnan mukaan :) )

EDIT: WOHOOO!! 2 viikon ahkera kiipeeminen kannatti. Nyt sitte tipahdettii ja todettiin jotta toimii. Sain luurit toimimaan alsalla tämän ohjeen mukaan toimimaan. Ainoat huomiokohdat tässä on äänilaitteiden blacklistille lisäämisessä. Eli pitää katsoa
Koodia: [Valitse]
less /proc/asound/modules komennolla mitkä laitteet on ja lisätä ne blacklistille. Myös ohjeen toisessa viestissä jossa ratkaistaan ongelma, puuttuvat blacklistin ja alsa-basen perästä .conf pääte. Tämä siis tiedoksi niille jotka painivat saman ongelman kanssa, ja löytävät tämän ketjun.
« Viimeksi muokattu: 16.09.09 - klo:19.53 kirjoittanut J-P »