Kirjoittaja Aihe: RAID-1 ei herännyt buutin jälkeen - superblock missing  (Luettu 1865 kertaa)

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
Kasasin eilen RAID-1 pakan ja kopion sinne datoja. Kaikki meni hienosti ja homma toimi. Aamulla buuttasin koneen ja katso raid pakkaa ei näkynytkään missään. No sitten googlella hakemaan neuvoja ja tähän on päästy.

1) Molemmat levyt ovat kunnossa ja mdadm -E antaa molemmista lupaavaa järkevää tietoa - correct lukee kaikkialla, joten oletan asioiden olevan kunnossa.

tikola@serveri:~$ sudo mdadm -E /dev/sdc1
/dev/sdc1:
          Magic : a92b4efc
        Version : 00.90.00
           UUID : 925e226b:c1661175:5c658924:daf7db08 (local to host serveri)
  Creation Time : Sun Jul 19 16:29:53 2009
     Raid Level : raid1
  Used Dev Size : 976759936 (931.51 GiB 1000.20 GB)
     Array Size : 976759936 (931.51 GiB 1000.20 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0

    Update Time : Mon Jul 20 09:44:54 2009
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0
       Checksum : 34c46d6 - correct
         Events : 8


      Number   Major   Minor   RaidDevice State
this     0       8       33        0      active sync   /dev/sdc1

   0     0       8       33        0      active sync   /dev/sdc1
   1     1       8       49        1      active sync   /dev/sdd1



2) md0 laitetta ei ole, eli pakka ei ole käynnistynyt

tikola@serveri:~$ sudo mdadm --query --detail /dev/md0
mdadm: md device /dev/md0 does not appear to be active.


3) Syylliseksi epäilen "superblokin" puuttumista toisesta pakan levystä.

tikola@serveri:~$ sudo mdadm -A /dev/md0 /dev/sdc1
mdadm: cannot open device /dev/sdc1: Device or resource busy
mdadm: /dev/sdc1 has no superblock - assembly aborted


Kaikki hyvät ajatukset otetaan vastaan - vaikka ei se levyjen formatointi ja pakan uudelleenkasaus ole mikään mahdottomuus sekään, mutta jos tuon saisi heräteltyä niin hyvä - ja samalla kun saisi idean miten pitää se toimivana seuraavan buutin yli niin kaikki olisi taas hienosti.


timo
« Viimeksi muokattu: 20.07.09 - klo:12.11 kirjoittanut tikola »

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
Vs: RAID-1 ei herännyt buutin jälkeen
« Vastaus #1 : 20.07.09 - klo:12.11 »
Jatketaan sen verran että pari buuttia ja sekalaisia mdadm tarjottuani olen päässyt tilaan, jossa md0 laite on olemassa ja toimii....tosin vain toisella levyllä. Levy joka ei ole mukana näyttäisi vaihtelevan, eli vuoronperään se superblock puuttuu jommasta kummasta limpusta.

Päästäänkö tästä siis siihen, minkä jostain keskustelusta luin, että koneessani SATA levyt buuttaavat hieman eritahtiin ja siten laitenimet menevät sekaisin....josta seuraa superblock ongelma.




timo

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
Vs: RAID-1 ei herännyt buutin jälkeen - superblock missing
« Vastaus #2 : 24.08.09 - klo:22.02 »
Nyt se on sitten ratkaistu.

Toinen levy oli minulle tuntemattomasta syystä päätynyt laitteeksi md_d0 varsinaisen raid pakkani ollessa md0. Toisin sanoen minulle oli ilmestynyt uusi md laite ja se toinen levy oli luiskahtanut sinne. Tiivistäen kaikista komennoista oikeasti tarvitut olivat.

more /proc/mdstat - tämä paljasti mitä kaikkia md laitteita minulla löytyy

sudo mdadm --stop  /dev/md_d0 - tällä pysäytettiin väärä laite

mdadm /dev/md0 -f -a /dev/sdd1 - tällä tuupattin se hukassa ollut levy kiinni oikeaan pakkaan

Ja toistaiseksi kaikki toimii - saa nähdä mitä buutti tälle tekee...

timo

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
Vs: RAID-1 ei heraa buutin - jalkeen md laitteet sekoavat
« Vastaus #3 : 03.09.09 - klo:13.28 »
Ja buutti hukkaa sen uudelleen ja tuo em. rimpsu pitaa toistaa jokaisen buuttauksen jalkeen. Rakentavia ideoita miten sen saisi pysymaan paalla kaivataan.

timo

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
9.10 versiossa on saavuttettu tila, jossa edelleenkin buutissa md0 laite katoaa ja tilalle tulee md_d0 laite. Välillä tuo md_d0 on ihan täydellinen kahden levyn raid-1 pakka ja välillä se toimii vain toisella levyllä. Myös mounttauksen joudun tekemään käsin, koska en ole vielä keksinyt tapaa raid-1 pakan pysyvään mounttaukseen.

Jatkan siis jokaisen buutin jälkeen seuraavalla komentorimpsulla, jolla palautan homman haluamalleni tolalle

cat /proc/mdstat
sudo mdadm --stop /dev/md_d0
sudo mdadm /dev/md0 --assemble --force --add /dev/sdd1 /dev/sdc1
sudo mount /dev/md0 /home/tikola/data


Tämä tapaus voidaan siis pitää ratkaistuna siinä mielessä että toimiva kiertotie on keksitty. Lopullista hyvä ja oikeaa ratkaisua ei vielä ole.


timo

« Viimeksi muokattu: 07.11.09 - klo:16.09 kirjoittanut tikola »

nm

  • Käyttäjä
  • Viestejä: 12916
    • Profiili
Vs: RAID-1 ei herännyt buutin jälkeen - superblock missing
« Vastaus #5 : 07.11.09 - klo:16.16 »
En osaa ratkaista varsinaista ongelmaa, kun en ole RAIDin kanssa taistellut, mutta nuo komennot voisi laittaa /etc/rc.local-tiedostoon (ennen exit 0 -riviä) automaattisesti ajettaviksi. Sudoa ei tarvitse käyttää, koska rc.local ajetaan pääkäyttäjän oikeuksin.

tikola

  • Käyttäjä
  • Viestejä: 130
    • Profiili
Vs: RAID-1 ei herännyt buutin jälkeen - superblock missing
« Vastaus #6 : 08.11.09 - klo:00.02 »
Periaatteessa tuossa ajatuksessa voisi olla tolkkua. Toisaalta sillä vain korjataan vika, mutta ei paikanneta syytä. Ennen tuota ratkaisumallia käytin hieman toisenlaisia komentoja ja niissä onglema oli ettei etukäteen ole ihan varma kumpi levy milloinkin oli mukaan lähtenyt. Oletan että tämä liittyy jotenkin SATA levyjen vaihtelevaan käynnistysjärjestykseen. Tuolla nykyisellä komentorimpsulla ei tämä vaikuta mitään, koska kumminkin kasaan sen aina uusiksi. Siis ideasi nähdäkseni voisi hyvinkin toimia. Jatkan kumminkin ensin varsinaisen syyn metsästämistä ja sitten kun kyllästyn tuon rimpsun toistamiseen alan pohtia ideaasi tarkemmin.

Kiitoksia vinkistä,

Timo