Kirjoittaja Aihe: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.  (Luettu 8651 kertaa)

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vaikuttaisi ettei ääni kortti tunnistu, mutta itsellä loppu etenemistavat. Gstreamer ilomoittaa: GStreamer ei löydä äänilaitteita. Voi olla, että sinulta puuttuu äänijärjestelmääsi liittyviä GStreamerin liitännäisiä. Tämä voi johtua myös käyttöoikeusongelmasta. 

Tässä pari tulostetta:
Koodia: [Valitse]
lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:04.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
00:04.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:04.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:04.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:0d.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV200 QW [Radeon 7500]

ja
Koodia: [Valitse]
lsmod |grep snd
snd_wss_lib            33920  0
snd_pcm_oss            46336  0
snd_mixer_oss          22656  1 snd_pcm_oss
snd_pcm                82948  2 snd_wss_lib,snd_pcm_oss
snd_page_alloc         16904  2 snd_wss_lib,snd_pcm
snd_opl3_lib           18560  0
snd_hwdep              15108  1 snd_opl3_lib
snd_mpu401_uart        15104  0
snd_seq_dummy          10756  0
snd_seq_oss            37760  0
snd_seq_midi           14336  0
snd_rawmidi            29696  2 snd_mpu401_uart,snd_seq_midi
snd_seq_midi_event     15104  2 snd_seq_oss,snd_seq_midi
snd_seq                56880  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29704  4 snd_wss_lib,snd_pcm,snd_opl3_lib,snd_seq
snd_seq_device         14988  6 snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    62628  12 snd_wss_lib,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15200  1 snd

Oliskohan ratkasua?


edit//gdm, otsikkoa muokattu
« Viimeksi muokattu: 05.05.09 - klo:17.52 kirjoittanut gdm »
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #1 : 05.05.09 - klo:00.53 »
Onko päivitys 8.10 -> 9.04
vai puhdas asennus?

Mitä kertoo "aplay -l; lshw -C multimedia"
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #2 : 05.05.09 - klo:01.07 »
Lainaus
Onko päivitys 8.10 -> 9.04
vai puhdas asennus?
Päivitys ja tarkalleen ottaen xubuntu. Asein siis 8.10 jonka samantien päivitin 9.04 joten eipä tullu testattua toimiko ne äänet siinä aiemassa.

Koodia: [Valitse]
aplay -l; lshw -C multimedia
aplay: device_list:217: äänikortteja ei löytynyt...

Kortti on ISA väylässä ja toimi opensuse 11.1 normaalisti.
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #3 : 05.05.09 - klo:01.12 »
Onko päivitys mennyt kokonaan läpi?
Koodia: [Valitse]
uname -a
Muistatko yhtään mikä kortti on kyseessä, helpottaisi huomattavasti selvittämisessä.

Tuolla hiukan lisäapua
https://help.ubuntu.com/community/SoundTroubleshooting
« Viimeksi muokattu: 05.05.09 - klo:01.14 kirjoittanut gdm »
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #4 : 05.05.09 - klo:09.58 »
Koodia: [Valitse]
uname -a
Linux karpalolonkero 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux
Kettelempa vielä kopasta mikä kortti on...
Ohhoh!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #5 : 05.05.09 - klo:10.03 »
Kortissa lukee "Yamaha 3D sound card" , "Bansan BS1" ja toisella pulella tarrassa "MS719      707146063"  Tässä on kaikki tietoni tuosta kortistä kun se on ylijäämä korttina mulle tullut.
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #6 : 05.05.09 - klo:10.24 »
Kortissa lukee "Yamaha 3D sound card" , "Bansan BS1" ja toisella pulella tarrassa "MS719      707146063"  Tässä on kaikki tietoni tuosta kortistä kun se on ylijäämä korttina mulle tullut.

Kaksi mahdollisuutta ainakin,
Kokeilla openSusen livelevyllä mikä kortti/moduuli siellä oikein on.

tai ajaa seuraava
Koodia: [Valitse]
wget -O alsa-info.sh http://alsa-project.org/alsa-info.sh && bash ./alsa-info.shja kertoa se URL niin pääsee katsomaan mitä se voisi kertoa.

ISA-väyläisten pitäisi kyllä toimia, joten hiukan ihmetyttää?
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #7 : 05.05.09 - klo:16.45 »
tossa ois :
http://www.alsa-project.org/db/?f=b4fdfb32810d417f41c34f468ae4fa1b4d66ee70


mun silmään ei näyttäny hyvältä   :-\

boottailempa vielä siltä opensusen liveltä...
Ohhoh!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #8 : 05.05.09 - klo:16.56 »
Opensusen levy kertoo kyseessä olevan:
OPL3-SA3 Sound Board
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #9 : 05.05.09 - klo:17.04 »
Opensusen levy kertoo kyseessä olevan:
OPL3-SA3 Sound Board

No nyt löytyi tällaista:
Koodia: [Valitse]
Module snd-opl3sa2
  ------------------

    Module for Yamaha OPL3-SA2/SA3 sound cards.

    isapnp - ISA PnP detection - 0 = disable, 1 = enable (default)

    with isapnp=0, the following options are available:

    port - control port # for OPL3-SA chip (0x370)
    sb_port - SB port # for OPL3-SA chip (0x220,0x240)
    wss_port - WSS port # for OPL3-SA chip (0x530,0xe80,0xf40,0x604)
    midi_port - port # for MPU-401 UART (0x300,0x330), -1 = disable
    fm_port - FM port # for OPL3-SA chip (0x388), -1 = disable
    irq - IRQ # for OPL3-SA chip (5,7,9,10)
    dma1 - first DMA # for Yamaha OPL3-SA chip (0,1,3)
    dma2 - second DMA # for Yamaha OPL3-SA chip (0,1,3), -1 = disable
   
    This module supports multiple cards and ISA PnP.  It does not support
    autoprobe (if ISA PnP is not used) thus all ports must be specified!!!
   
    The power-management is supported.

Eli kokeile ladata moduli:
Koodia: [Valitse]
sudo modprobe snd-opl3sa2Mitä tapahtuu? En usko kuitenkaan sen noin helpolla selviävän... :(
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #10 : 05.05.09 - klo:17.14 »
https://help.ubuntu.com/community/forum/hardware/OldSoundCard

Ehdin jo itsekin bongata jotain saman suuntaista...
Koodia: [Valitse]
sudo modprobe opl3 port=0x220 irq=5 dma1=1pitäiskö tuo karvata tosta ohjeesta entamallasi?
Koodia: [Valitse]
sudo modprobe snd-opl3sa2En biossista ainakaan osannut katsoa noita portteja yms....
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #11 : 05.05.09 - klo:17.17 »
Korvaa se aluksi antamallani, jos se ei toimi, niin sitten ruvetaan katsomaan niitä lisäasetuksia.
Kokeilemalla se selviää.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #12 : 05.05.09 - klo:17.40 »
No uli sellanen muutos, että palkissa näkyy nyt aktiivisena toi ääni säätö namikka mut ei silti kuulu...  :-\
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #13 : 05.05.09 - klo:17.42 »
No uli sellanen muutos, että palkissa näkyy nyt aktiivisena toi ääni säätö namikka mut ei silti kuulu...  :-\

Tarkista alsamixerin avulla ettei mikään äänilähtö ole mykistetty.
Koodia: [Valitse]
alsamixer
alsamixer -Dhw
Nuolinäppäimet liikkuttaa, M asettaa mykistyksen päälle/pois ja ESC lopettaa
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi.
« Vastaus #14 : 05.05.09 - klo:17.49 »
Koodia: [Valitse]
alsamixertuolla kaikki ok...
mutta sitten tää toinen heittää:
Koodia: [Valitse]
alsamixer -Dhw

alsamixer: function snd_ctl_open failed for hw: No such file or directory
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.
« Vastaus #15 : 05.05.09 - klo:17.55 »
Sitten pitää ruveta katsomaan niitä oikeita lisäarvoja tuolle ajurille,

Esim:
Koodia: [Valitse]
sudo modprobe snd-opl3sa2 port=0x220 irq=5 dma1=1
Mutta pitää poistaa edellinen moduuli käytöstä ensiksi
Koodia: [Valitse]
sudo modprobe -r snd-opl3sa2            tai-->>
sudo rmmod snd-opl3sa2
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.
« Vastaus #16 : 05.05.09 - klo:18.30 »
Koodia: [Valitse]
aplay -l
**** Luettelo PLAYBACK laitteista ****
kortti 0: OPL3SA23 [Yamaha OPL3-SA23], laite 0: WSS [Yamaha OPL3-SA23]
  Alalaitteet: 1/1
  Alalaite #0: subdevice #0

Koodia: [Valitse]
cat /proc/asound/cards
 0 [OPL3SA23       ]: OPL3SA2 - Yamaha OPL3-SA23
                      Yamaha OPL3-SA23 at 0x370, irq 5, dma 0&1

näyttää vahvasti että kortti tunnistui nyt  :D
http://www.abclinuxu.cz/hardware/pridavne-karty/zvukove-karty/yamaha/yamaha-opl3-sa23
Lainaus
Postup zprovoznění pod Linuxem
Karta je v modernich distribucich detekovana automaticky. Karta je PNP.

Alsa driver od 2.6 jadra.

pripadne lze pro detekci karty pouzit alsaconf.

pripadne nahrat modul snd-opl3-sa2
Mitä meinannee tuosssa  tuo teksti ajurista.... mutta nyt ainakin on tiedossa nuo Yamaha OPL3-SA23 at 0x370, irq 5, dma 0&1... jospa nyt tuottas tulosta.... :P
Ohhoh!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.
« Vastaus #17 : 05.05.09 - klo:19.01 »
Ei lähe toimii.
Koodia: [Valitse]
sudo modprobe snd_opl3sa2 port=0x370 irq=5 dma0=1
WARNING: All config files need .conf: /etc/modprobe.d/oss-compat, it will be ignored in a future release.
FATAL: Error inserting snd_opl3sa2 (/lib/modules/2.6.28-11-generic/kernel/sound/isa/snd-opl3sa2.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Koodia: [Valitse]
dmesg
.......
[   11.461477] piix4_smbus 0000:00:04.3: SMBus Host Controller at 0xe800, revision 0
[   11.575956] input: PC Speaker as /devices/platform/pcspkr/input/input3
........
tOssa vissiin jotain asiaan liittyvää tulostetta... ehkä  ;D
Ohhoh!

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.
« Vastaus #18 : 05.05.09 - klo:19.06 »
Kirjainkoolla ja merkillä on väliä
modprobe snd-
modprobe snd_
Sinun komennossa oli alaviiva, jonka takia herjaa.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Pjotor

  • Käyttäjä
  • Viestejä: 291
    • Profiili
Vs: Ubuntu 9.04 äänet eivät toimi Yamaha 3D OPL3-SA3.
« Vastaus #19 : 05.05.09 - klo:19.10 »
Lainaus
Kirjainkoolla ja merkillä on väliä
modprobe snd-
modprobe snd_
Sinun komennossa oli alaviiva, jonka takia herjaa
Sama herja...
Koodia: [Valitse]
sudo modprobe snd-opl3sa2 port=0x370 irq=5 dma0=1
WARNING: All config files need .conf: /etc/modprobe.d/oss-compat, it will be ignored in a future release.
FATAL: Error inserting snd_opl3sa2 (/lib/modules/2.6.28-11-generic/kernel/sound/isa/snd-opl3sa2.ko): Unknown symbol in module, or unknown parameter (see dmesg)
Ohhoh!