Kirjoittaja Aihe: PHP toimimaan ubuntussa [kysytty]  (Luettu 24002 kertaa)

Kullervo

  • Käyttäjä
  • Viestejä: 875
    • Profiili
PHP toimimaan ubuntussa [kysytty]
« : 27.03.06 - klo:12.34 »
Asentelin sitten ubuntun n. viisi vuotta vanhalle koneelleni yksinomaiseksi järjestelmäksi.
Ubuntu asentui nätisti, aikaakaan ei kulunut kuin (?) noin kaksi tuntia. Suurin aika kului asentamiseen tarvittavien tiedostojen päivityksessä.

Ajattelin sitten pystyttää testiserverin (Apache) ja saman tien asentaa siihen phpn, mysql tietokantaohjelman ja phpmyadminin... mutta!

test.php sivua selaimellani avatessa avautuukin laatikko jossa kysytään millä ohjelmalla se avataan vai tallennetaanko mahdollisesti levylle, miksi näin?

index.html sivu aukeaa ihan oikein, siis apache toiminee. PHP-tulkki ja Apache eivät sitten ilmeisesti "keskustele" keskenään oikein?

Koska olen ihan aloittelija linus-käyttäjä niin en osaa esittää ongelmaani kummemmin, siispä lisätietoja annetaan tarvittaessa.
« Viimeksi muokattu: 16.08.08 - klo:15.58 kirjoittanut Kari Argillander »

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Re: PHP toimimaan ubuntussa
« Vastaus #1 : 27.03.06 - klo:12.51 »
Terve!

Itsekin pyörittelen ubuntussa (ei server - asennus vaan ihan normi desktopasennus) apache 2:sta ja PHP 5:sta.

Moisen huomasin että oletuksena apache ei osannut löytää index.php - tiedostoja vaan yritti etsiä vain .htm ja .html - päätteisiä.

Tämän saa toimimaan muokkaamalla apachen asetustiedostoa (joka löytyy /etc/apache2/apache2.conf - jos siis olet asentanut apache 2:n)

Koodia: [Valitse]
DirectoryIndex index.php index.html index.htm index.cgi index.pl index.xhtml

Tälle riville lisäsin alkuun tuon index.php:n

Jos ei vielä auta, varmista että sinulla on oikeat paketit asennettuna. Ihan satavarmasti en osaa sanoa mitkä kaikki pitää olla asennettuna jotta apache & php toimisivat yhteen, jopa puoli kahteen, mutta itselläni on ainakin seuraavat apacheen ja php:n liittyvät asennettuna:
  • apache2
  • apache2-common
  • apache2-mpm-prefork
  • apache2-utils
  • libapache2-mod-php5 (tämä voisi olla sinulta puuttuva, voisi oireilla juurikin mainitsemallasi tavalla..)
  • php5
  • php5-common
  • php5-mysql (jos tietokantojen käyttä mysql:llä kiinnostaa..)
Ja asentaminenhan käy synaptic - ohjelmalla (löytyy jostain valikoista, en muista tai käynnistämällä komentoriviltä kirjoittamalla
Koodia: [Valitse]
sudo synapticja antamalla pääkäyttäjän salasana..

haulla etsit hakusanoilla 'apache2' ja 'php5' niin paketit löytyy. Merkkaat valintalaatikosta asennettavaksi ja painat installia..

Tai komentoriviltäkin voi yksittäisiä paketteja asentaa kirjoittelemalla
Koodia: [Valitse]
sudo apt-get install paketinnimi eli esim
Koodia: [Valitse]
sudo apt-get install libapache2-mod-php5 ja antamalla kysyttäessä pääkäyttäjän salasana.

Ja jos käytät php:n ja/tai apachen vanhempaa versiota niin niille varmastikin löytyy samanlaiset paketit mutta ilman noita kakkos tai vitosnumeroita.

Kysele lisävinkkiä jos ei onnistu..


r

ps. apachen ja mysql:n päälläpitäminen syö jonkin verran resursseja ja esim. viisi vuotta vanha kone taatusti kyllä jaksaa noita pyörittää mutta muistia voi jäädä jonkin verran vähemmän muiden ohjelmien käyttöön, jos meinaat samaa konetta myös työpöytäkäytössä käyttää..
« Viimeksi muokattu: 27.03.06 - klo:12.57 kirjoittanut rhk »
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

tkodex

  • Käyttäjä
  • Viestejä: 41
    • Profiili
Re: PHP toimimaan ubuntussa
« Vastaus #2 : 31.03.06 - klo:14.21 »
Isellänikin on sama ongelma kuin kysyjällä. PHP5 tulkki ei tunnu toimivan apache2:den kanssa. Ennen noi sai heittämällä toimimaan -> olisiko jokin uusi päivitys laittanut homman rikki. Kaikki kirjastot jota rhk mainitsee on asennettuna. Kun yrittää avata esim. ohjelma.php -sivua, niin selain vain kysyy mihin phtml tiedosto tallennetaan ja tämä phtml tiedosto (vaikka alunperin siis php) ei ole mennyt tulkin läpi, vaan kaikki <?php ?> tagit näkyvät.

Muokattu: http://www.ubuntuforums.org/showthread.php?t=147063
Huomasin, että tuossa vinkissä oleva komento "sudo a2enmod php5" antoi vain palautteen "This module does not exist!", vaikka libapache2-mod-php5  oli asennettuna. Poistin ko. paketin kokonaan ja asensin uudelleen ja kokeilin taas niin komento antoikin vastaukseksi "This module is already enabled!" ja web-sivut lähtivät toimimaan  :)
« Viimeksi muokattu: 31.03.06 - klo:14.40 kirjoittanut tkodex »

Kari Argillander

  • Käyttäjä
  • Viestejä: 437
  • Kubuntu - Hardy
    • Profiili
Vs: PHP toimimaan ubuntussa
« Vastaus #3 : 16.08.08 - klo:15.58 »
Voisiko ohjeen kirjoittaja/täydentäjät kirjoittaa viestin jossa vahvistavat että     

a) ohje on edelleen käyttökelpoinen Hardyssä (tuorein LTS, tuorein stable) eli uudet ominaisuudet eivät ole poistaneet tarvetta ohjeelle tai että ohjeessa käytetyt työkalut jne ovat edelleen Hardyssä käytössä
b) antavat luvan ohjeen siirtämiseen Ubuntu Suomen wikiin (http://wiki.ubuntu-fi.org). Kts. Wikin lisenssistä jne lisätietoja täältä: http://wiki.ubuntu-fi.org/#head-867666147f48c6b667ec0f6be3f5f16852046770
c) antavat luvan ohjeen siirtämiseen Linux.fi-wikiin (http://linux.fi/index.php/Etusivu). Kts. Wikin lisenssistä jne lisätietoja täältä: http://linux.fi/index.php/Linux.fi:Lisenssi

Sinun ei ole pakko antaa lupaa siirtää ohjetta molempiin wikeihin vastaat tällöin vain joka b:hen tai c:hen kyllä.
Kiitos!
Kaikkea täällä sanomaani saa käyttää public domain lisenssillä. Lainauksia ei saa käyttää ellei lainauksen lähde sitä salli. Tiedostoja ei saa käyttää ellei sitä erikseen sallita.

peran

  • Vieras
Vs: PHP toimimaan ubuntussa [kysytty]
« Vastaus #4 : 17.08.08 - klo:01.06 »
Eiköhän Wikin LAMP ohje ole aivan riittävä. Siinä on ratkaistu syvällisemmin ja täydellisemmin tässä ilmenneet asiat.