Kirjoittaja Aihe: (RATKAISTU) Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)  (Luettu 3145 kertaa)

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Morjens!

Nyt on Ubuntu 8.10 hommattu ja hienosti näyttää toimivan (myös mokkula!)
Ainoa ongelmana tuntuu olevan resoluutio :/

Meinaan kun käynnistän Live CD (Minkä tilasin ilmaiseksi postissa) ja pistän Livet pyörimään, ja alku lataukset on suoritettu, niin ei kestä minuuttiakaan kun ruutu menee ihan pimeäksi ja mitään ei pysty tekemään. Alussa hiiri kuitenkin näkyy jä vaaleanruskeata taustalla (tuntuu kanssa että resoluutio on silloin 1440*900, vaikka maksimissaan tässä pystyy olemaan 1280*800).

MUTTA

Sitten kun pistän ns. Safe Moden päälle niin kaikki toimii moitteettomasti mutta resoluutio on hitusen pienempi kuin normaalisti (jtn. 1280*762)
Olen kokeillut käsin muokkaa xorg tiedostoa, mutta ihan turhaan sillä mitään muutosta ei näy rebootin jälkeen.

Onko olemassa mitään ratkaisua?

ps. Onkos VIAlla hyvät laitetuet linuxin kanssa? :P
« Viimeksi muokattu: 28.02.09 - klo:01.01 kirjoittanut Zerottaja »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10768
    • Profiili
    • Tomin kotisivut
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #1 : 23.02.09 - klo:19.17 »
LiveCD:llä ei säily mitkään tiedot (jos et niitä vaikka muistitikulle tallenna tietty) eli siksi se Xorg.conffi häviää rebootissa.

VIA ei vissiin ole niitä kaikkein parhaiten tuettuja juttuja... :-\

Tarvitsisi varmaan tietää enemmän tuosta näytönohjaimesta. Jos et tiedä tarkempaa mallia (kuin VIA) niin käynnistä se levy safe modessa ja avaa pääte (Sovellukset > Apuohjelmat > Pääte) ja komenna lspci ja laita tuloste viestiin mukaan (siis kopioi se).

PS. Reson muuten näkee Järjestelmä > Asetukset > Näytön tarkkuus niin ei tarvitse arvailla... :)
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #2 : 23.02.09 - klo:19.32 »
http://linux.via.com.tw/support/downloadFiles.action

Täräytäpä tuolta. Ainaki Amilo 1703:n VIA-näyttis lähti toimaamaan ihan ok:sti.

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #3 : 23.02.09 - klo:19.59 »
LiveCD:llä ei säily mitkään tiedot (jos et niitä vaikka muistitikulle tallenna tietty) eli siksi se Xorg.conffi häviää rebootissa.

VIA ei vissiin ole niitä kaikkein parhaiten tuettuja juttuja... :-\

Tarvitsisi varmaan tietää enemmän tuosta näytönohjaimesta. Jos et tiedä tarkempaa mallia (kuin VIA) niin käynnistä se levy safe modessa ja avaa pääte (Sovellukset > Apuohjelmat > Pääte) ja komenna lspci ja laita tuloste viestiin mukaan (siis kopioi se).

PS. Reson muuten näkee Järjestelmä > Asetukset > Näytön tarkkuus niin ei tarvitse arvailla... :)

Unohdin ilmoittaa että asensin ubuntun koneelle ennen kuin aloin sähläämään xorgin kanssa, sori :D

Tälläistä tekstiä tuli kun kirjoitin päätteeseen ispci:
00:00.0 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.1 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:00.5 PIC: VIA Technologies, Inc. K8M890CE I/O APIC Interrupt Controller
00:00.7 Host bridge: VIA Technologies, Inc. K8M890CE Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800/K8T890 South]
00:02.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:03.0 PCI bridge: VIA Technologies, Inc. K8T890 PCI to PCI Bridge Controller
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 01)
04:01.0 Audio device: VIA Technologies, Inc. VT1708/A [Azalia HDAC] (VIA High Definition Audio Controller) (rev 10)

===

jussike, minulla juuri tuo kone! Voisipa täräyttää mutta en tiedä mitä tehdä :/
Anteeksi olen vielä hieman amatoori linuxien parissa...
Valaistakaapas hieman vielä
« Viimeksi muokattu: 23.02.09 - klo:20.05 kirjoittanut Zerottaja »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 10768
    • Profiili
    • Tomin kotisivut
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #4 : 23.02.09 - klo:20.21 »
Koodia: [Valitse]
01:00.0 VGA compatible controller: VIA Technologies, Inc. K8M890CE/K8N890CE [Chrome 9] (rev 01)
Hienoa. Näytönohjain näyttäisi olevan VIAn Chrome (yllätys yllätys kun viasta puhutaan...). :)
Onko paketti xserver-xorg-video-openchrome asennettuna? Voit asentaa sen vaikkapa Synapticilla. :) Siis jos pääset asennettuun Ubuntuun ja ymmärtääkseni pääset...
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #5 : 23.02.09 - klo:21.07 »
Tota Tomppelin juttua kantsii kokeilla ekaks.

Mut oisko tästä apua, vai pitäiskö olla vielä yksityiskohtaisemmat ohjeet?

http://forum.ubuntu-fi.org/index.php?topic=21487.msg160785#msg160785

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #6 : 23.02.09 - klo:22.03 »
Tota Tomppelin juttua kantsii kokeilla ekaks.

Mut oisko tästä apua, vai pitäiskö olla vielä yksityiskohtaisemmat ohjeet?

http://forum.ubuntu-fi.org/index.php?topic=21487.msg160785#msg160785

Nyt on resoluutiot kunnossa... Mutta... Ööh... Hiiri ei enään näy ruudulla kun korvasin xorg.confin ehdottamillasi asetuksilla... Mitäs nyt?

Olipa muuten hemmetin vaikeata päästä kirjoittamaan tätä tekstiä näkymättömän hiiren kanssa :P

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #7 : 23.02.09 - klo:23.42 »
Tota Tomppelin juttua kantsii kokeilla ekaks.

Mut oisko tästä apua, vai pitäiskö olla vielä yksityiskohtaisemmat ohjeet?

http://forum.ubuntu-fi.org/index.php?topic=21487.msg160785#msg160785

Nyt on resoluutiot kunnossa... Mutta... Ööh... Hiiri ei enään näy ruudulla kun korvasin xorg.confin ehdottamillasi asetuksilla... Mitäs nyt?

Olipa muuten hemmetin vaikeata päästä kirjoittamaan tätä tekstiä näkymättömän hiiren kanssa :P

No toi ohje oli 8.04-versiolle, joten ei ihme jos on pientä viilaamista.

8.10:n pitäis tunnistaa noi vermeet automaattisesti (ilman xorg.confia), joten kokeilepa vetäistä hiirtä koskeviin asetuksiin vaa # eteen, eli silloin niitä ei lueta. Jos ei auta niin kokeile kokonaan ilman xorg.confia.

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #8 : 24.02.09 - klo:18.27 »
Tota Tomppelin juttua kantsii kokeilla ekaks.

Mut oisko tästä apua, vai pitäiskö olla vielä yksityiskohtaisemmat ohjeet?

http://forum.ubuntu-fi.org/index.php?topic=21487.msg160785#msg160785

Nyt on resoluutiot kunnossa... Mutta... Ööh... Hiiri ei enään näy ruudulla kun korvasin xorg.confin ehdottamillasi asetuksilla... Mitäs nyt?

Olipa muuten hemmetin vaikeata päästä kirjoittamaan tätä tekstiä näkymättömän hiiren kanssa :P

No toi ohje oli 8.04-versiolle, joten ei ihme jos on pientä viilaamista.

8.10:n pitäis tunnistaa noi vermeet automaattisesti (ilman xorg.confia), joten kokeilepa vetäistä hiirtä koskeviin asetuksiin vaa # eteen, eli silloin niitä ei lueta. Jos ei auta niin kokeile kokonaan ilman xorg.confia.

Kokeilin pistää hiireä koskevia asetuksia pois mutta mitään erityistä ei tapahtunut...
Mitä meinaat "kokeile kokonaan ilman xorg.conffia."? Siis että poistaisin rivit jotka käsittelevät hiirtä?

Olisi kiva oikeasti saada ubuntu toimimaan... :(
Tässä vielä xorg.conffini ilman tietämiäni hiiriasetuksia:
Koodia: [Valitse]
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "Monitor"
Identifier "Monitor"
EndSection

Section "Device"
Driver "via"
Identifier "Configured Video Device"
Option "LCDPort"       "DFP_HIGHLOW"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection

Section "Module"
Disable  "glx"
Load  "dri"
Load  "extmod"
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "Configured Video Device"
    Monitor        "Monitor"
    DefaultDepth    24
    SubSection "Display"
Depth 24
Modes "1280x800"
Virtual 1280 800
EndSubSection
EndSection
===

Onko mitään ideoita?
« Viimeksi muokattu: 24.02.09 - klo:18.29 kirjoittanut Zerottaja »

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #9 : 24.02.09 - klo:18.46 »
Mitä meinaat "kokeile kokonaan ilman xorg.conffia."? Siis että poistaisin rivit jotka käsittelevät hiirtä?

Siis sitä, että 8.10 Ubuntu pitäs toimia, vaikka koko tiedostoa ei olisi olemassa. Ainakaan minulla Virtualbox-asennuksessa ei ole.

Mutta tarkemmin ajatellen eihän tuo käy, kun siellä on nyt tuo ajurimääritys Driver "via"

Hmm...en osaa nyt heti sanoa enempää.

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #10 : 24.02.09 - klo:22.49 »
Mitä meinaat "kokeile kokonaan ilman xorg.conffia."? Siis että poistaisin rivit jotka käsittelevät hiirtä?

Siis sitä, että 8.10 Ubuntu pitäs toimia, vaikka koko tiedostoa ei olisi olemassa. Ainakaan minulla Virtualbox-asennuksessa ei ole.

Mutta tarkemmin ajatellen eihän tuo käy, kun siellä on nyt tuo ajurimääritys Driver "via"

Hmm...en osaa nyt heti sanoa enempää.

Jaa. No täytynee kokeilla sokkona jotain tällä säätää...
Kiitos kuitenkin avusta.

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #11 : 24.02.09 - klo:23.36 »
Laitapa vielä se alkuperäinen antamani xorg.conf ja kokeile tätä.

Koodia: [Valitse]
Section "Screen"
    Identifier    "Default Screen"
    Device        "Configured Video Device"
    Monitor        "Monitor"
    DefaultDepth    24
    Option         "HWCursor" "On"
    SubSection "Display"
Depth 24
Modes "1280x800"
Virtual 1280 800
EndSubSection
EndSection

Eli kokeile lisätä tuo HWCursor-rivi ja kokeile sekä "On" että "Off" -arvoja.

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #12 : 25.02.09 - klo:19.28 »
Laitapa vielä se alkuperäinen antamani xorg.conf ja kokeile tätä.

Koodia: [Valitse]
Section "Screen"
    Identifier    "Default Screen"
    Device        "Configured Video Device"
    Monitor        "Monitor"
    DefaultDepth    24
    Option         "HWCursor" "On"
    SubSection "Display"
Depth 24
Modes "1280x800"
Virtual 1280 800
EndSubSection
EndSection

Eli kokeile lisätä tuo HWCursor-rivi ja kokeile sekä "On" että "Off" -arvoja.

Kokeilin, eikä mitään tapahtunut... Onko mitään muita keinoja muokata resoluutioita kuin pelkästään kirjoittamalla omiaan xorg.conffiin tai sillä "vaiha resoluutiota"-jutskalla :P
Tai onnistuisiko jos kirjoittaisi VESAn asetukset xorg.conffiin? Ainakin Opensusella resoluutio toimii mainiosti niillä asetuksilla.

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #13 : 25.02.09 - klo:21.09 »
Tai onnistuisiko jos kirjoittaisi VESAn asetukset xorg.conffiin? Ainakin Opensusella resoluutio toimii mainiosti niillä asetuksilla.

Koodia: [Valitse]
sudo dpkg-reconfigure -phigh xserver-xorg

Toi palauttaa xorg.conffin oletusasetuksiin.
Sitten voit kokeilla:

Koodia: [Valitse]
Section "Device"
.
.
.
Driver "vesa"
.
.
.
EndSection

Toinen (ehkä parempi) tapa olisi ottaa sieltä Opensusesta talteen xorg.conf. On tietysti mahdollista, että se käyttää Xorgista eri versiota, jolloin conffi ei taas suoraan toimi.

Mulla ei tähän ole sitten muita eväitä, kun *buntu 8.04 kehiin. Sitten taas tulee se, että se sun mokkula ei toimi yhtä suoraviivaisesti...

Yhteensopivuudet kantsis tosiaan tarkistaa ennen koneen ostoa...

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Vs: Resoluutio ongelmia (VIA Chrome9 HC IGP Family WDDM)
« Vastaus #14 : 28.02.09 - klo:01.01 »
Noniiin!

Nettiä vähän selailemalla löysin tähän koneeseen sopivan xorg.conffin ja resoluutiot toimii hyvin.
Kiitos kaikille avusta! :)

jussike

  • Käyttäjä
  • Viestejä: 979
    • Profiili
Jopjop :)

Laitatkos vielä näkyville toimivan konffin seuraavia varten.

HaXeri

  • Käyttäjä
  • Viestejä: 225
  • Arch linux & Kubuntu 10.04
    • Profiili
    • niksipedia
Juu minulla löytyy myös tämä todellinen HC piiri. Mikä on läppärin merkki/malli? Minulla on Fujitsu Siemens amilo li 1705 ja minulla ei toimi edes ibexin safe modissa mutta nyt käytän jauntyä ja se toimii moitteettomasti. 3d kiihdytyksiä vielä odotellaan (ilmeisesti jo mahdollinen mutta en ole vielä saanut toimimaan)
HUOMIO! Linux kouluihin! AMD Phenom II 3.2GHz X4  2x2gt 1600mhz 500gt
Dealextremestä tekniikkaa polkuhintaan

Zerottaja

  • Käyttäjä
  • Viestejä: 8
    • Profiili
Koodia: [Valitse]
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "dbe"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "record"
Load "v4l"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fi"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "Tarjeta de vídeo genérica"
Driver "vesa"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor genérico"
Option "DPMS"
HorizSync 30-62
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Tarjeta de vídeo genérica"
Monitor "Monitor genérico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection

Tälläisellä sain koneen resoluutiot toimimaan. Ilmeisesti Espaniaa jotkut kohdat, mutta eipä se tunnu haittaavan :P