Kirjoittaja Aihe: Päivitysongelma 8.10->9.04 [Ratkaistu]  (Luettu 2390 kertaa)

walterboy

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Päivitysongelma 8.10->9.04 [Ratkaistu]
« : 03.01.09 - klo:01.22 »
Tuollaista virheviestiä pukkaa kun yritän päivittää Jaunty Jackalopeen:

W:Tiedoston http://fi.archive.ubuntu.com/ubuntu/dists/jaunty-updates/Release nouto ei onnistunut  Unable to find expected entry  partner/binary-i386/Packages in Meta-index file (malformed Release file?)
, W:Tiedoston http://fi.archive.ubuntu.com/ubuntu/dists/jaunty-security/Release nouto ei onnistunut  Unable to find expected entry  partner/binary-i386/Packages in Meta-index file (malformed Release file?)
, E:Joidenkin hakemistotiedostojen nouto ei onnistunut, ne on ohitettu tai käytetty vanhoja.

Yritin vaihtaa Ruotsin palvelimeen, mutta se ei auttanut.
Onko muille foorumin jäsenille ilmennyt samanlaisia ongelmia?

//muoks, otsikkoa muokattu.
« Viimeksi muokattu: 06.01.09 - klo:12.51 kirjoittanut walterboy »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Päivitysongelma 8.10->9.04
« Vastaus #1 : 04.01.09 - klo:12.12 »
Millä tavalla yritit päivittää?
Vieläkö ongelma on ajankohtainen?

Jaunty on pahasti keskeneräinen, ja kannattaa miettiä omia valmiuksia sen käyttämiseen.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

harrykaa

  • Vieras
Vs: Päivitysongelma 8.10->9.04
« Vastaus #2 : 04.01.09 - klo:16.05 »
Saattaisi auttaa, jos lähetät tänne tiedoston "sources.list" sisällön.

Saat sen komentorivillä esiin esim. komennolla:
Koodia: [Valitse]
cat /etc/apt/sources.list
Voi nimittäin olla, että tuossa pakettivarastolistassa on jotain häikkää.

Toisaalta minulla ei ole kovinkaan hyviä kokemuksia distron päivittämisistä.
On aina varminta asentaa uudelleen ja vaikka jättää osio /home formatoimatta.
Ei saa unohtaa myöskään varmuuskopiointia.
Ja vielä, älä päivitä alfa-versiota ainoalle koneelle.

walterboy

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: Päivitysongelma 8.10->9.04
« Vastaus #3 : 05.01.09 - klo:20.24 »
Yritin päivittää komennolla "sudo update-manager -d"

Sources-list sisältää seuraavat rivit:

#
# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080626)]/ intrepid main restricted
deb-src http://archive.ubuntu.com/ubuntu/ intrepid restricted main #Added by software-properties

# deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080626)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://fi.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ intrepid restricted main multiverse universe #Added by software-properties

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ intrepid-updates restricted main multiverse universe #Added by software-properties

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner

# Line commented out by installer because it failed to verify:
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-security main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ intrepid-security restricted main multiverse universe #Added by software-properties
# Line commented out by installer because it failed to verify:
# Line commented out by installer because it failed to verify:
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-security universe
# Line commented out by installer because it failed to verify:
# Line commented out by installer because it failed to verify:
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-security multiverse
# Line commented out by installer because it failed to verify:
deb http://security.ubuntu.com/ubuntu/ intrepid-security restricted main multiverse universe
deb-src http://security.ubuntu.com/ubuntu/ intrepid-security restricted main multiverse universe #Added by software-properties
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ intrepid-proposed restricted main multiverse universe #Added by software-properties
deb http://fi.archive.ubuntu.com/ubuntu/ intrepid-backports restricted main multiverse universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ intrepid-backports restricted main multiverse universe #Added by software-properties
deb http://ppa.launchpad.net/netbook-remix-team/ubuntu intrepid main
deb-src http://ppa.launchpad.net/netbook-remix-team/ubuntu intrepid main

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Päivitysongelma 8.10->9.04
« Vastaus #4 : 05.01.09 - klo:20.51 »
Kokeile samaa, ilman sudoa komennon edessä, meneekö läpi.
jos ei, kokeile sudo do-release-upgrade -d jos sekään ei mene läpi, katsotaan sitten tarkemmin.

Ellei, onko järjestelmään asenneltu mitään eksoottisia omia virityksiä?

Pyyhi sources.list tiedostosta ensimmäisen # Line commented out by installer because it failed to verify:
rivin jälkeen kaikki.

proposed ja backports varastojen käyttö ei ole tarpeellista/järkevää, ellei siellä tiedä olevan jotain itselle tärkeää.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

walterboy

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: Päivitysongelma 8.10->9.04
« Vastaus #5 : 05.01.09 - klo:23.20 »
Kiitos neuvoista!
Kokeilen niitä jos ehdin illan aikana kannettavallani.

harrykaa

  • Vieras
Vs: Päivitysongelma 8.10->9.04
« Vastaus #6 : 05.01.09 - klo:23.21 »
Minusta tuossa sorsalistassa on selvästi sotkua.
Ei ihme, että tulee virheilmoituksia.

Katsokaapa vaikkapa rivejä:
# Line commented out by installer because it failed to verify:

Lisäksi löytyy ylimääräiset ja väärät security-osoitteet
ym. ym.

Korjasin koko tiedoston, joka näkyy olleen alfa-vaiheen asennus 26.6.2008.
Tässä sisällöllisesti sama lista, mutta ilman virheitä ja yksinkertaisempi.
Sen voi kopioida kokonaan entisen tilalla, vaikkapa avaamalla editori komennolla (kysyy salasanan)
Koodia: [Valitse]
gksudo gedit /etc/apt/sources.list
Ja sen jälkeen poistamalla vanha teksti kokonaan, uusi tilalle ja "tallenna".
Sitten toimii tuo Update Manager.
Tässä siis sisältö (alkaa merkistä #):


## deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Alpha i386 (20080626)]/ intrepid main restricted

## Official repositories
deb http://archive.ubuntu.com/ubuntu/ intrepid main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ intrepid main restricted multiverse universe

## Updates repositories
deb http://archive.ubuntu.com/ubuntu/ intrepid-updates main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ intrepid-updates main restricted multiverse universe

## Security repositories
deb http://security.ubuntu.com/ubuntu intrepid-security main restricted multiverse universe
deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted multiverse universe

## Backports repositories
deb http://archive.ubuntu.com/ubuntu/ intrepid-backports main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ intrepid-backports main restricted multiverse universe

## Partner repositories
deb http://archive.canonical.com/ubuntu intrepid partner
deb-src http://archive.canonical.com/ubuntu intrepid partner

## Medibuntu repositories
deb http://packages.medibuntu.org/ jaunty free non-free
deb-src http://packages.medibuntu.org/ jaunty free non-free

## Proposed repositories
deb http://archive.ubuntu.com/ubuntu/ intrepid-proposed main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu/ intrepid-proposed main restricted multiverse universe

## Netbook launchpad repository
deb http://ppa.launchpad.net/netbook-remix-team/ubuntu intrepid main
deb-src http://ppa.launchpad.net/netbook-remix-team/ubuntu intrepid main

walterboy

  • Käyttäjä
  • Viestejä: 43
    • Profiili
Vs: Päivitysongelma 8.10->9.04 [RATKAISTU]
« Vastaus #7 : 06.01.09 - klo:00.31 »
Kiitoksia neuvoista harrykaa ja gdm! Ongelma ratkesi sillä että otin ylimääräiset lähteet pois ("# Line commented out by installer because it failed to verify:" jälkeen olevat) ja päivitin käyttämällä "sudo do-release-upgrade -d" (olisi saattanut toimia "tavallisellakin" menetelmällä)