Kirjoittaja Aihe: Neuvoja (aloittelijalle) IBM ThinkPad 600E:n äänten korjaamisesta.  (Luettu 3690 kertaa)

Rad44

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Terrve,

Ajattelin harjoitella Ubuntun käyttöä vanhalla läppärillä, ennenkun ykköskone joutuu tulilinjalle. En ole siis ubuntua ennen käyttänyt, ja UNIXiakin melko vähän. Päällimmäinen ongelma, osaamattomuuteni lisäksi, lienee se, että äänet eivät toimi. Kone antaa errorin, jossa lukee että oikea GStreamer plugini ei ole asennettu tai että äänikortti ei ole konfiguroitu oikein.

Selailin aihetta sivuavia keskustelufoorumeita, ja törmäsin seuraavanlaiseen ohjeeseen:

_____________________________________________
Ok, this is what I found (http://www.ubuntuforums.org/showthread.php?t=94414) It works well with the 600E. To make you and overwiev I copy-paste it here:
A) disable Quickboot in the BIOS (Press F1 to enter BIOS etup on boot)
B) add these lines to /etc/modules:
sound
ad1848
uart401
snd-cs4236
C) Follow these instructions:
1. Blacklist the incorrect sound card in /etc/hotplug/blacklist. Add lines for

snd-cs46xx
cs46xx

as written above - with the xx's

2. Add the following lines into /etc/modprobe.d/alsa-base

alias char-major-116 snd
alias char-major-14 soundcore
alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388 irq=5 dma1=1 dma2=0
alias sound-slot-0 snd-card-0
alias sound-slot-1 snd-card-1

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

options snd cards_limit=1

NOTE: When copying and pasting the above, make sure that the line starting with 'options...' is one line ending with '...dma2=0'.

3. Reboot.
(THX to grumpymole)

________________________________________________________

Miten siis käytännössä toteutan nuo toimenpiteet?

1) /etc/modules:
yllä mainittua kansiota (?) en saa auki terminaalista. Komennolla "cd hakemisto"  pitäisi vissiin siirtyä kyseisen hakemiston, mutta komento "cd etc" ei avaa etc hakemistoa.
En ylipäätään ole aivan sinut tämän terminalin kanssa vaikka UNIX-aapista yritänkin selata. Jos totta puhutaan, en ole sinut edes UNIX-aapiseni kanssa.

2)Miten noita yllämainittuja linejä lisätään kansioon? näpytellään komentoiville oikean kansion avaamisen jälkeen, ja painetaan enteriä aina yhden rivin jälkeen?

3)Miten käytännössä blacklistaan väärän äänikortin? Onko minulla keinoa tietää, että mikä niistä on väärä äänikortti.

Olkaa ystävällisiä ja kirjoittakaa hitaasti, jotta info menee täälläpäässä perille. Tämä OS:n vaihtaminen on vaikea ja kivulias prosessi, joka todennäköisesti koituu kohtalokseni. Mutta jo ubuntun ensikerran käynnistettyäni minulle tuli lämmin olo - kuin olisin vaeltanut sumuisen laakson läpi ja tullut vihdoin kotiin. Onko väärin rakastua laitteeseen, vaikka se tuntuu hyvältä?

Kiitos paljon avusta!

Terveisin,

Anssi


p.s. Parasta tässä käyttöjärjestelmässä on näytönsäästäjä, jossa kuvottavaa möbius-strippiä pitkin hiihtävät kliffan väriset muurahaiset.



juyli

  • Vieras
1) /etc/modules:
yllä mainittua kansiota (?) en saa auki terminaalista.


sudo gedit /etc/modules

siirrät suoraa weppisivulta leikkaa/liimaa metodilla ko. tekstipätkän editoriin (Gedit). Hiiren oikealla näppäimellä maalaat alueen - ja vaihdat editoriin ja painat hiiren keskimmäistä näppäintä (jos sellainen on) Myös näppäimiä on käytettävissä ko. operaatioon. Ja muista tallentaa editoitava tiedosto.
Vinkki: tee selkeät kommentit editointiisi. Risuaita # toimii yleensä kommenttimerkkinä.
Muista jo ennen editointia tallentaa alkuperäinen (tosin vain osin toimiva) konffitiedosto.

Lisää ihmeteltävää kannettavastasi Linux-maailmassa:
http://www.linux-on-laptops.com/ibm.html
Ja tässä jo vanhentuneet, mutta sovellettavat ohjeet Debian 3.0 asennettuna laitteeseen:
http://condor.depaul.edu/~jkristof/debian-tp600e.html

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Itse tässä painiskelen samaisten ongelmien kanssa. Kyseessä siis täysin sama läppäri, käyttiksenä Xubuntu 7.10. Olen koettanut suunnilleen jokaista täältä tai ubuntuforumsilta löytynyttä kikkaa, mutta koneesta ei vain lähde ääntä. Onko vielä jotain mitä voisin koettaa?

peran

  • Vieras
Itse tässä painiskelen samaisten ongelmien kanssa. Kyseessä siis täysin sama läppäri, käyttiksenä Xubuntu 7.10. Olen koettanut suunnilleen jokaista täältä tai ubuntuforumsilta löytynyttä kikkaa, mutta koneesta ei vain lähde ääntä. Onko vielä jotain mitä voisin koettaa?

No, tässähän on ohjeet, mitä kohtaa et ymmärrä ? Mitä erroreita tulee ?
(Xubuntussa, Kubuntussa ja Ubuntussa äänet pelittää samalla tavalla).

Kupuntu

  • Käyttäjä
  • Viestejä: 804
  • Kubuntu 8.10 @ Amilo A1645
    • Profiili
Itellä on sama läppäri, ja sain eräillä ohjeilla toimimaan kaiken hienosti. Etsin ne ohjeet tähän.
EDIT: http://www.mueller.ch.vu/misc/tp600e_en.html Noilla ohjeilla toimii hienosti. En tehnyt noita ekoja kohtia mutta kohdasta 3 alaspäin. HUOM. siis minulla toimi. Tuolla on sitten myös BIOS asioita joilla voi saada koneen sekaisin jos ei seuraa ohjeita kunnolla.
« Viimeksi muokattu: 10.11.07 - klo:18.19 kirjoittanut Kupuntu »
Amilo A1645: AMD 3300+ 2.0 Ghz, 512 mb RAM, 80 gb kiintolevy.
Last.fm

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Itellä on sama läppäri, ja sain eräillä ohjeilla toimimaan kaiken hienosti. Etsin ne ohjeet tähän.
EDIT: http://www.mueller.ch.vu/misc/tp600e_en.html Noilla ohjeilla toimii hienosti. En tehnyt noita ekoja kohtia mutta kohdasta 3 alaspäin. HUOM. siis minulla toimi. Tuolla on sitten myös BIOS asioita joilla voi saada koneen sekaisin jos ei seuraa ohjeita kunnolla.

Tuttu ohje tuokin :) Pitänee silti koettaa vielä.

edit: joo ei ne pelaa. Tällaista pukkaa:

Koodia: [Valitse]
lauri@ibari:~$ dmesg | grep cs4
[   39.560000] cs4232-pnpbios: probe of 00:07 failed with error -16
[   42.216000] ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
lauri@ibari:~$ dmesg | grep CS4
[   39.548000] CS4232 WSS PnP manual resources are invalid, using auto config
[   39.548000] CS4232 WSS PnP configure failed for WSS (out of resources?)
[   39.548000] PnP BIOS detection failed for CS4232
« Viimeksi muokattu: 10.11.07 - klo:19.16 kirjoittanut dotsi »

Kupuntu

  • Käyttäjä
  • Viestejä: 804
  • Kubuntu 8.10 @ Amilo A1645
    • Profiili
Itellä on sama läppäri, ja sain eräillä ohjeilla toimimaan kaiken hienosti. Etsin ne ohjeet tähän.
EDIT: http://www.mueller.ch.vu/misc/tp600e_en.html Noilla ohjeilla toimii hienosti. En tehnyt noita ekoja kohtia mutta kohdasta 3 alaspäin. HUOM. siis minulla toimi. Tuolla on sitten myös BIOS asioita joilla voi saada koneen sekaisin jos ei seuraa ohjeita kunnolla.

Tuttu ohje tuokin :) Pitänee silti koettaa vielä.

edit: joo ei ne pelaa. Tällaista pukkaa:

Koodia: [Valitse]
lauri@ibari:~$ dmesg | grep cs4
[   39.560000] cs4232-pnpbios: probe of 00:07 failed with error -16
[   42.216000] ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
lauri@ibari:~$ dmesg | grep CS4
[   39.548000] CS4232 WSS PnP manual resources are invalid, using auto config
[   39.548000] CS4232 WSS PnP configure failed for WSS (out of resources?)
[   39.548000] PnP BIOS detection failed for CS4232
Tietkö sen bios jutun? Jos teit, niin voi olla että kuten sivuilla luki, bios pitää päivittää tai jotakin.
Amilo A1645: AMD 3300+ 2.0 Ghz, 512 mb RAM, 80 gb kiintolevy.
Last.fm

dotsi

  • Käyttäjä
  • Viestejä: 112
    • Profiili
Itellä on sama läppäri, ja sain eräillä ohjeilla toimimaan kaiken hienosti. Etsin ne ohjeet tähän.
EDIT: http://www.mueller.ch.vu/misc/tp600e_en.html Noilla ohjeilla toimii hienosti. En tehnyt noita ekoja kohtia mutta kohdasta 3 alaspäin. HUOM. siis minulla toimi. Tuolla on sitten myös BIOS asioita joilla voi saada koneen sekaisin jos ei seuraa ohjeita kunnolla.

Tuttu ohje tuokin :) Pitänee silti koettaa vielä.

edit: joo ei ne pelaa. Tällaista pukkaa:

Koodia: [Valitse]
lauri@ibari:~$ dmesg | grep cs4
[   39.560000] cs4232-pnpbios: probe of 00:07 failed with error -16
[   42.216000] ad1848/cs4248 codec driver Copyright (C) by Hannu Savolainen 1993-1996
lauri@ibari:~$ dmesg | grep CS4
[   39.548000] CS4232 WSS PnP manual resources are invalid, using auto config
[   39.548000] CS4232 WSS PnP configure failed for WSS (out of resources?)
[   39.548000] PnP BIOS detection failed for CS4232
Tietkö sen bios jutun? Jos teit, niin voi olla että kuten sivuilla luki, bios pitää päivittää tai jotakin.

Tein kyllä. En tiedä mistä kiikasti, voi olla että syynä oli ikivanha BIOS tai jotain, mutta nyt kuitenkin toimii. Ratkaisuksi muodostui tämä skripti.