Kirjoittaja Aihe: Bluetooth  (Luettu 20582 kertaa)

charn

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Bluetooth
« Vastaus #20 : 06.02.09 - klo:22.51 »
Itse erehdyin ostamaan juuri kyseisen a-linkin bluetoothdonglen, kun luki oikein, että toimii linuxissa. Toimiihan se. Tosin Hardy 8.04 ei ihan ilman kikkailua selviä tästä pienestä ihmeestä. Uudella kernelillä kai toimisi, http://kerneltrap.org/mailarchive/git-commits-head/2008/10/8/3556414, pitänee sekin testata jossain vaiheessa.

Komennolla
# sudo hciconfig hci0 reset
mokkulan saa kuitenkin toimimaan, liittämisen jälkeen.

Jussi52

  • Käyttäjä
  • Viestejä: 416
  • Lubuntu 18.04 ja android vehkeet
    • Profiili
Vs: Bluetooth ei ala toimia
« Vastaus #21 : 20.05.09 - klo:14.17 »
Tämä toimii. Ainut "säätäminen" on laitteen tökkääminen kiinni.
http://www.dealextreme.com/details.dx/sku.11866

Ja on halapa ;D

Minulla on pöytäkone johon ajattelin bluetoothin laittaa. Hommasin tuon mini usb adapterin. Ihan noin vain tökkäämällä se ei minulla toimi.
Tunnistuu kyllä, mutta ei sitten löydä Nokiaani. Jotain säätöä tarvitsee.
Buuttasin ilman "tikkua", annoin olla hetken ilman tikkua ja sitten pistin tikun kiinni. Sitten komento dsmeg I tail -20. Tuli seuraava:
Koodia: [Valitse]
jussipussi@jussipussi-desktop:~$ dmesg |tail -20
[   14.951983] Bridge firewalling registered
[   16.217344] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   16.367262] [drm] Initialized drm 1.1.0 20060810
[   16.522167] [drm] Initialized radeon 1.29.0 20080528 on minor 0
[   16.758900] agpgart-sis 0000:00:00.0: AGP 3.0 bridge
[   16.758925] agpgart-sis 0000:00:00.0: putting AGP V3 device at 0000:00:00.0 into 8x mode
[   16.758930] agpgart-sis 0000:00:00.0: SiS delay workaround: giving bridge time to recover
[   16.772045] agpgart-sis 0000:00:00.0: putting AGP V3 device at 0000:01:00.0 into 8x mode
[   17.002912] [drm] Setting GART location based on new memory map
[   17.002925] [drm] Loading R200 Microcode
[   17.002968] [drm] writeback test succeeded in 1 usecs
[   20.861794] eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
[   20.863915] eth0: Media Link Off
[   20.864234] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   31.300011] eth1: no IPv6 routers present
[   72.416017] usb 3-1: new full speed USB device using ohci_hcd and address 3
[   72.650534] usb 3-1: configuration #1 chosen from 1 choice
[   72.691430] Bluetooth: Generic Bluetooth USB driver ver 0.3
[   72.716783] usbcore: registered new interface driver btusb
[   77.832804] hci_cmd_task: hci0 command tx timeout

obexftp obexpushd on asennettu.
« Viimeksi muokattu: 21.05.09 - klo:09.44 kirjoittanut Jussi41 »
alkaa se kokemus karttua tästäkin

pekkis

  • Käyttäjä
  • Viestejä: 48
    • Profiili
Vs: Bluetooth
« Vastaus #22 : 06.06.09 - klo:18.38 »
KÖNIG mini Bluetooth dongle CMP-BLUEKEY31 hinta 9.35€. Toimii ilman kikkailuja periaatteella tökkää kiinni ja käytä.
piirinä on tuo Cambridge Silicon Radio.
Koodia: [Valitse]
#lsusb
...
Bus 011 Device 007: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
...



Kokeiltu Ubuntu 9.04 (AcerOne),Debian Testing (IBM A31p ja p30) ja  Ubuntu 9.04 (quad-core).

jakevm70

  • Käyttäjä
  • Viestejä: 98
    • Profiili
    • From China
Vs: Bluetooth ei ala toimia
« Vastaus #23 : 06.06.09 - klo:19.02 »
Tämä toimii. Ainut "säätäminen" on laitteen tökkääminen kiinni.
http://www.dealextreme.com/details.dx/sku.11866

Ja on halapa ;D

Minulla on pöytäkone johon ajattelin bluetoothin laittaa. Hommasin tuon mini usb adapterin. Ihan noin vain tökkäämällä se ei minulla toimi.
Tunnistuu kyllä, mutta ei sitten löydä Nokiaani. Jotain säätöä tarvitsee.
Buuttasin ilman "tikkua", annoin olla hetken ilman tikkua ja sitten pistin tikun kiinni. Sitten komento dsmeg I tail -20. Tuli seuraava:
Koodia: [Valitse]
jussipussi@jussipussi-desktop:~$ dmesg |tail -20
[   14.951983] Bridge firewalling registered
[   16.217344] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   16.367262] [drm] Initialized drm 1.1.0 20060810
[   16.522167] [drm] Initialized radeon 1.29.0 20080528 on minor 0
[   16.758900] agpgart-sis 0000:00:00.0: AGP 3.0 bridge
[   16.758925] agpgart-sis 0000:00:00.0: putting AGP V3 device at 0000:00:00.0 into 8x mode
[   16.758930] agpgart-sis 0000:00:00.0: SiS delay workaround: giving bridge time to recover
[   16.772045] agpgart-sis 0000:00:00.0: putting AGP V3 device at 0000:01:00.0 into 8x mode
[   17.002912] [drm] Setting GART location based on new memory map
[   17.002925] [drm] Loading R200 Microcode
[   17.002968] [drm] writeback test succeeded in 1 usecs
[   20.861794] eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
[   20.863915] eth0: Media Link Off
[   20.864234] ADDRCONF(NETDEV_UP): eth0: link is not ready
[   31.300011] eth1: no IPv6 routers present
[   72.416017] usb 3-1: new full speed USB device using ohci_hcd and address 3
[   72.650534] usb 3-1: configuration #1 chosen from 1 choice
[   72.691430] Bluetooth: Generic Bluetooth USB driver ver 0.3
[   72.716783] usbcore: registered new interface driver btusb
[   77.832804] hci_cmd_task: hci0 command tx timeout

obexftp obexpushd on asennettu.

Jaa-a, kyllä tuo mulla toimii edelleen ilman mitään kikkailuja. Ämpärit ja kuvat liikkuu Nokialaisista koneelle ja koneelta Nokialaisiin... ja samsungeihin sekä Sonyerkkoihin.
Eli ei ole ollut mitään ongelmia. Ja koneessa siis Hardy :)

rikonen

  • Käyttäjä
  • Viestejä: 87
  • Linux for ever
    • Profiili
Vs: Bluetooth
« Vastaus #24 : 31.12.09 - klo:00.06 »
Pluscom:in Bluetooth EDR V2 USB Dongle Adaptor toimii ilman kikkailuja myös. Testattu Ubuntu 8.04 Hardyssä.
Koodia: [Valitse]
#lsusb
...
Bus 002 Device 003: ID 1131:1004 Integrated System Solution Corp.
...

http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=280377591405

Halpa,  toimitus lentopostina suoraan postilaatikkon. Suosittelen!
Be curious and open minded. Be positive.

Alcareru

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Vs: Bluetooth
« Vastaus #25 : 18.01.11 - klo:12.35 »
Ajattelin heittää tänne, että juurikin vastikään uskalsin ostaa tuon parjatun A-linkin sinihampaan ja ainakin ubuntu 10.10:llä tuntuu toimivan heittämällä. Palikka kiinni ja yhteyttä muodostamaan. Nokia 6300 pariutui kivasti. Myös skype toimi mukavasti bt-headsetillä ja muutenkin äänet. Ainoastaan winen kanssa jostain syystä bt-headset ei suostunut toimimaan. Eli spotifyta ei nyt pääse niillä kuunteleen :'(

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11426
    • Profiili
    • Tomin kotisivut
Vs: Bluetooth
« Vastaus #26 : 18.01.11 - klo:15.09 »
Ajattelin heittää tänne, että juurikin vastikään uskalsin ostaa tuon parjatun A-linkin sinihampaan ja ainakin ubuntu 10.10:llä tuntuu toimivan heittämällä. Palikka kiinni ja yhteyttä muodostamaan. Nokia 6300 pariutui kivasti. Myös skype toimi mukavasti bt-headsetillä ja muutenkin äänet. Ainoastaan winen kanssa jostain syystä bt-headset ei suostunut toimimaan. Eli spotifyta ei nyt pääse niillä kuunteleen :'(

Mitä äänipalvelinta se Wine on asetettu käyttämään? Luulisin ALSAn toimivan. Katso Winen asetuksista Ääni-välilehti (voi aueta hitaasti).
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

cbz

  • Käyttäjä
  • Viestejä: 66
    • Profiili
Vs: Bluetooth
« Vastaus #27 : 18.01.11 - klo:22.54 »
Minäpäs laitan omat itkuni, johan sitä on yksinään tuherrettu.

Aikoinaan kun sai ostettua tikkuja jotka toimi ilman ajureita niin Windowsilla kuin Linuxilla, niin tuli hankittua A-Linkin tikku. Vanhemmilla Ubuntuilla pelasi loistavasti, mutta nyt 10.04:lla (64-bit) ei toimi niinkuin haluaisin. Vanhemmilla versioilla kun määritti työaseman nimen (esim. tuuba), niin työasema sen muisti vaikka käytti tikkua irti koneesta. 10.04 ei sitä tee, aina on oletuksena "Broadcom BCM2035". Jos vaihdat käsi niin se muistetaan niin kauan kun on tikku kiinni koneessa. Onko kellään tähän jotain kätevää korjausta?

Toinen mikä tuntuu mättävän oikeastaan suuremmin on se, että Bluetooth toimii epävakaasti. Kun kytken niin suurella todennäköisyydellä et saa yhteyttä ja kun käytät irti niin voi toimia. Toinen vaihtoehto on sammuttaa Bluetooth-palvelu ja käynnistää se uudestaan niin lähtee pelaamaan (ehkä)

lsusb:
Bus 008 Device 002: ID 0a5c:200a Broadcom Corp. Bluetooth dongle

lokeista kaivettua:
usb 8-2: new full speed USB device using uhci_hcd and address 2
usb 8-2: configuration #1 chosen from 1 choice
Bluetooth: Core ver 2.15
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: Generic Bluetooth USB driver ver 0.6
usbcore: registered new interface driver btusb
Bluetooth: L2CAP ver 2.14
Bluetooth: L2CAP socket layer initialized
Bluetooth: BNEP (Ethernet Emulation) ver 1.3
Bluetooth: BNEP filters: protocol multicast
Bridge firewalling registered
Bluetooth: SCO (Voice Link) ver 0.6
Bluetooth: SCO socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM ver 1.11
Bluetooth: HIDP (Human Interface Emulation) ver 1.2


Ideoita, ratkaisuja?