Kirjoittaja Aihe: Tabit ja kompakti näkymä Hardyn Nautilukseen [ohjeita, kesken]  (Luettu 2025 kertaa)

anttimr

  • Käyttäjä
  • Viestejä: 1625
    • Profiili
Tässä ketjussa rikomme Hardyn yrittämällä kääntää ja asentaa uusimman Nautiluksen Gnomen svn:stä.  :P

Miksi?
Gnome 2.24 myötä tiedostoselaimeen tulee kaksi isompaa uutta, kauan kaivattua ominaisuutta: välilehdet ja tiivis tiedostolistaus - näkymä sekä pienempänä detaljina irrotettavien medioiden kohdalle "eject" painike. Intrepid ei vaikuta olevan vielä vakaa ja kaikki eivät ehkä halua asentaa sitä julkaisun jälkeenkään. Tabien hyödyllisyys riippuu työskentelytavoista , mutta ainakin itse ajaudun ilman niitä usein harmilliseen tilanteeseen, jossa useita tiedostoselain-ikkunoita on hankalasti levällään ympäri työtiloja. Välilehdet saattavat olla suurin yksittäinen käytettävyysparannus tulevassa Ubuntu-julkaisussa ja siksi on kiva saada ne omalle työpöydälle jo tänään. Ynnä, on muuten vaan huvin ja opettelun kannalta hauska kokeilla kääntää tällaista hieman suurempaa ohjelmistoa.

Miksi ei?
Rikkoo ainakin nautilus ja nautilus-data paketit, joiden päivitykset on skipattava jatkossa. Kenties rikkoo muutakin - olen testannut tätä vasta hetken. Checkinstallilla tehtyjen pakettien asennus vaati rumia --force-overwriteja.
Älä yritä tätä, jos et ymmärrä ohjeita, jos et osaa palauttaa systeemiäsi kuntoon ongelmien ilmaantuessa tai ennenkaikkea - jos haluat säilyttää systeemit vakaana! Mitään toimivuustakeita ei ole, sen sijaan takaan, että  Nautilus 2.23 särkee Ubuntusi, syö makaroonilaatikon jääkaapistasi jne. jne. kauheaa.

Joku joka oikeasti ymmärtää näistä, voisi kommentoida tätä ohjetta ja koitan parannella sitä tai lisätä vielä ISOMMALLA präntättyjä varoituksia tarpeen mukaan. Ihan mukava olisi myös tietää, pystyykö Nautiluksen kääntämään helposti / järkevämmin myös Intrepidin sorsista tai jopa asentamaan Intrepidin repoista. Sen saa joku muu kokeilla. Nyt tuli tehtyä näin, ja alustavasti kokeiltuna tämä siis toimii. 

--
Ohjeet ovat aika toistaiseksi ylimalkaisia, koska oletan, että kiinnostuneilla on yhtä hyvät, mieluumin paremmat tiedot kääntämisestä kuin itselläni ja lisäksi joissakin kohdissa on varmasti puutteita, koska muistiinpanoja ei tullut oikein tehtyä. :)

1. Asennetaan build-essentials, subversion, autoconf ja nautiluksen ym. kääntämiseen tarvittavat kehityspaketit (joista osa on nähtävästi kuitenkin vanhentuneita 2.23 versioiden suhteen). src-merkinnät tulee olla käytössä sources.listissä.

sudo apt-get install build-essentials checkinstall subversion autoconf
sudo apt-get build-dep nautilus libgnome2-0 libeel2-2

2. Ennen kuin päästään rakentamaan Nautilusta, täytää kääntää joitain gnomen komponentteja, tässä järjestyksessä. Kääntäminen deb-paketiksi saakka.
./configure --prefix=/usr
make
sudo checkinstall -D

Valitettavasti konflikteja tulee jo asennettujen pakettien tiedostojen kanssa. Pakettien asennus raakasti dpkg --force-overwrite -i menetelmällä. Sanoinko jo, että ohje rikkoo Hardyn.

1. http://ftp.gnome.org/pub/gnome/sources/intltool/0.40/intltool-0.40.0.tar.gz
2. http://ftp.gnome.org/pub/gnome/sources/gnome-desktop/2.23/gnome-desktop-2.23.4.tar.gz
3. http://ftp.gnome.org/pub/gnome/sources/libgnome/2.23/libgnome-2.23.4.tar.gz
- libmoniker_extra_2.a puutteesta tuli valitusta, kopioin sen manuaalisesti tarvittuun paikkaan.
4. http://ftp.gnome.org/pub/gnome/sources/eel/2.23/eel-2.23.4.tar.bz2

3. Poistetaan vanha Nautilus alta pois aiheuttamasta virheilmoituksia.

sudo apt-get remove nautilus nautilus-data

4.
svn co http://svn.gnome.org/svn/nautilus/trunk nautilus
./configure --prefix=/usr
make
checkinstall -D
sudo dpkg -i paketin_nimi.deb

...jatkuu
---

Nautilus aukeaa käynnistyksen jälkeen spatial-moodissa. Asetuksista saa vaihdettua takaisin browser-moodiin.
Välilehtien käyttölogiikka muistuttaa Epiphanyä. Uusia välilehtiä tehdään esim. näppäimellä ctrl+t. Hiiren keskinapilla avataan kansioita uuteen lehteen. Tiedostoja ja kansioita voi raahailla lehdestä toiseen.
« Viimeksi muokattu: 27.07.08 - klo:20.19 kirjoittanut anttimr »
Ubuntu 12.10 Quantal Quetzal

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: Tabit ja kompakti näkymä Hardyn Nautilukseen
« Vastaus #1 : 27.07.08 - klo:14.29 »
Tässä ketjussa rikomme Hardyn yrittämällä kääntää ja asentaa uusimman Nautiluksen Gnomen svn:stä.  :P

näin saa toki tehdä jos niin haluaa.

mietin vaan, että onko tuohon jotain todellista tarvetta? tai siis, eikö riittäisi hakea ubuntun kehitysversiosta valmiiksi debianisoidut sorsapaketit ja kääntää niistä omassa ympäristössä debianin kääntötyökaluilla ihan valideja debian-paketteja?

en tosin tiedä miten tuon uuden nautiluksen sovittaminen nykygnomeen onnistuu noin riippuvuuksien kannalta, mutta saahan sitä yrittää :)
Janne

anttimr

  • Käyttäjä
  • Viestejä: 1625
    • Profiili
Vs: Tabit ja kompakti näkymä Hardyn Nautilukseen
« Vastaus #2 : 27.07.08 - klo:14.45 »
Lainaus
mietin vaan, että onko tuohon jotain todellista tarvetta? tai siis, eikö riittäisi hakea ubuntun kehitysversiosta valmiiksi debianisoidut sorsapaketit ja kääntää niistä omassa ympäristössä debianin kääntötyökaluilla ihan valideja debian-paketteja?

Tämä vaihtoehto kävi kyllä mielessä, kuten aloitusviestin viimeisessä kappaleessa lukeekin, mutta en tutkinut sitä sen pidemmälle. Ajattelin, ehkä perustettomasti, että nautilus-paketin lukuisten riippuvuuksien / build-riippuvuuksien kanssa joutuu pulaan. Kannustan asiasta kiinnostuneita ottamaan tilanteesta mieluummiin itse selvää, kuin seuraamaan näitä mun puolivillaisia ohjeita (jotka siis ovat vielä kesken).
« Viimeksi muokattu: 27.07.08 - klo:20.22 kirjoittanut anttimr »
Ubuntu 12.10 Quantal Quetzal

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
Vs: Tabit ja kompakti näkymä Hardyn Nautilukseen
« Vastaus #3 : 27.07.08 - klo:20.35 »
Tämä vaihtoehto kävi kyllä mielessä, kuten aloitusviestin viimeisessä kappaleessa lukeekin, mutta en tutkinut sitä sen pidemmälle

svn:stä on varmaan kuitenkin mahdollista saada tuoreempaa kamaa. en ole ihan varma kuinka usein tuota paketoidaan, mutta toisaalta kehityksen tässä vaiheessa se myös vanhenee kovin nopeasti.

Ajattelin, ehkä perustettomasti, että nautilus-paketin lukuisten riippuvuuksien / build-riippuvuuksien kanssa joutuu pulaan.

onhan tuokin tietysti mahdollista, mutta samat riippuvuudet sillä svn-versiollakin pitäisi olla.
Janne