Kirjoittaja Aihe: RATKAISTU: VMvare Server asennus Ubuntu 8.04 ei onnistu  (Luettu 1755 kertaa)

ressu

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Olen yrittänyt useaan otteeseen saada asennettua alla olevan linkin mukaisesti VMware Serveriä, mutta kaatuu aina koodilaatikossa olevaan virheilmoitukseen. Onko kenelläkään tietoa mistä suunnasta ongelmaa voisi lähteä etsimään tai nettisivua, jossa olisi selkeät asennusohjeet.

Hieman tuntuu siltä, että tämä versio (VMware-server-1.0.4-56528), mitä olen koittanut asentaa, ei sovellukaan tähän Ubuntu 8.04 versioon,
mutta en ole löytänyt muitakaan yhtä selkeitä asennusohjeita.

Asennusohjeen linkki: http://www.ubuntugeek.com/how-to-install-vmware-server-in-ubuntu-710-gutsy-gibbon.html

Koodia: [Valitse]
Building the vmmon module.

Using 2.6.x kernel build system.
make: Siirrytään hakemistoon "/tmp/vmware-config2/vmmon-only"
make -C /lib/modules/2.6.24-16-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Siirrytään hakemistoon "/usr/src/linux-headers-2.6.24-16-generic"
  CC [M]  /tmp/vmware-config2/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config2/vmmon-only/./include/vmware.h:25,
                 from /tmp/vmware-config2/vmmon-only/linux/driver.c:48:
/tmp/vmware-config2/vmmon-only/./include/vm_basic_types.h:161: error: conflicting types for ‘uintptr_t’
include/linux/types.h:40: error: previous declaration of ‘uintptr_t’ was here
In file included from /tmp/vmware-config2/vmmon-only/linux/driver.h:20,
                 from /tmp/vmware-config2/vmmon-only/linux/driver.c:49:
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined
In file included from /tmp/vmware-config2/vmmon-only/linux/driver.h:20,
                 from /tmp/vmware-config2/vmmon-only/linux/driver.c:49:
/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’
include/linux/poll.h:65: error: previous declaration of ‘poll_initwait’ was here
/tmp/vmware-config2/vmmon-only/linux/driver.c:147: warning: initialization from incompatible pointer type
/tmp/vmware-config2/vmmon-only/linux/driver.c:151: warning: initialization from incompatible pointer type
/tmp/vmware-config2/vmmon-only/linux/driver.c: In function ‘LinuxDriver_Ioctl’:
/tmp/vmware-config2/vmmon-only/linux/driver.c:1659: error: ‘struct mm_struct’ has no member named ‘dumpable’
make[2]: *** [/tmp/vmware-config2/vmmon-only/linux/driver.o] Virhe 1
make[1]: *** [_module_/tmp/vmware-config2/vmmon-only] Virhe 2
make[1]: Poistutaan hakemistosta "/usr/src/linux-headers-2.6.24-16-generic"
make: *** [vmmon.ko] Virhe 2
make: Poistutaan hakemistosta "/tmp/vmware-config2/vmmon-only"
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.
« Viimeksi muokattu: 26.06.08 - klo:20.27 kirjoittanut ressu »

ressu

  • Käyttäjä
  • Viestejä: 24
    • Profiili
Vs: VMvare Server asennus Ubuntu 8.04 ei onnistu
« Vastaus #1 : 25.06.08 - klo:20.21 »
Latasin uusimman version valmistajan kotisivulta ja sain asennuksen menemään ongelmitta läpi käskyttämällä asennuskansiosta "sudo ./vmware-install.pl", mutta silti ohjelmaa avattaessa tulee tiimalasi hetkeksi ja ohjelma ei käynnisty.

Koitan vielä buutata koneen, jos se vaikka auttaisi  ???

Ettei vaan edellisen asennuksen rippeet häiritsisi ja siksi tämä uusi asennuskin meni kankkulan kaivoon.

EDIT:
Ei buutti auttanut...
« Viimeksi muokattu: 25.06.08 - klo:20.30 kirjoittanut ressu »

Clouseau

  • Käyttäjä
  • Viestejä: 11
    • Profiili
Vs: VMvare Server asennus Ubuntu 8.04 ei onnistu
« Vastaus #2 : 26.06.08 - klo:16.59 »
Latasin uusimman version valmistajan kotisivulta ja sain asennuksen menemään ongelmitta läpi käskyttämällä asennuskansiosta "sudo ./vmware-install.pl", mutta silti ohjelmaa avattaessa tulee tiimalasi hetkeksi ja ohjelma ei käynnisty.

Koitan vielä buutata koneen, jos se vaikka auttaisi  ???

Ettei vaan edellisen asennuksen rippeet häiritsisi ja siksi tämä uusi asennuskin meni kankkulan kaivoon.

EDIT:
Ei buutti auttanut...

Taitaa olla sama vika kuin mulla, tuosta puuttuu yksi kirjasto libgcc_s.so.1:

Kaverit kerto että näin se korjaantuu ja mulla korjaantui!

sudo cp /lib/libgcc_s.so.1 /usr/lib/vmware/lib/libgcc_s.so.1/libgcc_s.so.1

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Vs: VMvare Server asennus Ubuntu 8.04 ei onnistu
« Vastaus #3 : 26.06.08 - klo:17.17 »
http://ubuntuforums.org/showthread.php?t=779934

Mä asentelin viime viikolla tolla ohjeella. Lisäksi tarvittiin vain paketti libxtst6 varmaan sen takia kun tossa koneessa ei X:ää ollut.
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

ressu

  • Käyttäjä
  • Viestejä: 24
    • Profiili
RATKAISTU: VMvare Server asennus Ubuntu 8.04 ei onnistu
« Vastaus #4 : 26.06.08 - klo:20.26 »
http://ubuntuforums.org/showthread.php?t=779934

Mä asentelin viime viikolla tolla ohjeella. Lisäksi tarvittiin vain paketti libxtst6 varmaan sen takia kun tossa koneessa ei X:ää ollut.

Miljoonat kiitokset toimivasta linkistä, jonka avulla VMWare asentui ja lähti kerralla toimimaan. Vihdoinkin pääsen asentamaan Windows Server 2003:n ja rakentamaan siihen AD:n testiympäristöksi.