Kirjoittaja Aihe: Televisio Tietokoneesta..  (Luettu 7756 kertaa)

LinuxManne

  • Vieras
Televisio Tietokoneesta..
« : 06.05.08 - klo:19.25 »
Moi!

Käytössä Artec14 ja FujiTech USB digi-TV,
Ubuntu 8.04 ja Kaffeine ja Me-TV, tilanne on, että,
kumpikaan ohjelmista eikä tikuista tuota oikein toimi yhteistyössä,,

mulla oli toi Ubuntu 7.10 ja siinä jokin vanha kernel, mutta,
kun mulla on nää automaattiset päivitykset päällä, ni kernelin päivityksen myötä,
ilmeisesti lakkasi toimimasta TV..

mitenkä on nämä digi-teeveet, Ubuntussa ( Taikka Fedorassa Kubuntussa Mandrivassa )
mikä olisi varma toimisin valinta USB tikuksi taikka kortiksi jos haluaa että TV näkyisi myös myöhemmissä Linux versioissa..

//-----

kiitos,,
« Viimeksi muokattu: 06.05.08 - klo:19.34 kirjoittanut LinuxJari »

UbunTux

  • Käyttäjä
  • Viestejä: 2046
  • KubunTux
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #1 : 06.05.08 - klo:19.37 »
Tuota vanhalla kernelillä sen digitikun pitäisi toimia, jos on toiminut. Jos tuo on Artec T14BR niin kernelissä 2.6.25 pitäisi olla tuki (linux.fi mukaan). Eli nykyisessä Ubuntussa se ei heittämällä toimi.
Sinun pitää kääntää v4l uudelleen. Varminta on ensin poistaa ne vanhat lähdekoodit ja hakea uudelleen (ettei ala väärään kerneliin kääntämään).


Suosittelen, että et  aktivoi epävirallisia päivityksiä. Xine hajoaa ja paukkuu Ubuntussa kokemukseni mukaan noin usein.
KDE neon
Uudempaa KDE:tä Ubuntulla

LinuxManne

  • Vieras
Vs: Televisio Tietokoneesta..
« Vastaus #2 : 06.05.08 - klo:19.44 »
Tuota vanhalla kernelillä sen digitikun pitäisi toimia, jos on toiminut. Jos tuo on Artec T14BR niin kernelissä 2.6.25 pitäisi olla tuki (linux.fi mukaan). Eli nykyisessä Ubuntussa se ei heittämällä toimi.
Sinun pitää kääntää v4l uudelleen. Varminta on ensin poistaa ne vanhat lähdekoodit ja hakea uudelleen (ettei ala väärään kerneliin kääntämään).


Suosittelen, että et  aktivoi epävirallisia päivityksiä. Xine hajoaa ja paukkuu Ubuntussa kokemukseni mukaan noin usein.

Mitä tarkoitat kun kirjoitit poistaa vanhat lähdekoodit ja hakea uudelleen ??

onkos monimutkainen toimi vaiko joku sudo litania ??

//-----

kiitos,,

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11447
    • Profiili
    • Tomin kotisivut
Vs: Televisio Tietokoneesta..
« Vastaus #3 : 06.05.08 - klo:19.47 »
Minä olen aina asennellut sen v4l-ajurin uudestaan. http://wiki.ubuntu-fi.org/digitv_info
Kannattaa tallennella se komento litanja yhdeksi tiedostoksi jolle antaa suoritus oikeudet ja ajaa sen aina kun tarvitsee kääntää ne uudestaan.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

LinuxManne

  • Vieras
Vs: Televisio Tietokoneesta..
« Vastaus #4 : 08.05.08 - klo:10.17 »
Minä olen aina asennellut sen v4l-ajurin uudestaan. http://wiki.ubuntu-fi.org/digitv_info
Kannattaa tallennella se komento litanja yhdeksi tiedostoksi jolle antaa suoritus oikeudet ja ajaa sen aina kun tarvitsee kääntää ne uudestaan.

Asentelin V4l ajurit uudestaan ja hieman selailin ohjeitanne muutenkin, ohjeista löytyi että Artec14 toimisi lennosta ??

jtapio@jtapio-desktop:~/v4l-dvb$ lsusb
Bus 004 Device 008: ID 15a4:9016
Bus 004 Device 007: ID 13fe:1a00 Kingston Technology Company Inc. 512MB/1GB Flash Drive
Bus 004 Device 006: ID 041e:4053 Creative Technology, Ltd
Bus 004 Device 005: ID 04b4:8613 Cypress Semiconductor Corp. CY7C68013 EZ-USB FX2 USB 2.0 Development Kit
Bus 004 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 03f0:0701 Hewlett-Packard ScanJet 5300c/5370c
Bus 001 Device 003: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
Bus 001 Device 001: ID 0000:0000
jtapio@jtapio-desktop:~/v4l-dvb$     

Artec14 on ilmeisesti tuo Cypress Semiconductor Corp.
mutta ei Kaffeine sitä tunnu löytävän, eikä edes Me-TV, mikä neuvoksi..

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #5 : 08.05.08 - klo:10.43 »
Oletko asentanut tuon mukaan, vanhat roippeet ensin veke.

http://wiki.ubuntu-fi.org/digitv_info

Pitäisi sen jälkeen toimia. Tuo menee könttinä, kun kopioit sen päätteeseen, tuo v4l rimpsu. Näyttäisi, et sulla on jäänyt kesken toi asennus.

E. jos sulla BR 14, patchit pitää olla kanssa kunnossa.
« Viimeksi muokattu: 08.05.08 - klo:10.47 kirjoittanut shelby »
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

LinuxManne

  • Vieras
Vs: Televisio Tietokoneesta..
« Vastaus #6 : 08.05.08 - klo:13.28 »
Oletko asentanut tuon mukaan, vanhat roippeet ensin veke.

http://wiki.ubuntu-fi.org/digitv_info

Pitäisi sen jälkeen toimia. Tuo menee könttinä, kun kopioit sen päätteeseen, tuo v4l rimpsu. Näyttäisi, et sulla on jäänyt kesken toi asennus.

E. jos sulla BR 14, patchit pitää olla kanssa kunnossa.

"Vanhat roippeet" ovat sitten mitä ??
entä kuinka minä poistan nämä "vanhat roippeet"..

Artec14 vaan ja ollut nyt 2kk pimeänä ??

Se toimii XPssä mutta XPssä taas ei toimi netti joku mato varmaankin ??

"Näyttäisi siltä että sulla on jäänyt kesken toi asennus"  ???

//----

kiitos,,
« Viimeksi muokattu: 08.05.08 - klo:13.33 kirjoittanut LinuxJari »

UbunTux

  • Käyttäjä
  • Viestejä: 2046
  • KubunTux
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #7 : 08.05.08 - klo:13.54 »
Tikku ulos ja sisään.
Miltä näyttää sitten
Koodia: [Valitse]
dmesg|tail
KDE neon
Uudempaa KDE:tä Ubuntulla

LinuxManne

  • Vieras
Vs: Televisio Tietokoneesta..
« Vastaus #8 : 08.05.08 - klo:14.50 »
Tikku ulos ja sisään.
Miltä näyttää sitten
Koodia: [Valitse]
dmesg|tail

jtapio@jtapio-desktop:~$ dmesg|tail
[   59.213280] NET: Registered protocol family 17
[   60.372176] NET: Registered protocol family 10
[   60.372814] lo: Disabled Privacy Extensions
[   72.328662] eth0: no IPv6 routers present
[ 1770.828608] eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[ 1780.837802] eth0: no IPv6 routers present
[ 2348.659116] sr0: CDROM not ready.  Make sure there is a disc in the drive.
[ 7501.666225] xine_extractor[7124]: segfault at b30f5821 eip b776da17 esp b52d6690 error 4
[10246.505028] usb 4-4: new high speed USB device using ehci_hcd and address 8
[10246.637316] usb 4-4: configuration #1 chosen from 1 choice

jtapio@jtapio-desktop:~$ lsusb
Bus 004 Device 008: ID 04b4:8613 Cypress Semiconductor Corp. CY7C68013 EZ-USB FX2 USB 2.0 Development Kit
Bus 004 Device 007: ID 15a4:9016
Bus 004 Device 006: ID 13fe:1a00 Kingston Technology Company Inc. 512MB/1GB Flash Drive
Bus 004 Device 005: ID 041e:4053 Creative Technology, Ltd
Bus 004 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 03f0:0701 Hewlett-Packard ScanJet 5300c/5370c
Bus 001 Device 003: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
Bus 001 Device 001: ID 0000:0000
jtapio@jtapio-desktop:~$

jeh, tollasta näyttää, on ollut nyt 2kk alhaalla tää usb TV,, ( Artec14 )
olisi mukava jos toimisi taas..


kokeilin irroittaa ton USB jakajan ja nyt näyttää tälläistä..

[ 7501.666225] xine_extractor[7124]: segfault at b30f5821 eip b776da17 esp b52d6690 error 4
[10246.505028] usb 4-4: new high speed USB device using ehci_hcd and address 8
[10246.637316] usb 4-4: configuration #1 chosen from 1 choice
[10923.259940] usb 4-4: USB disconnect, address 8
[10939.029173] usb 4-3: USB disconnect, address 4
[10939.029183] usb 4-3.1: USB disconnect, address 5
[10939.029471] usb 4-3.2: USB disconnect, address 6
[10939.035469] usb 4-3.4: USB disconnect, address 7
[10943.866533] usb 4-3: new high speed USB device using ehci_hcd and address 9
[10943.998896] usb 4-3: configuration #1 chosen from 1 choice
jtapio@jtapio-desktop:~$


//----

kiitos,,
« Viimeksi muokattu: 08.05.08 - klo:15.04 kirjoittanut LinuxJari »

UbunTux

  • Käyttäjä
  • Viestejä: 2046
  • KubunTux
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #9 : 08.05.08 - klo:15.07 »
Kannattaa seurata miten tämä ketju kehittyy:
http://forum.ubuntu-fi.org/index.php?topic=18120.0

Mielestäni sama ongelma.
KDE neon
Uudempaa KDE:tä Ubuntulla

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11447
    • Profiili
    • Tomin kotisivut
Vs: Televisio Tietokoneesta..
« Vastaus #10 : 08.05.08 - klo:16.01 »
Hmm...kumpi sinulla nyt sitten on? Artec T14 vai Artec T14 BR? Ne menee helposti sekaisin ja toinen vaati (en tiedä varmaksi nykyisestä tilasta) enemmän säätöä huonomman tuen takia.
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

shelby

  • Käyttäjä
  • Viestejä: 1865
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #11 : 08.05.08 - klo:19.20 »
Oletko asentanut tuon mukaan, vanhat roippeet ensin veke.

http://wiki.ubuntu-fi.org/digitv_info

Pitäisi sen jälkeen toimia. Tuo menee könttinä, kun kopioit sen päätteeseen, tuo v4l rimpsu. Näyttäisi, et sulla on jäänyt kesken toi asennus.

E. jos sulla BR 14, patchit pitää olla kanssa kunnossa.

"Vanhat roippeet" ovat sitten mitä ??
entä kuinka minä poistan nämä "vanhat roippeet"..

Artec14 vaan ja ollut nyt 2kk pimeänä ??

Se toimii XPssä mutta XPssä taas ei toimi netti joku mato varmaankin ??

"Näyttäisi siltä että sulla on jäänyt kesken toi asennus"  ???

//----

kiitos,,


Eli poistat kaikki v4l:ään viittaavat kansiot ja jos sulla BR14 niin patchit kanssa. Eli vanha tikun asennus tyhjäksi ja täysin uusi asennus. Tuossa ylempänähän on ohje. Sulla on varmaan uusi kernel, eli joudut tekeen firmwarenkin uusiksi. Mut siinä ne on ohjeessa, jonka kopioin sinulle. Onnea asennukseen.

Niin vielä, jos sulla on pelkkä Artec 14, pitäisi mennä heittämällä vai nakkaamallako. :D
« Viimeksi muokattu: 08.05.08 - klo:19.22 kirjoittanut shelby »
Ubu Gnome 20.04.3 LTS
Win 8.1 laptop I
Win 10 laptop II
Ubu Mate 20.04.3 LTS
Kubu 20.04.3 LTS

SkinGull

  • Käyttäjä
  • Viestejä: 30
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #12 : 15.07.08 - klo:23.07 »
Kysästään tässä samassa ketjussa.
Elikkä, tuo Fuj:Tech digikortti toimi mulla ennen kuin asensin päivitykset. Nyt koneessa (Ubuntu hardy) on uusimmat päivitykset, mutta kun äsken piti ruveta katsomaan televisiota, ei tuossa Kaffeinessa ole enää valikossa TV:n katselu mahdollisuutta. Johtuuko se uusimmista päivityksistä (uskon niin), vai onko joku muu vialla? Onko mahdollisuutta saada se näkyviin, vai täytyykö mun jotenkin palauttaa vanhemmat päivitykset (tai asentaa Ubuntu uusiksi ja jättää päivittämättä)???

crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Televisio Tietokoneesta..
« Vastaus #13 : 16.07.08 - klo:11.23 »
Se vanhin Artec T14 (?) on rikki uudemmissa Kerneleissä. Sen verran sitä tuossa taannoin katsoin että näyttäisi olevan laitteen USB-ID:t poistettu, liekö niitä on tarvittu johonkin uudempoaan laitteeseen. Artec T14A ja T14BR toimivat. Samoin Fujitech yms. kun lataa kehitysajurit.

Antti

karzu

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #14 : 18.07.08 - klo:03.24 »
Anysee itsellä toimii ainaskin moitteetta.



sudo apt-get install mercurial linux-headers-$(uname -r) build-essential

hg clone http://linuxtv.org/hg/v4l-dvb/

cd v4l-dvb

make distclean

make

sudo make install

sudo modprobe dvb-usb-anysee

Ja ei muuta kun Anysee kiinni ja kafeine päälle.
3ghz-2g-7600gs-8.10

makro

  • Käyttäjä
  • Viestejä: 76
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #15 : 18.07.08 - klo:16.17 »
Se vanhin Artec T14 (?) on rikki uudemmissa Kerneleissä. Sen verran sitä tuossa taannoin katsoin että näyttäisi olevan laitteen USB-ID:t poistettu, liekö niitä on tarvittu johonkin uudempoaan laitteeseen. Artec T14A ja T14BR toimivat. Samoin Fujitech yms. kun lataa kehitysajurit.

Antti

Itselläni on kahdessa koneessa Hardy Heron 8,04 ja molemmissa toimii heittämällä Artec T14 BR. Kuva näkyy niin Kaffeinellä kuin Me-Tv:llä.
#460767

DiiZei

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #16 : 30.07.08 - klo:18.04 »
Olen myös ostamassa tota Fuj:techin parin kympin tikkua. Mikä on tämänhetkinen tilanne, toimiiko vehje täysin ku latailee jotkut paketit? Kaukosäädin? Lähinnä tarkoituksena olisi ajastaa ohjemia tallentumaan kovalevylle.

RipaRapa

  • Käyttäjä
  • Viestejä: 10
  • Ubuntu 8.04
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #17 : 31.07.08 - klo:20.13 »
Olen myös ostamassa tota Fuj:techin parin kympin tikkua. Mikä on tämänhetkinen tilanne, toimiiko vehje täysin ku latailee jotkut paketit? Kaukosäädin? Lähinnä tarkoituksena olisi ajastaa ohjemia tallentumaan kovalevylle.

Fuj:tech toimii Ubuntu 8.04 ja 7.10 kun antaa jonkin verran alle 10 terminaalikomentoa. Kaukosäädin ei toimi. Crope yritti sille tukea, mutta poisti sen ainakin toistaiseksi koska näppäilyt tuottivat "sarjatulta".

En ole saanut YLE Peking HD kanavaa näkymään laitteen omalla antennilla vaikka lähetysasema näkyy pihalta, muutoin tuntuu toimivan normaalisti. Antenni on siis varsin vaatimaton.

Pientä kiusaa aiheittaa se että joutuu aina uuden kerneliversion jälkeen tekemään asennuksen uusiksi, mutta toivottavasti saamme tuen piakkoin kerneliin?

t. RipaRapa

crope

  • Käyttäjä
  • Viestejä: 817
  • Fedora 12
    • Profiili
    • http://palosaari.fi/
Vs: Televisio Tietokoneesta..
« Vastaus #18 : 01.08.08 - klo:14.04 »
Sen vertasen tuossa viimeviikolla muutin ajuria jotta siinä on nyt moduli-rapametri kaukosäätimen valintaa varten. Tuo Fujitechin tikku on käsittääkseni uudelleen brändätty MSI DIGIVOX Mini II versio 3. Kaukosäädinkin on jopa prikulleen sama. Enivei, sen kaukosäätimen saa päälle kun komentaa rmmod dvb-usb-af9015; modprobe dvb-usb-af9015 remote=2 . Tämä siksi että ko. laite + miljoona muuta käyttävät Afatechin reference design USB-ID:tä valmistajan omien sijaan niin on vähän hankaluuksia mapata kaukosäädintä tuohon ID:hen. Mutta on mulla pari jippoa vielä mielessä joilla ainakin osaksi saan tuota automatisoitua.

Antti

redu

  • Käyttäjä
  • Viestejä: 487
    • Profiili
Vs: Televisio Tietokoneesta..
« Vastaus #19 : 04.08.08 - klo:13.36 »
Kaffeinella Espoon lähettimen Peking HD?
Kaffeine löysi PEKING HD:n, kun lisäsin fi.espoo määrittelyyn 198.5MHz:n VHF-kanavan. Vinkuääni tuli päälle niinkuin pitikin, mutta kuva ei. Kiikastaa kai h.264dekooderista? Miten määritän Xineen ja Kaffeineen tällaisen dekooderin?
Ref:
Windozessa pelittää (DVBViewer).
Laitekokoonpano:
Ubuntu 7.10, Core2Duo2.4G, Nebula PCI-kortti

redu
Ubuntua 98%, Winkua 2%