Kirjoittaja Aihe: Uusi asennus 8.04 <-- [otsikko on vähän harhaanjohtava]  (Luettu 7953 kertaa)

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Uusi asennus 8.04
« Vastaus #20 : 01.05.08 - klo:17.19 »
Koodia: [Valitse]
sudo apt-get install sun-java6-jre sun-java6-pluginpitäisi tepsiä, hyväksyt vaan SUNin lisenssiehdot, ja otat tuon toisen javan käyttöön

Koodia: [Valitse]
sudo update-alternatives --config javaja sunin java käyttöön (numeronäppäimillä)

Pahoittelen näitä komentorivi komentoja..
Pääasia kuitenkin on se että, asia saadaan toimimaan

Eräs toinen tapa olisi ollut poistaa kaikki javat käytöstä ja asentaa uudelleen, seikkailla sivuille jossa pyytää asentamaan pluginin
Muistissani ei ole yhtään sivua missä tuo tapahtuu, joten ehdotan tätä tapaa
(paitsi youtube) mutta se ehdottaa vaan flash-pluginin asennusta...
« Viimeksi muokattu: 01.05.08 - klo:17.20 kirjoittanut GoddamnDevil »
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

DJ Tsvetkoff 4ever

  • Vieras
Vs: Uusi asennus 8.04
« Vastaus #21 : 01.05.08 - klo:23.54 »
Pistetään tän otsikon alle. Asensin aamulla 3 kerran uudelleen puhtaalta pöydältä ja silti: Pulseaudio veke, että äänet toimii, FF3 veke ja FF2 koneelle, että sivut aukee tänä päivänä ja Gmail toimii. Muuten toimii tosi hyvin! Tosin hitaampi kuin edellinen versio. Mikä lie vikana?. Sit tuo josta laitetaan automaattinen kirjautuminen päälle?... sen käynnistys vie ainaki 5 min. Toimii silti ja se on hyvä :) Prossy pysyy tasasesti yli 30% jo käynnistyksessä. Ei koskaan ali tainnut käydäkään?

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #22 : 02.05.08 - klo:05.48 »
Koodia: [Valitse]
sudo apt-get install sun-java6-jre sun-java6-pluginPahoittelen näitä komentorivi komentoja.
Ohje kirjoittaa jotain terminaaliin kertoo selvästi ja tarkasti mitä tehdä. Erinomaista  :)

Kehoitus katsoa jostain valikosta ja paneelista näyttää helpolta toteuttaa. Kuitenkin minä ja moni muu onnistumme usein näkemään väärän paneelin tai painikkeen.

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #23 : 03.05.08 - klo:13.29 »
Koodia: [Valitse]
sudo apt-get install sun-java6-jre sun-java6-pluginpitäisi tepsiä, hyväksyt vaan SUNin lisenssiehdot, ja otat tuon toisen javan käyttöön
Tulos
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo apt-get install sun-java6-jre sun-java6-plugin
[sudo] password for ukki:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
sun-java6-jre on jo uusin versio.
sun-java6-jre on merkitty käsin asennettavaksi.
sun-java6-plugin on jo uusin versio.
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.
ukki@ikinubuntu:~$
Varmaan pitäisi opiskella Java-ohjelmointia, jotta voisi lopulta ymmärtää javasotkut! Kauan sitten jotain puuhasinkin Algol, Basic ja Fortran-kielillä. Ehkä on aika alkaa C++ vai pitääkö kietoutua Pythoniin?

"sun-java6-jre on merkitty käsin asennettavaksi" - Valikkojen kautta löytyy Java Control Panel > Java Applet Runtime Settings > Product Name = JRE, Version 1.6.0_06 ja Location= /usr/lib/jvm/java-6-sun-1.6-0....
ja paneeli, jonka mukaan on Enabled, joskaan toisen paneelin mukaan yhtään Trusted Certificates ei ole tiedossa.

Miksi tehdä käsityötä kun edellisen perusteella Java JRE on asennettu? Pitääkö ladata ohjelmat ja kääntää?

Edelleen Sampo sinnikkäästi väittää, että "Käyttämässäsi tietokoneessa ei ole asennettuna tarvittavaa Java Runtime-ohjelmistoa. Java Runtime-ohjelmisto tarvitaan verkkopankin turvaratkaisua varten."  >:(

Näköjään minulta puuttui
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo update-alternatives --config java
[sudo] password for ukki:

There are 2 alternatives which provide `java'.

  Selection    Alternative
-----------------------------------------------
          1    /usr/lib/jvm/java-6-sun/jre/bin/java
*+        2    /usr/lib/jvm/java-6-openjdk/jre/bin/java

Paina enteriä säilyttääksesi oletuksen[*], tai valitse numerolla: 1
Using '/usr/lib/jvm/java-6-sun/jre/bin/java' to provide 'java'.
ukki@ikinubuntu:~$

Joten suljen selaimen. Käynnistän Firefoxin uudelleen ja suunnistaan toivorikkaana Sampoon!
« Viimeksi muokattu: 03.05.08 - klo:13.41 kirjoittanut fossiili »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Uusi asennus 8.04
« Vastaus #24 : 03.05.08 - klo:13.41 »
Koodia: [Valitse]
sudo apt-get install sun-java6-jre sun-java6-pluginpitäisi tepsiä, hyväksyt vaan SUNin lisenssiehdot, ja otat tuon toisen javan käyttöön
Tulos
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo apt-get install sun-java6-jre sun-java6-plugin
[sudo] password for ukki:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
sun-java6-jre on jo uusin versio.
sun-java6-jre on merkitty käsin asennettavaksi.
sun-java6-plugin on jo uusin versio.
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.
ukki@ikinubuntu:~$

Edelleen Sampo sinnikkäästi väittää, että "Käyttämässäsi tietokoneessa ei ole asennettuna tarvittavaa Java Runtime-ohjelmistoa. Java Runtime-ohjelmisto tarvitaan verkkopankin turvaratkaisua varten."  >:(
[/quote]

Päivitetään varmuuden vuoksi kaikki
[code]sudo apt-get update && sudo apt-get dist-upgrade
no niin, päivitys tehty, Java on siis asennettu, hyvä, mutta onko otettu käyttöön?
Koodia: [Valitse]
sudo update-alternatives --config java[/code]
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #25 : 03.05.08 - klo:13.45 »
Kiirehdin liikaa kun vaimo odottaa puutarhatöihin ...
luen hyvät ohjeet huolella ja jatkan myöhemmin. Kärsivällisyytä :-[

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Uusi asennus 8.04
« Vastaus #26 : 03.05.08 - klo:13.57 »
Itse kokeilin asentaa tuon itse ehdottamani paketin, mutta mutta, ei toiminut ei.
Kyseinen verkkopankki toimi jos ensimmäinen java on tuo sunin suljettu versio.
Mutta jos alla on tuo openJDK niin ei toimi.

Luultavasti tuo javan linkitys pelastaa tilanteen...
Mutta tehdään toisella tapaa ensiksi.

Katsotaan mitä java-kikkareita on saatavilla
Koodia: [Valitse]
sudo update-java-alternatives -l
Lainaus
sudo update-java-alternatives -l
java-6-openjdk 1061 /usr/lib/jvm/java-6-openjdk
java-6-sun 63 /usr/lib/jvm/java-6-sun

Otetaan haluttu käyttöön
Koodia: [Valitse]
sudo update-java-alternatives -s java-6-sunja kokeillaan uudestaan.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #27 : 03.05.08 - klo:15.10 »
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo update-java-alternatives -l
[sudo] password for ukki:
java-6-openjdk 1061 /usr/lib/jvm/java-6-openjdk
java-6-sun 63 /usr/lib/jvm/java-6-sun
ukki@ikinubuntu:~$ sudo update-java-alternatives -s java-6-sun
Ei vaihtoehtoja kohteelle appletviewer.
Ei vaihtoehtoja kohteelle apt.
Pitäisi kaiken mahdollisen olla koneella ...

juhpek

  • Käyttäjä
  • Viestejä: 17
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #28 : 03.05.08 - klo:15.58 »
Olkoon vaikka sata viestiä aiheesta.

En ymmärrä tämän aloituksen tarkoitusta. Ei kysymystä, ei mitään ratkaisua mihinkään. Ei mitään asiaa. Se, että myöhemmät viestit sisältävät ohjeita, ei auta tämmöisessä aloituksessa. Ei tästä otsikosta voi päätellä mitään.

Vai olenko ymmärtänyt väärin palstan tarkoituksen? Luulin, että pyydämme ratkaisuja ongelmiin niiltä, jotka osaavat. Ja että keskustelemme aiheesta.

audi

  • Käyttäjä
  • Viestejä: 1124
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #29 : 03.05.08 - klo:16.24 »
En ymmärrä tämän aloituksen tarkoitusta. Ei kysymystä, ei mitään ratkaisua mihinkään. Ei mitään asiaa. Se, että myöhemmät viestit sisältävät ohjeita, ei auta tämmöisessä aloituksessa. Ei tästä otsikosta voi päätellä mitään.

Ohjeissa sanotaan näin:

Lainaus
Kun kysyt apua forumilla:
1) Käytä kuvaavaa otsikkoa, esim. "3D-pelit eivät toimi NVIDIA Geforce 6600 GT -näytönohjaimellani", ei "apuaa, ei toimi!!" ja kysy vain yhteen asiaan liittyviä kysymyksiä yhdessä ketjussa eli älä upota samaan viestiisi esim. näytönohjain-, kaukosäädin- ja wlan-ongelmia.
Mozillazine

A1398 ym romua,  macOS 10.13
Linux Mint 18, Mate

jubuntu

  • Käyttäjä
  • Viestejä: 206
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #30 : 03.05.08 - klo:19.49 »
Olkoon vaikka sata viestiä aiheesta..

Kirjoitin tämän aiheen alunperin yleistä keskustelua osioon. Ja juuri sen tähden, ettei viestissäni ollut mitään kysymystä tai vastausta mihinkää.
Kunhan ilmaisin tuntojani, sillä olen elänyt siirtymävaihetta Winows ---> Linux.
Moderaattorit siirisivät tämän tähän osioon ja tämä elää nyt omaa elämäänsä, irti siitä mikä oli minun alkuperäinen tarkoitukseni / ajatukseni.

Tämä selvennykseksi.

Jukka
Siirtynyt Linux-maailmaan kesällä 2007. Hardy Heron 8.04
Kone: LapTop FJ Amilo A1650G, Ram 1 Gb. Kiintolevy 80 Gb

fossiili

  • Käyttäjä
  • Viestejä: 785
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #31 : 05.05.08 - klo:10.39 »
En ymmärrä tämän aloituksen tarkoitusta. Ei kysymystä, ei mitään ratkaisua mihinkään. Ei mitään asiaa.
"Uusi asennus" - kun linuxin on asentanut, eka ongelma on saada ne nettiosoitteet toimimaan, mitä juuri vaivatta Windowssilla katseli. Siksi minusta se, näkyykö www.yle.fi/pikkukakkonen (pikku Saaran tärppi) tai https://verkkopankki.sampopankki.fi/html/index.html?site=SBNBFI&secsystem=E2 ("Kirjautuminen verkkopankkiin ei onnistunut") liittyvät 100% aiheeseen "Uusi asennus".

En ymmärrä ongelmaasi :)

f7391

  • Käyttäjä
  • Viestejä: 20
    • Profiili
Vs: Uusi asennus 8.04
« Vastaus #32 : 08.05.08 - klo:11.49 »
Koodia: [Valitse]
sudo apt-get install sun-java6-jre sun-java6-pluginpitäisi tepsiä, hyväksyt vaan SUNin lisenssiehdot, ja otat tuon toisen javan käyttöön
Tulos
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo apt-get install sun-java6-jre sun-java6-plugin
[sudo] password for ukki:
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Luetaan tilatietoja... Valmis       
sun-java6-jre on jo uusin versio.
sun-java6-jre on merkitty käsin asennettavaksi.
sun-java6-plugin on jo uusin versio.
0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 2 päivittämätöntä.
ukki@ikinubuntu:~$
Varmaan pitäisi opiskella Java-ohjelmointia, jotta voisi lopulta ymmärtää javasotkut! Kauan sitten jotain puuhasinkin Algol, Basic ja Fortran-kielillä. Ehkä on aika alkaa C++ vai pitääkö kietoutua Pythoniin?

"sun-java6-jre on merkitty käsin asennettavaksi" - Valikkojen kautta löytyy Java Control Panel > Java Applet Runtime Settings > Product Name = JRE, Version 1.6.0_06 ja Location= /usr/lib/jvm/java-6-sun-1.6-0....
ja paneeli, jonka mukaan on Enabled, joskaan toisen paneelin mukaan yhtään Trusted Certificates ei ole tiedossa.

Miksi tehdä käsityötä kun edellisen perusteella Java JRE on asennettu? Pitääkö ladata ohjelmat ja kääntää?

Edelleen Sampo sinnikkäästi väittää, että "Käyttämässäsi tietokoneessa ei ole asennettuna tarvittavaa Java Runtime-ohjelmistoa. Java Runtime-ohjelmisto tarvitaan verkkopankin turvaratkaisua varten."  >:(

Näköjään minulta puuttui
Koodia: [Valitse]
ukki@ikinubuntu:~$ sudo update-alternatives --config java
[sudo] password for ukki:

There are 2 alternatives which provide `java'.

  Selection    Alternative
-----------------------------------------------
          1    /usr/lib/jvm/java-6-sun/jre/bin/java
*+        2    /usr/lib/jvm/java-6-openjdk/jre/bin/java

Paina enteriä säilyttääksesi oletuksen[*], tai valitse numerolla: 1
Using '/usr/lib/jvm/java-6-sun/jre/bin/java' to provide 'java'.
ukki@ikinubuntu:~$

Joten suljen selaimen. Käynnistän Firefoxin uudelleen ja suunnistaan toivorikkaana Sampoon!


Sain sekä Sampopankin että työpaikan Personec Travelin (samantyyppinen java-kötöstys kuin Sampopankki) toimimaan näin:

- avaa Synaptic-paketinhallinta
- etsi "jdk"
- merkkaa poistettavaksi asennetut OpenJDK-paketit ja poista ne
- asenna Sun:n java-paketit (ilmeisesti olet jo asentanut ne)

Täällä käytössä 32 bit 8.04 ja Firefox 3 Beta 5 ja nyt toimii.

EDIT: Eipä toimikaan. Kirjautuminen onnistuu, mutta sitä seuraavan turvaluvun antaminen ei enää onnistukaan, koska nelinumeroisen luvun, jonka vastine pitäisi antaa turvalukukortista, syöttäminen ei onnistu. Syöttäminen ei onnistu, koska nelinumeroista lukua ei näy eikä näkyvillä myöskään ole kenttää, johon vastinluku pitäisi kirjoittaa.... Tosi hyvä systeemi!
« Viimeksi muokattu: 08.05.08 - klo:11.58 kirjoittanut f7391 »