Kirjoittaja Aihe: [RATKAISTU] Ei pysty asentamaan mitään ohjelmia????  (Luettu 3621 kertaa)

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Meen lisää/poista valikkoon, ja yritän asentaa jotain tulee ilmoitus (testasin useampaa, jokaisessa tulee tämä):
Tämä sovellus on ristiriidassa muiden asennettujen ohjelmistojen kanssa. Asentaaksesi sovelluksen tulee ristiriidassa olevat ohjelmistot poistaa ensin.

Vaihda Synaptic-pakettienhallinnan puolelle korjataksesi tämän ongelman.

Sitten menen synaptic pakettienhallintaan, ja koitan sen kautta asentaa jotain, tulee ilmoitus:

Kaikkia paketteja ei voi merkitä asennettavaksi tai päivitettäväksi

Seuraavian pakettien riippuvuuksia ei voi selvittää. Tarkista, että kaikki tarvittavat pakettivarastot on määritelty asetuksissa.


AUTTAKAA NOPEASTI, ennenku tapan tän koneen!
« Viimeksi muokattu: 01.04.08 - klo:16.00 kirjoittanut samuaaltonen »

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #1 : 01.04.08 - klo:15.26 »
Ensiapuna leikkaa-liimaa seuraavat komennot komentoriville!

Yrittää korjata paketit
Koodia: [Valitse]
sudo dpkg --configure -aYrittää korjata riippuvuudet
Koodia: [Valitse]
sudo apt-get -f install
jos edelliset komennot menee läpi ilman virheitä
Koodia: [Valitse]
sudo apt-get update && sudo apt-get upgrade
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #2 : 01.04.08 - klo:15.36 »
Ensiapuna leikkaa-liimaa seuraavat komennot komentoriville!

Yrittää korjata paketit
Koodia: [Valitse]
sudo dpkg --configure -aYrittää korjata riippuvuudet
Koodia: [Valitse]
sudo apt-get -f install
jos edelliset komennot menee läpi ilman virheitä
Koodia: [Valitse]
sudo apt-get update && sudo apt-get upgrade

0 päivitetty, 0 uutta asennusta, 0 poistettavaa ja 0 päivittämätöntä.
Ei auttanut :(


gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #3 : 01.04.08 - klo:15.39 »
Vieläkö mättää pakettien asentaminen?

jos vastaus on ei, niin kaikki hyvin.

jos vastaat kyllä, niin liitä komennon tuloste tänne
Koodia: [Valitse]
cat /etc/apt/sources.list
EDIT: Huom, vain yksi pakettienhallinta ohjelma auki kerrallaan!
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

Toni Alenius

  • Käyttäjä
  • Viestejä: 1506
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #4 : 01.04.08 - klo:15.40 »
oletko vaihtanut/poistanut pakettilähteitä?
Ubuntu 20.04.06 LTS
16 GB DDR3
Intel® Core™ i5 CPU 760 @ 2.80GHz × 4
GeForce GT 730 2GB
480 GB SSD

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #5 : 01.04.08 - klo:15.42 »
oletko vaihtanut/poistanut pakettilähteitä?

En ole tehnyt juuri mitään, asensin tämän ubuntun juuri, ehdin päivittää päivitykset ja kun rupesin etsimään lisääpoistasta tarvitsemiani ohjelmia niin ongelma ilmeni.


Vieläkö mättää pakettien asentaminen?

jos vastaus on ei, niin kaikki hyvin.

jos vastaat kyllä, niin liitä komennon tuloste tänne
Koodia: [Valitse]
cat /etc/apt/sources.list
EDIT: Huom, vain yksi pakettienhallinta ohjelma auki kerrallaan!
Kyllä:
Koodia: [Valitse]
deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

# Line commented out by installer because it failed to verify:
#deb http://fi.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://fi.archive.ubuntu.com/ubuntu/ gutsy universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://fi.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu gutsy partner
# deb-src http://archive.canonical.com/ubuntu gutsy partner

deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse

# Avant Window Navigator
deb http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator
deb-src http://download.tuxfamily.org/syzygy42 gutsy avant-window-navigator

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #6 : 01.04.08 - klo:15.44 »
Kokeilin vielä asentaa komentoriviltä jotain:

Koodia: [Valitse]
zamux@ZamuxDating:~$ sudo apt-get install xmms
Luetaan pakettiluetteloita... Valmis
Muodostetaan riippuvuussuhteiden puu       
Reading state information... Valmis
Joitakin paketteja ei voitu asentaa. On ehkä vaadittu mahdottomia tai,
jos käytetään epävakaata jakelua, joitain vaadittuja paketteja ei ole
vielä luotu tai siirretty Incoming-kansiosta.

Koska komennettiin vain yksi toimenpide, erittäin todennäköisesti
paketti ei lainkaan ole asennettavissa ja olisi tehtävä vikailmoitus
tuosta paketista.
Seuraavista tiedoista voi olla hyötyä selvitettäessä tilannetta:

Näillä paketeilla on tyydyttämättömiä riippuvuuksia:
  xmms: Riippuvuudet: libmikmod2 (>= 3.1.10) mutta ei ole asennuskelpoinen
E: Rikkinäiset paketit
tulee vaa tommosta


E: ja koitanpa asentaa mitä tahansa niin tulee aina tommosta jotai ryydyttymättömiä riippuvuuksia.

Toni Alenius

  • Käyttäjä
  • Viestejä: 1506
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #7 : 01.04.08 - klo:15.45 »
Avaa synaptic, etsi valikoista "Pakettilähteet" (eng. Repositories) tjsp, ruudulle aukeaa lista, lisää rasti muutamaan pakettilähteeseen, tallenna asetukset ja klikkaa Synapticista "Refresh", ja koita asentaa paketteja uudelleen.
Ubuntu 20.04.06 LTS
16 GB DDR3
Intel® Core™ i5 CPU 760 @ 2.80GHz × 4
GeForce GT 730 2GB
480 GB SSD

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #8 : 01.04.08 - klo:15.50 »
Avaa synaptic, etsi valikoista "Pakettilähteet" (eng. Repositories) tjsp, ruudulle aukeaa lista, lisää rasti muutamaan pakettilähteeseen, tallenna asetukset ja klikkaa Synapticista "Refresh", ja koita asentaa paketteja uudelleen.
Samulla oli käytössä jo kaikki tarpeelliset pakettivarastot!
Kokeilun vuoksi voisi vaihtaa serveriä, hae lähteestä: Main server

Herjaako tuo apt-get install jokaisella paketilla?
vaiko pelkästään xmms kohdalla?
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #9 : 01.04.08 - klo:15.52 »
Avaa synaptic, etsi valikoista "Pakettilähteet" (eng. Repositories) tjsp, ruudulle aukeaa lista, lisää rasti muutamaan pakettilähteeseen, tallenna asetukset ja klikkaa Synapticista "Refresh", ja koita asentaa paketteja uudelleen.

Tulee ilmoitus:
Kaikkien pakettivarastojen sisällysluetteloita ei voi noutaa

Pakettivarasto ei ehkä ole enää käytettävissä tai siihen ei saatu yhteyttä verkko-ongelmista johtuen. Käytetään mahdollista vanhempaa versiota luettelosta. Muutoin tämä pakettivarasto jätetään huomiotta. Tarkista verkkoyhteytesi ja pakettivaraston osoitteen oikeinkirjoitus asetuksista.


verkkoongelmaa tässä tuskin on koska miten pystyisin sitten kirjoittamaan tänne foorumillekaan

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #10 : 01.04.08 - klo:15.53 »
Avaa synaptic, etsi valikoista "Pakettilähteet" (eng. Repositories) tjsp, ruudulle aukeaa lista, lisää rasti muutamaan pakettilähteeseen, tallenna asetukset ja klikkaa Synapticista "Refresh", ja koita asentaa paketteja uudelleen.
Samulla oli käytössä jo kaikki tarpeelliset pakettivarastot!
Kokeilun vuoksi voisi vaihtaa serveriä, hae lähteestä: Main server

Herjaako tuo apt-get install jokaisella paketilla?
vaiko pelkästään xmms kohdalla?

herjaa kaikkien kohdalla mitä olen tähän mennessä kokeillut, yhden pienen paketin (en muista nimeä) se tosin asensi (joku zip pakkausohjelma tjms).

Eli mitä/miten tuo main server juttu

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #11 : 01.04.08 - klo:15.59 »
Voi olla että palvelimissa on vain jotain häikkää tällä hetkellä??

Valikko->Järjestelmä->Ylläpito->Ohjelmalähteet
Hae lähteestä: palvelin maalle suomi
muuta se :Main server

jonka jälkeen se lataa listauksen uudestaan.

kokeile uudestaan asentaa.
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!

samuaaltonen

  • Käyttäjä
  • Viestejä: 26
    • Profiili
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #12 : 01.04.08 - klo:15.59 »
RATKAISTU, :D

En tiedä mitä tein, mutta nyt toimii. asensin tuolta synapticista jotai pikkupaketteja ni lähti yhtäkkii toimii. kiitos paljon teille, annoitte apua todella nopeasti. :)

gdm

  • Sitä saa mitä tilaa...
  • Käyttäjä
  • Viestejä: 4363
    • Profiili
    • Keskustelualueiden säännöt
Vs: Ei pysty asentamaan mitään ohjelmia????
« Vastaus #13 : 01.04.08 - klo:16.01 »
RATKAISTU, :D

En tiedä mitä tein, mutta nyt toimii. asensin tuolta synapticista jotai pikkupaketteja ni lähti yhtäkkii toimii. kiitos paljon teille, annoitte apua todella nopeasti. :)
Hyvä että, meistä oli apua, mutta tuo RATKAISTU toimii parhaiten kun muokka ensimmäisen viestin otsikkoa ;)
Lisää [Ratkaistu] aloitusviestiin jos ongelmasi selviää!
Saamasi tuki on ilmaista, joten älä vaadi tai uhkaile saadaksesi apua!