Kirjoittaja Aihe: amsn asennusongelma debianissa  (Luettu 2909 kertaa)

anonyymikäyttäjä

  • Käyttäjä
  • Viestejä: 136
    • Profiili
amsn asennusongelma debianissa
« : 22.03.08 - klo:12.11 »
ongelmia tällä kertaa amsn asennuksen kanssa, debian käyttöjärjestelmässä, paketti ei suostu asentumaan koneelleni, tulee vain seuraavanlainen virheilmoitus: Error: dependency is not satisfiable: libc6, vaikka minä olen asentanut pakettienhallinnan kautta libc6 kirjastot.

masa

  • Käyttäjä
  • Viestejä: 494
    • Profiili
Vs: amsn asennusongelma debianissa
« Vastaus #1 : 22.03.08 - klo:13.53 »
En muuten osaa tota ratkaista mut ootko kokeillu jos tuon libc6 :n kokonaan poistaminen ja uudelleen asentaminen auttais?
matti_mato

Kun pulma ratkeaa, lisääppä ekan viestin otsikkoon [RATKAISTU] :)

Pavao

  • Käyttäjä
  • Viestejä: 61
  • Arch Linux
    • Profiili
Vs: amsn asennusongelma debianissa
« Vastaus #2 : 22.03.08 - klo:14.20 »
En muuten osaa tota ratkaista mut ootko kokeillu jos tuon libc6 :n kokonaan poistaminen ja uudelleen asentaminen auttais?

Libc6 paketista riippuu suurin osa järjestelmän paketeista eli ÄLÄ KOKEILE POISTAA SITÄ.

Asennatko tuota amsnää ihan pakettivarastoista vai jostain netistä poimitusta paketista? Ilmeisesti libc6 on eri versio kun minkä amsn haluaisi.

Mikä debianin versio? Etch?

Onko tuosta virheilmoituksesta tarkempaa versiota? Semmoinen jossa näkyisi versionumerot olisi hyvä.
"Children are smarter than any of us.
Know how I know that?
I don't know one child with a full time job and children."

Bill Hicks

anonyymikäyttäjä

  • Käyttäjä
  • Viestejä: 136
    • Profiili
Vs: amsn asennusongelma debianissa
« Vastaus #3 : 24.03.08 - klo:13.28 »
virheilmoituksesta ei valitettavasti ole tarkempaa versiota  :( , ainakaan minä en ole nähnyt mitään muuta kyseisessä virheilmoituksessa, virheilmoitus tulee kun yritän käynnistää asennusta gdebi ohjelmalla, ja ongelma on esiintynyt sekä debianissa että mint linuxissa, debianin versio on 4.0.
« Viimeksi muokattu: 25.03.08 - klo:19.14 kirjoittanut anonyymikäyttäjä »

Pavao

  • Käyttäjä
  • Viestejä: 61
  • Arch Linux
    • Profiili
Vs: amsn asennusongelma debianissa
« Vastaus #4 : 24.03.08 - klo:20.08 »
Lainaus
yritän käynnistää asennusta gdebi ohjelmalla
Olettaisin siis, että kyseessä on netistä ladattu paketti. Ilmeisesti uudempi kuin debianin stable pakettivarastoissa.

Jos vanha amsn kelpaa, se löytyy pakettivarastoista, ja sen saa asennettua komennolla

Koodia: [Valitse]
apt-get install amsn
Ulkonäkö ilmeisesti on rumempi tuossa vanhassa amsn:ssä ja muutenkin joitain toimintoja ei taida olla. Tuota ladattua pakettia et luultavasti saa asennettua, koska libc6-kirjasto on niin olennainen osa käyttöjärjestelmää, että et voi sitä päivittää yhteensopivaksi amsn:n kanssa.

Voisitko vielä kokeilla paketin asentamista komentoriviltä komennolla
Koodia: [Valitse]
dpkg -i [paketinnimi] ja pastettaa tänne mitä se ilmoittaa? Tuon pitäisi antaa tarkempi virheilmoitus.
"Children are smarter than any of us.
Know how I know that?
I don't know one child with a full time job and children."

Bill Hicks