Kirjoittaja Aihe: Wow:n grafiikka ei toimi kunnolla  (Luettu 4261 kertaa)

-kirsi

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Wow:n grafiikka ei toimi kunnolla
« : 06.02.08 - klo:17.36 »
Elis, olen etsiskelly tietoa tästä nyt jo kahden päivän ajan, joten pakkohan se on nyt kysyä neuvoa. :D Eli ekaksi tiedot koneesta:

Acer Aspire 3613LC
Intel Celeron M prosessor 370
(1,5GHz, 400 MHz FSB, 1MB L2 cache)
Integroituna näyttiksenä:
Intel corporation Mobile 915GM/GMS/910GML
40GB kovu
Muistia alunperin ollu 265Mb, lisämuistia 1G
Ja lisäksi Ubuntun Gutsy käyttöjärjestelmänä.

Nonii, eli itse siihen asiaan. Asensin tuon wowin tähän koneelle winen kautta, (wine on päivitetty uusimpaan versioon) Nyt olen käytellyt tuota wowia ja asetuksia muokkaillut aika laillakin ja ihan hyvältä näyttää, kunnes pelissä yritin mennä sisätiloihin. Näyttö tuli täyteen viivoja ja meni lähes täysin valkoiseksi, ainoastaan hahmot näkyivät. Lisäksi kun yritän muokata wowin grafiikka-asetuksia, ne eivät syystä tai toisesta tallennu, lisäksi nyt on tullut vika, joka poistuu kun wowin grafiikka asetuksista painaa default-nappia.

Muuten peli tosiaan toimisi hyvin, mutta sisätiloihin ei jostain syystä voi mennä. Pakko sanoa, että koko wowin asennus on ollut tuskaa ja verta. :D Mutta toivotaan, että se vielä kannattaa. ;)

Edit: niin, OpenGl on ja käytän sitä
« Viimeksi muokattu: 06.02.08 - klo:18.12 kirjoittanut -kirsi »

fingerling

  • Käyttäjä
  • Viestejä: 200
  • Linux user #460757
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #1 : 06.02.08 - klo:18.28 »
Oletko tehnyt winen rekisteriin tämän kyseisen muutoksen?
Lainaus
Almost mandatory performance enhancing tweak
This is a simple registry edit for Wine that will dramatically increase the framerate in game for both ATi and nVidia users.

Open a terminal window, type regedit and press enter. This will start the Wine equivalent of the windows registry editor. If you are familiar with using the registry editor under windows then this is pretty much the same.

Notice: the guide below is case sensitive!

1. Find this key HKEY_CURRENT_USER\Software\Wine\
2. Highlight the wine folder in the left hand pane by clicking left on it. The icon should change to an open folder
3. Right-click on the wine folder and select [NEW][KEY]
4. Replace the text New Key #1 with OpenGL
5. Right-click in the right hand pane and select [NEW] then [String Value]
6. Replace New Value #1 with DisabledExtensions
7. Then double click anywhere on the line, a dialog box will open.
8. In the value field type GL_ARB_vertex_buffer_object

Kopioin ubuntun enkun kieliseltä foorumilta.
Itsellä pyörii erittäin hyvin wowi ja asennus oli täysin samanlainen kuin wintoosassa. Koneesi on kyllä näytönohjaimen(myös prossu hidastaa) osalta vähän alitehoinen ja etenkin raideissa ja outlandissa sekää suurissa kaupungeissa (IF,SW etc.) voi odottaa erittäin suurta lagia..
Niitä asetuksia voi muokata helpoiten WTF kansiosta löytyvästä config.wtf tiedostosta. Tässä olisi oma mutta siinä on melkein kaikki täysillä asetuksilla:
Koodia: [Valitse]
SET locale "enGB"
SET hwDetect "0"
SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1280x1024"
SET gxRefresh "50"
SET gxMultisampleQuality "0.000000"
SET lod "1"
SET fullAlpha "1"
SET SmallCull "0.010000"
SET DistCull "500.000000"
SET trilinear "1"
SET frillDensity "32"
SET farclip "537"
SET specular "1"
SET particleDensity "1.000000"
SET unitDrawDist "300.000000"
SET M2UsePixelShaders "0"
SET movie "0"
SET expansionMovie "0"
SET Gamma "1.000000"
SET readTOS "1"
SET readEULA "1"
SET showToolsUI "0"
SET MusicVolume "0.40000000596046"
SET SoundVolume "1"
SET MasterVolume "1"
SET realmList "eu.logon.worldofwarcraft.com"
SET patchlist "eu.version.worldofwarcraft.com"
SET realmName "Earthen Ring"
SET gameTip "15"
SET AmbienceVolume "0.60000002384186"
SET minimapInsideZoom "1"
SET uiScale "0.81000000238419"
SET useUiScale "1"
SET checkAddonVersion "0"
SET scriptErrors "1"
SET MasterSoundEffects "0"
SET EnableMusic "0"
SET EmoteSounds "0"
SET SoundListenerAtCharacter "0"
SET minimapZoom "0"
SET CombatDamage "0"
SET CombatHealing "0"
SET mouseSpeed "1"
SET profanityFilter "0"
SET cameraYawMoveSpeed "90"
SET cameraYawSmoothSpeed "180"
SET cameraDistanceMaxFactor "2"
SET statusBarText "1"
SET UnitNameNPC "1"
SET cameraDistanceMoveSpeed "15"
SET targetNearestDistanceRadius "22"
SET targetNearestDistance "44"
SET UberTooltips "0"
SET UnitNamePlayerPVPTitle "0"
SET gxWindow "1"
SET DesktopGamma "1"
SET coresDetected "1"
SET readTerminationWithoutNotice "1"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET Sound_OutputDriverName "System Default"
SET videoOptionsVersion "1"
SET gxMaximize "1"
SET gxMultisample "1"
SET textureFilteringMode "3"
SET spamFilter "0"
SET Sound_NumChannels "64"
SET ChatMusicVolume "0.30000001192093"
SET ChatSoundVolume "0.40000000596046"
SET ChatAmbienceVolume "0.30000001192093"
SET Sound_EnableErrorSpeech "0"
SET Sound_MasterVolume "1"
SET Sound_SFXVolume "1"
SET Sound_MusicVolume "0.30000001192093"
SET Sound_AmbienceVolume "0.5"
SET Sound_EnableEmoteSounds "0"
SET Sound_ZoneMusicNoDelay "1"
SET Sound_EnableSoundWhenGameIsInBG "1"
SET groundEffectDist "110"
SET weatherDensity "0"
SET ffxGlow "0"
SET ffxDeath "0"
SET OutboundChatVolume "1"
SET InboundChatVolume "1"
SET VoiceActivationSensitivity "0.40000003576279"
SET ShowTargetCastbar "1"
SET CombatLogRangeCreature "50"
SET accountName "xxxxx"
SET autoDismountFlying "1"
SET autoSelfCast "1"
SET cameraView "0"
SET SlideBarConfig "anchor=right;position=222.88887515262"
SET gxTripleBuffer "1"
SET gxFixLag "1"
SET gxApi "opengl"
SET gxCursor "0"
SET shadowLevel "0"
SET groundEffectDensity "48"
SET Sound_EnableReverb "1"
« Viimeksi muokattu: 06.02.08 - klo:18.30 kirjoittanut fingerling »
Kun sekä ylläpitäjä että käyttäjä on sama henkilö, ajaudutaan skitsofreniaan. -Asmo Koskinen

-kirsi

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #2 : 06.02.08 - klo:20.00 »
Eli joo olen tehnyt tuon jutun tuossa aikaisemmin. Myös tuota listaa olen muokkaillut, mutta kuitenkaan en sitä nyt saa kunnolla toimimaan.

Jos joku viitsisi jelpata vähän näitten asetusten kanssa, kun en ole ihan täysin varma miten ne pitäis laittaa. Niin joo, esim. tuo gxRefresh muokkaus ei tallenna ollenkaan.

SET gxColorBits "24"
SET gxDepthBits "24"
SET gxResolution "1024x768"
SET gxRefresh "60"
SET hwDetect "0"
SET doodadAnim "0"
SET lodDist "100.000000"
SET SmallCull "0.080000"
SET DistCull "350.000000"
SET frillDensity "8"
SET farclip "350.000000"
SET particleDensity "0.900000"
SET movie "0"
SET readTOS "1"
SET realmList "eu.logon.worldofwarcraft.com"
SET gxApi "opengl"
SET ffxDeath "0"
SET ffxGlow "0"
SET readEULA "1"
SET readScanning "-1"
SET readContest "-1"
SET gxMultisampleQuality "0.000000"
SET soundMaxHardwareChannels "12"
SET locale "enGB"
SET readTerminationWithoutNotice "1"
SET coresDetected "1"
SET videoOptionsVersion "1"
SET showToolsUI "1"
SET Sound_OutputDriverName "System Default"
SET patchlist "eu.version.worldofwarcraft.com"
SET realmName "Jaedenar"
SET M2UsePixelShaders "0"
SET M2UseShaders "0"
SET UIFaster "2"
SET gameTip "36"
SET Sound_VoiceChatInputDriverName "System Default"
SET Sound_VoiceChatOutputDriverName "System Default"
SET gxFixLag "0"
SET textureFilteringMode "0"
SET Gamma "1.000000"
SET lastCharacterIndex "1"
SET minimapZoom "5"
SET SoundOutputSystem "1"
SET SoundBufferSize "100"
SET spellEffectLevel "0"
« Viimeksi muokattu: 06.02.08 - klo:20.06 kirjoittanut -kirsi »

John Rivera

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #3 : 13.02.08 - klo:12.23 »
Omituinen ongelma.
Itsekkin olen aktiivi wowittaja.

Tuota laittesito listaa katsellessa on todettava että vaikka tuo kone pyörittäisi hyvin windows puolella (Direct 3D) niin voi OpenGL suorituskyky(puutuvia kiihdytys toimintoja) olla niin heikko että se selittää nuo ongelmat.

Asetuksille kannattaa kokeilla ihan raakasti parikin kertaa poistaa nuo hakemistot cache, interface ja wtf joissa on muuttuva data kuten asetukset, ja katsoa muuttuuko mikään...

AION

  • Käyttäjä
  • Viestejä: 150
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #4 : 23.02.08 - klo:11.00 »
Hmmm... itse en Wowia pelaa suurista näkemys ristiriidoista johtuen (GuildWars :P) mutta käsitykseni mukaan wine tarvii/(tarvitsi ennen ainakin) muutaman patchatun *.dll:n.
Homma tehdään niin, että asennetaan ensin kaikki paketit joita tarvitaan Winen compilaamiseen, haetaan patchit ja patchataan source code ja sitten compilataan wine. Tarkempia ohjeita WineHQ:sta, heidän ircci kannulta tai joltain kuka tietää enemmän kuin minä. On myös erittäin todennäköistä, että wowi pathcatut dll:t saa ladattua suoraan ja tarvitsee vain sijoittaa ne winen system32 kansioon.

slux

  • Käyttäjä
  • Viestejä: 52
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #5 : 26.02.08 - klo:10.43 »
Tuota laittesito listaa katsellessa on todettava että vaikka tuo kone pyörittäisi hyvin windows puolella (Direct 3D) niin voi OpenGL suorituskyky(puutuvia kiihdytys toimintoja) olla niin heikko että se selittää nuo ongelmat.

Ei OpenGLstä puutu mitään mitä DX:ssä olisi. Toki pelin GL-tuki voi olla huonoa, mutta se ei ole OpenGL:n vika.

Yksi mahdollinen ongelmien syy on, että tuossa Intelin ajurin kiihdytyksessä Linuxin puolella on vain ongelmia. Uudempien ohjainmallien ajurien tilasta en tosin osaa paljon sanoa... joskus olen ongelmiin vanhemmilla Intelin integroiduilla törmännyt.

John Rivera

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #6 : 26.02.08 - klo:16.09 »
Hmmm... itse en Wowia pelaa suurista näkemys ristiriidoista johtuen (GuildWars :P) mutta käsitykseni mukaan wine tarvii/(tarvitsi ennen ainakin) muutaman patchatun *.dll:n.
Homma tehdään niin, että asennetaan ensin kaikki paketit joita tarvitaan Winen compilaamiseen, haetaan patchit ja patchataan source code ja sitten compilataan wine. Tarkempia ohjeita WineHQ:sta, heidän ircci kannulta tai joltain kuka tietää enemmän kuin minä. On myös erittäin todennäköistä, että wowi pathcatut dll:t saa ladattua suoraan ja tarvitsee vain sijoittaa ne winen system32 kansioon.

Josko ei nyt ryhdyttäisi ongelmaa enää ainakaan pahentamaan arvailemalla, vaan koitettaisiin ratkaista se käytännössä.

Itselläni WoW toimii loistavasti, joten Kirsi-:n ongelma todennäköisesti on tuossa intergroidussa näytönohjaimessa, ne nyt kun ovat melkoisen rajallisia kyvyiltään...

Julle ^^

  • Käyttäjä
  • Viestejä: 34
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #7 : 29.02.08 - klo:12.01 »
ehhehehhe  ;D mullakin ois pieni ongelma noitten grafiikkojen kaa  ;D tsekatkaa kuva

[ylläpito on poistanut liitteen]

idiootti

  • Käyttäjä
  • Viestejä: 96
    • Profiili
Vs: Wow:n grafiikka ei toimi kunnolla
« Vastaus #8 : 13.05.08 - klo:17.22 »
ehhehehhe  ;D mullakin ois pieni ongelma noitten grafiikkojen kaa  ;D tsekatkaa kuva
Sama ongelma täälä. Tosin pelkästään opengl:ää käyttäessä, mutta fps dx:llä on liian alhainen.

SET M2UseShaders "0" lisäys config.wtf tiedostoon voi auttaa.
« Viimeksi muokattu: 13.05.08 - klo:17.45 kirjoittanut idiootti »