Kirjoittaja Aihe: [Ratkaistu]A-Link WLAN USB-verkkokortti ajurien asennus  (Luettu 7685 kertaa)

Lartza

  • Käyttäjä
  • Viestejä: 28
    • Profiili
En ymmärrä asennusta kunnolla. Sanotaan, että: "To build zd1211 you will need: Configured kernel source code for the kernel you are
running. Ideally, Configured means that you have at least run 'make config', 'make
enuconfig', or 'make xconfig'. If your platform is not SMP system, please don't
config SMP supported, because when module loaded, this will make unresolved
symbol."

Ja tota en ymmärrä: "2.2 Build and install the package:
The package contains drivers for ZD1211 and ZD1211B. If you doesn’t have specified
request, both of them will be installed.
Under the extracted directory, there is a Makefile in it. Because our driver can support for
kernel 2.4 and kernel 2.6, there are two sets of rule in the Makefile. One has to modify
the Makefile according to the path of “kernel source tree” and the version of the kernel
in your system. In the Makefile, you may see the following statements,
# if the kernel is 2.6.x, turn on this
#KERN_26=y
#KERNEL_SOURCE=/usr/src/linux-2.6.7
# if the kernel is 2.4.x, turn on this
KERN_24=y
KERNEL_SOURCE=/usr/src/linux-2.4.20-8
If you want to build the kernel under the kernel of 2.4.x, one has to let the variable
KERN_24=y and comment the KERN_26=y like that as the example above and modify
the variable KERNEL_SOURCE to the path which you install the kernel source. After
doing these things, one just need to type the “make”, and the driver module will be
generated and installed."

Tarvitsen kernelin sourcen ja mistä jos tarvitsen?
Miten se sitten käännetään?
Ja mikä on SMP?

Selventäsisittekö kiitos.

EDIT: Toimii. En ollut kokeillut tikkua, mutta luin vain, joten luulin, että tarvitsee ajurit. Ei tarvitse ainakaan 7.04.
« Viimeksi muokattu: 10.12.07 - klo:15.41 kirjoittanut Lartza »

waari

  • Käyttäjä
  • Viestejä: 56
    • Profiili
Vs: A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #1 : 10.12.07 - klo:13.41 »
tarkoitatko sellaista usb paikkaan laitettavaa A-linkin wlan sovitinta?itselläni käytössä ubuntu 7.10 jossa laite toimii suoraan,kuten myös 7.04 versiossa.
ei tarvinnut asentaa ajureita.

Marbo

  • Käyttäjä
  • Viestejä: 427
    • Profiili
    • Toimi.org
Vs: A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #2 : 10.12.07 - klo:14.05 »
Niin ja kertoisitko mikä alink se on? Itselläni myös A-LINK:n usb wlan ja toimii ilman mitää. Senkun törkkäs vaan.

Linux user #460798

Lartza

  • Käyttäjä
  • Viestejä: 28
    • Profiili
Vs: A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #3 : 10.12.07 - klo:15.27 »
Ei niitä ole kuin yhdenlainen: http://www.a-link.com/WL54USB.html?id=5PY8xKeU. Itse en ole kokeillut vielä, mutta kaikkialla sepitetään ajureista. USBhen juu ja wlan adapteri. Itselläni Ubuntu 7.04.

Marbo

  • Käyttäjä
  • Viestejä: 427
    • Profiili
    • Toimi.org
Vs: A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #4 : 10.12.07 - klo:15.30 »
Ei niitä ole kuin yhdenlainen: http://www.a-link.com/WL54USB.html?id=5PY8xKeU. Itse en ole kokeillut vielä, mutta kaikkialla sepitetään ajureista. USBhen juu ja wlan adapteri. Itselläni Ubuntu 7.04.

Itselläni tuo ihan sama, ja käytössä on Ubuntu 7.10. Ei ollu muuta kun törkkäs kiinni koneeseen ja sit valitsi sieltä wlan verkon ja sit mentiin internetin saloihin. :)

Linux user #460798

Mi_Kaheli

  • Käyttäjä
  • Viestejä: 19
    • Profiili
Vs: [Ratkaistu]A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #5 : 10.12.07 - klo:21.00 »
Itselläni myös sama, erilaisissa kuorissa... huomattavasti kookkaampi, harmaa, kantikas... ehkäpä vanhempi malli.. tosin mallinumero on juuri sama..  eli itsellänikin siis toimii suoraan, eikä ole pätkinyt wlan vielä kertaakaan, tosin ei ole tuolla palikalla pätkinyt koskaan.

wally

  • Käyttäjä
  • Viestejä: 138
    • Profiili
Vs: [Ratkaistu]A-Link WLAN USB-verkkokortti ajurien asennus
« Vastaus #6 : 15.01.08 - klo:21.51 »
Sain jopa Broadcomin wlanin kohtuu nätisti toimimaan kannettavalla, mutta tämä A-Linkin tikku, jonka pöytäkonetta varten hommasin, ei kyllä toimi suorilta minulla Gutsyssä.

dmesg, kun törkkää tikun kiinni:
Koodia: [Valitse]
[  372.768000] usb 5-2: new high speed USB device using ehci_hcd and address 5
[  372.900000] usb 5-2: configuration #1 chosen from 1 choice
[  373.016000] usb 5-2: reset high speed USB device using ehci_hcd and address 5
[  373.200000] zd1211rw 5-2:1.0: firmware version 4725
[  373.244000] zd1211rw 5-2:1.0: zd1211b chip 0ace:1215 v4810 high 00-1a-9f AL2230_RF pa0 g--NS
[  373.248000] zd1211rw 5-2:1.0: eth1
[  373.300000] ADDRCONF(NETDEV_UP): eth1: link is not ready

lsusb:
Koodia: [Valitse]
Bus 005 Device 005: ID 0ace:1215 ZyDAS
iwconfig tulostaa:
Koodia: [Valitse]
eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"zd1211"
          Mode:Managed  Frequency:2.412 GHz  Access Point: Invalid   
          Bit Rate=1 Mb/s   
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

iwlist eth1 scanning:
Koodia: [Valitse]
eth1      No scan results
Ja tosiaan yhtään wlan-tukiasemaa ei näy myöskään graafisilla työkaluilla. Täällä pitäisi näkyä useita.

Pitäisikö joku moduuli ladata mahdollisesti?