Kirjoittaja Aihe: Ralink:in WLAN-kortit toimimaan Breezyssä. (rt2400, rt2500, rt2561, rt2570)  (Luettu 32317 kertaa)

LittleLion

  • Käyttäjä
  • Viestejä: 1232
    • Profiili
    • http://koti.mbnet.fi/littleli/
Olen täällä foorumilla huomannut, että aika monella on ollut ongelmia Ralink:in WLAN-korttien kanssa vaikka niiden pitäisi olla parhaiten Linuxilla toimivia WLAN-kortteja. Tämä ongelma johtuu suurelta osalta siitä, että Ralink:iltä on tullut uusia piiriä ulos ja vanhatkin ovat muuttuneet, joten Ubuntun mukana tulevat ajurit eivät ole tarpeeksi uusia toimiakseen näiden piirien kanssa. Suurin ongelmahan tässä on se, että ajureiden kääntäminen vaatii käännös työkalut ja niiden asentaminen on vähän hankalaa ilman verkkoa.


Normaali tilannehan on se, että käyttäjä ei tiedä mikä kortti koneessa on tai ainakaan mitä piiriä se käyttää. Niinpä se pitää selvittää ensimmäiseksi. Sen selvittämiseksi joudut ensin käynnistämään konsolin. (Löytyy Gnome:n valikosta nimellä Terminal ja KDE:n valikosta nimellä Konsole) Kirjoita konsoliin komento: lspci ja etsi rivi, jossa puhutaan jotain WLAN-kortistasi. Jos piirisarja on rt2400, rt2500, rt2561 tai rt2570 tämä ohje on sinua varten.


Aluksi tarvitset käydä jollakin tietokoneella jossa internetti toimii ja latamaan seuraavat paketit: http://koti.mbnet.fi/littleli/ubuntu/breezy-extra-drivers/ralink_wlan_drivers.tar.gz ja http://fi.archive.ubuntu.com/ubuntu/pool/main/l/linux-source-2.6.12/linux-image-2.6.12-10-386_2.6.12-10.30_i386.deb siirrä ne Ubuntu koneellesi USB-tikulla tai cd:llä.

Ubuntun Breezyn (32-bit) oletus kernelihän on 2.6.12-9-386, mutta koska Ubuntu päivittää sen kuitenkin heti, kun verkko saadaan kuntoon versioon: 2.6.12-10-386 joten se kannattaa tehdä jo ennen ajureiden asennusta. Se onnistuu asentamalla aikaisemmin latamasi paketti: linux-image-2.6.12-10-386_2.6.12-10.25_i386.deb ja asentamalla se konsolissa komennolla: sudo dpkg -i linux-image-2.6.12-10-386_2.6.12-10.25_i386.deb komento pyytää salasanaa, joten anna sille oma salasanasi. Nyt käynnistä koneesi uudelleen ja valitse käynnistys valikosta (GRUB) rivi: Ubuntu, kernel 2.6.12-10-386


Kopioi ajuri paketti cd:ltä omaan kotihakemistoosi. Paketin nimi on: ralink_wlan_drivers.tar.gz

Seuraavaksi asennetaan ajurit kirjoittamalla seuraavat komennot konsolissa:
tar -zxf ralink_wlan_drivers.tar.gz purkaa ajuri paketin
cd ralink_wlan_drivers Mennää ajuri kansioon.
sudo ./install.sh Asennetaan ajurit.


Nyt ajurit on asennettu ja voit ladata ne komennolla: sudo modprobe ajurin_nimi jossa ajurin_nimi korvataan ajuri paketin nimellä. Nimet menevät seuraavasti:
Piirisarja   Ajuri
rt2400      rt2400
rt2500      rt2500
rt2561      rt61
rt2570      rt2570

Lisäksi kannattaa ajaa komento: echo ajurin_nimi |sudo tee -a /etc/modules jolloin se asettaa tuon ajurin latautumaan aina käynnistettäessä.


Sitten pitää langaton yhteys konfiguroida. Tässä vaiheessa tarvitset tietää: langattoman verkon nimen, käytetäänkö salausta ja jos käytettään niin mitä salausta (WPA/wep), tuleeko ip-osoitteet dhcp:ltä(automaattisesti) vai tarvitsetko asettaa ne käsin.

1. Helpompi tapa
Useimmat kortit voit konfiguroida ottamalla Gnomessa: System -> Administration -> Networking ja asettamalla langattoman verkon asetukset. Laite on yleensä ra0

2. Vaikeampi tapa
Jos tuo tapa ei onnistu joudut asettamaan verkkoasetukset käsin. Se onnistuu muokkamalla tiedostoa /etc/network/interfaces ja lisäämällä sinne rivit:
Koodia: [Valitse]
auto ra0
iface ra0 inet dhcp
jolloin ip-osoitteiden tulee tulla dhcp:ltä jos ne pitää asettaa käsin ne pitää laittaa tuohon tiedostoon.

Varsinaiset langattoman verkon asetukset tulee määrittää tiedostoon: /etc/Wireless/RT2500STA/RT2500STA.dat kaikilla muilla piireillä paitsi rt2561, jolla ne täytyy laittaa tiedostoon: /etc/Wireless/RT61STA/rt61sta.dat

Ohjeet tuon tiedoston konfigurointii löydät tästä ohjeesta kohdasta: "File: Configuration File: RT2500STA.dat"

Lopuksi verkko tulee vielä käynnistää uudelleen komennolla: sudo /etc/init.d/networking restart

HUOM! tämä ohje toimii vain 32-bittisen Ubuntun PC-version kanssa, jos sinulla on käytössä joku muu Ubuntun versio ja tarvitset apua Ralink:in korttisi kanssa laita viestiä tänne foorumille.

Tässä ohjeessa asennettavat ajurit ovat minun kääntämiäni 8.1.2006 joten jos niissä ongemia laittakaa viestiä suoraan minulle.
« Viimeksi muokattu: 20.03.06 - klo:14.44 kirjoittanut LittleLion »

suokki

  • Käyttäjä
  • Viestejä: 10
    • Profiili
No mites sitte AMD prosessorien kanssa tää juttu toimii? tää taitaa olla ainoastaa 32bittisille.
kaljuunnuin kun asensin linuxin.

LittleLion

  • Käyttäjä
  • Viestejä: 1232
    • Profiili
    • http://koti.mbnet.fi/littleli/
No mites sitte AMD prosessorien kanssa tää juttu toimii? tää taitaa olla ainoastaa 32bittisille.

Nuo ajurit on käännetty 32-bittiselle käyttöjärjestelmälle. Nuo ajurit pystyy kääntämään myös 64-bittiselle järjestelmälle, mutta itse en voi sitä tehdä, koska minulla ei ole 64-bittistä järjestelmää.

Flei

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Minun ongelmani oli A-Link WL54PC WLAN (Rt2500). Asensin tuon paketin LittleLionin ohjeen mukaan mutta tuota Rt2500:n ajuria ei ilmesty näkyviin ollenkaan. Luin sitten jostain että Breezyssä on valmiina tuo 2500:n ajuri. Ja http://www.ubuntuforums.org/showthread.php?t=78250 mukaan muokkasin tiedoston /etc/network/interfaces muotoon

iface ra0 inet dhcp
pre-up iwconfig ra0 essid YOUR-SSID
pre-up iwconfig ra0 mode managed
pre-up iwpriv ra0 set Channel=11
pre-up iwpriv ra0 set AuthMode=WPAPSK
pre-up iwpriv ra0 set EncrypType=AES
pre-up iwpriv ra0 set WPAPSK="YOUR-WPA-PSK"
pre-up iwpriv ra0 set TxRate=0

Ja nyt toimii.

(Ja tämähän ei ole oikea paikka tätä kysyä mutta millä saa kde:ssä tuon työpöydän näkyviin? Siis kaikkien ikkunoiden alta  ??? )

Tuon langattoman verkon saaminen toimintaan vie kyllä minua taas monen askeleen päähän windowsista. Kunhan vielä joutaa kokeilemaan että toimisiko Nokian PcSuite tässä Kubuntussa...

LittleLion

  • Käyttäjä
  • Viestejä: 1232
    • Profiili
    • http://koti.mbnet.fi/littleli/
Minun ongelmani oli A-Link WL54PC WLAN (Rt2500). Asensin tuon paketin LittleLionin ohjeen mukaan mutta tuota Rt2500:n ajuria ei ilmesty näkyviin ollenkaan.

Paha sano mistä tuo johtuu, kun et kertonut tarkemmin.


Lainaus
Luin sitten jostain että Breezyssä on valmiina tuo 2500:n ajuri. Ja http://www.ubuntuforums.org/showthread.php?t=78250 mukaan muokkasin tiedoston /etc/network/interfaces muotoon
Ja nyt toimii.

Joo. Kyllä Breezyssä on rt2500 ajuri valmiina, mutta se on sen verran vanha, ettei riitä kaikille. Hyvä joka tapauksessa, että toimii.

JussiN

  • Käyttäjä
  • Viestejä: 2
    • Profiili
En saa noita ajureita toimimaan kuin puoliksi.

RT61 Wireless  ESSID:""
          Mode:Auto  Channel:0  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Link Quality=0/70  Signal level:-121 dBm  Noise level:-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Ajurit ei ilmeisesti lue rt61sta.dat tiedostoa.
essid, modet ja salaukset on määritelty tiedostoon.

mitkä noista bin fileistä pitää olla myös tuolla /etc/Wireless/RT61STA/  hakemistossa.


LittleLion

  • Käyttäjä
  • Viestejä: 1232
    • Profiili
    • http://koti.mbnet.fi/littleli/
En saa noita ajureita toimimaan kuin puoliksi.

RT61 Wireless  ESSID:""
          Mode:Auto  Channel:0  Bit Rate=54 Mb/s
          RTS thr:off   Fragment thr:off
          Link Quality=0/70  Signal level:-121 dBm  Noise level:-111 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Ajurit ei ilmeisesti lue rt61sta.dat tiedostoa.
essid, modet ja salaukset on määritelty tiedostoon.

Onhan sinulla nuo rivit tuolla /etc/network/interfaces tiedostossa? Ja sen jälkeen buuttasit verkon komennolla: sudo /etc/init.d/networking restart


Lainaus
mitkä noista bin fileistä pitää olla myös tuolla /etc/Wireless/RT61STA/  hakemistossa.

Eikös siellä ole tiedostot: rt2561.bin  rt2561s.bin  rt2661.bin


JussiN

  • Käyttäjä
  • Viestejä: 2
    • Profiili
Jep, kaikki on niinkuin pitääkin, mut ei toimi.

iwconfig näyttää samalta ja ifconfig:lla ip puuttuu.
iwlist scan: näyttää kolme eri verkkoa mutta ei omaa.

Loppuu keinot kesken...

Niin ja lspci näyttää: Network controller:Ralink:Unknown device 0302
« Viimeksi muokattu: 23.01.06 - klo:20.38 kirjoittanut JussiN »

LittleLion

  • Käyttäjä
  • Viestejä: 1232
    • Profiili
    • http://koti.mbnet.fi/littleli/
Lainaus
Niin ja lspci näyttää: Network controller:Ralink:Unknown device 0302

hmm. Oletko varma, että tuo kortti käyttää rt2561 piiriä? Ralinkillä on muistaakseni olemassa vielä yksi muu piiri, mutta se ei toimi kuin rt2x00 ajurilla, joka taas vaatii vähintään 2.6.13 kernelin, joten sitä ei saa toimimaan ilman kernelin kääntöä, kuin vasta dapperissa.

Norppa

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Niin ja lspci näyttää: Network controller:Ralink:Unknown device 0302

Itselläni näyttää ihan samaa. Korttini hiljaittain ostettu WL54PC, jonka piirisarjan pitäisi ainakin olla rt2500.

Mitäköhän tässä nyt kannattaisi ihan ensimmäiseksi tehdä. Voiko yhteydet saada toimimaan, vaikka lspci näyttäisikin unknownia?

Jackal

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Osaisiko joku auttaa seuraavaan ongelmaan?

Eli wlan-kortti on A-Link WL54PC (PCMCIA), ja asensin ajurit täsmälleen ylläolevan ohjeen mukaan.

Mutta kun menen nyt asennuksen jälkeen järjestelmä-->hallinta-->verkkoasetukset, valitsen "langaton yhteys" ja klikkaan "ominaisuudet" niin koko Ubuntu (5.10) jämähtää paikoilleen??
Kyseinen kortti kyllä näkyy siellä olevan

Koneeni on IBM ThinkPad 600.
Aiemmin win XP:ssä wlanin kanssa ei ollut ongelmia.

erggi

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Re: Ralink:in WLAN-korti.... rt61 malli
« Vastaus #11 : 25.01.06 - klo:21.39 »
Heijsan te kellä lspci antaa:

Network controller:Ralink:Unknown device 0302

Mulla on myös sama tilanne. Nou hätä  ;) Kirjoitan tätä juuri ubuntulla ko. wlanin läpi.

Tuntemattomuus johtuu [vissiin] siitä, että kyseessä on oikeasti kovin uusi siru rt61, ja se ole vielä linuskan tiedossa.  Tässä tapauksessa toistaiseksi ehkä käsittääkseni ainoa toimiva ajuri on valmistajan sivulla http://www.ralink.com.tw/supp-1.htm oleva rt61 ajuri. Tätä kirjoitettaessani oli saatavilla vain ajuri http://www.ralink.com.tw/drivers/Linux/2005_1230_RT61_Linux_STA_Drv1.0.3.0.tar.gz.

Sieltä vaan uusinta pakeettia ja sitten purku ja siellä on readme joka ihan oikeasti kannattaa lukea. Tein asiat readmen mukaan ja homma pelas ihan suoralta kädeltä PAITSI että luin sieltä rivien välistä asioita kuten tein hakemistot joita ei valmiina ollut ja käytin komennoissa sudoa ja asensin sysutils (oisko universe puketti?) paketin jotta sain käyttööni dos2unix komennon jota readmessa suvereenisti käytettiin sekä opeteltuani vi:n peruskomennot voidakseni editoida binäärimuotoista konffifilua jne. Siinä vaiheessa kun sain tehtyä sudo /sbin/insmod rt61.ko onnistuneesti (eli heti) ja laitettuani kotiverkon wep salausasetukset yms
komennolla
erg@lubuntu:/etc/Wireless/RT61STA$ sudo vi -b rt61sta.dat

käynnistin ubuntun verkkomanagerin (joo ja täs vaihees kortin ledit heräs eloon ja alkoivat vilkutella mulle) ja katsoin et siel on oikeet asetukset myös mm. dhcp painoin vaan aktivoi niin lubuntu sai ip:n ja homma toimii!

Itelläki homma vielä sen verran kesken et pitäs saada kortti automaagisesti käyntiin buutissa.


Lisätään vielä edelliseen että kortti on A-Link WL54PC (PCMCIA) huutonetistä ostettu ihkauus laite. Luulin kanssa ostaessani että siinä on rt2500 ja kun ajuriseedeelläkin oli vain rt2500 hakemistot niin ei hyvä tullu. Cd:llä tullut Windows ajuri toimii tosin ihan ookoosti, linux ajurin kanssa lopetin kikkailun aika pian ja hyvä niin. Kannettava on ibm thinkpad t21 ja ubuntu on dapper drake flight-3. ???
« Viimeksi muokattu: 26.01.06 - klo:09.17 kirjoittanut erggi »

shroom

  • Käyttäjä
  • Viestejä: 1
  • Tietojenkäsittelijä Tampereelta.
    • Profiili
Tuntemattomuus johtuu [vissiin] siitä, että kyseessä on oikeasti kovin uusi siru rt61, ja se ole vielä linuskan tiedossa.  Tässä tapauksessa toistaiseksi ehkä käsittääkseni ainoa toimiva ajuri on valmistajan sivulla http://www.ralink.com.tw/supp-1.htm oleva rt61 ajuri. Tätä kirjoitettaessani oli saatavilla vain ajuri http://www.ralink.com.tw/drivers/Linux/2005_1230_RT61_Linux_STA_Drv1.0.3.0.tar.gz.

Lisätään vielä edelliseen että kortti on A-Link WL54PC (PCMCIA) huutonetistä ostettu ihkauus laite. Luulin kanssa ostaessani että siinä on rt2500 ja kun ajuriseedeelläkin oli vain rt2500 hakemistot niin ei hyvä tullu. Cd:llä tullut Windows ajuri toimii tosin ihan ookoosti, linux ajurin kanssa lopetin kikkailun aika pian ja hyvä niin. Kannettava on ibm thinkpad t21 ja ubuntu on dapper drake flight-3. ???

Täytynee kertoa, että olen säätänyt saman kortin, eli A-Linkin Wl54PC PCMCIA-kortin, toimimaan Ubuntussa (Breezy Badger), mutta oikeista verkkoasetuksista huolimatta kortti ei näytä lähtevän toimimaan ilman, että kernelin käynnistää irqpoll-optiolla.

Yllä esitetty oletus pitää mielestäni paikkansa, sillä aluksi parempi puoliskoni sääti korttia ja sai sen hetkeksi toimimaan aivan oikeilla ajureilla (rt61). Kuitenkaan käynnistyksen jälkeen kortti ei enää pelannut, jolloin epäilin, että mies olisi asentanut väärät ajurit, koska levyllä oli tosiaan mukana Linuxille rt2500-ajurit. Tarkempien selvittelyjen jälkeen huomasin, että levyllä oli ilmeisesti Windows-ajureina rt61-ajurit (ainakin ajuritietoja penkoessa törmäsin merkkijonoon rt61.sys). Nämä rt61-ajurit pelasivat hienosti Windowsissa, jolloin päätin alusta lähtien kokeilla uudestaan rt61-ajureiden kääntämistä ja asentamista.

Lainaus
Sieltä vaan uusinta pakeettia ja sitten purku ja siellä on readme joka ihan oikeasti kannattaa lukea. Tein asiat readmen mukaan ja homma pelas ihan suoralta kädeltä PAITSI että luin sieltä rivien välistä asioita kuten tein hakemistot joita ei valmiina ollut ja käytin komennoissa sudoa ja asensin sysutils (oisko universe puketti?) paketin jotta sain käyttööni dos2unix komennon jota readmessa suvereenisti käytettiin sekä opeteltuani vi:n peruskomennot voidakseni editoida binäärimuotoista konffifilua jne. Siinä vaiheessa kun sain tehtyä sudo /sbin/insmod rt61.ko onnistuneesti (eli heti (joo ja täs vaihees kortin ledit heräs eloon ja alkoivat vilkutella mulle)) ja laitettuani kotiverkon wep salausasetukset yms
komennolla
erg@lubuntu:/etc/Wireless/RT61STA$ sudo vi -b rt61sta.dat

Aivan alun alkaen mieheni kokeili irqpoll-optiota rt61-ajureiden kanssa, mutta tällä ei ollut vaikutusta ilmeisesti siksi, ettei verkkoasetukset olleet oikein tai niitä ei oltu lisätty /etc/network/interfaces tiedostoon. En vieläkään tiedä, millainen rooli ajurin asetustiedosto rt61sta.dat:lla on, mutta sinulla se ilmeisesti riitti kuitenkin eikä tarvinnut lisätä mitään iwconfig- ja iwpriv-rivejä interfaces-tiedostoon, jos oikein tulkitsen? En siis tiedä, toimisiko se nyt ihan pelkästään rt61-asetustiedoston tiedoilla.

Ubuntun verkkomanagerista ei ollut ainakaan mitään apua. Toisaalta, käytämme WPA:ta WEP:n sijasta, jolle tuota kautta ei voi asetuksia määrittääkään.

Lainaus
Itelläki homma vielä sen verran kesken et pitäs saada kortti automaagisesti käyntiin buutissa.

Minulla riitti rt61.ko modulin kopioiminen kansioon /lib/modules/kernel/extra/ , jossa kernel on siis uname -r tuloste eli käytössä olevan kernelin versio, ja /etc/modules-tiedostoon rt61-merkkijonon lisääminen. Listassa on automaattisesti ladattavat modulit, ja tuon perusteella järjestelmä osaa hakea automaattisesti rt61.ko:n tuolta extra-hakemistosta ja ladata sen muistiin.

Nyt siis ongelmana on, että kernel täytyy käynnistää irqpoll-parametrilla, muuten jostain syystä ilmestyvän IRQ #9 disabled -ilmoituksen jälkeen kortti sammahtaa (kortti käyttää siis tätä keskeytystä, näin newbiena en osaa tätä kommentoida sen tarkemmin). Valot saattavat vilkkua hetken, mutta menevät pois päältä. Tällöin rt61-moduli näkyy lsmodilla ja näyttäisi olevan käytössäkin, mutta tukiasemaan ei saa millään yhteyttä.

Satunnaisesti IRQ-disablointia ei tapahtunut, jolloin kortti lähti ihan kiltisti toimimaan, mutta tähän ei voi ainakaan pelkästään luottaa. Tahtoisin siis selvittää, voiko korttia käyttää lainkaan ilman tuota irqpoll-parametria.

erggi

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Ilmeisesti gnomen nettityökalu lisäs nämä rivit itse interfaces tiedostoon:

iface ra0 inet dhcp
wireless-essid ************
wireless-key **********************'*

auto ra0


Kokeilin jo tuota mitä ehdotit ja jostain syystä ubuntu lataa rt2500 modulin ja rt61 jää lataamatta. Kokeilen tässä vielä. Manuaalisesti saan kortin kyllä toimimaan.

erggi

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Nyt on aika pienet ongelmat jälellä. siltä ainakin tuntuu.

Tilanne on nyt se, että mulla on /etc/network/interfaces tiedosto konffattu (edellä sisältö) ja /etc/Wireless/RT61STA/rt61sta.dat konffattu oman kotiverkkoni mukaisesti. En tarvitse gnomen network-adminia mihinkään enää, mulla kortti toimii kun vain manuaalisesti menen /lib/modules/kernel/extra:an ja sanon sudo insmod rt61.ko.

Tämä alkoi pelaamaan näin kun poistin jatkuvasti kernelin jumittaneen iwconfig ohjelman. Tämä ajuri ei pidä iwconfigista, vaan käyttää ifconfigia. Iwconfig on osa libiw28 pakettia ainakin tässä dapperissa. Poistin sen ja samalla poistui myös ubuntu-minimal mikä ei kai ole ihan välttämätön  ;D

Nyt siis enää pitäisi saada mokoma moduuli ladattua buutissa.  :) Olen melko hukassa tän ubuntun kanssa, kun olen vuosia käyttänyt vain gentoota ja siellä asiat on ihan eri lailla varsinkin näissä käynnistys asioissa. >:(

Norppa

  • Käyttäjä
  • Viestejä: 6
    • Profiili
Äh, liian hyvältä se WL54PC:n "varma toiminta Linuxissa" kuulostikin ;)

Ei kai siinä auta muuta kuin odottaa sopivaa mielentilaa ja alkaa joku päivä tappelee tosissaan tän kanssa..

erggi

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Norppa:

kyllä tää ihan varmatoimiselta tuntuu jahka saa asennettua.  ;D

Jackal

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Osaisiko joku auttaa seuraavaan ongelmaan?

Eli wlan-kortti on A-Link WL54PC (PCMCIA), ja asensin ajurit täsmälleen ylläolevan ohjeen mukaan.

Mutta kun menen nyt asennuksen jälkeen järjestelmä-->hallinta-->verkkoasetukset, valitsen "langaton yhteys" ja klikkaan "ominaisuudet" niin koko Ubuntu (5.10) jämähtää paikoilleen??
Kyseinen kortti kyllä näkyy siellä olevan

Koneeni on IBM ThinkPad 600.
Aiemmin win XP:ssä wlanin kanssa ei ollut ongelmia.


Ratkaisin itse..
http://forum.ubuntu-fi.org/index.php?topic=1691.0

Edelleen wlan-kortti on mykkä? ajurit pitäis olla kunnossa.

erggi

  • Käyttäjä
  • Viestejä: 44
    • Profiili
Alko näköjään toi rt61.ko modulin lataus toimia käynnistyksen yhteydessä kun luovuin ubuntun vakiokernelistä ja käänsin oman. Pätsäsin samalla suspend2 tuen vaniljakerneliin, alkais olee läppäri toimintakelponen nyt  ;D

Jackal

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Ubuntu 5.10 + IBM TP 600 + A-Link WL54PC PCMCIA + kernel 2.6.10

Ubuntu tunnistaa kortin ja pystyn skannaamaan saatavilla olevia verkkoja, mutta kortissa ei pala valot enkä saa IP-osoitetta. Mikä vikana..?