Kirjoittaja Aihe: GoaH - Laskutusohjelma julkaisu  (Luettu 7247 kertaa)

hss-kobolt

  • Käyttäjä
  • Viestejä: 16
    • Profiili
Vs: GoaH - Laskutusohjelma julkaisu
« Vastaus #20 : 14.07.08 - klo:10.48 »

Minulla täsmälleen sama ongelma.



apache2 error.log :ssa lukee seuraava:

Koodia: [Valitse]
[Mon Jul 14 10:28:34 2008] [error] [client 192.168.0.1] DBI connect('dbname=laskutus','laskutus',...) failed: FATAL:  Ident authentication failed for user "laskutus", referer: http://192.168.0.2/goah_www/
[Mon Jul 14 10:28:34 2008] [error] [client 192.168.0.1]  at ./aliohjelmat.pl line 38, referer: http://192.168.0.2/goah_www/
[Mon Jul 14 10:28:34 2008] [error] [client 192.168.0.1] 1 at ./aliohjelmat.pl line 38., referer: http://192.168.0.2/goah_www/
[Mon Jul 14 10:28:34 2008] [error] [client 192.168.0.1] Premature end of script headers: login.pl, referer: http://192.168.0.2/goah_www/

samalla /var/log/postgresql/postgresql-8.3-main.log :ssa lukee:

Koodia: [Valitse]
2008-07-14 10:28:09 EEST LOG:  database system is ready to accept connections
2008-07-14 10:28:09 EEST LOG:  incomplete startup packet
2008-07-14 10:28:34 EEST FATAL:  Ident authentication failed for user "laskutus"

postgresql versio:

Koodia: [Valitse]
root@kotiserveri:/var/log/postgresql# apt-cache policy postgresql-8.3
postgresql-8.3:
  Asennettu: 8.3.3-0ubuntu0.8.04
  Ehdokas: 8.3.3-0ubuntu0.8.04
  Versiotaulukko:
 *** 8.3.3-0ubuntu0.8.04 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     8.3.1-1 0
        500 http://archive.ubuntu.com hardy/main Packages

 ???

hss-kobolt

  • Käyttäjä
  • Viestejä: 16
    • Profiili
Vs: GoaH - Laskutusohjelma julkaisu
« Vastaus #21 : 14.07.08 - klo:10.57 »

Muistin juuri ongelman lokaalien kanssa tuota tietokantaa luodessa merkistöllä: LATIN1 joten tein tuon oletuksella webminissä.

Koodia: [Valitse]
root@kotiserveri:/var/log/postgresql# su - postgres
postgres@kotiserveri:~$ createdb goah_db -E LATIN1
createdb: database creation failed: ERROR:  encoding LATIN1 does not match server's locale fi_FI.UTF-8
DETAIL:  The server's LC_CTYPE setting requires encoding UTF8.


Ilmeisesti muillakin on kokemusta samasta.

TapioSalonsaari

  • Käyttäjä
  • Viestejä: 2
    • Profiili
    • GoaH
Vs: GoaH - Laskutusohjelma julkaisu
« Vastaus #22 : 16.07.08 - klo:09.22 »
Hss-kobolt ja Kimmoke näyttäisivät painivan saman ongelman parissa, eli kirjautuminen tietokantaan ei syystä tai toisesta toimi. Ongelmaa voisi lähtä perkkaamaan muuttamalla/lisäämällä pg_hba.conf:iin hieman tietoturvattoman rivin:
Koodia: [Valitse]
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
local    all     all         trust
Tuolla luotetaan kaikkiin käyttäjiin ilman salasanakyselyä, jotka ottavat yhteyttä kantaan unix-socketilla. Mutta kuten todettua, tuo ei oikein ole tuotantokelpoinen asetus.

Kirjautumisongelma kannattanee muutenkin perkata ensin psql-clientillä suoraan komentoriviltä. Sen jälkeen kun kannan palvelimen asetukset ovat kohdallaan ne voi alkaa syöttämään goah:n konffeihin.

Toivottavasti hajanaiset ajatukset aamukahvin ääreltä auttavat edes johonkin suuntaan. Ja vielä lopuksi muistutuksena GoaH:n oma/virallinen foorumi http://forum.goah.org
« Viimeksi muokattu: 16.07.08 - klo:09.24 kirjoittanut TapioSalonsaari »

Sami Lahtinen

  • Käyttäjä
  • Viestejä: 29
    • Profiili
Vs: GoaH - Laskutusohjelma julkaisu
« Vastaus #23 : 16.07.08 - klo:22.33 »
Hss-kobolt ja Kimmoke näyttäisivät painivan saman ongelman parissa, eli kirjautuminen tietokantaan ei syystä tai toisesta toimi. Ongelmaa voisi lähtä perkkaamaan muuttamalla/lisäämällä pg_hba.conf:iin hieman tietoturvattoman rivin:
Koodia: [Valitse]
# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
local    all     all         trust
Tuolla luotetaan kaikkiin käyttäjiin ilman salasanakyselyä, jotka ottavat yhteyttä kantaan unix-socketilla. Mutta kuten todettua, tuo ei oikein ole tuotantokelpoinen asetus.


Myös...

# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD
local    all     all         md5

... pitäisi toimia. Mutta kuten Tapio sanoikin, niin "trust" on parempi aluksi, että näkee homman toimivan, sen jälkeen sitten tiukemmaksi.


Muistin juuri ongelman lokaalien kanssa tuota tietokantaa luodessa merkistöllä: LATIN1 joten tein tuon oletuksella webminissä.

Koodia: [Valitse]
root@kotiserveri:/var/log/postgresql# su - postgres
postgres@kotiserveri:~$ createdb goah_db -E LATIN1
createdb: database creation failed: ERROR:  encoding LATIN1 does not match server's locale fi_FI.UTF-8
DETAIL:  The server's LC_CTYPE setting requires encoding UTF8.


Ilmeisesti muillakin on kokemusta samasta.

Täällä lisää tuosta aiheesta https://bugs.launchpad.net/ubuntu/+source/postgresql-common/+bug/207779

--
Sami Lahtinen