Näytä kirjoitukset

Tässä osiossa voit tarkastella kaikkia tämän jäsenen viestejä. Huomaa, että näet viestit vain niiltä alueilta, joihin sinulla on pääsy.


Viestit - DaMan

Sivuja: [1]
1
Siirtymä on jo suoritettu toiseen -toistaiseksi- ilmaiseen kirjapitosoftaan kitupiikkiin. Vanhat kirjanpidot edelleen viemättä sinne ja tarkoitus on säilyttää ne tilittimessä.

Tilitin näyttäisi asentuvan ja toimivan ongelmitta Lubuntu 20.04:n ja uusimman openjdk releasen kanssa (14).

Koodia: [Valitse]
sudo apt-get install openjdk-14-jre libitext-java
wget https://helineva.net/deb/pool/main/t/tilitin/tilitin_1.5.0-1_all.deb
sudo dpkg -i tilitin_1.5.0-1_all.deb


2
On tullut pitkään pidettyä kirjapito pöytälaatikkofirmassa ja parissa yhdistyksessä ohjelmalla Tilitin. Hyvä softa. Nyt se sitten pitäisi asentaa uudelle alustalle.
Olen aina tykännyt jostain syystä tuosta Mint distrosta ja edelleen sillä pitäisi mennä. Uusi alusta on Linux Mint 18.3  (4.10.0-38-generic #42~16.04.1-Ubuntu) eli tavallaan xenialin forkkihan tuo Mintti on. Uusi mintti on nyt sitten tungettu täyteen erilaisia servuja nyt vielä pitäisi ahtaa sinne Tilitin.

Vakiona tuo Mintti asentaa Java8:n ja sillä pitäisi mennä koska muut vielä tärkeämmät palvelut samassa myllyssä vaatii tuon kasin. Ei ole vaihtoehtoja. Se on ainakin oltava.
Koodia: [Valitse]
openjdk version "1.8.0_151"
OpenJDK Runtime Environment (build 1.8.0_151-8u151-b12-0ubuntu0.16.04.2-b12)
OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode)

No, nyt sitten ongelmaksi muodostui että tuo Tilitin haluaa välttämättä vanhemman version Javasta.
Koodia: [Valitse]
Selecting previously unselected package tilitin.
(Reading database ... 202320 files and directories currently installed.)
Preparing to unpack tilitin_1.5.0-1_all.deb ...
Unpacking tilitin (1.5.0-1) ...
dpkg: dependency problems prevent configuration of tilitin:
 tilitin depends on java6-runtime | java7-runtime | openjdk-6-jre | openjdk-7-jre; however:
  Package java6-runtime is not installed.
  Package java7-runtime is not installed.
  Package openjdk-6-jre is not installed.
  Package openjdk-7-jre is not installed.
 tilitin depends on libitext-java; however:
  Package libitext-java is not installed.

dpkg: error processing package tilitin (--install):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22+linuxmint1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 tilitin

Ilmeisesti siis ainoa keino on laittaa java7 rinnalle?  Vai pystyykö jollain parametreillä emuloimaan 8:lla 7:aa?

Olen yrittänyt monenlaista netistä löytynyttä tapaa mutta ei ole vielä löytynyt sellaista jolla lähtisi toimimaan. Järjestelmä ei anna asentaa kahta javaa yhtääaikaa. Jos onnistuu niin kyllä sitten löytyy ratkaisuja kumpi niistä on oletuksena mutta kun ei osaa laittaa niitä yhtäaikaa koneeseen. Ja että asia menisi oikein vaikeaksi niin molemmat javat pitäisi olla vielä normaalisti UI:sta tai upgradella päivitettävissä turvallisuussyistä, eli kyseeseen ei tulee siis mitkään kääntämiset tai purkkaviritykset.

Yritin kokeeksi .rpm paketteja aliaksella mutta joo ei. Menee vaikeaksi eikä edes toiminut. Pitäisi olla nopea ja helppo koska takuuvarmasti tämän saman proseduurin joutuu viemään vielä monta kertaa läpi (esim. Mint Tara 19 taitaa olla muutaman kuukauden päässä). Ja varmasti joutuu vielä säätämään moneen otteeseen. Ratkaisu ei ole myöskään vanha distro VM:n koska pitää olla helposti käytettävissä myös tavalliselle käyttäjälle.

Yritin vielä Ubuntu 17.10:llä ja 18.04Beta1:llä mutta ei. Sama kivi kengässä edelleen.  Tää on varmasti triviaali juttu mutta ei nyt minulle oikein avautunut.

Sivuja: [1]