Kirjoittaja Aihe: UEFI käynnistysongelma [Ratkaistu]  (Luettu 2705 kertaa)

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
UEFI käynnistysongelma [Ratkaistu]
« : 05.10.23 - klo:13.24 »
Uudessa läppärissäni (ASUS-Vivobook F515EA) on Windows 11 ja UEFI systeemi. Asensin siihen Ubuntu 20.04:n ja kaikki toimi hyvin, mutta grub -valikkoa en saanut esiin. Käytin boot-repair -ohjelmaa ja sen korjausehdotusten toteuttamisen jälkeen ubuntu käynnistyy terminaalin prompttiin: grub> ja siitä en ole päässyt eteenpäin. Täytyyko asentaa ubuntu uudestaan ja miten sitten saisi grub -valikon esiin? Windowssia en halua poistaa. Laitteessa on siis kaksi SSD levyä, joista alkuperäinen (500 GB) sisältää nuo UEFI -hommat ja Windowssin. Jälkeen päin on lisätty toinen SSD (1 TB), jolle ubuntu on asennettu. Asennuksessa ei ilmennyt mitään kummallista.
« Viimeksi muokattu: 10.10.23 - klo:16.04 kirjoittanut ubutumpula »

nm

  • Käyttäjä
  • Viestejä: 16295
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #1 : 05.10.23 - klo:13.40 »
Tuossa kahden levyn kokoonpanossa on mahdollista sijoittaa Grubin shimmi/lataaja joko 500 GB:n levyn EFI-osiolle tai vaihtoehtoisesti 1 TB:n levylle omalle EFI-osiolle. Voi olla, että Asusin firmware osaa poimia lataajan vain sieltä 500 GB:n levyltä, mutta molempia vaihtoehtoja kannattaa testata.

Ennen Ubuntun uudelleenasennusta olisi hyvä varmistaa, että 1 TB:n levy on täysin tyhjä, tai  että siellä on GPT-osiotaulu, eikä perinteinen DOS/MBR-osiointi, joka aiheuttaa hankaluuksia UEFI:n kanssa.

Kannattaisi myös asentaa suoraan Ubuntu 22.04, ellei ole erityistä syytä käyttää vanhaa 20.04:ää.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #2 : 05.10.23 - klo:23.41 »
Asensin Ubuntun 1 TB:n levylle. Kaikki toimii muuten hyvin, mutta grub -valikkoa ei tule esiin eli käynnistyy suoraan Ubuntuun. Käynnistyslataaja asennettu 1 TB:n levylle; ei antanut asentaa 500 GB:n levylle. Vaihto Ubuntun ja Windowsin välillä tapahtuu UEFI:n kautta ja on siis hiukan hankalaa.
Mielenkiintoista asiassa on se, että pöytäkoneessa grub -valikko kyllä tulee esiin, vaikka ei sieltäkään pääse alkuperäistä Windowsia käynnistämään kuin UEFI:n kautta. kaikki Linux -distrot käynnistyy kuitenkin grub -valikon kautta (4 erilaista).

nm

  • Käyttäjä
  • Viestejä: 16295
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #3 : 06.10.23 - klo:00.16 »
On normaalia, että Grub-valikko on oletuksena piilossa. Sen saa esiin käynnistyksen alussa shift-näppäimellä tai joissain koneissa escillä.

Nykyisin os-prober on vakiona pois käytöstä potentiaalisten tietoturvaongelmien vuoksi, ja siksi Windowsia tai muita käyttöjärjestelmiä ei automaattisesti tunnisteta, eikä niitä lisätä valikkoon. Voit kytkeä os-proberin päälle lisäämällä /etc/default/grub -asetustiedostoon rivin:

Koodia: [Valitse]
GRUB_DISABLE_OS_PROBER=false
Tallenna tiedosto ja aja sitten vielä update-grub:

Koodia: [Valitse]
sudo update-grub
Jos os-prober havaitsee muita käyttöjärjestelmiä, GRUB-valikko avautuu automaattisesti. Muussa tapauksessa sen voi pakottaa näkyviin asetuksella:

Koodia: [Valitse]
GRUB_TIMEOUT_STYLE=menu

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #4 : 06.10.23 - klo:12.39 »
Jotain muuttui. Kokeilin ensin grub -valikon esiin saantia shift:iä painamalla ja se toimi eli grub -valikko tuli esiin. Sitten lisäsin tuon OS_PROBER:in, mutta valikkoon ei tuo Windows ilmestynyt. Sitten lisäsin toisen linux -distron (Manjaro) ja grub -valikko tuli esiin, mutta siis ilman Windowssia. Windowsin joutuu siis käynnistämään UEFI:n kautta. Ei kauhean hankalaa, ja ehkä hyväkin asia, koska pääsääntöisesti käytän Ubuntua. Jostain syystä Mint ei suostunut asentumaan; onkohan ollenkaan sopiva UEFI:n kanssa... ja Manjaro, jonka siis asensin, ei käynnisty muuten kuin "fallback initramfs" -valinnalla.

nm

  • Käyttäjä
  • Viestejä: 16295
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #5 : 06.10.23 - klo:12.57 »
Sitten lisäsin tuon OS_PROBER:in, mutta valikkoon ei tuo Windows ilmestynyt.

Varmista, ettei /etc/default/grub-tiedostossa ole toista riviä, jossa GRUB_DISABLE_OS_PROBER asetetaan. Mitä sanoo:

Koodia: [Valitse]
grep PROBER /etc/default/grub

Jostain syystä Mint ei suostunut asentumaan; onkohan ollenkaan sopiva UEFI:n kanssa...

Linux Mint on täysin UEFI- ja Secure Boot -yhteensopiva. Asennusohjelma taitaa olla eri kuin Ubuntussa, mutta yleensä se toimii samalla tavalla.


ja Manjaro, jonka siis asensin, ei käynnisty muuten kuin "fallback initramfs" -valinnalla.

Kuulostaa siltä että normaalista initramfs:stä puuttuu tarvittavia moduuleja.

maksim

  • Käyttäjä
  • Viestejä: 254
  • Mikähän tässä nyt mättää?????
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #6 : 06.10.23 - klo:13.42 »
ja Manjaro, jonka siis asensin, ei käynnisty muuten kuin "fallback initramfs" -valinnalla.
Ubuntu (myös Fedora) kirjoittaa Manjaron kohdalla grubiin virheellisen menuentry -rivin ja se on korjattava käynnistysvaiheessa editoimalla ko riviä grubissa.
Tässä virheellinen rivi:
Koodia: [Valitse]
initrd /boot/amd-ucode.img^/boot/initramfs-6.4-x86_64.img
Tässä toimiva rivi:
Koodia: [Valitse]
initrd /boot/amd-ucode.img /boot/initramfs-6.4-x86_64.img
Korjauksesta saa vain istuntokohtaisen avun.


ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #7 : 06.10.23 - klo:13.52 »
grep PROBER /etc/default/grub sanoo:

GRUB_DISABLE_OS_PROBER=false

eli kaiketi niin kuin pitääkin.

Joo, kyllä Mint asentui hyvin pöytäkoneeseen, mutta läppärissä ei tapahtunut mitään.

Manjaro ei pöytäkoneessakaan käynnisty Ubuntun grub:illa, mutta Manjaron grub:illa käynnistyy ihan hyvin. Tuntuisi, että Manjaron grub:issa on jokin vipu, jota Ubuntun grub:issa ei ole.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #8 : 10.10.23 - klo:15.56 »
Järjestelmäni jäänee seuraavaksi:

Ubuntu ja muut linux distrot käynnistetään grub-valikosta siten, että secure boot ei ole käytössä ja
Windows käynnistetään silloin, kun secure boot on käytössä pitämällä "Esc" pohjassa bootin aikana, jolloin saadaan esiin valikko, josta voi valita joko Ubuntun tai Windowsin. Muut linux-distrot näkyvät myös siinä valikossa, mutta eivät siitä käynnisty, koska eivät käynnisty secure bootin käytössä ollessa.

Näilläkin pärjää.

raimo

  • Käyttäjä
  • Viestejä: 4211
  • openSUSE Tumbleweed
    • Profiili
Vs: UEFI käynnistysongelma
« Vastaus #9 : 10.10.23 - klo:16.30 »
Järjestelmäni jäänee seuraavaksi:

Ubuntu ja muut linux distrot käynnistetään grub-valikosta siten, että secure boot ei ole käytössä ja
Windows käynnistetään silloin, kun secure boot on käytössä pitämällä "Esc" pohjassa bootin aikana, jolloin saadaan esiin valikko, josta voi valita joko Ubuntun tai Windowsin. Muut linux-distrot näkyvät myös siinä valikossa, mutta eivät siitä käynnisty, koska eivät käynnisty secure bootin käytössä ollessa.

Näilläkin pärjää.

Ei ole aina ESC, minulla se on Lenovo pöytäkoneessa ENTER-näppäin. Pärjääpä hyvinkin, ainoa haitta on että bluetooth-näppäimistö ei toimi enenkuin järjestelmä on käynnissä. Siksi pitää olla perinteinen langaton tai langallinen näppis valmiusasemissa kun käynnistää koneen.
« Viimeksi muokattu: 12.10.23 - klo:00.52 kirjoittanut raimo »
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski