Kirjoittaja Aihe: [Ratkaistu] En pääse Samballa toisiin koneisiin ?  (Luettu 7122 kertaa)

nm

  • Käyttäjä
  • Viestejä: 16278
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #20 : 28.08.23 - klo:19.09 »
1. Avaa Nemo yhdellä Mint-koneella. Klikkaa jaettavaa kansiota hiiren oikeanpuoleisella painikkeella. Valitse valikosta "Jaa..." ja määritä jako.
2. Avaa Nemo toisella Mint-koneella ja avaa Verkot-sijainti. Näkyykö ensimmäinen kone ja sen jaettu kansio verkoissa?


erkki@EnsioHPV:~$ testparm
Load smb config files from /etc/samba/smb.conf
Unknown parameter encountered: "sever string"
Ignoring unknown parameter "sever string"
WARNING: Ignoring invalid value 'standalone sever' for parameter 'server role'
Error loading services.

Tuon EnsioHPV-koneen /etc/samba/smb.conf-tiedostossa on kirjoitusvirheitä ("sever", kun pitäisi olla "server"). Korjaa virheet tai poista virheellinen tiedosto ja asenna samba uudelleen.

Kuten qwertyy jo pari kertaa totesi, homma menee metsään, jos säädät liikaa itse sen sijaan, että käyttäisit toimivia valmiita mekanismeja.
« Viimeksi muokattu: 28.08.23 - klo:19.13 kirjoittanut nm »

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #21 : 28.08.23 - klo:19.21 »
EnsioHPV ei ole "loca"- verkossa.
inet 192.168.1.125/24 brd 192.168.1.255 scope global dynamic noprefixroute wlo1
       valid_lft 85908sec preferred_lft 85908sec

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #22 : 28.08.23 - klo:19.45 »
Johtuu siitä, että kone ilmoitti, ettei Samba ole asennettu. Asensin sen ja kaikki ei mennyt oikein, joten siitä, johtui. Ja näköjään silmät eri paria.
Siellä oli vielä virhe "usershare allow guest". " guests".
Nyt testparam antaa samanlaisen tuloksen kuin toinen kone.

Nyt täytyy opetella ajamaan Sambaa !

Tuhannet kiitokset jälleen !

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #23 : 28.08.23 - klo:19.52 »
On siellä vielä jotakin.
"netstat --inet -nlp":lla ei ole Win10 konetta. Toinen Mint näkee.

Tämä ns." viallinen kone" ei näe Win-konetta

udp        0      0 192.168.1.133:138       0.0.0.0:*     

PS. taidan sekoilla. Ehkä en osaa vielä käyttää. Tutkailen.   

No nyt Linux Mint homma toimii. Vielä opettelen Windows 10 käytön. Pitää nyt katsoa tarkemmin toi video.                 -
« Viimeksi muokattu: 28.08.23 - klo:21.32 kirjoittanut Eeriikki »

kaulahuivi

  • Käyttäjä
  • Viestejä: 378
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #24 : 28.08.23 - klo:22.06 »

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #25 : 30.08.23 - klo:20.17 »
No, niin, nyt toimii Mint.it keskenään. Ja myöskin Mint ---> Windows,
mutta Windows ----> Mint ei toimi.
Windows "verkko" löytää "itsensä, windows", mutta ei 2 kpl Mint:iä.

Olisiko ideaa mitä pitäisi tarkistaa tai yksinkertaisesti en osaa luod yhteyttä tai liittää.
« Viimeksi muokattu: 30.08.23 - klo:20.20 kirjoittanut Eeriikki »

qwertyy

  • Käyttäjä
  • Viestejä: 5679
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #26 : 30.08.23 - klo:21.42 »
No, niin, nyt toimii Mint.it keskenään. Ja myöskin Mint ---> Windows,
mutta Windows ----> Mint ei toimi.
Windows "verkko" löytää "itsensä, windows", mutta ei 2 kpl Mint:iä.

Olisiko ideaa mitä pitäisi tarkistaa tai yksinkertaisesti en osaa luod yhteyttä tai liittää.
Nyt pätkii hiukan itsellä, mutta yksi kokeilemisen arvoinen homma on, että katsot ensin Mint koneen tai koneiden IP-osoitteet ja yrität yhdistää suoraan Windowsista tyyliin avamalla Windowsin tiedostoselaimestsa, siltä "tämä tietokone" sivulta, jossa näkyy kiintolevyt, niin oikealla napilla tai valikoista "lisää verkkosijainti". Sitten syötät Määritä sijainti kohdassa osoitteen tyyliin

\\192.168.0.1\

Kun saat viimeisen kenoviivan, luonnollisesti oman Mint asennuksesi IP:n jälkeen (ylläoleva esimerkki mikä ei takuulla toimi), niin on hyvin mahdollista, että Windows tarjoaa jaetut Samba kansiot pudotusvalikkoon alapuolelle. Sitten tulee luonnollisesti salasanapyyntö ja käyttäjätunnus. Itse asiassa huomasin juuri äsken, että omalla palvelimella oleva Jellyfin jako ei näkynyt Windowsin selaimessa lainkaan, mutta siihen pystyy ylläolevasti kuitenkin kirjautua. Sen jälkeen asema näkyykin pysyvänä kansiona tuolla "Tämä tietokone" sivulla verkkosijaintina.

En nyt tosiaan varmaksi muistele yhtään, mutta taisi olla, että vaati wins rivin samba.conf tiedostoon, että jako tuli näkyviin selailemalla. Browseable parametri muistaakseni olla myös 'yes' tilassa.
Mielenkiinnosta vilkaisin tuon palvelimen smb.conf tiedoston ja selkeästi taas muistelen väärin

IP Mint koneelle selviää verkkoasetuksista tai päätteessä komentamalla
Koodia: [Valitse]
ip a
« Viimeksi muokattu: 30.08.23 - klo:22.00 kirjoittanut qwertyy »

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #27 : 30.08.23 - klo:22.40 »
Joo, nyt alkaa selviämään. Vaikeeta on ollut. Salasantat, kansiot, milloin mitäkin. Oikeen selkeätä video-ohjetta ei ole ollut ?
Temppu 1 : Windows "Tiedostohallinnan Verkot" yläriville : \\192.168.1.100 ja tässä konessa jakaminen annetaan jollekin kansiolle. Niin tämä kansio "Kuvat" näkyy tässä ko. osoitteessa Windous:sessa.
Tai sitten "jaat" kaikki kansiot Mint:in "Koti"-hakemistossa eli oikeudet niiden näkymiseen verkossa.
Temppu 2: Löytyy seuraavasta osoitteesta:
https://www.youtube.com/watch?v=vW_Up_11dpg

Nyt tåytyy valita näistä kahdesta "Temppu 1 & 2" temppusta, sopiiko molemmat kaikkiin siirtoihin vai pitääkö olla toinen temppu toisiin tehtäviin.
Tämäkään sepustus ei ole ihan "oikein" kaikkien temppujen tiimoilta, koska ruutiinit on vieä sisäänajovaiheessa.
Mutta tämä selviää, kun käyttää molemppia "Temppuja"  siten, että muodotuu rutiinit.

Pitää käydä läpi asetukset Windows 10 "Verkko-ja jakamiskeskus" "Jakamisen lisäasetukset", niissä hipsut;
"Yksityinen", "Vieras tai julkinen" ja "Kaikki verkot".
Votko kokeilla pääsetkö Windows "Verkko"  \\192.168.1.100 ? Jätän sinne auki "liitoksen" "Cellmapper".
Ei kait se ole mahdollista, mutta yllätyksiä aina on !
Niin, kait ne määritykset on asetettu "smb-conf"iin.
Ei mun luontainen äly riitä, mitä sinne pitää osata kirjoittaa ja ei kait tätä "Elinajan odote":tta pidä käyttää lian vaikeisiin asioihin.

qwertyy

  • Käyttäjä
  • Viestejä: 5679
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #28 : 30.08.23 - klo:22.48 »
Tee niin kuin tässä videossa, mutta älä yritä käyttää tuota browse painiketta,vaan laita se IP siihen vasemmalle kuten yllä laitoin.
https://youtu.be/I6Bi84Wkkvo?si=a2rUQKQgb0H7DeUT

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: En pääse Samballa toisiin koneisiin ?
« Vastaus #29 : 31.08.23 - klo:09.11 »
Joo, kyllä toimii joka suuntaan.

Onko seuraavassa korjattavaa ? En muista miksi "security = user" piti sulkea.

  GNU nano 6.2                                                                     smb.conf                                                                             
[global]

workgroup = WORKGROUP
server string = %h server (Samba, Ubuntu)
#security = user
;   interfaces = 127.0.0.0/8 eth0
;   bind interfaces only = yes
log file = /var/log/samba/log.%m
max log size = 1000
logging = file
panic action = /usr/share/samba/panic-action %d
server role = standalone server
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
pam password change = yes
map to guest = bad user
;   logon path = \\%N\profiles\%U
;   logon drive = H:
;   logon script = logon.cmd
; add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
; add machine script = /usr/sbin/useradd -g machines -c "%u machine account" -d /var/lib/samba -s /bin/false %u
; add group script = /usr/sbin/addgroup --force-badname %g
;   include = /home/samba/etc/smb.conf.%m
;   idmap config * :              backend = tdb
;   idmap config * :              range   = 3000-7999
;   idmap config YOURDOMAINHERE : backend = tdb
;   idmap config YOURDOMAINHERE : range   = 100000-999999
;   template shell = /bin/bash
  usershare allow guests = yes

;[homes]
;   comment = Home Directories
;   browseable = no                                                                           
;   read only = yes
;   create mask = 0700
;   directory mask = 0700
;   valid users = %S

;[netlogon]
;   comment = Network Logon Service
;   path = /home/samba/netlogon
;   guest ok = yes
;   read only = yes

;[profiles]
;   comment = Users profiles
;   path = /home/samba/profiles
;   guest ok = no
;   browseable = no
;   create mask = 0600
;   directory mask = 0700

[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

;   write list = root, @lpadmin

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: [Ratkaistu] En pääse Samballa toisiin koneisiin ?
« Vastaus #30 : 30.09.23 - klo:12.04 »
Ratkaiseva tekijä Samban toiminnalle minun tapauksessani on :
- force user = "PC name"   ( erkki@EerikHPU:~$ ) eli "whoami".