Kirjoittaja Aihe: Lenovo ThinkCentre Edge e72 - UEFI bugi [Ratkaistu, ainakin suunnilleen]  (Luettu 3647 kertaa)

qwertyy

  • Käyttäjä
  • Viestejä: 5688
    • Profiili
Ajattelinpa laittaa tänne oman kertomuksen otsikon koneesta ja käyttiksen asennustuskailuista. Spoileri: Kyseinen kone ei vain pysty boottamaan mitään distroa UEFI-tilassa.

Eli dyykkasin SER-jätteisiin menevän otsikon mukaisen koneen ja ajattelin tehdä siitä ns. natiivin Windows 7 koneen ja laittaa jonkin Linux distron esim. Debianin toiselle asemalla.

Koneessa sattui olemaan valmiiksi 128Gt SSD asema kiinni ja eipä siinä kuin hommiin ja muistinkin sai onneksi 8Gt kun sattui olemaan sopiva ylimääräinen samanmoinen jäänyt hyllyyn. Biosista oletusasetukset (optimized) päälle ja asentamaan. Kaikki meni ihan kivasti. Yksi iltapäivä/ilta päivityksiä, muutamia ajureita ja boottailua kuten vanhoissa Windowseissa tapana on. Järjestelmä kunnossa ja ilta.

Päivä kaksi. Tosiaan ajattelin että Bookworm on niin todella lähellä julkaisua, että laitetaas se toiselle hylätylle _kiintolevylle_. Latasin "netinstall" kuvan ja boottasin sen. No tietysti sattui niin, että eetterikaapelia ei saanut koneeseen ja USB-mallia joka toimisi Linuxissa suoraan ei sattunut oleen saatavilla. Eipä siinä, laitetaan sitten puhelimen USB-nettijaon kautta menemään ja homma etenee....Hitaasti, mutta asennus valmistuu loppuviimein. Post näyttö vilahtaa ja heti perään "Error 1962. No operating system found... jotain tämän tapaista". Biosiin ja se no niin, laitetaas boottijärjestys oikeaksi ja uudelleen. Sama homma. Alkoi hämmästyttämään. Eikö virta jotenkin riitä haaroittimella kun koneessa on vielä optinen asema, eli kaikki muut asemat irti ja sama homma. Siirto Windowsin sata kaapeloinnin paikalle. Sama homma. Menikö jotain rikki? Samat kaapelit, mutta Windows asema kiinni ja välitön OK boottaus. Mitä perhanaa tunne. Menikö asema oikeasti rikki tuossa välissä. No sattui silmään yksi pieni SATA SSD, että no tehdään sitten taas kaikki uudelleen.

Sama homma. Nyt alkoi hälytyskellot soida ja livetikulla gpartedilla katsomaan asemia ja kaikki näyttää ihan normaalilta, eli asemat käytännössä täysin varmasti kondiksessa. Sitten katseleen BIOS-asetuksia oikein ajatuksella. Ok, koneessa on Legacy ja UEFI tila. Oletuksena, että kone yrittää käyttää UEFI-tilaa ensisijaisesti. Yritin etsiä onkos se nyt CMS-asetusta, joka joskus on aiheuttanut erikoisuuksia aiemmissa asennuksissa. Ei löydy mitään siihen liittyvää. No manuaalisesti tarkemmin USB-boot ja sieltä legacy boot ja sitä ennen laitoin oletustilaksi Legacyn. Nyt katsoin täysin varmasti USB-bootissa, että tikun voi selkeästi valita erikseen Legacy tai UEFI tilassa. Eli legacy siis päälle ja kaikki uusiksi. No nyt varmasti toimii. Uudelleen käynnistys ja täysin sama virheilmoitus edelleen. Takaisin biosiin katsomaan, että eikö se UEFI lähtenytkään pois ja homma oli mennyt juuri kuten tarkoitus oli, eli valikossa edelleen Legacy tila. Nyt alkoi jo oikeasti vähän kasvaan jotain otsalohkoon. Käynnistin koneen taas Windowsilla ja kokeilin hakea Bios päivityksiä koneeseen. Löytyi koneen seriaalilla sopivat Windowsista päivitettävä ja USB päivitettävä. Näiden kanssa pari tuntia taistelua ja kumpikin päätyy oliko Error 42 Child Process terminated tilaan Windowsissa ja vaikka FreeDOS:lla kokeiltuna. Vanhoja edeltäviä Bioseja ei tietenkään enää löytynyt mistään, vaikka changelog kertoi, että päivityksiä olisi pitänyt tulla vaikka kuinka paljon  ::)

Olut naamariin ja miettiä hetki, että pitääkö oikeasti toi kone muka jättää Windows koneeksi, että siihen ei muka Linuxia saa asennettua mitenkään. En hyväksynyt ajatusta ja vielä tutkiin Biosia. Jossain vaiheessa huomasin, että on koneesta saa poistettua UEFI tuen kokonaan yhdestä asetusvalikosta. Ajattelin, että no tuo ei hyödytä mitään kun kokoajan on Legacya valikoissa ja todistetusti erikseen boot valikosta vielä erikseen valittu Legacy tilaa. Ajattelin, että no ihan se ja sama tässä vaiheessa, että otetaan vaikka pois päältä ja kappas. Välitön boot Linuxiin.

Kokeilin pari kertaa ja varmistin, että kyllä asia on noin kyseisessä Lenovon koneessa. Boottasin vielä manuaalivalinta valikkoon kun kaikki asemat on kiinni ja siinä vasta tajusin yhden asian. UEFI ja Legacy valinta on mahdollinen, mutta vain ja ainoastaan USB-laitteille. Ei enää kun oletkin SATA-laitteiden kohdalla.

Eli tällainen pitkä tarina, jonka ajattelin jakaa, koska moista ei ole itselle vielä koskaan tullut eteen. Mutta loppuhyvin, kaikki hyvin. Vai onko? No ei tietenkään ole, koska se Windows on asemalla edelleen UEFI-asennettuna ja nyt se pitäisi taistella GPT-osionnista MBR-osiontiin yms. No taidan jyrätä vain yli ja laittaa päivitykset valumaan sinne.

Että sellaista pari iltaa  :D
« Viimeksi muokattu: 10.06.23 - klo:00.40 kirjoittanut qwertyy »

Tomin

  • Palvelimen ylläpitäjä
  • Käyttäjä / moderaattori+
  • Viestejä: 11455
    • Profiili
    • Tomin kotisivut
Vs: Lenovo ThinkCentre Edge e72 - UEFI bugi
« Vastaus #1 : 09.06.23 - klo:23.28 »
Tästä tulee mieleen kaksi ajatusta:

Yhdellä koneella UEFI ei suostunut mitäänkään käynnistämään Grubia ennen kuin nimesin sen tiedoston tietyllä tavalla. Siinä oli muistaakseni sentään Intelin tekemä emolevy. :-\ En muista, mikä tiedostonimi siinä piti olla, mutta nettihaku tuo pari ehdotusta. Toisaalta en yrittänyt edes dual boottia kyseisellä koneella. Ehkä se olisi ollut vielä vaikeampaa.

Toinen ajatus on, että periaatteessa BIOS-käynnistys (eli CMS-käynnistys) pystyy myös käyttämään GPT-osiontia eli sinänsä sitä ei tarvitse muuttaa, mutta Windows ei osaa käynnistyä sellaiselta levyltä eli pitäisi kuitenkin käyttää eri levyjä. Ja tämä tietenkin vaatii sen, että UEFIn toteutus on järkevä eikä ala sekoilemaan nähdessään GPT-levyn. ;D

Bonuksena vielä muistelen, että yhdessä koneessa tein muunnoksen toiseen suuntaan (BIOS-käynnistyksestä UEFI-käynnistykseen valmiiksi GPT-osioidulla levyllä) ja se ei suostunut unohtamaan CSM:n käyttöä ennen kuin tyhjensin käynnistyssektorin. ::)
Automaattinen allekirjoitus:
Lisäisitkö [RATKAISTU] ketjun ensimmäisen viestin aiheeseen ongelman ratkettua, kiitos.

qwertyy

  • Käyttäjä
  • Viestejä: 5688
    • Profiili
Vs: Lenovo ThinkCentre Edge e72 - UEFI bugi
« Vastaus #2 : 10.06.23 - klo:00.39 »
Voisi tosiaan olla jotain noihin linkkeihisi viittaavaa, erityisesti tuo nimeäminen. Ei ole kyllä noin omituista tapausta ole tullut vastaan, että miksi ihmeessä Windows asentui UEFI:na, mutta Linux ei. Tosiaan kokeilin Bookwormia, Lubuntun 22.04:sta ja mikä kolmas vielä. Kaikilla täysin sama homma, vaikka tuhosi kaikki levyltä tyhjäksi ja antoi asentimen tehdä kaikki alusta loppuun. Tosiaan siis järjestelmät oli eri asemilla.

Koomisesti vielä tuossa aiemmin kirjoitin siihen tyyliin, että kaikki meni loppuviimein hyvin, mutta olin tuossa vaiheessa saanut Lubuntun käynnistymään ja asennus oli menossa Bookwormin loppuosissa. Vaan ei se vielä ihan putkeen mennyt kun jostain syystä joutui vielä tehdä Boot-repairin livetikulla.

Taisipa olla ensimmäinen kerta kun luin valmistajan manuaalia, että miten Biosin asetukset saa jumppereilla nollattua. Se nyt oli lähinnä vain epätoivoinen kokeilu kun yritin tuota Biosia päivitellä.

Hiukan tekisi mieli kokeilla sorkkia, että löytyisikö jotain täydellisesti vian sinetöivää juttua, mutta taidan mielenterveyden takia jättää välistä kun nyt kaikki alkoi vihdoin viimein toimia halutusti. Positiivisesti Bookworm palkitsi ja sain siinä käännettyä ajurit tuolle yhdelle ongelmalliselle usb-wifi TP-Link tikulle, jossa en ole ennen onnistunut, vaikka muutamia kertoja kokeillut eri kokoonpanoilla, että jotain hyvää loppuviimein :D

*Lisäys*
Laitetaanpa vielä hiukan tarkemmin koneen malli, eli ilmeisesti Edge 72 (ThinkCentre) - Type 3493 jos joku sattuu kyseiseen koneeseen törmäämään ja ihmettelemään samaa.

*Lisäys2*
Olen joskus tehnyt Windows asennukselle tuon GPT-MBR muunnoksen, en nyt kyllä varmaksi sano kummin päin ne tein ja onnistui, mutta ei ollut kyllä ihan triviaali juttu.
« Viimeksi muokattu: 10.06.23 - klo:00.49 kirjoittanut qwertyy »

Roberto

  • Käyttäjä
  • Viestejä: 177
    • Profiili
Tästä tulee mieleen tilanne kun taistelin erään DELL koneen kanssa.
Siinä ei legacy käynnistys onnistunut millään konstilla sisäisiltä SSD tai M.2 levylltä.
Siinä on nyt UEFI Ubuntu.

Löysin tämäntapaista juttua.

Dell is limiting BIOS in the latest hardware.
Has nothing whatsoever to do with DELL.
Microsoft and INTEL etc made class 3 UEFI mandatory.
This means no more legacy, no more 32 bit and no more CSM MBR booting.
They announced this wayy back in 2017.
So ALL vendors are going along with the no more legacy and no more 32 bit.

Dell OptiPlex 7470 (All in One), i5-9500 (6) @ 4,4 GHz, 32 Gt DDR4, Samsung 980 (PCIe NVMe M.2 SSD 2280) 500 Gt
Jäähyllä olevat: Amiga 500, C64