Kirjoittaja Aihe: [Ratkaistu] Ei toimi : "sudo apt update && sudo apt full-upgrade"  (Luettu 1887 kertaa)

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Mitä tehdä kun perinteinen "sudo apt update" herjaa ?

sudo apt update && sudo apt full-upgrade
[sudo] erkki-käyttäjän salasana:           
Siv:1 http://cdn.dyn.com/dynupdater/debian stable/ InRelease
Nouda:2 http://cdn.dyn.com/dynupdater/debian stable/ Release [1 481 B]         
Löytyi:3 http://security.ubuntu.com/ubuntu jammy-security InRelease           
Nouda:4 http://cdn.dyn.com/dynupdater/debian stable/ Release.gpg [327 B]       
Löytyi:5 http://no.archive.ubuntu.com/ubuntu jammy InRelease                   
Löytyi:6 https://linux.teamviewer.com/deb stable InRelease                     
Löytyi:7 http://no.archive.ubuntu.com/ubuntu jammy-updates InRelease
Siv:4 http://cdn.dyn.com/dynupdater/debian stable/ Release.gpg
Siv:8 https://ftp.acc.umu.se/mirror/linuxmint.com/packages vera InRelease
Löytyi:9 http://no.archive.ubuntu.com/ubuntu jammy-backports InRelease
Löytyi:10 https://ftp.acc.umu.se/mirror/linuxmint.com/packages vera Release
Luetaan pakettiluetteloita... Valmis
W: GPG error: http://cdn.dyn.com/dynupdater/debian stable/ Release: Detached signature file '/var/lib/apt/lists/partial/cdn.dyn.com_dynupdater_debian_stable_Release.gpg' is in unsupported binary format
E: The repository 'http://cdn.dyn.com/dynupdater/debian stable/ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
« Viimeksi muokattu: 19.05.23 - klo:14.44 kirjoittanut Eeriikki »

nm

  • Käyttäjä
  • Viestejä: 16197
    • Profiili
Vs: Ei toimi : "sudo apt update && sudo apt full-upgrade"
« Vastaus #1 : 19.05.23 - klo:11.00 »
W: GPG error: http://cdn.dyn.com/dynupdater/debian stable/ Release: Detached signature file '/var/lib/apt/lists/partial/cdn.dyn.com_dynupdater_debian_stable_Release.gpg' is in unsupported binary format
E: The repository 'http://cdn.dyn.com/dynupdater/debian stable/ Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

Dynupdaterin lähteessä tai sen allekirjoituksessa on jotain vikaa. Kokeile poistaa lähde järjestelmästä. Onnistunee graafisen "Software sources"-asetustyökalun kautta, jos kyseessä on Linux Mint. Asenna lähde tai Dynupdater sitten uudelleen, jos edelleen tarvitset kyseistä sovellusta.

Ubuntun universe, multiverse ja restricted -lähteet eivät nähtävästi ole lainkaan käytössä, mutta en tiedä onko se normaalia Mintissä?


Sinänsä tuo Dynupdaterin ongelma ei ole fataali koko järjestelmän päivitysten kannalta, mutta suorittamasi komentojono pysähtyy virheeseen, koska && jatkaa seuraavaan komentoon vain jos edellisen suoritus päättyy virheettömästi (eli prosessi palauttaa 0:n komentotulkille).
« Viimeksi muokattu: 19.05.23 - klo:11.04 kirjoittanut nm »

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: Ei toimi : "sudo apt update && sudo apt full-upgrade"
« Vastaus #2 : 19.05.23 - klo:11.09 »
Kävin laittamassa "Ohjelmalähteisiin" oletusasetukset, koska Ruotsin serverit herjas samalla lailla kuin nämä oletukset.
Tässä kuva.

nm

  • Käyttäjä
  • Viestejä: 16197
    • Profiili
Vs: Ei toimi : "sudo apt update && sudo apt full-upgrade"
« Vastaus #3 : 19.05.23 - klo:12.25 »
Dynupdaterin lähde on varmaankin tuolla Lisäohjelmistolähteet -välilehdellä. Poista se sieltä.

Järjestelmän omat lähteet ovat kunnossa, eikä peilipalvelimen vaihtaminen ratkaise tätä, koska vika on tuossa tietyssä Dynupdater-sovelluksen lähteessä.

Eeriikki

  • Käyttäjä
  • Viestejä: 815
    • Profiili
Vs: Ei toimi : "sudo apt update && sudo apt full-upgrade"
« Vastaus #4 : 19.05.23 - klo:14.44 »
Joo, kiitokset ! Toimii.