Kirjoittaja Aihe: Gimpin raw-editori  (Luettu 1899 kertaa)

nm

  • Käyttäjä
  • Viestejä: 12704
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #20 : 27.12.18 - klo:12.26 »
Kysymys kuuluukin, mahtaisiko kyseinen file-darktable -plugin toimia 2.10 (snap asennus) kanssa, ja minnehän se pitäisi toiseen koneeseen kopioida. Käsin tuota plugin-lausetta ei pysty asetuksiin lisäämään kaiketikaan, vaan Gimpin pitää se plugin löytää itse. Molemmissa koneissa siis 16.04 ja Gnome Flashback.

Darktable-liitännäinen ei toistaiseksi toimi Gimpin Snap-, Flatpak- eikä Appimage-paketoinneissa. Ulkoisen ohjelman käynnistäminen on varmaankin mahdollista saada toimimaan manuaalisilla kytkennöillä, mutta vaatinee perehtymistä. Myös tarvittavan liitännäisen lisääminen valmiiseen pakettiin lienee hyvin haastavaa.

Helpompaa käyttää deb-paketointia Ubuntu 18.04:ssä ja asentaa vanha Darktable siihen.


Lisäksi se, miksi ei Darktable (ainakin 2.4) ei saa kopterin DNG-tiedostoa auki, kaipaisi korjausta. Voin toimittaa DNG-tiedoston, jos tarvitaan. Hyvää loppuvuotta toivottaen :)

Kannattaa kokeilla Darktable 2.6:lla, ja jos ei silläkään toimi, raportoi ongelma kehittäjille.


Gimpissä, ainakin siinä 2.9x kehitysversiossa oli, hyvä optisen vääristymän korjaus, jolla kaartunut horisonttikin oikeni napin painalluksella, kun sain asetukset kohdilleen.

Linssikorjauksen voisi tehdä myös Darktablella: Easily Convert FishEye Lens Drone Pics to RectLinear (Normal) Pictures
« Viimeksi muokattu: 27.12.18 - klo:12.33 kirjoittanut nm »

New_user

  • Käyttäjä
  • Viestejä: 1061
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #21 : 27.12.18 - klo:13.11 »
Kysymys kuuluukin, mahtaisiko kyseinen file-darktable -plugin toimia 2.10 (snap asennus) kanssa, ja minnehän se pitäisi toiseen koneeseen kopioida. Käsin tuota plugin-lausetta ei pysty asetuksiin lisäämään kaiketikaan, vaan Gimpin pitää se plugin löytää itse. Molemmissa koneissa siis 16.04 ja Gnome Flashback.

Darktable-liitännäinen ei toistaiseksi toimi Gimpin Snap-, Flatpak- eikä Appimage-paketoinneissa. Ulkoisen ohjelman käynnistäminen on varmaankin mahdollista saada toimimaan manuaalisilla kytkennöillä, mutta vaatinee perehtymistä. Myös tarvittavan liitännäisen lisääminen valmiiseen pakettiin lienee hyvin haastavaa.

Helpompaa käyttää deb-paketointia Ubuntu 18.04:ssä ja asentaa vanha Darktable siihen.

Asensin taas Sanp-version 2.10:stä. Plugin -hakemistojen polut löytyvät asetuksista ja toisesta (ei homen puolella) löytyy file-darktable -liitännäinen (nyt jaettuna kirjastona, ei suoritettavana ohjelmana kuten 2.9:ssä) kyllä oletuksena. Env-komento ei kuitenkaan näytä, että ympäristömuuttuja gimp-plugin-dir olisi asetettu. Onko vika sitten siinä, en tiedä? Huh sentään tätä sotkua. Lienee paras poistaa koko Gimp ja yrittää toisesta koneesta tuoda jotenkin 2.99 kopioimalla tähän. Muuta tietä en oikein löydä enää, kun 2.9x paketointia ei löydy enää mistään.

New_user

  • Käyttäjä
  • Viestejä: 1061
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #22 : 27.12.18 - klo:16.36 »
Asiaan liittyen; olisiko mahdollista paketoida toisessa koneessa oleva ja toimiva Gimp 2.9.9 uudelleen ja tuoda sitten tähän koneeseen. Netistä löysin tällaisen ohjeen, mutta se ei sellaisenaan ainakaan suoraan toiminut. Kaatuu tuohon --get-selectionsiin.

Koodia: [Valitse]
$ sudo apt-get install dpkg-repack fakeroot
$ mkdir ~/dpkg-repack; cd ~/dpkg-repack
$ fakeroot -u dpkg-repack `dpkg --get-selections | grep install | cut -f1`

(the last command will take some time)

Now if you scroll to your home folder, you should find a folder called "dpkg-repack" which should have all the deb files of all your installed packages.

RE-INSTALL
If you want to re-install the packages, navigate to the folder with the packages and input the following command in the terminal:
Code:

sudo dpkg -i *.deb

En lähde päivittämään tässä vaiheessa Ubuntua. Aiemmista kokemuksista johtuen tilanne yleensä vain eskaloituu ja tulee kaikelaista muuta murhetta ja säätöä. Ei tässä tarvittaisi kuin toimiva Gimp 2.9.9 tähän, ja homma olisi sillä selvä kenties vuosiksi.


nm

  • Käyttäjä
  • Viestejä: 12704
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #23 : 27.12.18 - klo:17.24 »
Gimp 2.10.2 paketoituna Ubuntu 16.04:lle: https://launchpad.net/~alex-p/+archive/ubuntu/gimp

Huomaa, että asennettavan paketin nimi on gimp-devel.

New_user

  • Käyttäjä
  • Viestejä: 1061
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #24 : 27.12.18 - klo:18.39 »
Gimp 2.10.2 paketoituna Ubuntu 16.04:lle: https://launchpad.net/~alex-p/+archive/ubuntu/gimp

Huomaa, että asennettavan paketin nimi on gimp-devel.

Tämä ratkaisi tilanteen!!! Kiitoksen määrää sinulle en pysty edes mittaamaan!

Postimies

  • Käyttäjä
  • Viestejä: 2198
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #25 : 29.12.18 - klo:14.44 »
Darktable sisältää kyllä valokuvan korjaukseen tarvittavat työkalut. LensFun kirjasto kannattaa päivittää uudemmaksi ja tehdä linssikorjakset automaattisesti sillä. Ei edes nappia tarvitse painaa jos ei halua. Ja voi tietysti tehdä skriptin joka tekee kerralla satoihin kuviin linssikorjauksen, terävöinnin, kohinan poiston, pienen saturaatin lisäyksen, vesileiman, tekijäoikeustiedot, .... Gimppiin saa kyllä lensfun lisäosan, mutta DT:ssä se on vakiona ja vaatii säätämistä vain jos ei tunnista jotain optiikkaa.

Photoshop ja LR muuttuneet kk maksullisiksi ja niiden kehitys on ollut vähän paikallaan. Monet kilpailevat softat kehittyneen ja menneet jopa ohi. Monet tuntuvat hokevan sitä mantraa, että Photari pitää olla ja sen kilpailija tai vaihtoehto on Gimp jota käytetään jos Photaria ei ole. On kai joku tottumisjuttu, että kuva pitää avata Gimpissä. En äkkiseltään keksi miksi kuva pitää avata Gimpissä kun DT:ssä jotain 50 erilaista lisäosaa. G’MIC on myös saatavilla. Olen pitänyt Gimppiä enempi piirusteluohjelmana, jolla ei käyttöä RAW-kuville. Tasot, syväykset ja efectit sitten oma maailmansa.

Kameramaailmassa Nikon ja Canon ammatti vehkeet jääneet myös jälkeen. Monet vaihtaneet Fujiin tai Sonyyn. Mikä köyhälle harrastajalle kiva kun hyviä vaihtolaitteita kivasti saatavilla. Itselle kelpaa vielä vanhanaikainen peilillinen Nikon, jonka tarkennus ei pärjää Sonylle.

New_user

  • Käyttäjä
  • Viestejä: 1061
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #26 : 29.12.18 - klo:15.17 »
Darktable sisältää kyllä valokuvan korjaukseen tarvittavat työkalut. LensFun kirjasto kannattaa päivittää uudemmaksi ja tehdä linssikorjakset automaattisesti sillä. Ei edes nappia tarvitse painaa jos ei halua. Ja voi tietysti tehdä skriptin joka tekee kerralla satoihin kuviin linssikorjauksen, terävöinnin, kohinan poiston, pienen saturaatin lisäyksen, vesileiman, tekijäoikeustiedot, .... Gimppiin saa kyllä lensfun lisäosan, mutta DT:ssä se on vakiona ja vaatii säätämistä vain jos ei tunnista jotain optiikkaa.

Photoshop ja LR muuttuneet kk maksullisiksi ja niiden kehitys on ollut vähän paikallaan. Monet kilpailevat softat kehittyneen ja menneet jopa ohi. Monet tuntuvat hokevan sitä mantraa, että Photari pitää olla ja sen kilpailija tai vaihtoehto on Gimp jota käytetään jos Photaria ei ole. On kai joku tottumisjuttu, että kuva pitää avata Gimpissä. En äkkiseltään keksi miksi kuva pitää avata Gimpissä kun DT:ssä jotain 50 erilaista lisäosaa. G’MIC on myös saatavilla. Olen pitänyt Gimppiä enempi piirusteluohjelmana, jolla ei käyttöä RAW-kuville. Tasot, syväykset ja efectit sitten oma maailmansa.

Kameramaailmassa Nikon ja Canon ammatti vehkeet jääneet myös jälkeen. Monet vaihtaneet Fujiin tai Sonyyn. Mikä köyhälle harrastajalle kiva kun hyviä vaihtolaitteita kivasti saatavilla. Itselle kelpaa vielä vanhanaikainen peilillinen Nikon, jonka tarkennus ei pärjää Sonylle.

Kiitokset Postimiehelle ajatuksista. Itse ehkä olen hieman vanhakantainen, kenties ikävuosistakin johtuen, mutta järeämpi kuvankäsittelyohjelma on mieleen profiilimuunnosten, värinhallinnan ja joskus tasojenkin vuoksi. Phoshoppiin tottuneena olen mieltynyt jo jossain määrin Gimpin käyttöön, ja mielestäni Gimpin pitääkin olla enempi sellainen ammattilaissuuntautunut, vakavasti otettava, katu-uskottava. Kyllä Linux sellaisen tarvitsee. Toivon myös kovasti, että Corel jaksaisi sovittaa PaintShop Pron Linuxille, kun kerran AfterShot Prokin jo on. Kaupallinen  tarjonta tuo uskottavuutta käyttöjärjestelmälle ja jatkuvuutta ja uskottavuutta myös ohjelmistokehitykseen.

Kun kuitenkin puhe oli Gimpin raw-editorista, se on itselleni välttämätön esim. kopterikuvien takia. Kopteri kyllä tekee suoraan myös jpegit, mutta kovin valjuina ja kalpeina, jolloin raw on  hyvä vaihtoehto lähteä liikkelle, kun siinä on koko kennon data sen täydellä värisyvyydellä. Kuitenkin ihmetyttää, että kun DNG:n piti olla yleinen standardi, niin siinäkin nyt sitten tuntuu olevan kamerakohtaisia eroja. Se harmittaa. Darktablesta en osaa laittaa asetuksia muuten niin, että kuva lähtisi siitä Kodak pro photo profiilissa. Valitseepa output-profiiliin mitä tahansa, kuva tuee Gimpiin "color profile from EXR chromaticities" merkittynä. Eipä tuo sinänsä haittaa, kun kuvan voi tuossa kääntää työtilaprofiiliin.

Postimies

  • Käyttäjä
  • Viestejä: 2198
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #27 : 29.12.18 - klo:18.31 »
Eikö niitä kuvia voi tehdä melko valmiiksi jo DT:ssä? Oletko tutustunut DT:n presetteihin tai tyyleihin. Voit valita vaikka tuhat kuvaa kerralla ja valita niihin sopivat tyylin. Homman voi myös automatisoida. Voi valita tietyn kameran ja/tai objektiivin ja kun ehdot metadatasta täyttyy se otetaan käyttöön. Itse en pidä editoinnista. Jos lomareisulla otettu yli 1000 kuvaa en niitä erikseen editoi. Linssivääristymät ja kohinanpoisto tapahtuu automaattisesti. Valmiitakin löytyy jos ei itse viitsi askarrella. ks vaikka https://dtstyle.net/.

DT kyllä tukee värienhallintaa. Jos työpöydän värienhallinta kunnossa ei käsittääkseni DT:n asetuksiin juuri tarvitse koskea. Itse olen tallentanut tuotokseni levylle enkä ikinä avannut suoraan toisessa editorissa. Nettiin upatuista kuvita olen yleensä poistanut metadatan. Levylle talletuissa kuvissa on icc-profiili ja kaikki editointihistoria ja se mitä itse on pistänyt. Sieltä saa editointihistorian talteen jos muuten mennyt rikki tai haluaa palauttaa tietyn pisteen.

DNG tiedostot pitäisi olla tuettuja. ks https://www.darktable.org/resources/camera-support/
Tuolla myös linkki johon voi lähettää esimerkkikuvia. Voit myös liittyä postituslistalle ja pistää sinne linkin, niin kehittäjät voivat etsiä virhettä.

Itsellä oli joskus ongelma pakattujen Fujin raf-kuvien kanssa. Päivityksen jälkeen ongelma poistui.

New_user

  • Käyttäjä
  • Viestejä: 1061
    • Profiili
Vs: Gimpin raw-editori
« Vastaus #28 : 29.12.18 - klo:20.28 »
Kiitos kommentista. Olemme ihan erilaisia kuvaajia. Mulla lomareissulta kertyy muutama kymmenen kuvaa, ja sitten toisaalta teen isoja kuvatauluja jne. Tapansa on kullakin tehdä asioita. Gimpistä en lähde luopumaan. DNG:n PITI olla standardi formaatti, mutta ainakin DJI-kopterini DNG:t eivät kaikille ohjelmille kelpaa. Uskon, että kopterivalmistaja on jossain mennyt aidan yli matalimmasta kohdasta. Pitää tutkailla Dartablen tukea ja kenties lähettää sinne kopterin DNG.