Kirjoittaja Aihe: [ratkaistu] Grubin ongelmaa, ei vaan toimi  (Luettu 1340 kertaa)

sigfrid

  • Käyttäjä
  • Viestejä: 5
    • Profiili
[ratkaistu] Grubin ongelmaa, ei vaan toimi
« : 06.02.17 - klo:12.38 »
Hei,

olen uusi täällä ja esitän ekan kysymyksen.  Kone on 4770k-prosessorilla ja MSI:n emolla (32GB muistia) Ubuntu 16.04 ja sain Java-sriptejä ajaessani muutaman satunnaisen stack overflon, skriptillä, joka on ollut käytössä vuosia ja toiminut hyvin.  Ajattelin ajaa muistiotestin GRUB-valikosta.  Muutin GRUB_DEFAULT=2, nollasta kahteen.  Yllätys - kone hyppää bootista MSI:n biosiin, ei GRUB-valikkoon.   En ymmärrä.   Yritin päästä shiftillä GRUBiin, korjausmodeen.  Se ei toimi.  Sensijaan esc:llä pääsee GRUB-valikkoon, josta puuttuu se muistin testaus!   Mikään ei mene niinkuin Strömsössä :)
« Viimeksi muokattu: 06.02.17 - klo:19.31 kirjoittanut sigfrid »

AimoE

  • Käyttäjä
  • Viestejä: 1589
    • Profiili
Vs: Grubin ongelmaa, ei vaan toimi
« Vastaus #1 : 06.02.17 - klo:12.49 »
Onko koneessa vain Ubuntu, ei mitään muita käyttiksiä? Ubuntun mukana tulevat grubin oletusasetukset ovat vanhentuneet, ja jos Ubuntu on yksin, grubia ei saa näkyviin ilman asetusten korjausta. Olen tehnyt omat korjaukseni tähän tapaan:

Koodia: [Valitse]
# diff grub grub-orig

7,9c7,8
< #GRUB_HIDDEN_TIMEOUT=0
< #GRUB_HIDDEN_TIMEOUT_QUIET=true
< GRUB_TIMEOUT_STYLE=countdown
---
> GRUB_HIDDEN_TIMEOUT=0
> GRUB_HIDDEN_TIMEOUT_QUIET=true

eli olen ottanut pois vanhentuneet GRUB_HIDDEN-asetukset ja lisännyt tilalle GRUB_TIMEOUT_STYLE-asetuksen. Tällä muutoksella saan grubin näkyviin silloinkin kun Ubuntu on ihan yksinään koneella.

sigfrid

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Grubin ongelmaa, ei vaan toimi
« Vastaus #2 : 06.02.17 - klo:13.19 »
Yksin on.  No,  jo vähän ihmettelinkin, että miksi minulla ei toimi ja kaikilla muilla googlen mukaan toimii :)  Kiitos ohjeista, nyt päästiin eteenpäin. 

nm

  • Käyttäjä
  • Viestejä: 13103
    • Profiili
Vs: Grubin ongelmaa, ei vaan toimi
« Vastaus #3 : 06.02.17 - klo:18.57 »
Sensijaan esc:llä pääsee GRUB-valikkoon, josta puuttuu se muistin testaus!   Mikään ei mene niinkuin Strömsössä :)

Memtest86+ ei taida toimia UEFI-koneissa. PassMark Memtest toimii, mutta se on asennettava erikseen.

sigfrid

  • Käyttäjä
  • Viestejä: 5
    • Profiili
Vs: Grubin ongelmaa, ei vaan toimi
« Vastaus #4 : 06.02.17 - klo:19.33 »
Sensijaan esc:llä pääsee GRUB-valikkoon, josta puuttuu se muistin testaus!   Mikään ei mene niinkuin Strömsössä :)

Memtest86+ ei taida toimia UEFI-koneissa. PassMark Memtest toimii, mutta se on asennettava erikseen.

Kiitos tiedosta.   Siinä ilmeinen syy siihen, että memtest puuttuu Grub-valikosta.