Kirjoittaja Aihe: 10.10 Ubuntu-julkaisuasi ei tueta enää ?  (Luettu 1277 kertaa)

oh1xe

  • Käyttäjä
  • Viestejä: 353
    • Profiili
    • OH1XE
10.10 Ubuntu-julkaisuasi ei tueta enää ?
« : 21.06.12 - klo:17.19 »
Päivytysten hallinta kertoo näin 10.10 versiolla:
"Ubuntu-julkaisuasi ei tueta enää.
"Tälle Ubuntun versiolle ei enää tule turvallisuuspäivityksiä tai kriittisiä päivityksiä. Ole hyvä ja päivitä uudempaan versioon."

Päätteessä "sudo apt-get update" kuitenkin haki vielä yli 10MB paketteja.
Miten nämä eroavat toisistaan?
Miten "turvattomaksi" menee pysyttäessä wanhallla koneella vanhalla versiossa?

thewk

  • Käyttäjä
  • Viestejä: 433
    • Profiili
Vs: 10.10 Ubuntu-julkaisuasi ei tueta enää ?
« Vastaus #1 : 21.06.12 - klo:17.36 »
Tuota on varmaan vaikea arvioida kun ihan tuettujenkin käyttisten kanssa joillain on tietoturvaongelmia ja joillain ei, puhuttaessa siis ihan samasta käyttöjärjestelmämerkistä kuitenkin  :)

Käytän itse tässä paraikaa Mac OS X 10.5:ttä PowerPC-koneella, käyttikseen tullut useampia vuosia sitten viimeiset päivitykset (huom. Intel -versioon on julkaistu tänä vuonna yksi, ei PPC), selaimena tosin tuettuna oleva TenFourFox joka oletuksena disabloi Flashin ja Javan kun niistä ei saa ajanmukaista versiota tälle raudalle. Palomuurin kytkin päälle ja siihen "häivetilan".

En usko että varsinkaan Ubuntun kanssa on syytä huolestua vaikka vähän ylipäivittyä versiota käyttääkin.
« Viimeksi muokattu: 21.06.12 - klo:17.38 kirjoittanut thewk »
Kasattu PC: AMD Ryzen 5 5600x | 16Gt RAM | GeForce GTX 1060 6Gt | 512Gt NVME SSD, 128Gt SATA SSD, 1T HDD | CDRW / DVDRW | Win 11 + Ubuntu 20.04

HP Compaq DC5800 MT: Intel Xeon X3330 | 4Gt RAM | Radeon HD 8490 1Gt | 500Gt SATA HDD | CDRW / DVDRW | Ubuntu 20.04 64-bit

Ganymedes

  • Käyttäjä
  • Viestejä: 3915
    • Profiili
Vs: 10.10 Ubuntu-julkaisuasi ei tueta enää ?
« Vastaus #2 : 21.06.12 - klo:17.45 »
Päivytysten hallinta kertoo näin 10.10 versiolla:
"Ubuntu-julkaisuasi ei tueta enää.
"Tälle Ubuntun versiolle ei enää tule turvallisuuspäivityksiä tai kriittisiä päivityksiä. Ole hyvä ja päivitä uudempaan versioon."

Päätteessä "sudo apt-get update" kuitenkin haki vielä yli 10MB paketteja.
Miten nämä eroavat toisistaan?
Miten "turvattomaksi" menee pysyttäessä wanhallla koneella vanhalla versiossa?

Niinhän se hakee, mutta nämä eivät ole Canonicalin eli Ubuntun omia vaan sellaisten kolmansien osapuolten ohjelmistojen päivityksiä, joita kuitenkin tulee Ubuntu päivitysten kautta. Tuo herja koskee Canonicalin itse Ubuntua.

Turvattomuutta tai turvallisuutta voi lähestyä monesta näkökannasta, mutta itse olen käyttänyt matriisiajattelua tuossa:

http://forum.ubuntu-fi.org/index.php?topic=38259.msg297882#msg297882

Tarkoitan sitä, että turvallisuustekijöitä on monia ja ne muodostovat matriisin ... kokonaisturvallisuus riippuu siitä missä matriisin solussa oikeastaan ollaan. Tuohon tapaukseesi tätä voisi soveltaa vaikka kysymyksellä mitä koneellasi tehdään ... riippuu siitäkin tämä matriisin yksi tahko.

Joka tapauksessa turvallisuus muuttuu epämääräiseksi jos ohjelmia ei päivitetä, mikä tarkoittaa hallitsematonta riskiä. Joka tapauksessa päivittämättömät, virheelliset ohjelmat, joita on periaatteessa samallalailla kaikissa käyttöympäristöissä, ovat käyttäjän virheiden jälkeen merkittävä turvariski ja näin on myös Ubuntussa. (Käyttäjän virheiksi lasken tässä nyt, makuasia, ei-turvallisista lähteistä ladatut ohjelmat, väärin tehdyt serveri/etäohjelmien konfiguroinnit ja suoranaiset virheet kuten väärä reagointi kalastelu (fishing) yrityksiin ja roskapostiin sekä tietysti älyttömät salasanat ja vastaavat virheet).
« Viimeksi muokattu: 21.06.12 - klo:17.47 kirjoittanut Ganymedes »