Kirjoittaja Aihe: [RATKAISTU] Apachen virittely : Useampi itsenäinen web sivusto.  (Luettu 7190 kertaa)

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Älä tee noin sitä vaan yksi määritys ja laita ServerAlias sinne.  Teet vaikka www.sivu.fi  ja aliasmääritys sivu.fi.

 
Koodia: [Valitse]
<VirtualHost *>
        ServerAdmin admin@sivu.fi
        ServerName  www.sivu.fi
        ServerAlias sivu.fi



vähän kesti ennen kuin pääsi kokeilemaan, mutta ei auttanut tuo.
Sites availablessakaan ei ole nyt muita kuin tuo www.sivu.fi määäritys jossa httpdocsit on käsketty katsoa /vhosts/sivu.fi/httpdocs
kansiosta, mutta silti www.sivu.fi hakee /vhosts/default hakemistosta!
T.
Tunkkaamo

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Ja apache reloadia tehtäessä tulee varoitus:

Koodia: [Valitse]
warn : NamevirtualHost www.sivu.fi:0 has no Virtualhosts.

Auttaisikohan tuo selvittämään asiaa...
T.
Tunkkaamo

Kullervo

  • Käyttäjä
  • Viestejä: 830
    • Profiili
Älä tee noin sitä vaan yksi määritys ja laita ServerAlias sinne.  Teet vaikka www.sivu.fi  ja aliasmääritys sivu.fi.

 
Koodia: [Valitse]
<VirtualHost *>
        ServerAdmin admin@sivu.fi
        ServerName  www.sivu.fi
        ServerAlias sivu.fi



vähän kesti ennen kuin pääsi kokeilemaan, mutta ei auttanut tuo.
Sites availablessakaan ei ole nyt muita kuin tuo www.sivu.fi määäritys jossa httpdocsit on käsketty katsoa /vhosts/sivu.fi/httpdocs
kansiosta, mutta silti www.sivu.fi hakee /vhosts/default hakemistosta!

Minulla tuo porttinumero:
<VirtualHost *:80>
Koodia: [Valitse]
<VirtualHost *:80>
        ServerAdmin admin@sivu.fi
        ServerName  www.sivu.fi
        ServerAlias sivu.fi

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Tarkasta että sinulla on tämä:

/etc/apache2/conf.d/virtual.conf


Koodia: [Valitse]
#
#We are running multiple virtual hosts.
#

NameVirtualHost *

Tuo määrittää että käytämme nimeen perustuvaa virtuaalihostingia = yksi ip-osoite palvelee monta nimeä eli domainia (oletus on osoitteeseen perustuva virtuaalihosting eli yksi ip-osoite per domain).
« Viimeksi muokattu: 15.03.10 - klo:10.07 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

John Rivera

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Tämä aihe ei ole enää ajankohtainen koska se mitä ajattelin tehdä ei yksinkertaisesti ole mahdollista.
Katso tämä aihe
http://forum.ubuntu-fi.org/index.php?topic=32178.0

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Et onnistu ?   En nyt ole aivan varma mitä olet yrittänyt tehdä  mutta helpoksi minä ainakin koen virittää vaikka viisi domainia samalle Apachelle.   No, antaa olla tällä erää, noista ohjeista yllä on hyötyä kuitenkin niille jotka tarvitsevat tuota.

Kysykää muut jos jokin asia ei selviä ylläolevista esimerkeistä.


Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Tarkasta että sinulla on tämä:

/etc/apache2/conf.d/virtual.conf


Koodia: [Valitse]
#
#We are running multiple virtual hosts.
#

NameVirtualHost *

Ei ollut koko filua olemassa joten tein sellaisen:

Apachea reloudatessa tulee ilmo:

Koodia: [Valitse]

warn NameVirtualHost www.sivu.fi:0 has no VirtualHosts
warn NameVirtualHost *:0 has no VirtualHosts

Tuo määrittää että käytämme nimeen perustuvaa virtuaalihostingia = yksi ip-osoite palvelee monta nimeä eli domainia (oletus on osoitteeseen perustuva virtuaalihosting eli yksi ip-osoite per domain).

T.
Tunkkaamo

Kullervo

  • Käyttäjä
  • Viestejä: 830
    • Profiili
katso /etc/apache2/ports.conf

Lainaus
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

Ja NEWS.Debian

Lainaus
apache2 (2.2.9-3) unstable; urgency=low

  * The directive "NameVirtualHost *" has been changed to "NameVirtualHost
    *:80". It has also been moved from sites-available/default to ports.conf.
    This allows to ship a proper SSL default virtual host config in
    sites-available/default-ssl, but it means that if you use several name
    based virtual hosts:
    
    - you will have to change <VirtualHost *> to <VirtualHost *:80> in your
      name based virtual hosts

    - you need to add more NameVirtualHost directives if you use other ports
      than 80 with name based virtual hosts. You may also have to add these
      ports to the default virtual host in /etc/apache2/sites-available/default
      (like this: "<VirtualHost *:80 *:81>").
    
    If you prefer to revert to the old setup instead (and don't need the
    default-ssl host), just change "NameVirtualHost *:80" back to
    "NameVirtualHost *" in ports.conf and "<VirtualHost *:80>" to
    "<VirtualHost *>" in sites-available/default.

  * For mod_disk_cache, caching is again disabled in disk_cache.conf by
    default. It usually makes more sense to enable this on a per-virtual host
    basis.

 -- Stefan Fritsch <sf@debian.org>  Mon, 30 Jun 2008 19:47:52 +0200

Eli ilmeisesti sinulla on ristiriita ports.conf -tiedoston ja tuon /etc/apache-2/sites-enabled/www.sivu.fi -tiedoston kesken.
« Viimeksi muokattu: 18.03.10 - klo:12.53 kirjoittanut Kullervo »

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Tämän ratkaisu antaa vieläkin odottaa itseään:

ports.conf nyt:

Koodia: [Valitse]

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
    Listen 443
</IfModule>


sites-available/www.sivu.fi:

Koodia: [Valitse]
NameVirtualHost  www.sivu.info
<VirtualHost *:80>

Mutta apache uudelleenkäynnistettäessä tulee:

Koodia: [Valitse]
#/etc/init.d/apache2 reload

VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
warn NameVirtualHost www.sivu.fi:0 has no VirtualHosts
warn NameVirtualHost *:0 has no VirtualHosts
warn NameVirtualHost *:80 has no VirtualHosts
T.
Tunkkaamo

Kullervo

  • Käyttäjä
  • Viestejä: 830
    • Profiili
Tässä mallia omasta palvelimesta
Koodia: [Valitse]
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
ServerName  www.sivu.fi
ServerAlias sivu
       

Ja otetaan käyttöön
Koodia: [Valitse]
sudo a2ensite www.sivu.fi ja uudelleen käynnistys

John Rivera

  • Käyttäjä
  • Viestejä: 166
    • Profiili
Hmm, mielenkiintoista että ketju alkoi elää sitten omaa elämää...

Taitaa apachen ja yleensäkkin palvelimen virittely oppaat olla sellaista mille olisi kysyntää, ja niin että ohjeet kestävät ubuntun kehitys (6kk välein ja LTS)...

Itselle kyllä kelpaisi tuollainen ohje miten tehdä useamman websivun konfiguraatio kun käytössä on vain yksi kiinteä looginen (ei numeerinen) osoite.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Tunkkaamo,  sinulla puuttuu tavaraa tuosta sites-available/www.sivu.fi tiedostosta.  Itselläni on  tähän tyyliin:

Koodia: [Valitse]
<VirtualHost *>
        ServerAdmin tunkkaamo(at)jokin-sähköposti-osoite
        ServerName  www.sivu.fi
        ServerAlias sivu.fi

        # Indexes + Directory Root.
        DirectoryIndex index.html
        DocumentRoot /var/www/www.sivu.fi/htdocs/

        # CGI Directory
        ScriptAlias /cgi-bin/ /var/www/www.sivu.fi/cgi-bin/
        <Location /cgi-bin>
                Options +ExecCGI
        </Location>


        # Logfiles
        ErrorLog  /var/www/www.sivu.fi/logs/error.log
        CustomLog /var/www/www.sivu.fi/logs/access.log combined
</VirtualHost>

Tällöin sivut pitää sijoittaa ---> /var/www/www.sivu.fi/htdocs   hakemistoon. Huomaa että määritykset alkavat alkumerkillä <VirtualHost *>   ja loppuvat loppumerkillä </VirtualHost>.    Jos haluat pitää sivut, cgi-bin: it ja logit jossain muualla niin muokkaa tuosta sopivaksi.  Tämä on vain yksi malli ja kaikki tuolla ei ole pakollista mutta pääset sillä liikkeelle heti.  Näitä tehdään yksi kutakin domainia kohti ja ladataan käyttöön kuten yllä on kerrottu.
Tuo ports.conf on itselläni samanlainen kuin sinulla.
« Viimeksi muokattu: 29.03.10 - klo:10.00 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Tunkkaamo,  sinulla puuttuu tavaraa tuosta sites-available/www.sivu.fi tiedostosta.  Itselläni on  tähän tyyliin:


Olisi tietysti voinut lainata selkeämmin, mutta kyllä ne loputkin konffat siellä www.sivu.fi filussa on...
T.
Tunkkaamo

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Tässä mallia omasta palvelimesta
Koodia: [Valitse]
<VirtualHost *:80>
        ServerAdmin webmaster@localhost
ServerName  www.sivu.fi
ServerAlias sivu
        

Ja otetaan käyttöön
Koodia: [Valitse]
sudo a2ensite www.sivu.fi ja uudelleen käynnistys

Eli se NameVirtualHost  www.sivu.fi:stä  kokonaan pois?

Kokeilin ylläolevaa.mutta eipä auttanut.
a2ensite ilmoitti että on jo enabloitu ja apache2 reload ne "normaalit" mixing * ports and non -* ports with a NameVirtualHost is not supported....
Sivut näkyvät kuten ennenkin sivu.fi sieltä missä pitääkin ja www.sivu.fi tulee sitkeästi Default kansiosta...

« Viimeksi muokattu: 29.03.10 - klo:23.21 kirjoittanut Tunkkaamo »
T.
Tunkkaamo

mrl586

  • Käyttäjä
  • Viestejä: 4516
    • Profiili
Aja a2dissite-komento ennen a2ensite-komentoa.

Kullervo

  • Käyttäjä
  • Viestejä: 830
    • Profiili
Eli se NameVirtualHost  www.sivu.fi:stä  kokonaan pois?

Kyllä.

Onkohan polut noissa sites-available -tiedostoissa varmasti oikein?

http://httpd.apache.org/docs/2.2/mod/core.html#documentroot
Lainaus
The DocumentRoot should be specified without a trailing slash.

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Eli se NameVirtualHost  www.sivu.fi:stä  kokonaan pois?

Kyllä.

Onkohan polut noissa sites-available -tiedostoissa varmasti oikein?

http://httpd.apache.org/docs/2.2/mod/core.html#documentroot
Lainaus
The DocumentRoot should be specified without a trailing slash.

Polut on kyllä oikein, dokumentin mukaan.
T.
Tunkkaamo

Tunkkaamo

  • Käyttäjä
  • Viestejä: 231
    • Profiili
    • Tunkkaamo
Aja a2dissite-komento ennen a2ensite-komentoa.

Jep, eipä auttanut sekään.

Arvioisin että tässä on Parallels Pleskillä osuutta asiaan: Sitä käytetään servun hallintaan ja domainit on alunperin luotu sillä.

T.
Tunkkaamo

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Lainaus
Sivut näkyvät kuten ennenkin sivu.fi sieltä missä pitääkin ja www.sivu.fi tulee sitkeästi Default kansiosta...


Oletan että olet tarkastanut kaikki kolme konffauspaikkaa. Periaatteessa defaultista haetaan sivut jos osumaa ei tule noista "Virtual" -määrityksistä, esim. jos tullaan kiinni pelkällä ip-osoitteella selaimessa.
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.

ajaaskel

  • Palvelimen ylläpitäjä
  • Käyttäjä
  • Viestejä: 3384
    • Profiili
Kävin katsomassa tuon www.sivu.fi DNS-määrityksiä. En tutkinut miksi nuo varanimipalvelimet antavat virhettä.  Itselläni www.sivu.fi olisi määritetty CNAME -tietueeksi eikä A -tietueeksi mutta tämä liittyy siihen että ip-osoitteeni voi vaihdella ja saatan myös käyttää postipalvelinta samassa osoitteessa/koneessa.  Tuo CNAME tarkoittaa aliasnimeä samaan tapaan kuin teit Apachella ja vaikka alias määritettäisiin DNS puolella niin se pitää silti laittaa myös Apacheen.

dig www.sivu.fi

; <<>> DiG 9.6.1-P2 <<>> www.sivu.fi
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32570
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.sivu.fi.         IN   A

;; ANSWER SECTION:
www.sivu.fi.      84331   IN   A   77.240.18.15

;; Query time: 41 msec
;; SERVER: 208.67.222.220#53(208.67.222.220)
;; WHEN: Fri Apr  2 18:26:19 2010
;; MSG SIZE  rcvd: 45

(whois:)
nserver: dns1.louhi.net [OK]  
nserver: dns2.louhi.net [ERROR]  
nserver: dns3.louhi.net [ERROR]

Edit:   Tutkin hieman lisää, tuolla määrittelytavalla A vastaan CNAME ei varmaankaan ole yhteyttä varsinaiseen ongelmaasi.

PS. Off-Topic: Oliskos erittäin kokeneelle administraattorille hyviä työtarjouksia kun näkyy olevan firma tuon linkin takana ?   :)
« Viimeksi muokattu: 02.04.10 - klo:21.39 kirjoittanut ajaaskel »
Autamme ilolla ja ilmaiseksi omalla ajallamme.  Ethän vaadi, uhoa tai isottele näin saamasi palvelun johdosta.