Kirjoittaja Aihe: DECchip 21041 (Tulip) ja DHCP-ongelma  (Luettu 1860 kertaa)

rantanplan

  • Käyttäjä
  • Viestejä: 13
    • Profiili
DECchip 21041 (Tulip) ja DHCP-ongelma
« : 27.12.08 - klo:18.37 »
Kryptisehkö ongelma, löytyisikö ajatuksia:

Ubuntu Server 8.04 LTS, verkkokortteina SiS 900 (integroitu) ja DECchip 21041 Tulip (PCI).

Jo käyttistä asennettaessa tuon tulipin kanssa oli ongelmia, asennusohjelma tunnisti kortin ja valot syttyi kun piuhan kytki, mutta kortille ei herunut DHCP:lta IP-osoitetta. Siinä vaiheessa siis kytkin verkkopiuhan tuohon SiS:iin, homma toimi ja sain koneen asennettua.

Kun kone oli jaloillaan aloin sitten hakkaamaan päätäni seinään tuon tulipin kanssa. Siinähän on koksiverkolle BNC-liitin ja 10 mbps ethernet-liitin. Ethtool kertoi, että verkkokortti käyttää BNC-liitäntää, joten vaihdoin sen TP:ksi (Twisted Pair).

Tämän jälkeen tilanne on se, että jos määritän IP:n staattiseksi, homma toimii. Sen sijaan kun yritän käyttää tulipia DHCP:llä dynaamisen IP:n kanssa, ei IP-osoitetta heru. Paitsi että - kun koneen boottaa, kortti saa DHCP:ltä IP:n. Kun taas pudotan kortin alas ja ylös (ifdown > ifup), ei IP-osoitetta jälleen enää heru.

Tämähän on jokseenkin haasteellista, kun nimenomaan ko. kortti oli tarkoitus asettaa ulkoverkolle DHCP:llä, osoitteen vaihtuminen käytännössä pakottaisi boottaamaan koko roskan.


Löytyykö arvon guruilta jotain ajatuksia? Viimeinen ajatushan on tietty kortin vaihtaminen :P

Tuplanolla

  • Käyttäjä
  • Viestejä: 1420
  • Reg. Linux user #423604
    • Profiili
Vs: DECchip 21041 (Tulip) ja DHCP-ongelma
« Vastaus #1 : 27.12.08 - klo:20.46 »
Löytyykö arvon guruilta jotain ajatuksia? Viimeinen ajatushan on tietty kortin vaihtaminen :P
No, aika vanha kortti jos on vielä bnc-liitin ja vaan 10mbps muutenkin, eikä tollaset peruskortit paljoa maksakaan nykyään ;)

Mihin tarvit kahta, miksi ylipäätään on tälläinen ylimääräinen?
Lisää [ratkaistu] ketjun ensimmäisen viestin otsikkoon, kun ongelma ratkeaa!

rantanplan

  • Käyttäjä
  • Viestejä: 13
    • Profiili
Vs: DECchip 21041 (Tulip) ja DHCP-ongelma
« Vastaus #2 : 27.12.08 - klo:21.15 »
No, aika vanha kortti jos on vielä bnc-liitin ja vaan 10mbps muutenkin, eikä tollaset peruskortit paljoa maksakaan nykyään ;)

Kieltämättä, mutta toiminut mallikkaasti tähän saakka ;)

Mihin tarvit kahta, miksi ylipäätään on tälläinen ylimääräinen?

Koneesta on tulossa sellainen söpö pieni kotiserveri, eli hoitaa palomuurin + NATin + levypalvelimen + LAMP + jne virkaa. Tuo tulip on WAN-kortti, sinänsä se riittäisi siihen hommaan mainiosti. Jos siis vaan toimisi :P

Sattui olemaan tähän hätään ainoa kortti joka oli hyllyssä.. vaivaa vaan, että mikä voi moisen aiheuttaa?


Toki samalla voikin kysyä arvon raadilta, että millaisia hinta-laatu-suhteeltaan kelvohkoja kortteja ubuntuihinne tungette? :P