Kirjoittaja Aihe: USB -tikku ei toimi  (Luettu 5333 kertaa)

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
USB -tikku ei toimi
« : 24.02.08 - klo:16.47 »
Hei,
olen tätä kysellyt aikaisemminkin, vaan en ole saanut vastausta. Josko nyt joku tietäisi ratkaisun.

Laitan usb-tikun paikalleen ja saan ilmoituksen:
Koodia: [Valitse]
Unable to mount the volume 'KINGSTON'.
Syynä on wrong fs-type tai joku muu.
Details kehottaa kysymään dmesg | tail, joka antaa seuraavaa:
Koodia: [Valitse]
jussi@jussin-laptop:~$ dmesg | tail
[ 5628.352000] sda: Mode Sense: 23 00 00 00
[ 5628.352000] sda: assuming drive cache: write through
[ 5628.352000] SCSI device sda: 2015232 512-byte hdwr sectors (1032 MB)
[ 5628.352000] sda: Write Protect is off
[ 5628.352000] sda: Mode Sense: 23 00 00 00
[ 5628.352000] sda: assuming drive cache: write through
[ 5628.356000]  sda: sda1
[ 5628.356000] sd 0:0:0:0: Attached scsi removable disk sda
[ 5628.444000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 5629.292000] FAT: Unrecognized mount option "usefree" or missing value
jussi@jussin-laptop:~$

USB-tikku toimii kaikissa muissa koneissa ja tässäkin koneessa, kun käytössä on KDE. Mutta Gnomessa tulee tämä ongelma.

Digi-kamera mounttautuu ja toimii kuin unelma, niin että tuo usb-väylä on kyllä kunnossa. Jostain syystä siis
Koodia: [Valitse]
[ 5629.292000] FAT: Unrecognized mount option "usefree" or missing value
Mitäs Gnomelle pitäisi kertoa, että tuo ongelma katoaisi?
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

juyli

  • Vieras
Vs: USB -tikku ei toimi
« Vastaus #1 : 24.02.08 - klo:18.53 »
Jostain syystä siis
Koodia: [Valitse]
[ 5629.292000] FAT: Unrecognized mount option "usefree" or missing valueMitäs Gnomelle pitäisi kertoa, että tuo ongelma katoaisi?

Pariin kertaan on ongelmaasi koitettu vastailla. En käytä Gnomea, mutta tuo virheilmoitus viittaa tiedostojärjestelmään FAT. Mount komennolla tuloste:
Koodia: [Valitse]
/dev/sdb1 on /media/disk type vfat (rw,nosuid,nodev,shortname=mixed,uid=XXXX,utf8,umask=077,usefree)
Kokeilepa tallentaa kaikki kortin datat, ja vaihtaa tiedostojärjestelmäksi vaikkapa vfat?
Minulla on Kingston -tikkuja, jotka ovat toimineet aivan mainiosti ongelmitta.

PS. Onko kyseessä muuten Dapper vai Feisty?

larpa

  • Vieras
Vs: USB -tikku ei toimi
« Vastaus #2 : 24.02.08 - klo:19.01 »
Lainaus
PS. Onko kyseessä muuten Dapper vai Feisty?
Näyttäs olevan feisty.

juyli

  • Vieras
Vs: USB -tikku ei toimi
« Vastaus #3 : 24.02.08 - klo:19.16 »
Lainaus
PS. Onko kyseessä muuten Dapper vai Feisty?
Näyttäs olevan feisty.
Vain niin. Huomasin typerän kysymyksesi, sillä ajanmukaisin Ubuntu-jakelu olisi Gutsy (7.10), jota tietenkin itse käytän. Dapper (6.06/6.06.1) soveltuu niille, jotka haluavat "vakautta" nykyaikaisuuden kustannuksella (palvelimet+muu ns. tuotantokäyttö). Feistyn (7.04) käytön hyötyjä en ymmärrä, ellei jokin erityissofta vaadi nimenomaan ko. version käyttämistä.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #4 : 24.02.08 - klo:19.29 »
Niin,
tota itse asiassa mulla on Gutsy Gibbon, en tiedä mistä tuo feisty informaatio tuli.
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #5 : 24.02.08 - klo:19.34 »
ihmeellistä tässä on se, että KDE työpöydällä tuo tikku toimii moitteettomasti. Nyt haluaisin kuitenkin tehdä duunia pelkästään Gnomen puolella.

Mites tuo tiedostojärjestelmän vaihtaminen tehdään, jos kokeilen sitä KDE:n puolella?
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

Anssi

  • Käyttäjä
  • Viestejä: 1342
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #6 : 24.02.08 - klo:19.35 »
Niin,
tota itse asiassa mulla on Gutsy Gibbon, en tiedä mistä tuo feisty informaatio tuli.


sinun profiilin asetuksista johtuvaa... sinun allekirjoituksessa lukee
Lainaus
JusSi
http://jinux.pokat.org/jussi/  (OpenOffice.org blogini)
Feisty

Anssi

  • Käyttäjä
  • Viestejä: 1342
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #7 : 24.02.08 - klo:19.40 »
tämä nyt on vähän off topic, mutta...
Lainaus
PS. Onko kyseessä muuten Dapper vai Feisty?
Näyttäs olevan feisty.
Vain niin. Huomasin typerän kysymyksesi, ...

nyt en oikein itse ymmärtänyt siis haukuitko omaa kysymystäsi typeräksi? :)


JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #8 : 24.02.08 - klo:19.44 »
No hyvä,
korjasin profiilin ajan tasalle. Sorry huolimattomuus ...
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

petteriIII

  • Käyttäjä
  • Viestejä: 673
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #9 : 24.02.08 - klo:20.00 »
Ubuntu-forumilla väitettiin, että kerneli 2.6.20-<jotakin> ei ymmärrä sanaa usefree. Lataa uudempi kerneli jos mitenkään mahdollista, sillä toinen korjaustapa on epätoivoinen - käske: 'sudo gconf-editor' ja poista sana usefree kohdassa: System - storage - default_options - vfat -- mount_options
Todennäköisesti ohje toimii myös, mutta en voinut testata koska minulla on uusi kerneli.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #10 : 24.02.08 - klo:20.34 »
Joo,
kerneliin tää liittyy!

Kernelin 2.6.17 ja 2.6.20, jotka mulla asennettuina, eivät osaa mountata tikkua. Uusin kerneli (2.6.22) mounttaa tikun lennosta niin kuin pitääkin, mutta sitten tulee yllättäen uusi ongelma. Verkko ei yhdisty ja network manager kertoo seuraavaa:

Koodia: [Valitse]
Please contact your system administrator to resolve the following problem:

SIOCGIFFLAGS error: No such device

Eli suo siellä, vetelä täällä.

Muistaakseni Mikrobitin uusimmassa numerossakin todettiin tämä ongelma ja ratkaisuksi esitettiin kernelin puukottamista. Jos sen nyt osais jotenkin tehdä ...
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #11 : 24.02.08 - klo:21.09 »
Hei,

tää ohje tuntuu n yt oikealta:
käske: 'sudo gconf-editor' ja poista sana usefree kohdassa: System - storage - default_options - vfat -- mount_options

Tosin vieläkin tulee seuraava virheilmoitus:
Koodia: [Valitse]
jussi@jussin-laptop:~$ dmesg | tail
[  319.380000] sda: Mode Sense: 23 00 00 00
[  319.380000] sda: assuming drive cache: write through
[  319.380000] SCSI device sda: 2015232 512-byte hdwr sectors (1032 MB)
[  319.384000] sda: Write Protect is off
[  319.384000] sda: Mode Sense: 23 00 00 00
[  319.384000] sda: assuming drive cache: write through
[  319.384000]  sda: sda1
[  319.384000] sd 0:0:0:0: Attached scsi removable disk sda
[  319.416000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  320.056000] FAT: Unrecognized mount option "usefree" or missing value
jussi@jussin-laptop:~$

Luulen, että virhe on nyt tuo "missing value", sillä kun tuota optiota korjataan tuolla gconf-editor työkalulla, sinne jää yksi ylimääräinen pilkku, jota en saa millään pois.

Koodia: [Valitse]
/system/storage/default_options/vfat/mount_options [shortname=mixed, uid=,uft8,umask=077, exec,]
Voisko kyse olla tästä?

Miten tuota tiedostoa pääsis korjaamaan käsipelillä?
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #12 : 24.02.08 - klo:21.22 »
No joo,
sain sen viimeisen pilkun pois. Pelkkä edit ei riittänyt, vaan piti komentaa myös delete merkkiriville.
Ja silti sama ongelma toistuu, paitsi että tuo viimeisen rivin virheilmoitus tulee nyt kaksi kertaa.

Pitäiskö tuossa kohden

Koodia: [Valitse]
uid=, utf8
olla jotain lisää /toisin?
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

juyli

  • Vieras
Vs: USB -tikku ei toimi
« Vastaus #13 : 24.02.08 - klo:21.24 »
Kernelin 2.6.17 ja 2.6.20, jotka mulla asennettuina, eivät osaa mountata tikkua. Uusin kerneli (2.6.22) mounttaa tikun lennosta niin kuin pitääkin, mutta sitten tulee yllättäen uusi ongelma. Verkko ei yhdisty ja network manager kertoo seuraavaa:

Mutta tuo onkin taas jo ihan eri asia. Siis kernel 2.6.22-14 on jakeluversion virallinen kernel-versio. Jos verkkosi taas ei toimi, pitää etsiä syyt, miksi verkkosi ei toimisi uusimman _virallisen kernel-version_ kanssa.
Valinta on sinun: itke sitä, ettei jokin muistikortti toimi vanhan kernel-version kanssa, tai korjaa verkkoasennuksesi nykyisessä, turvallisessa kernel-versiossa. Suosittelen jälkimmäistä vaihtoehtoa.
Apujakin verkkoyhteyksien kanssa saat, kertomalla kunnolla tarvittavat perustiedot, joilla verkkosi toimii.

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #14 : 24.02.08 - klo:21.42 »
jep,

mielelläni tuota uusinta kerneliä käyttäisin.

Mutta tuo onkin taas jo ihan eri asia. Siis kernel 2.6.22-14 on jakeluversion virallinen kernel-versio. Jos verkkosi taas ei toimi, pitää etsiä syyt, miksi verkkosi ei toimisi uusimman _virallisen kernel-version_ kanssa.
Valinta on sinun: itke sitä, ettei jokin muistikortti toimi vanhan kernel-version kanssa, tai korjaa verkkoasennuksesi nykyisessä, turvallisessa kernel-versiossa. Suosittelen jälkimmäistä vaihtoehtoa.
Apujakin verkkoyhteyksien kanssa saat, kertomalla kunnolla tarvittavat perustiedot, joilla verkkosi toimii.

En osaa muuta sanoa kuin, että minulla on langaton verkko kotona ja noilla vanhemmillä kerneleillä ei ole ongelmaa verkon käytössä. DHCP hakee osoitteet ja sitten mennään. Uusi kernel antaa tuon ilmoituksen, josta en ymmärrä mitään.

Koodia: [Valitse]
SIOCGIFFLAGS error: No such device
JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.

Anssi

  • Käyttäjä
  • Viestejä: 1342
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #15 : 24.02.08 - klo:21.50 »
jep,

mielelläni tuota uusinta kerneliä käyttäisin.

Mutta tuo onkin taas jo ihan eri asia. Siis kernel 2.6.22-14 on jakeluversion virallinen kernel-versio. Jos verkkosi taas ei toimi, pitää etsiä syyt, miksi verkkosi ei toimisi uusimman _virallisen kernel-version_ kanssa.
Valinta on sinun: itke sitä, ettei jokin muistikortti toimi vanhan kernel-version kanssa, tai korjaa verkkoasennuksesi nykyisessä, turvallisessa kernel-versiossa. Suosittelen jälkimmäistä vaihtoehtoa.
Apujakin verkkoyhteyksien kanssa saat, kertomalla kunnolla tarvittavat perustiedot, joilla verkkosi toimii.

En osaa muuta sanoa kuin, että minulla on langaton verkko kotona ja noilla vanhemmillä kerneleillä ei ole ongelmaa verkon käytössä. DHCP hakee osoitteet ja sitten mennään. Uusi kernel antaa tuon ilmoituksen, josta en ymmärrä mitään.

Koodia: [Valitse]
SIOCGIFFLAGS error: No such device

eli siis usb-tikku toimii uudella kernelillä?

jos ongelma on wlan niin sitten varmaan pitäis vähän saada infoa siitä sinun käyttämästä wlan sovittimesta...

miksi ylipäätään olet käyttänyt noita vanhoja kerneleitä?
« Viimeksi muokattu: 24.02.08 - klo:21.52 kirjoittanut Anssi »

JussiS

  • Käyttäjä
  • Viestejä: 682
    • Profiili
Vs: USB -tikku ei toimi
« Vastaus #16 : 24.02.08 - klo:23.38 »
Moi,

eli siis usb-tikku toimii uudella kernelillä?
jos ongelma on wlan niin sitten varmaan pitäis vähän saada infoa siitä sinun käyttämästä wlan sovittimesta...
miksi ylipäätään olet käyttänyt noita vanhoja kerneleitä?

Syy vanhan kernelin käyttöön on kerrottu täällä: http://forum.ubuntu-fi.org/index.php?topic=13055.msg94814#msg94814

Pöytäkoneessa uudet kernelit eivät toimi lainkaan. Tässä kannettavassa osittain. Kun katson connection propeties ja sieltä configure, niin tulee viestiä:

Koodia: [Valitse]
The interface does not exist. Check that it is correctly typed and that it is correctly supported by your system.
Mitäs noista wlan jutuista pitäisi kertoa?

JusSi
Ubuntu 22.04.1 LTS (XPS 13, DELL), Ubuntu Mate 22.04.1 LTS, Linux Mint 20.3.