Kirjoittaja Aihe: VPN-tunneli Helsingin Yliopiston verkkoon  (Luettu 83680 kertaa)

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #20 : 11.06.08 - klo:17.26 »
Osaako joku sanoa mikä täällä mättää: http://mureakuha.com/paste/?0b6fb24e7541c8dfb369d32b10b8adc5

Eli yhteys ilmeisesti aukeaa mutta web ei pelaa..


r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #21 : 09.10.08 - klo:10.05 »
Osaakos joku ratkoa tällaisia:
a) vpn sanoo [ok] mutta bitti ei liiku sen jälkeen lainkaan, mihinkään
b) mokkulalla (eri kone jne) sanoo myös [ok] ja bitti muualle liikkuu ok mutta yliopiston suuntaan ei tunnu olevan muutosta..


r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #22 : 17.12.08 - klo:13.47 »
a) vpn sanoo [ok] mutta bitti ei liiku sen jälkeen lainkaan, mihinkään

Hei
Mulla on ollut tämä ongelma aina, kun olen kokeillyt yhdistää vpn:llä yliopiston verkkoon. Aluksi näin oli myös OS X:ssä, kunnes tajusin lisätä yliopiston dns-osoitteen verkkoasetuksiin. Joten on mahdollista, että kyseessä on Linuxissakin dns-ongelma.

Linuxilla en voi pingata esim. osoitteeseen www.google.fi vpn:n ollessa päällä, mutta kun pingaan suoraan ip-osoitteella, saan vastauksen connection refused (tai jotakin vastaavaa en muista tarkkaan). Tämä viittaisi käsittääkseni siihen, että vpn:n toimiessa verkkoon voi yhdistää, koska yhteys palvelimeen on olemassa, sitä vain ei sallita. En ole keksinyt, miten tuo dns-ongelma selvitettäisiin linuxissa... Pitäis varmaan lukea se **** manuaali...

Terv. Jussi M.
« Viimeksi muokattu: 18.02.09 - klo:17.42 kirjoittanut verneri »

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
a) vpn sanoo [ok] mutta bitti ei liiku sen jälkeen lainkaan, mihinkään

Hei
Mulla on ollut tämä ongelma aina, kun olen kokeillyt yhdistää vpn:llä yliopiston verkkoon. Aluksi näin oli myös OS X:ssä, kunnes tajusin lisätä yliopiston dns-osoitteen verkkoasetuksiin. Joten on mahdollista, että kyseessä on Linuxissakin dns-ongelma. ---

Nyt tämä vihdoin ratkesi. Asensin kannettavaan Ubuntu 8.10 ja sitten aptitudella openvpn, sekä hain tarvittavat tiedostot yliopiston ohjelmistojakelusta. Yliopiston HUPNETissä netin selaaminen toimi (mitä nyt openvpn piti käynnistää uudestaan, jos sitä ei ollut pitkään aikaan käyttänyt). Kotona reitittimen takana ja Welhon laajakaistassa ongelmat jatkuivat, mutta onneksi tämä oli kohtalaisen helppo ratkaista: Kirjoitin tiedostoon /etc/resolv.conf olemassa olevien nimipalvelinrivien jälkeen tekstin 'nameserver' ja sen jälkeen yliopiston dns-palvelimen IP-osoitteen, joka on 128.214.4.64. Nyt verkko toimii oikein ja Netmottiin ja FinnElibin artikkeleihin pääsee. Katsotaan, kirjoittuuko resolv.conf bootatessa yli...

Koodia: [Valitse]
nameserver 128.214.4.64
PS. Joo... /etc/resolv.conf kirjoittuu yli bootissa, melkein arvasin. MItenkähän ton dns-palvelimen lisäämisen saisi automatisoitua?

« Viimeksi muokattu: 18.02.09 - klo:17.57 kirjoittanut verneri »

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #24 : 19.02.09 - klo:14.46 »
Kiitos vinkeistä, testataanpas mitä tapahtuu..

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

AlbertRetro

  • Käyttäjä
  • Viestejä: 1084
  • Puun uudelleenistutus auttaa usein... <resetointi>
    • Profiili
a) vpn sanoo [ok] mutta bitti ei liiku sen jälkeen lainkaan, mihinkään
Hei
Mulla on ollut tämä ongelma aina, kun olen kokeillyt yhdistää vpn:llä yliopiston verkkoon. Aluksi näin oli myös OS X:ssä, kunnes tajusin lisätä yliopiston dns-osoitteen verkkoasetuksiin. Joten on mahdollista, että kyseessä on Linuxissakin dns-ongelma. ---
Nyt tämä vihdoin ratkesi. Asensin kannettavaan Ubuntu 8.10 ja sitten aptitudella openvpn, sekä hain tarvittavat tiedostot yliopiston ohjelmistojakelusta. Yliopiston HUPNETissä netin selaaminen toimi (mitä nyt openvpn piti käynnistää uudestaan, jos sitä ei ollut pitkään aikaan käyttänyt). Kotona reitittimen takana ja Welhon laajakaistassa ongelmat jatkuivat, mutta onneksi tämä oli kohtalaisen helppo ratkaista: Kirjoitin tiedostoon /etc/resolv.conf olemassa olevien nimipalvelinrivien jälkeen tekstin 'nameserver' ja sen jälkeen yliopiston dns-palvelimen IP-osoitteen, joka on 128.214.4.64. Nyt verkko toimii oikein ja Netmottiin ja FinnElibin artikkeleihin pääsee. Katsotaan, kirjoittuuko resolv.conf bootatessa yli...
Koodia: [Valitse]
nameserver 128.214.4.64PS. Joo... /etc/resolv.conf kirjoittuu yli bootissa, melkein arvasin. MItenkähän ton dns-palvelimen lisäämisen saisi automatisoitua?

Kirjoitin tuon resolv kokeeksi Synapticin hakuun ja tulos oli liian hyvä.
Sitten on vielä se ohjelman pätkä resolvconf, saisiko sillä jotain aikaan...

Terveisin Alpertti
    "...minä mikään viisas ole, tahdon elää vain kuin ihminen..."   http://forum.ubuntu-fi.org/index.php?topic=22423.new#new  counter.li.org #417588

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #26 : 19.02.09 - klo:15.17 »
Tuosta DNS:stä: näyttääpi löytyvän myös moinen kuin /etc/openvpn/update-resolf-conf

Luulen että se suoritetaan openvpn-yhteyden auetessa ja sinne voi konffata ne halutut dns:t käyttöön.
eli mahdollisesti lisäämällä alkupuolelle rivi

foreign_option_1='dhcp-option DNS 128.214.4.64'


ja sitten tuonne openvpn.confiin tällaiset:
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

Pystyykö joku (verneri?) testaamaan tekeekö tämä sen mitä pitäisi?

Hassua tosin, itse olen saanut aina pelaamaan ilman mitään dns-kikkailuja..
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #27 : 20.02.09 - klo:02.09 »
foreign_option_1='dhcp-option DNS 128.214.4.64'


ja sitten tuonne openvpn.confiin tällaiset:
up /etc/openvpn/update-resolv-conf
down /etc/openvpn/update-resolv-conf

Pystyykö joku (verneri?) testaamaan tekeekö tämä sen mitä pitäisi?

Hei

Nyt toimii. Tein kuten neuvoit, homma ei onnistunut ensin. Löysin kuitenkin apt-cache:lla paketin nimeltä resolvconf, jonka asentamisen jälkeen verkkoyhteydet alkoivat toimia. Nyt en jaksa perehtyä asiaan enempää. Pääasia, että toimii.


Koodia: [Valitse]
sudo apt-get install resolvconf
Kiitos ja hyvää yötä.

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #28 : 20.02.09 - klo:10.42 »
Sain täällä pelaamaan seuraavalla tavalla (lisään tuonne alkupään ohjeisiin)

Koodia: [Valitse]
sudo echo "up /etc/openvpn/update-resolv-conf">>/etc/openvpn/openvpn.conf
sudo echo "down /etc/openvpn/update-resolv-conf">>/etc/openvpn/openvpn.conf
lisää tiedoston /etc/openvpn/update-resolf-conf alkuun rivi
Koodia: [Valitse]
foreign_option_1='dhcp-option DNS 128.214.4.64'
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #29 : 20.02.09 - klo:11.49 »
Sain täällä pelaamaan seuraavalla tavalla (lisään tuonne alkupään ohjeisiin)

Koodia: [Valitse]
sudo echo "up /etc/openvpn/update-resolv-conf">>/etc/openvpn/openvpn.conf
sudo echo "down /etc/openvpn/update-resolv-conf">>/etc/openvpn/openvpn.conf
lisää tiedoston /etc/openvpn/update-resolf-conf alkuun rivi
Koodia: [Valitse]
foreign_option_1='dhcp-option DNS 128.214.4.64'


Terve Risto Hoo ja kiitos avusta.


Selvennykseksi vielä, mitä olen tehnyt, sekä mikä toimii ja mikä ei:

Kirjoitin ehdottamasi rivit update-resolv-conf-tiedostoon ja openvpn.confiin. Näiden lisääminen pelkästään ei auttanut siinä, että verkko olisi lähtenyt toimimaan. Pelkästään nämä rivit kirjoittamalla resolv.conf ei muokkautunut halutunlaiseksi openvpn:ää käynnistettäessä. Vasta, kun olin asentanut resolvconf-nimisen paketin ja sen jälkeen käynnistin openvpn:n, /etc/resolv.conf-tiedostoon ilmestyivät rivit 'domain helsinki.fi' ja ''nameserver 128.214.4.64". Tämän jälkeen netti toimi. Ja tämä ratkaisu toimii siis Ubuntu 8.10:ssä (ja mahdollisesti 8.04:ssä - en ole kokeillut), mutta Ubuntu 7.10 ei toimi tälläkään ratkaisulla HY-VPN:n kanssa. Viikonloppuna aion päivittää 8.10:een myös pöytäkoneeni, joten ongelma poistunee sitten!

Mitenkähän tämän ratkaisun saisi lisätyksi yliopiston ohjesivuille? Se voisi helpottaa monen ihmisen elämää, jotka eivät ole lukeneet tätä ketjua.

[EDIT]Kas. Tuollahan Alpertti olikin yllä jo maininnut tuon resonfconfin... Ja nyt sitten vasta tajusin, pahus.[/EDIT]
« Viimeksi muokattu: 20.02.09 - klo:11.52 kirjoittanut verneri »

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #30 : 20.02.09 - klo:12.08 »
Verneri: ok, lisään tuon resolfconf - paketin ohjeisiin.

Alunperin yliopiston sivuilla oli vain redhat -ohjeet tms, lähetin heille väsäämäni Ubuntu-ohjeet. Ehkä voisi tehdä tänne Ubuntu-wikiin wikisivun aiheesta (käyttäjiä on kuitenkin jopa enemmän kuin jollain supercustom-kaukosäätimellä tms :) ja lähettää sinne tiedon että linkkaavat meidän wikiin..

Eli verneri: viitsisitkö kirjoitella ubuntu-fi -wikiin aiheesta oppaan? Vaatii oman kirjautumisen/rekjisteröitymisen, kts http://forum.ubuntu-fi.org/index.php?topic=46.msg151#msg151


r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #31 : 20.02.09 - klo:12.38 »

--
Eli verneri: viitsisitkö kirjoitella ubuntu-fi -wikiin aiheesta oppaan? Vaatii oman kirjautumisen/rekjisteröitymisen, kts http://forum.ubuntu-fi.org/index.php?topic=46.msg151#msg151


Joo, pitääpä kirjoitella...

vpv

  • Käyttäjä
  • Viestejä: 185
  • 3 * Fedora + OpenWRT
    • Profiili
    • Fedora-sivuni
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #32 : 21.04.09 - klo:21.29 »
Onko kukaan onnistunut saamaan OpenVPN-yhteyttä HY:lle toimimaan NetworkManagerin kanssa? Itselläni on Fedora käytössä ja sikäli tämä ei tietysti tavallaan kuulu edes tänne, mutta kysynpähän, kun tämä keskustelu tulee Googlellakin usein esiin jos sopivasti hakee.

Fedorassahan yhteys sinänsä toimii helposti, asennetaan paketti openvpn, ladataan sertifikaatti ja konffitiedosto hakemistoon /etc/openvpn ja komennetaan service openvpn start.

NetworkManagerin VPN-pluginilla yhteyttä ei kuitenkaan synny, olisi tavallaan kätevämpi, jos sen saisi toimimaan siitä.

Olen kokeillut seuraavia asetuksia:

Yhdyskäytävä: open.vpn.helsinki.fi
Tyyppi: Salasana
CA-varmenne: liteca.crt

Sitten lisäasetuksista "Käytä LZO-pakkausta" ja "Käytä TAP-laitetta", koska tuon yliopiston jakeleman konffitiedoston perusteella ajattelin, että ovat tarpeelliset. Ei toimi, ovatpa valittuna tai eivät.

Fedoran /var/log/messagesiin tulee tällaista:

Koodia: [Valitse]
Apr 21 21:11:26 localhost NetworkManager: <info>  Starting VPN service 'org.freedesktop.NetworkManager.openvpn'...
Apr 21 21:11:26 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 6100
Apr 21 21:11:26 localhost NetworkManager: <WARN>  vpn_service_watch_cb(): VPN service 'org.freedesktop.NetworkManager.openvpn' exited with error: 1
Apr 21 21:11:26 localhost NetworkManager: <info>  Policy set 'System eth0' (eth0) as default for routing and DNS.
Apr 21 21:11:32 localhost NetworkManager: <info>  VPN service 'org.freedesktop.NetworkManager.openvpn' did not start in time, cancelling connections

Onko kukaan kokeillut (uudehkolla) Ubuntulla, toimisiko?

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #33 : 22.08.09 - klo:12.38 »
Tuntuu että keskimäärin ihmisillä on aika paljon ongelmia tän kanssa: vaikka yhteys muodostuu ja IP tulee ja kaikki niin ei vaan data liiku. En tiedä missä vika, clientissa, ISP:ssä vai yliopistolla mut jotenkin mutu on että yli puolella homma EI toimi. Saa vinkkailla jos on ideoita..

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #34 : 03.09.09 - klo:14.29 »
Löysin VPN-yhteydestä taas yhden ongelman ja ratkaisun... Olen noin puoli vuotta käyttänyt Debian Lennyä, ja VPN-yhteyttä pystyttäessäni törmäsin taas vanhaan ongelmaan: "yhteys muodostuu, mutta bitti ei liiku". Mikään tässä ketjussa annetuista ohjeista ei auttanut, mutta törmäsin Googlatessani Debiannin bugiraporttiin #494998. Tuon http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494998 linkin takaa löysin siis ratkaisun ongelmaan: koska Debianissa openvpn on käännetty tietoturvan kannalta hyvin tiukoilla asetuksilla, update-resolv-conf ei saa muokata resolv.conf tiedostoa (tai siis sitä tiedostoa, johon tuo on linkitetty). Ongelman voi kiertää lisäämällä openvpn.conf tiedostoon seuraavan rivin:

Koodia: [Valitse]
script-security 2
Tämä saattaa siis toimia Ubuntussakin. En tosin tiedä, onko tuo raportissa mainittu "script-security parameter" käytössä Ubuntussa. Kannattaa katsoa, ilmestyykö yhteyden muodostamisen jälkeen resolv.confiin yliopiston nimipalvelinmen osoite. Jos ei, tätä ratkaisua voisi kokeilla.

Noihin bugiraportissa oleviin virheilmoituksiin en kylläkään törmännyt missään vaiheessa, mutta joka tapauksessa tämä muokkaus ratkaisi mun ongelmani.

Terv. Jussi M.
« Viimeksi muokattu: 03.09.09 - klo:14.39 kirjoittanut verneri »

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #35 : 03.09.09 - klo:15.20 »
Hienoa, Kiitos verneri!

Pystyisikö joku ongelmatapaus tätä kokeilemaan?

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

verneri

  • Käyttäjä
  • Viestejä: 10
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #36 : 25.11.09 - klo:15.32 »
Terve

Kokeilin aikaisempaa ehdottamaani korjausta suht modifioimattomalla Karmic UNR-asennuksella:



Löysin VPN-yhteydestä taas yhden ongelman ja ratkaisun... Olen noin puoli vuotta käyttänyt Debian Lennyä, ja VPN-yhteyttä pystyttäessäni törmäsin taas vanhaan ongelmaan: "yhteys muodostuu, mutta bitti ei liiku". Mikään tässä ketjussa annetuista ohjeista ei auttanut, mutta törmäsin Googlatessani Debiannin bugiraporttiin #494998. Tuon http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=494998 linkin takaa löysin siis ratkaisun ongelmaan: koska Debianissa openvpn on käännetty tietoturvan kannalta hyvin tiukoilla asetuksilla, update-resolv-conf ei saa muokata resolv.conf tiedostoa (tai siis sitä tiedostoa, johon tuo on linkitetty). Ongelman voi kiertää lisäämällä openvpn.conf tiedostoon seuraavan rivin:


Koodia: [Valitse]
script-security 2
Tämä saattaa siis toimia Ubuntussakin. En tosin tiedä, onko tuo raportissa mainittu "script-security parameter" käytössä Ubuntussa. Kannattaa katsoa, ilmestyykö yhteyden muodostamisen jälkeen resolv.confiin yliopiston nimipalvelinmen osoite. Jos ei, tätä ratkaisua voisi kokeilla.

Koskemattomassa Karmicissa hy-vpn näyttäisi toimivan ilman tuota script-seurity-riviäkin, joten ehkä tää nyt sitten keskimäärin toimii Ubuntu-ihmisillä - toivottavasti ainakin.

simohell

  • Käyttäjä
  • Viestejä: 87
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #37 : 23.03.10 - klo:13.16 »
Onko kenelläkään kokemusta Untuntu 9.10 + Firehol käyttämisestä?

Aikaisemmin minulla toimi VPN, mutta nykyään tökkii joku mikä liittyy palomuuriin. Kun palomuurin kytkee pois, vpn toimii ok, mutta kun se on päällä, bitit ei liiku koneelta ulospäin. Pitäisi varmaankin saada jotain portteja auki...  (Firehol on käyttöliittymä iptablesiin)
« Viimeksi muokattu: 23.03.10 - klo:14.52 kirjoittanut simohell »
"Freedom fighters, speak with your tongues,
sing with the might of the wind in your lungs!"
--Donovan Leitch

Tha-Fox

  • Käyttäjä
  • Viestejä: 3315
  • Arch Linux && CentOS
    • Profiili
    • http://kettu.dy.fi
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #38 : 23.03.10 - klo:13.30 »
simohell, tekstisi ei näy. Katso tästä ohjeita tuohon asetuksen vaihtamiseen.

simohell

  • Käyttäjä
  • Viestejä: 87
    • Profiili
Vs: VPN-tunneli Helsingin Yliopiston verkkoon
« Vastaus #39 : 23.03.10 - klo:14.52 »
simohell, tekstisi ei näy. Katso tästä ohjeita tuohon asetuksen vaihtamiseen.

Ok. Kiitos. Vaihdettu, ja edellinen viesti muutettu.
"Freedom fighters, speak with your tongues,
sing with the might of the wind in your lungs!"
--Donovan Leitch