Kirjoittaja Aihe: "Failed to start the X Server..." asennuksessa  (Luettu 3816 kertaa)

Tampio

  • Käyttäjä
  • Viestejä: 3
    • Profiili
"Failed to start the X Server..." asennuksessa
« : 17.10.06 - klo:22.04 »
Pistin Ubuntun levyn asemaan ja ruutuun ilmestyi valikko, jossa luki "Start Ubuntu" "Start Ubuntu in safe graphics mode" jne..  Siitä kun valitsen "Start Ubuntu" niin kone raksuttaa jonkun aikaa ja sitten tulee ilmoitus "Failed to start the X Server (your graphical interface). It is likely  that it is not set up correctly. Would you like to view the X server output to diagnose the problem?" Siihen kun vastaan yes tulee tällainen ilmoitus: "
"X Window System Version 7.0.0
Release Date: 21 Dec. 2005
X Protocol Version 11, Revision 0, Release 7.0
Build operating system: Linux 2.6.15.7 x86_64
Current operating system: Linux ubuntu 2.6.15-26-amd64-generic #1 SMP
PREEMPT Thu Aug 3 02:52:35 UTC 2006 x86_64
Build date: 16 March 2006

Module loader present
Markers: (--) probed, (**) from config file, (==) default setting, (++)
  from command line, (!!) notice, (II) informational, (ww) warning,  (EE)
error, (NI) not implemented, (??) unknown, (==) unknown file:
"/var/log/xorg.0.log", Time: Tue, Oct 17 11:30:10 2006
(==) Using config file: "ext/X11/xorg.config"

Siitä sitten ok ja tulee: "Would you like to view detailed X server output as well?"
Tuohon yes ja tulee taas ylhäällä olevan kaltainen pätkä tekstiä ja sitten "The X server is now disabled. Restart GDM when it is configured correctly"


Jos äskeisen sijaan valitsen alussa sen "Start Ubuntu in safe graphics mode" niin kone raksuttaa taas jonkun aikaa ja sitten näyttö sammuu ja täytyy painaa resettiä.

Oletan että näyttikseen tämä jotenkin liittyy, joka on Radeon x800gto. Mitenkäs sitä Ubuntua sitten oikeen pääsis asentelemaan? Kertokaa sitten juurta jaksain kun en ole ikinä Linuxiin koskenut.

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #1 : 17.10.06 - klo:22.13 »
Itselläni on ollut samantapaisia ongelmia, niistä päästiin jotenkuten näin:

Paina Ctrl+Alt+F1 -> pääset komentoriville

Tapa viallinen graafinen tila kirjoittamalla:
Koodia: [Valitse]
sudo killall gdm
Konfiguroi X oikein:
Koodia: [Valitse]
sudo dpkg-reconfigure xserver-xorgValitse ajuriksi "Vesa", se toimii minulla, mutta aiheuttaa lagia. Kiintolevyasennuksen jälkeen voi laittaa kunnon ajurit, että alkaa toimimaan täydellisesti. Mene default-asetuksilla muuten, paitsi valitse resoluutio-kohdasta haluamasi välilyönnillä. Kun tulee 3:n kohdan valinta, valitse Simple, ja arvio näyttösi koko.

Sen jälkeen kun olet päässyt takaisin, kirjoita:
Koodia: [Valitse]
sudo /etc/init.d/gdm start
Ja jos ei tule niin, paina vielä Ctrl+Alt+F7.

Jotenkin näin sain sen toimimaan.

zeitkugel

  • Käyttäjä
  • Viestejä: 1
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #2 : 18.10.06 - klo:10.07 »
Samantyyppistä vikaa täälläkin. Koetan siis saada uusimmalta livelevyltä käyntiin Ubuntua  ->En millään saa xserveriä käyntiin. Näyttiksenä on myöskin x800. Safe graphics mode ei käynnisty mihinkään, joten olen koettanyt käynnistellä sitä ylempää versiota. Xserverin virheilmoituksen pidemmässä versiossa lukee lopussa "no screens found" Olen koettanut
Koodia: [Valitse]
sudo dpkg-reconfigure xserver-xorguseampaan kertaan, mutta aina x;ää restartatessa ilmoittaa että Gnomen käynnistyksessä [fail]
Olen koettanut kikkailla X;n konffauksessa vesaa ja atia, muuten olen mennyt defaulteilla.
Olisikos jotain idioottivarmaa kikkaa saada Ubuntua käyntiin. Olen aika noobio linuxin kanssa, mutta nyt olisi tarkoitus asentaa U winkkarin rinnalle ja alkaa perehtyä lähemminkin linuxiin. Ultimate goal olisi jättää winkkari vain pelikäyttöön.  ;)

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #3 : 18.10.06 - klo:21.28 »
Oletteko kokeilleet 
tappaa GDM:n ( 'sudo killall gdm' tai 'sudo /etc/init.d/gdm stop' ),
sitten konffata X-serverin (sudo dpkg-reconfigure xserver-xorg),
ja käynnistää gdm:n uudelleen ( sudo /etc/init.d/gdm start )?

Akru

  • Käyttäjä
  • Viestejä: 41
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #4 : 19.10.06 - klo:12.37 »
Muistaakseni tuo vika korjaantuu laittamalla xorg.conf tiedostoon driver kohtaan, jossa lukee "ati" niin muutat siihen "radeon" kaverilla sama näyttis ja sama ongelma oli.

Tampio

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #5 : 20.10.06 - klo:07.19 »
Koitin configuroida sitä X-serveriä uudestaan ja laitoin ajuriksi Vesan mutta ei auttanut. Näyttö pimeni niin kuin safe graphics modea käytettäessä. Mutta kun laitoin xorg.confissa sen "ati":n tilalle "radeon" niin johan toimi. Sitten kun kerkiän asentelemaan niin tulen kysymään lisää siinä ilmenevistä ongelmista.

Tampio

  • Käyttäjä
  • Viestejä: 3
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #6 : 20.10.06 - klo:20.30 »
Noniin. Nyt on Ubuntut asennettu. Nyt sitten tuli sellainen ongelma ettei netti toimi. Mitä nyt näitä foorumeita etsiskelin niin ongelman taitaa aiheuttaa tämä sisäinen ADSL-modeemi, TW IA-300C. Onko se nyt sitten niin, että sillä voi suosiolla heittää sorsaa ja käy ostamassa ulkoisen ADSL-modeemin? Sitten täytyy ostaa myös verkkokortti, onko jotain tiettyjä mitä kannattaisi välttää Linuxia silmällä pitäen?
« Viimeksi muokattu: 20.10.06 - klo:20.33 kirjoittanut Tampio »

Regel

  • Käyttäjä
  • Viestejä: 1090
  • Lucid
    • Profiili
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #7 : 20.10.06 - klo:20.37 »
Näyttäisi tuolle olevan joitain Linux-ajureita, mutta lähinnä Mandrakelle, Suselle ja Redhatille. Voithan kuitenkin koettaa.

juyli

  • Vieras
Re: "Failed to start the X Server..." asennuksessa
« Vastaus #8 : 22.10.06 - klo:23.36 »
Oletan että näyttikseen tämä jotenkin liittyy, joka on Radeon x800gto. Mitenkäs sitä Ubuntua sitten oikeen pääsis asentelemaan?

Koodia: [Valitse]
sudo dpkg-reconfigure xserver-xorg

Tuo komentorimpsu on ohjelma X:n configurointiin. Jos toimivaa ajuria ei löydy, täytyy tutustua tarkemmin laitevalmistajan sivuihin. Vesa-ajurin pitäisi toimia kaikilla perus-vga yhteensopivilla näyttökorteilla.
Tuo näytönohjaimesi on uusinta uutta, joten ihan helposti edes laitevalmistajan sivuilta ei sille löydy
ajuria. Jokin beta-ajuri saattaa Ati:lta löytyä.

Juckiz

  • Käyttäjä
  • Viestejä: 15
    • Profiili
Vs: "Failed to start the X Server..." asennuksessa
« Vastaus #9 : 03.09.07 - klo:17.41 »
Nostetaan vanha treadi ylös kun en viitsi tämän takia aloittaa uutta...

Minulla tuli ongelmia kun päivitin Ubuntun automaattisilla päivityksillä.

Eli sain puukotettua xorg.confin (ilmeisesti) kuntoon täältä löytyvillä ohjeilla ja pääsin graafiseen tilaan. Kiitos siitä!

Mutta nyt pitäisi saada Nvidian ajurit kuntoon. Nvidia Settings sanoo seuraavaa:

"You do not appear to be using the NVIDIA X driver.
Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server."

Eli mitähän tuo tarkoittaa? Voinko vain Envyllä imuttaa ajurit uusiksi?

Feisty
Asus A8N-SLI SE
Club 3D 8600GTS

juyli

  • Vieras
Vs: "Failed to start the X Server..." asennuksessa
« Vastaus #10 : 03.09.07 - klo:18.38 »
Nostetaan vanha treadi ylös kun en viitsi tämän takia aloittaa uutta...
Yli vuoden vanhoihin viesteihin ei kannata perustaa vaan aloittaa aihe uudelleen. Jakeluversiot ovat muuttuneet jo monasti.
Ubuntu-tutuksi Wiki on asiaa: http://fi.wikibooks.org/wiki/Ubuntu_tutuksi
Minulla tuli ongelmia kun päivitin Ubuntun automaattisilla päivityksillä.
Nvidian poropietariajurit riippuvat kovasti kernel-versiosta (kernel-headers), joka koneelta löytyy. Lähtökohta on se, että poropietariajurit pitää asentaa uudelleen kernel-version vaihtuessa. Joskus kernel-versio päivittyy ennenkuin ko. kernel-versioon soveltuvat nvidian ajurit.
Joskus pitää käyttää vanhempaa kerneliä, jotta ajurit toimivat.

Juckiz

  • Käyttäjä
  • Viestejä: 15
    • Profiili
Vs: "Failed to start the X Server..." asennuksessa
« Vastaus #11 : 03.09.07 - klo:18.46 »
Niin eli olin asentanut toimivat ajurit näyttikselle ja kaikki pelitti (esim. Beryl)  ennenkuin päivitin ubuntua.
Nyt vaan haen parasta tapaa saada Nvidian ajurit uudelleen käyttöön.