Kirjoittaja Aihe: Päivitysongelma 20.04 - > 22.04 [Ratkaistu]  (Luettu 2922 kertaa)

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Päivitysongelma 20.04 - > 22.04 [Ratkaistu]
« : 27.10.23 - klo:11.24 »
Yrittäessäni päivittää Ubuntu 20.04 LTS -> 22.04 LTS, niin päivitys ei onnistu ja tulee ilmoitus:

Päivitettäessä tapahtui virhe. Tämä on yleensä jonkinlainen verkko-ongelma. Tarkista verkkoyhteytesi toiminta ja yritä uudelleen.

W:Updating from such a repository can´t be done securely, and is therefore disabled by default., W: See apt-secure(8) manpage for repository creation and user configuration details., W:GPG error: https://updates.signal.org/desktop/apt xenial InRelease: seuraavia allekirjoituksia ei voinut varmentaa koska julkista avainta ei ole saatavilla: NO_PUBKEY D980A17457F06:The repository
´https://updates.signal.org/desktop/apt xenial InRelease´ is not signed.

Voiko asialle tehdä mitään?

Pöytäkoneessani, josta on kysymys, on asennettuna puhdas asennus 22.04 LTS, mutta kaikki omat tiedostot ja asennetut lisäohjelmat ovat 20.04 LTS:ssä ja siksi yritin päivittää tuon viimemainitun uudempaan versioon. Olisi aika työlästä asentaa kaikki lisäohjelmat uudelleen. Asetukset kaiketi säilyisivät lisäohjelmien osalta eriilisessä HOME -osiossa, jos sen voisi liittää tuohon jo asennettuun puhtaaseen 22.04 LTS:ään.
« Viimeksi muokattu: 29.10.23 - klo:18.33 kirjoittanut ubutumpula »

kamara

  • Käyttäjä
  • Viestejä: 2951
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #1 : 27.10.23 - klo:13.16 »
Voi...

... poista signal:n ohjelmistolähde ennen uuden version päivitystä.

Sen voinee tehdä synaptic-ohjelmalla.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #2 : 27.10.23 - klo:13.39 »
Suoraan Signal -ohjelmistolähdettä ei löydy, mutta se lienee liittyy johonkin muuhun lähteeseen, mutta mihin?

epiphone

  • Käyttäjä
  • Viestejä: 1067
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #3 : 27.10.23 - klo:13.54 »
Suoraan Signal -ohjelmistolähdettä ei löydy, mutta se lienee liittyy johonkin muuhun lähteeseen, mutta mihin?
Mitä palauttaa seuraava komento?

Koodia: [Valitse]
cat /etc/apt/sources.list
« Viimeksi muokattu: 27.10.23 - klo:13.56 kirjoittanut epiphone »
Kahvi on väkevin juomani

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #4 : 27.10.23 - klo:14.12 »
Tällaista antoi cat /etc/apt/sources.list

# deb cdrom:[Ubuntu 20.04 LTS (Finnish Remix) _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ focal main restricted
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates main restricted
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ focal universe
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic universe
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates universe
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fi.archive.ubuntu.com/ubuntu/ focal multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://fi.archive.ubuntu.com/ubuntu/ focal-updates multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fi.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse
# deb-src http://fi.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://security.ubuntu.com/ubuntu focal-security main restricted
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://security.ubuntu.com/ubuntu focal-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://security.ubuntu.com/ubuntu focal-security multiverse
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb https://dl.winehq.org/wine-builds/ubuntu/ focal main # otettu pois käytöstä päivitettäessä versioon focal
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main
# deb https://dl.winehq.org/wine-builds/ubuntu/ cosmic main # otettu pois käytöstä päivitettäessä versioon focal
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ cosmic main
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ bionic main

epiphone

  • Käyttäjä
  • Viestejä: 1067
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #5 : 27.10.23 - klo:15.16 »
Entäs sitten mitä tulostaa seuraava komento?

Koodia: [Valitse]
ls /etc/apt/sources.list.d
« Viimeksi muokattu: 27.10.23 - klo:15.17 kirjoittanut epiphone »
Kahvi on väkevin juomani

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #6 : 27.10.23 - klo:16.20 »
Tällaista antoi  ls /etc/apt/sources.list.d

Ubuntu@20.04 LTS:~$ ls /etc/apt/sources.list.d
nilarimogard-ubuntu-webupd8-bionic.list
nilarimogard-ubuntu-webupd8-bionic.list.distUpgrade
signal-xenial.list
signal-xenial.list.distUpgrade
teams.list
teams.list.distUpgrade
teamviewer.list
teamviewer.list.distUpgrade
teamviewer.list.save

epiphone

  • Käyttäjä
  • Viestejä: 1067
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #7 : 27.10.23 - klo:16.24 »
Tällaista antoi  ls /etc/apt/sources.list.d

Ubuntu@20.04 LTS:~$ ls /etc/apt/sources.list.d
nilarimogard-ubuntu-webupd8-bionic.list
nilarimogard-ubuntu-webupd8-bionic.list.distUpgrade
signal-xenial.list
signal-xenial.list.distUpgrade
teams.list
teams.list.distUpgrade
teamviewer.list
teamviewer.list.distUpgrade
teamviewer.list.save
Okei. Tuollahan se signal lähde on. Mutta pitääköhän nuo muutkin lähteet poistaa tuolta/etc/apt/sources.list.d, jotta pystyy päivittämään uudempaan Ubuntuun?
Kahvi on väkevin juomani

AimoE

  • Käyttäjä
  • Viestejä: 2718
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #8 : 27.10.23 - klo:16.38 »
Kun avaa Ohjelmistopäivitykset ja sieltä välilehden "Muut ohjelmistot", niin sieltä voi ruksata pois kaikki lisälähteet. Sitten upgraden jälkeen voi kokeilla palauttaa niitä.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #9 : 27.10.23 - klo:16.41 »
Tällaista antoi  ls /etc/apt/sources.list.d

Ubuntu@20.04 LTS:~$ ls /etc/apt/sources.list.d
nilarimogard-ubuntu-webupd8-bionic.list
nilarimogard-ubuntu-webupd8-bionic.list.distUpgrade
signal-xenial.list
signal-xenial.list.distUpgrade
teams.list
teams.list.distUpgrade
teamviewer.list
teamviewer.list.distUpgrade
teamviewer.list.save
Okei. Tuollahan se signal lähde on. Mutta pitääköhän nuo muutkin lähteet poistaa tuolta/etc/apt/sources.list.d, jotta pystyy päivittämään uudempaan Ubuntuun?

Ainakaan noita signalista eteenpäin olevia en taida tarvita mihinkään.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #10 : 28.10.23 - klo:15.54 »
No niin, sitten on päivitetty 22.04 LTS:ään. Ja koko homma meni kiville, niin kuin ounastelin. Päivitys lähti hyvin alkuun, mutta sitten tuli useita ilmoituksia, että jotain ei voitu tehdä, mutta päivitystä jatketaan. Loppuun meni, mutta ei tavanomaisesti. Kun käynnistin sitten uudelleen, niin meni kernel paniikkiin ja homma tyssäsi siihen. Kuitenkin muista vaihtoehdoista löytyi aiempi kernel, jolla suostui käynnistymään. Jotenkin molemmat kernelit näyttivät vanhoilta, kun vertasin siihen puhtaaseen asennukseen. Eli: 5.4.0-165-generic meni paniikkiin, mutta 5.4.0-163-generic käynnistyi. Suurin piirtein systeemin toimii (kaikkea en ole vielä kokeillut), mutta Firefox ei kännistynyt. Siis todella monen mutkan kautta sain sen vanhan poistettua (kun oli ja ei ollut olemassa) ja asensin uuden sekä varmuuskopiolta kirjanmerkit, niin ainakin näennäisesti toimii.
Infossa sanoo version olevan 22.04  Jammy Jellyfish eli ainakin sen kohdan on päivittänyt. Tuo kernel vain ihmetyttää.

Koska minulla on tuo puhdas asennus, niin mitä kaikkea pitäisi tehdä, että saisin erillisellä osiolla olevan HOME:n sen käyttöön. Käsittääkseni fstab:iin pitää laittaa HOME -osion UUID, mutta pitääkö sitä ennen jotain tehdä asennuksessa jo olevalle HOME -hakemistolle? Tietenkin kaikki lisäohjelmat, joita on muutamia, pitää asentaa uudestaan, mutta asetukset niihin tullenee HOME -osiolta.

nm

  • Käyttäjä
  • Viestejä: 16246
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #11 : 28.10.23 - klo:17.15 »
Ubuntu 22.04:ssä on ilman hwe-päivityksiä kernelin versio 5.15. Hwe-päivityksillä saa version 6.2. Voit kokeilla asentaa sen komennolla:

Koodia: [Valitse]
sudo apt install linux-image-generic-hwe-22.04
Home-osion saat liitettyä toiseen järjestelmään lisäämällä liitoksen /etc/fstab-tiedostoon ja siirtämällä nykyisen /home:n sisällön muualle. Tyhjä /home-kansio saa kuitenkin jäädä paikalleen liitospisteeksi.
Jos vanhassa järjestelmässä on eri käyttäjiä tai tileillä on eri UID tai GID, myös /etc/passwd, /etc/shadow ja /etc/groups -tiedostoja voi joutua editoimaan.
« Viimeksi muokattu: 28.10.23 - klo:17.19 kirjoittanut nm »

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #12 : 28.10.23 - klo:22.58 »
Koitin tuota kernelin asennusta: sudo apt install linux-image-generic-hwe-22.04

Mutta "Käsittely keskeytettiin liian monien virheiden takia."

Luulen ettei tuosta oikein kunnollista tule. Eli täytynee siirtää kamat tuohon puhtaaseen asennukseen.

nm

  • Käyttäjä
  • Viestejä: 16246
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #13 : 29.10.23 - klo:00.07 »
Koitin tuota kernelin asennusta: sudo apt install linux-image-generic-hwe-22.04

Mutta "Käsittely keskeytettiin liian monien virheiden takia."

Luulen ettei tuosta oikein kunnollista tule. Eli täytynee siirtää kamat tuohon puhtaaseen asennukseen.

Voi olla niinkin, tai sitten voi olla kiinni jostain pienemmästä ongelmasta yhdessä paketissa. Pitäisi nähdä koko listaus asennusyrityksestä. Siitä näkisi tarkemmin, mihin ongelmaan dpkg tuossa törmää.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #14 : 29.10.23 - klo:14.49 »
Tässä listaus "Haluatko jatkaa? [K/e]" kysymyksen jälkeen:

(Luetaan tietokantaa... 302030 tiedostoa ja hakemistoa asennettu tällä hetkellä.)
Poistetaan linux-image-5.4.0-165-generic (5.4.0-165.182)...
/etc/kernel/postrm.d/initramfs-tools:
update-initramfs: Deleting /boot/initrd.img-5.4.0-165-generic
/etc/kernel/postrm.d/zz-update-grub:
Sourcing file `/etc/default/grub'
/usr/sbin/grub-mkconfig: 27: /etc/default/grub: x: not found
run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127
dpkg: error processing package linux-image-5.4.0-165-generic (--remove):
 installed linux-image-5.4.0-165-generic package post-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
Käsittelyssä tapahtui liian monta virhettä:
 linux-image-5.4.0-165-generic
Käsittely keskeytettiin liian monien virheiden takia.
E: Sub-process /usr/bin/dpkg returned an error code (1)

Näyttäisi ainakin grub:iin liittyvää ongelmaa olevan. Tuntuu omituiselta että ei löydä /etec/default/grub , vaikka se kyllä näyttäisi siellä olevan.

nm

  • Käyttäjä
  • Viestejä: 16246
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #15 : 29.10.23 - klo:17.23 »
/usr/sbin/grub-mkconfig: 27: /etc/default/grub: x: not found

/etc/default/grub-tiedosto on kyllä olemassa ja grub-mkconfig löytää sen, mutta tiedostossa on syntaksivirhe. Rivillä 27 on nähtävästi x-kirjain väärässä paikassa. Ehkä olet editoinut sitä nanolla ja yrittänyt sulkea editorin, mutta ctrl on jäänyt pois matkasta. Korjaa virhe, niin pääset eteenpäin.

ubutumpula

  • Käyttäjä
  • Viestejä: 107
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04
« Vastaus #16 : 29.10.23 - klo:17.59 »
Siinähän se vika olikin, tosin ei x ollut liikaa, vaan välilyönneistä oli kysymys. On kysymys näytöntarkkuudesta ja siinä oli jäänyt sen kertaa merkin (x) eteen ja taakse välilyönti. Nyt kaiketi järjestelmä toiminee.

Ja nyt on sitten käynnistetty uudelleen ja kerneli on vaihtunut uudempaan: 6.2.0-35-generic. Edelleen kuitenkin ilmoittaa järjestelmäongelmasta. Joskohan tuo ilmoitus häviäisi seuraavan päivityksen myötä.
« Viimeksi muokattu: 29.10.23 - klo:18.26 kirjoittanut ubutumpula »

nm

  • Käyttäjä
  • Viestejä: 16246
    • Profiili
Vs: Päivitysongelma 20.04 - > 22.04 [Ratkaistu]
« Vastaus #17 : 29.10.23 - klo:18.45 »
Varmista vielä, että kaikki muutkin päivitykset ovat asentuneet:

Koodia: [Valitse]
sudo apt update
Koodia: [Valitse]
sudo apt full-upgrade