Kirjoittaja Aihe: KDE neon locale vinoilee. [RATKAISTU]  (Luettu 2175 kertaa)

raimo

  • Käyttäjä
  • Viestejä: 4151
  • openSUSE Tumbleweed
    • Profiili
KDE neon locale vinoilee. [RATKAISTU]
« : 18.10.23 - klo:22.47 »
Moi taas, yhtä ongelmaa.
Koodia: [Valitse]
raimo@kone-3:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_BW.UTF-8
LANGUAGE=en_GB
LC_CTYPE="en_BW.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=en_FI.UTF-8
LC_COLLATE="en_BW.UTF-8"
LC_MONETARY=en_FI.UTF-8
LC_MESSAGES="en_BW.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=
raimo@kone-3:~$

Mistä tuota lähtis kaivelemaan miksi nuo virheet on alussa. Ilmenee jokaisessa päivityksessä ja sanoo pudottautuvansa C localeen tms.

Päivitys:
Koodia: [Valitse]
raimo@kone-3:~$ sudo apt update && sudo apt full-upgrade
Get:1 file:/var/lib/preinstalled-pool jammy InRelease
Ign:1 file:/var/lib/preinstalled-pool jammy InRelease
Get:2 file:/var/lib/preinstalled-pool jammy Release [3949 B]
Get:2 file:/var/lib/preinstalled-pool jammy Release [3949 B]
Hit:4 https://repo.nordvpn.com//deb/nordvpn/debian stable InRelease                       
Get:5 https://dl.google.com/linux/chrome/deb stable InRelease [1825 B]                               
Get:6 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                             
Get:7 https://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1078 B]                     
Get:8 https://packages.microsoft.com/repos/edge stable InRelease [3569 B]                             
Hit:9 https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu jammy InRelease                         
Get:10 http://archive.neon.kde.org/user jammy InRelease [178 kB]               
Get:11 https://packages.microsoft.com/repos/edge stable/main amd64 Packages [8737 B]
Hit:12 http://archive.ubuntu.com/ubuntu jammy InRelease                                               
Get:13 http://security.ubuntu.com/ubuntu jammy-security/main amd64 DEP-11 Metadata [43.1 kB]
Get:14 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [119 kB]
Get:15 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 DEP-11 Metadata [55.0 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [1066 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 DEP-11 Metadata [101 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 c-n-f Metadata [16.0 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [976 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [993 kB]
Get:21 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 DEP-11 Metadata [305 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy-updates/multiverse amd64 DEP-11 Metadata [940 B]
Fetched 3977 kB in 3s (1403 kB/s)                 
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
2 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: file:/var/lib/preinstalled-pool/dists/jammy/Release.gpg: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
Entering ResolveByKeep
Calculating upgrade... Done
The following packages have been kept back:
  irqbalance
The following packages will be upgraded:
  microsoft-edge-stable
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 163 MB of archives.
After this operation, 6490 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 https://packages.microsoft.com/repos/edge stable/main amd64 microsoft-edge-stable amd64 118.0.2088.57-1 [163 MB]
Fetched 163 MB in 22s (7389 kB/s)                                                                     
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB",
        LC_ALL = (unset),
        LC_TIME = "en_FI.UTF-8",
        LC_MONETARY = "en_FI.UTF-8",
        LC_ADDRESS = "fi_FI.UTF-8",
        LC_TELEPHONE = "fi_FI.UTF-8",
        LC_NAME = "fi_FI.UTF-8",
        LC_MEASUREMENT = "fi_FI.UTF-8",
        LC_IDENTIFICATION = "fi_FI.UTF-8",
        LC_NUMERIC = "fi_FI.UTF-8",
        LC_PAPER = "fi_FI.UTF-8",
        LANG = "en_BW.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
(Reading database ... 202785 files and directories currently installed.)
Preparing to unpack .../microsoft-edge-stable_118.0.2088.57-1_amd64.deb ...
Unpacking microsoft-edge-stable (118.0.2088.57-1) over (118.0.2088.46-1) ...
Setting up microsoft-edge-stable (118.0.2088.57-1) ...
Processing triggers for man-db (2.10.2-1) ...
Not building database; man-db/auto-update is not 'true'.
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
raimo@kone-3:~$


Koodia: [Valitse]
raimo@kone-3:~$ cat /etc/locale.conf
LANG=en_US.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_MONETARY=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_NUMERIC=fi_FI.UTF-8
LC_PAPER=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8


Koodia: [Valitse]
raimo@kone-3:~$ cat .config/plasma-localerc
[Formats]
LANG=en_BW.UTF-8
LC_MONETARY=en_FI.UTF-8
LC_TIME=en_FI.UTF-8

[Translations]
LANGUAGE=en_GB
raimo@kone-3:~$
« Viimeksi muokattu: 19.10.23 - klo:16.15 kirjoittanut raimo »
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

raimo

  • Käyttäjä
  • Viestejä: 4151
  • openSUSE Tumbleweed
    • Profiili
Vs: KDE neon locale vinoilee.
« Vastaus #1 : 18.10.23 - klo:23.52 »
Taisin saada kuntoon ihan vaan tällä komennolla:
Koodia: [Valitse]
sudo locale-gen
En merkitse vielä ratkaistuksi, pitää varmistaa että se varmasti toimii.
Arch Wiki näytti jällen kyntensä. :)
https://wiki.archlinux.org/title/Locale

No en saannut:

Koodia: [Valitse]
raimo@kone-3:~$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_BW.UTF-8
LANGUAGE=en_GB
LC_CTYPE="en_BW.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=en_FI.UTF-8
LC_COLLATE="en_BW.UTF-8"
LC_MONETARY=en_FI.UTF-8
LC_MESSAGES="en_BW.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=

En käsitä mistä se kaivaa ton "en_BW.UTF-8" lokalin, se on kuitenkin kommentoituna
/etc/locale.gen -tiedostossa. Outoa! :(

Tuoltahan se Plasman lokaali-asetuksista löytyi, korjasin sitä muutenkin, eihän sellaista edes ole kuin en_FI, pikemminkin fi_FI

Koodia: [Valitse]
raimo@kone-3:~$ cat .config/plasma-localerc
[Formats]
LANG=en_GB.UTF-8
LC_MONETARY=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8

[Translations]
LANGUAGE=en_GB
« Viimeksi muokattu: 19.10.23 - klo:08.08 kirjoittanut raimo »
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

raimo

  • Käyttäjä
  • Viestejä: 4151
  • openSUSE Tumbleweed
    • Profiili
Vs: KDE neon locale vinoilee.
« Vastaus #2 : 19.10.23 - klo:16.13 »
Sain kuntoon, nyt en ole ollenkan varma mikä tämän ratkaisi?
Ainakin se että lisäsin LC_ALL=fi_Fi.UTF-8, se ei tullut näkyviin locale -komennon jälkeen, mutta aukaisi jonkun synkän portin ilmeisesti koska nyt locale menee virheittä ja samoin päivitykset.
Kiva olisi tietää mikä todellinen korjaus oli, mutta RATKAISTU! :)
Koodia: [Valitse]
raimo@kone-3:~$ locale
LANG=en_US.UTF-8
LANGUAGE=en_GB
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=fi_FI.UTF-8
LC_TIME=fi_FI.UTF-8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=fi_FI.UTF-8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER=fi_FI.UTF-8
LC_NAME=fi_FI.UTF-8
LC_ADDRESS=fi_FI.UTF-8
LC_TELEPHONE=fi_FI.UTF-8
LC_MEASUREMENT=fi_FI.UTF-8
LC_IDENTIFICATION=fi_FI.UTF-8
LC_ALL=

Joo minähän ajoin
Koodia: [Valitse]
sudo locale-genkomennon ja sen jälkeen se alkoi toimimaan,
eli asetuksiin oikeat (ei en_FI vaan fi_FI) ja sitten tuo sudo locale-gen.
« Viimeksi muokattu: 19.10.23 - klo:16.29 kirjoittanut raimo »
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski