Kirjoittaja Aihe: Asus läppärin ubuntupäivityksen jäkeen ei käynnisty "eipäs ratkennutkaan"  (Luettu 3942 kertaa)

AimoE

  • Käyttäjä
  • Viestejä: 2725
    • Profiili
Viivästettyjen pakettien luettelo näyttää yhden paketin jonka nimessä on ldap. Sen paketin (version) asentamista en suosittele, eikä suosittele myöskään Canonicalin kuvaus viivästettyjen pakettien ideasta. Postasin molemmat linkit jo aiemmin ketjuun apt-vika, joka rikkoi Jammy-päivitykset ihan koosteeksi siitä mistä ietoa ja neuvoja voisi löytää. Siis en tarkoita, etteikö omia juttuja kannattaisi selvitellä omissa ketjuissaan, kaikin mokomin voi. Ajattelin vain koota tietoa ketjuun, jonka otsikosta näkee mistä on kyse.

karimarkku66

  • Käyttäjä
  • Viestejä: 161
    • Profiili
Jätin omaan arvoonsa nuo, sillä eivät ratkaise miksei langaton netti toimi. Harmikseni en ole kaapelin avulla päässyt testaamaan, sillä piuha kadoksissa, hommaan nyt sen ja jos ei kaapelikaan auta, voo pistää mietintämyssyä päähän.

nm

  • Käyttäjä
  • Viestejä: 16277
    • Profiili
Eli koneessa on jokin jumi, eikä yhdistä yhteenkään langattomaan, verkkoon. Tunnistaa ne haulla ja kolmio syttyy ylänurkassa, ei vaan yhdisty. Jäikö tuossa työpöydän palautuksessa nyt jotain pois.

Voi tosiaan olla että järjestelmästäsi on päivitysongelman yhteydessä poistunut jotain muutakin. Aika vaikea kuitenkin arvata, mitä siellä olisi tapahtunut. Oireiden perusteella liittyy ehkä Network Manageriin tai mahdollisesti nimipalveluun (DNS). Toimiikohan yhteys ilman nimipalvelua, eli pystytkö esimerkiksi pingaamaan osoitetta 8.8.8.8:

Koodia: [Valitse]
ping -c 3 8.8.8.8
Lainaus
Koodia: [Valitse]
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=115 time=1.08 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=115 time=0.296 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=115 time=0.316 ms

karimarkku66

  • Käyttäjä
  • Viestejä: 161
    • Profiili
Ping antaa vastaavan rimpsun, kuin mitä laitoit. Ja kone tunnistaa kaikki ympärillä olevat verkot ongelmitta, kysyy uuteen vefkkoon salasanan ja yhdistää, jolloin verkkokuvake syttyy. Mutta siihen se jää. Edit, sain kokeiltua nyös kaapelin kautta yhteyttä, mutta sekään ei auta. Päätteellä koetin network manageria käynnistää, mutta se herjaa ettei sitä löydy.
« Viimeksi muokattu: 14.08.23 - klo:10.12 kirjoittanut karimarkku66 »

nm

  • Käyttäjä
  • Viestejä: 16277
    • Profiili
Ping antaa vastaavan rimpsun, kuin mitä laitoit. Ja kone tunnistaa kaikki ympärillä olevat verkot ongelmitta, kysyy uuteen vefkkoon salasanan ja yhdistää, jolloin verkkokuvake syttyy. Mutta siihen se jää. Edit, sain kokeiltua nyös kaapelin kautta yhteyttä, mutta sekään ei auta.

OK, siinä tapauksessa vika on nimipalvelussa. Mitä tiedosto /etc/resolv.conf sisältää?

Koodia: [Valitse]
cat /etc/resolv.conf
Mitä nameserver-alkuisia rivejä listauksessa näkyy?

Tarkista myös, että tiedoston symbolinen linkki osoittaa oikeaan paikkaan:

Koodia: [Valitse]
ls -l /etc/resolv.conf
Lainaus
lrwxrwxrwx 1 root root 39 elo    14  2022 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf


Voisit myös kokeilla asettaa nimipalvelimen manuaalisesti Ubuntun verkkoasetuksissa. Nimipalveluna voi käyttää Googlen DNS-palvelimia 8.8.8.8 ja 8.8.4.4
Katso tämä ohje nimipalvelinasetusten muuttamiseen: https://phoenixnap.com/kb/ubuntu-dns-nameservers
« Viimeksi muokattu: 14.08.23 - klo:12.41 kirjoittanut nm »

maksim

  • Käyttäjä
  • Viestejä: 253
  • Mikähän tässä nyt mättää?????
    • Profiili
Olisikohan tässä ratkaisua Ubuntun DNS -ongelmaan?

https://forum.ubuntu-fi.org/index.php?topic=57474.msg438477#msg438477

Eli näin esim Googlen nimipalvelimet:

DNS=8.8.8.8.8
FallbackDNS=8.8.4.4

Ja jos toimii niin vaihdat sitten oman palveluntarjoajasi DNS -osoitteet.
« Viimeksi muokattu: 14.08.23 - klo:11.27 kirjoittanut maksim »

raimo

  • Käyttäjä
  • Viestejä: 4194
  • openSUSE Tumbleweed
    • Profiili
Voisit myös kokeilla asettaa nimipalvelimen manuaalisesti Ubuntun verkkoasetuksissa. Nimipalveluna voi käyttää Googlen DNS-palvelimia 8.8.8.8 ja 4.4.4.4
Katso tämä ohje nimipalvelinasetusten muuttamiseen: https://phoenixnap.com/kb/ubuntu-dns-nameservers

Suom huom 8.8.4.4 on oikea, 4.4.4.4 väärä joka ei toimi. ;)
Tietä käyden tien on vanki. Vapaa on vain umpihanki.
Aaro Hellaakoski

nm

  • Käyttäjä
  • Viestejä: 16277
    • Profiili
Voisit myös kokeilla asettaa nimipalvelimen manuaalisesti Ubuntun verkkoasetuksissa. Nimipalveluna voi käyttää Googlen DNS-palvelimia 8.8.8.8 ja 4.4.4.4
Katso tämä ohje nimipalvelinasetusten muuttamiseen: https://phoenixnap.com/kb/ubuntu-dns-nameservers

Suom huom 8.8.4.4 on oikea, 4.4.4.4 väärä joka ei toimi. ;)

Aivan, kiitos korjauksesta!

karimarkku66

  • Käyttäjä
  • Viestejä: 161
    • Profiili
Ping antaa vastaavan rimpsun, kuin mitä laitoit. Ja kone tunnistaa kaikki ympärillä olevat verkot ongelmitta, kysyy uuteen vefkkoon salasanan ja yhdistää, jolloin verkkokuvake syttyy. Mutta siihen se jää. Edit, sain kokeiltua nyös kaapelin kautta yhteyttä, mutta sekään ei auta.

OK, siinä tapauksessa vika on nimipalvelussa. Mitä tiedosto /etc/resolv.conf sisältää?

Koodia: [Valitse]
cat /etc/resolv.conf
Mitä nameserver-alkuisia rivejä listauksessa näkyy?

Tarkista myös, että tiedoston symbolinen linkki osoittaa oikeaan paikkaan:

Koodia: [Valitse]
ls -l /etc/resolv.conf
Lainaus
lrwxrwxrwx 1 root root 39 elo    14  2022 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf


Voisit myös kokeilla asettaa nimipalvelimen manuaalisesti Ubuntun verkkoasetuksissa. Nimipalveluna voi käyttää Googlen DNS-palvelimia 8.8.8.8 ja 8.8.4.4
Katso tämä ohje nimipalvelinasetusten muuttamiseen: https://phoenixnap.com/kb/ubuntu-dns-nameservers

Nameserver antaa tuloksen 127.0.0.53

ja symbolinen linkki lrwxrwxrwx 1 root root 39 maalis 25 2021

Pahoittelen kirjoitusasua, sillä teen tätä toisella läppärillä.

nm

  • Käyttäjä
  • Viestejä: 16277
    • Profiili

Nameserver antaa tuloksen 127.0.0.53

ja symbolinen linkki lrwxrwxrwx 1 root root 39 maalis 25 2021

Pahoittelen kirjoitusasua, sillä teen tätä toisella läppärillä.

Symbolisen linkin tiedoista puuttuu olennaisin eli loppuosa, jossa näkyy, mihin tiedostoon linkki osoittaa. Oliko kohteena /run/systemd/resolve/resolv.conf?

Kokeilitko nimipalvelimen asettamista manuaalisesti verkkoyhteyden asetuksissa?
« Viimeksi muokattu: 15.08.23 - klo:11.20 kirjoittanut nm »

karimarkku66

  • Käyttäjä
  • Viestejä: 161
    • Profiili

Nameserver antaa tuloksen 127.0.0.53

ja symbolinen linkki lrwxrwxrwx 1 root root 39 maalis 25 2021

Pahoittelen kirjoitusasua, sillä teen tätä toisella läppärillä.

Symbolisen linkin tiedoista puuttuu olennaisin eli loppuosa, jossa näkyy, mihin tiedostoon linkki osoittaa. Oliko kohteena /run/systemd/resolve/resolv.conf?

Kokeilitko nimipalvelimen asettamista manuaalisesti verkkoyhteyden asetuksissa?

Symbolisen linkin loppuosa,  /run/systemd/resolve/stud-resolv.conf

En vielä muuta ole kokeillut

nm

  • Käyttäjä
  • Viestejä: 16277
    • Profiili
Symbolisen linkin loppuosa,  /run/systemd/resolve/stud-resolv.conf

OK, /run/systemd/resolve/stub-resolv.conf käy.


En vielä muuta ole kokeillut

Sitten kun asetat DNS-palvelinten osoitteet, muista lopuksi katkaista verkkoyhteys ja ottaa se uudelleen käyttöön. Tarkista sitten resolvectl:llä, että Current DNS Server on 8.8.8.8:

Koodia: [Valitse]
resolvectl
Lainaus
Current DNS Server: 8.8.8.8
DNS Servers: 8.8.8.8 8.8.4.4

karimarkku66

  • Käyttäjä
  • Viestejä: 161
    • Profiili
En jaksanut enempää taistella komentojen kanssa, vaan asensin aiemman version tikulta sisään. Herjasi toki heti päivitystä uusimpaan lts versioon, mutta jätin vielä odottamaan vakaampaa jakelua. Nyt toimii kaikki ilman eri säätöä.