Kirjoittaja Aihe: Vähän kääntämistä ja erittäin vähän paketointia ja patchausta [siirrettävissä]  (Luettu 44925 kertaa)

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
ok, tässä siis hyvin lyhyt ja pelkistetty johdatus pakettien kääntämiseen debianin sorsista. debian sorsilla tarkoita tietysti lähdekoodeja joissa on debianin työkalujen vaatima informaatio paketoinnista ym. tämän näkee yleensä siitä, että lähdekoodien päähakemistossa on hakemisto nimeltään debian.

otetaan nyt sitten vaikka esimerkiksi tuo aikaisemmin kyselty libgphoto2, vaikka siihen annettu patchi ei kuulemma toiminutkaan toivotulla tavalla, mutta päästäänpähän samalla ihmettelemään patchausta.

asennetaan monissa kääntämisissä vaaditut peruskamat:
Koodia: [Valitse]
# apt-get install build-essential fakeroot
luodaan hakemisto siirrytään sinne jotta homma olisi siistimpää
Koodia: [Valitse]
$ mkdir koodi;cd koodi
haetaan paketin lähdekoodit:
Koodia: [Valitse]
$ apt-get source libgphoto2
tässä välissä olisi hyvä patchata lähdekoodi jos siihen on tarvetta. se hoituu komennolla patch ;) esim. tuo osoitteessa https://bugzilla.ubuntu.com/attachment.cgi?id=4164 lymyilevä patchi asennettaisiin näin:
ensin patchi tietty noudettaisiin ja sen jälkeen (riippuen mistä hakemistosta tuo patchi olisi tehty, senhän näkee kun kurkkaa mitä se pitää sisällään) komennettaisiin:
Koodia: [Valitse]
$ patch -p0<libgphoto2.ptp_ignore_file_dups.diff
tuolle p:lle annettava numero riippuu niitä patchin sisällä määritellyistä poluista ja omasta sijainnista. lisään aiheesta man patch.

nyt tuota ei tosin tarvitse enää patchata sillä patchi on jo asennettuna kyseiseen pakettiin ja jos sitä yrittää siitäkin huolimatta asentaa, niin ohjelma varoittaa kyllä.

seuraavaksi siirrytään hakemistoon jossa lähdekoodit ovat:
Koodia: [Valitse]
$ cd libgphoto2-2.1.6/
tarkastetaan ovatko kaikki kääntämiseen tarvittavat kirjastot asennettuina:
Koodia: [Valitse]
$ dpkg-checkbuilddeps
dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>> 3.0.0) zlib1g-dev libtool libusb-dev (>= 1:0.1.5) libgpmg1-dev libexif-dev (>= 0.6.12) libjpeg62-dev

eivät näköjään, asennetaan ne:
Koodia: [Valitse]
# apt-get install debhelper zlib1g-dev libtool libusb-dev libgpmg1-dev libexif-dev libjpeg62-dev
sitten ei muuta kuin kääntämään. käytetään dpkg-dev -paketin mukana tullutta scriptiä joka paketoi käännetyn softan meille valmiiksi:
Koodia: [Valitse]
$ dpkg-buildpackage -rfakeroot
sitten odotellaan...
kun homma on valmis, siirrytään hakemistorakenteessa pykälä kohti juurta ja huomataan, että siihen hakemistoon on pullahtanut läjä uusia tiedostoja:
Koodia: [Valitse]
$ ls
libgphoto2-port0_2.1.6-1ubuntu6_i386.deb
libgphoto2.ptp_ignore_file_dups.diff
libgphoto2-2-dev_2.1.6-1ubuntu6_i386.deb
libgphoto2-2.1.6
libgphoto2_2.1.6.orig.tar.gz
libgphoto2_2.1.6-1ubuntu6.diff.gz
libgphoto2_2.1.6-1ubuntu6.dsc
libgphoto2_2.1.6-1ubuntu6_i386.changes
libgphoto2-2_2.1.6-1ubuntu6_i386.deb

nyt meitä kiinnostaa tietysti vain .deb -päätteiset tiedostot joita on kolme ja niistäkin yksi on developement versio, jota ei tarvita jos itse käännettävät ohjelmat eivät sitä vaadi. sitten vaan asennetaan nämä uudet paketit (tai lähetetään kaverille tai mitä tahansa. tosin yleensä kannatta kyllä testata niitä paketteja ennen jakamista ;) ).

Koodia: [Valitse]
# dpkg -i libgphoto2-port0_2.1.6-1ubuntu6_i386.deb libgphoto2-2_2.1.6-1ubuntu6_i386.deb
siinäpä tuo, helppoa kuin mikä. tosin kannattaa huomioida, että tässä ohjeessa olevista komennoista vain #-alkuiset vaativat rootin oikeudet, muita ei kannata rootin oikeuksin edes tehdä.

yleensähän noita paketteja on aika turha kääntää itse, jos ei halua välttämättä asentaa jotain patchia, muuttaa oletuksena käytettyjä kääntöparametreja (joista ei edes puhuttu tässä) tai kääntää jotain softaa jota ei syystä tai toisesta löydy paketinhallinnasta. itse olen asentanut palvelimelle paketinhallinan ulkopuolelta ohjelman nimeltään mcabber.
« Viimeksi muokattu: 16.08.08 - klo:13.40 kirjoittanut Kari Argillander »
Janne

Kari Argillander

  • Käyttäjä
  • Viestejä: 437
  • Kubuntu - Hardy
    • Profiili
Voisiko ohjeen kirjoittaja/täydentäjät kirjoittaa viestin jossa vahvistavat että     

a) ohje on edelleen käyttökelpoinen Hardyssä (tuorein LTS, tuorein stable) eli uudet ominaisuudet eivät ole poistaneet tarvetta ohjeelle tai että ohjeessa käytetyt työkalut jne ovat edelleen Hardyssä käytössä
b) antavat luvan ohjeen siirtämiseen Ubuntu Suomen wikiin (http://wiki.ubuntu-fi.org). Kts. Wikin lisenssistä jne lisätietoja täältä: http://wiki.ubuntu-fi.org/#head-867666147f48c6b667ec0f6be3f5f16852046770

Kiitos!
« Viimeksi muokattu: 13.08.08 - klo:23.01 kirjoittanut Kari Argillander »
Kaikkea täällä sanomaani saa käyttää public domain lisenssillä. Lainauksia ei saa käyttää ellei lainauksen lähde sitä salli. Tiedostoja ei saa käyttää ellei sitä erikseen sallita.

janne

  • Käyttäjä
  • Viestejä: 5150
    • Profiili
a) versionumerot ovat vanhoja, mutta muuten ihan validia kamaa
b) toki
Janne

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Meneekö kuinka oleellisesti päällekäin tämän kanssa: http://linux.fi/index.php/Deb-paketin_tekeminen

r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Heikki Mäntysaari

  • Käyttäjä / tiedottaja
  • Viestejä: 377
    • Profiili
Aikalailla samat asiat löytyvät Linux.fin artikkelista (täydensin sitä juuri hieman tämän osa-alueen osalta). En näkisi tarpeelliseksi tämän oppaan siirtämistä mihinkään wikiin.
Suomenkielinen Linux-wiki: Linux.fi - katso myös http://linux.fi/foorumi

Risto H. Kurppa

  • Käyttäjä
  • Viestejä: 3024
  • Useita Kubuntuja ajossa.
    • Profiili
    • http://risto.kurppa.fi
Aikalailla samat asiat löytyvät Linux.fin artikkelista (täydensin sitä juuri hieman tämän osa-alueen osalta). En näkisi tarpeelliseksi tämän oppaan siirtämistä mihinkään wikiin.

jepu eli tuohon jannen viestin alkuun voisi lisätä linkit linux.fi:n oppaisiin ja ilmoittaa ettei tätä enää ylläpidetä.


r
UUSI UBUNTUN KÄYTTÄJÄ: SÄÄSTÄ AIKAASI LUKEMALLA  -> TÄMÄ <-

Kari Argillander

  • Käyttäjä
  • Viestejä: 437
  • Kubuntu - Hardy
    • Profiili
tämä on jo vanhentuneissa joten tuskin tarvetta ;)
Kaikkea täällä sanomaani saa käyttää public domain lisenssillä. Lainauksia ei saa käyttää ellei lainauksen lähde sitä salli. Tiedostoja ei saa käyttää ellei sitä erikseen sallita.